JOS- ja JA-funktioiden sekä TAI- ja EI-funktioiden yhteiskäyttö

Huomautus: Microsoft haluaa tarjota sinulle ajantasaisinta ohjesisältöä mahdollisimman nopeasti omalla kielelläsi. Tämä sivu on käännetty automaation avulla, ja siinä saattaa olla kielioppivirheitä tai epätarkkuuksia. Tarkoitus on, että sisällöstä on sinulle hyötyä. Kertoisitko sivun alareunassa olevan toiminnon avulla, oliko tiedoista hyötyä? Tästä pääset helposti artikkelin englanninkieliseen versioon.

JOS-funktion avulla voit tehdä loogisen vertailun arvon ja odotetun arvon välillä testaamalla ehtoa ja palauttamalla tuloksen, jos ehto on Tosi tai Epätosi.

  • JOS(jokin on Tosi, tee jotain, muutoin tee jotain muuta)

Mitä jos haluat testata useita ehtoja, jossa entä jos kaikki ehdot täytyy olla tosi tai EPÄTOSI (ja), tai vain yhden ehdon on olla tosi tai EPÄTOSI (tai), tai Jos haluat tarkistaa, jos ehto ei täytä ehtoja ? Kaikki 3 funktioiden avulla voidaan yhteiskäyttöä, mutta se on paljon tavallisimmista näkyvät Parittainen ja jos-funktioita.

Käytä JOS-funktiota JA-, TAI- ja EI-funktioiden kanssa, jos haluat tehdä monta vertailua siitä, ovatko ehdot Tosi vai Epätosi.

Syntaksi

  • JOS(JA()) - JOS(JA(looginen1, [looginen2], ...), arvo_jos_tosi, [arvo_jos_epätosi]))

  • JOS(TAI()) - JOS(TAI(looginen1, [looginen2], ...), arvo_jos_tosi, [arvo_jos_epätosi]))

  • JOS(EI()) - JOS(EI(looginen1), arvo_jos_tosi, [arvo_jos_epätosi]))

Argumentin nimi

Kuvaus

looginen_testi (pakollinen)

Testattava ehto.

arvo_jos_tosi (pakollinen)

Palautettava arvo, jos loogisen_testin tulos on TOSI.

arvo_jos_epätosi (valinnainen)

Palautettava arvo, jos loogisen_testin tulos on EPÄTOSI.

Seuraavassa on yleiskatsaus siitä, miten voit jäsennellä ANDtaiei -funktiota ja yksitellen. Kun yhdistät kullekin niistä ja jos-lauseke, ne lukea tältä:

  • JA – =JOS(JA(jokin on Tosi, jokin muu on Tosi), arvo jos Tosi, arvo jos Epätosi)

  • TAI – =JOS(TAI(jokin on Tosi, jokin muu on Tosi), arvo jos Tosi, arvo jos Epätosi)

  • EI – =JOS(EI(jokin on Tosi), arvo jos Tosi, arvo jos Epätosi)

Esimerkkejä

Seuraavassa on esimerkkejä joitakin yleisiä sisäkkäisiä IF(AND()), IF(OR()) ja IF(NOT()) lausekkeita. JA ja tai funktiot voivat tukea 255 yksittäisiä ehtoja, mutta se ei ole hyvä käyttää useampaa kuin muutaman, koska monimutkaisia, sisäkkäisen kaavat voivat siirtyä hankalaa muodosta, Testaa ja säilyttää. NOT-funktio käsittelee vain yhden ehdon.

Esimerkkejä numeeristen arvojen ja tekstin arvioimiseen käyttämällä JOS-funktiota JA-, TAI- ja EI-funktioiden kanssa

Kaavojen selitykset niiden logiikan mukaisesti:

Kaava

Kuvaus

=JOS(JA(A2>0,B2<100),TOSI, EPÄTOSI)

Jos A2 (25) on suurempi kuin 0, ja B2 (75) on pienempi kuin 100 ja palauttaa arvon TOSI, muuten palautus EPÄTOSI. Tässä tapauksessa molemmat ehdot ovat tosia, joten funktio palauttaa arvon TOSI.

=JOS(JA(A3=”Punainen”,B3=”Vihreä”),TOSI,EPÄTOSI)

Jos A3 (”sininen”) = ”punainen”, B3 ja (”vihreä”) on yhtä kuin ”vihreä” palauttaa arvon TOSI, palautetaan muutoin EPÄTOSI. Tässä tapauksessa vain ensimmäinen ehto on TOSI, jotta, palautuu EPÄTOSI.

=JOS(TAI(A4>0,B4<50),TOSI, EPÄTOSI)

Jos A4 (25) on suurempi kuin 0, tai B4 (75) on pienempi kuin 50 ja palauttaa arvon TOSI, muuten palautus EPÄTOSI. Tässä tapauksessa vain ensimmäinen ehto on TOSI, mutta vaatii koska tai vain yhden argumentin arvo on TOSI, kaava palauttaa arvon TOSI.

=JOS(TAI(A5=”Punainen”,B5=”Vihreä”),TOSI,EPÄTOSI)

Jos A5 (”sininen”) on yhtä suuri kuin ”punainen”, tai-B5 (”vihreä”) on yhtä kuin ”vihreä” palauttaa arvon TOSI, palautetaan muutoin EPÄTOSI. Tässä tapauksessa toinen argumentti on TOSI, joten kaava palauttaa arvon TOSI.

=JOS(EI(A6>50),TOSI,EPÄTOSI)

Jos A6 (25) ei ole suurempi kuin 50 ja palauttaa arvon TOSI, palautetaan muutoin EPÄTOSI. Tässä tapauksessa 25 ei ole suurempi kuin 50, joten kaava palauttaa arvon TOSI.

=JOS(EI(A7=”Punainen”),TOSI,EPÄTOSI)

Jos A7 (”Sininen”) EI ole yhtä kuin ”Punainen”, palauta arvo TOSI, muuten palauta arvo EPÄTOSI.

Huomaa, että kaikki esimerkkejä sulkeva Sulje kirjoitetut vastaaviin ehdot täyttyvät. Jäljellä olevat TOSI tai EPÄTOSI-argumentit ovat vasemmalle osana ulompi Jos-lauseke. Voit korvata tekstiä tai numeeriset arvot TOSI tai EPÄTOSI-arvot palautetaan esimerkeissä.

Seuraavassa on esimerkkejä päivämäärien vertailemiseen JA-, TAI- ja EI-funktioilla.

Esimerkkejä päivämäärien arvioimiseen käyttämällä JOS-funktiota JA-, TAI- ja EI-funktioiden kanssa

Kaavojen selitykset niiden logiikan mukaisesti:

Kaava

Kuvaus

=JOS(A2>B2,TOSI,EPÄTOSI)

Jos A2 on suurempi kuin B2 palauttaa arvon TRUE, Palauta muutoin EPÄTOSI. 03/12/14 on suurempi kuin 01/01/14, joten kaava palauttaa arvon TOSI.

=JOS(JA(A3>B2,A3<C2),TOSI,EPÄTOSI)

Jos A3 on suurempi kuin B2 ja A3 on pienempi kuin C2, palauttaa totuusarvon TOSI, palautetaan muutoin EPÄTOSI. Tässä tapauksessa molemmat argumentit ehdot täyttyvät, joten kaava palauttaa arvon TOSI.

=JOS(TAI(A4>B2,A4<B2+60),TOSI,EPÄTOSI)

Jos A4 on suurempi kuin B2 tai A4 on pienempi kuin B2 + 60, palauttaa arvon TOSI, muuten palautus EPÄTOSI. Tässä tapauksessa ensimmäinen argumentti on TOSI, mutta toinen on EPÄTOSI. Koska tai vain on yksi argumenteista on TOSI, kaava palauttaa arvon TOSI. Jos ohjattua kaavan laskeminen, kaava-välilehdestä näet, miten Excel laskee kaavan.

=JOS(EI(A5>B2),TOSI,EPÄTOSI)

Jos A5 ei ole suurempi kuin B2, palauttaa arvon TOSI, muuten palautus EPÄTOSI. Tässä tapauksessa A5 on suurempi kuin B2, joten kaava palauttaa arvon EPÄTOSI.

Esimerkki ohjatusta Kaavan laskeminen -toiminnosta

JA-, TAI- ja EI-funktioiden käyttö ehdollisen muotoilun kanssa

Voit myös käyttää ja, tai niin, ETTEIVÄT ne ehdollisen muotoilun ehtojen kanssa kaava-vaihtoehto. Kun teet näin voit jättää Jos-funktio ja ja, tai käyttää, ei omia.

Valitse Aloitus -välilehdessä Ehdollinen muotoilu > uusi sääntö. Seuraavaksi ”Yksinkertaisen kaavan avulla, mitkä solut muotoillaan”-vaihtoehto, kirjoita haluamasi kaava ja käyttää valittua muotoa.

Ehdollinen muotoilu > Muokkaa sääntöä -valintaikkuna, jossa näkyy Kaava-menetelmä

Käyttäen aiempaa Päivämäärät-esimerkkiä kaavojen pitäisi näyttää seuraavalta.

Esimerkkejä JA-, TAI- ja EI-funktioita käytöstä ehdollisen muotoilun testeihin

Kaava

Kuvaus

=A2>B2

Jos A2 on suurempi kuin B2, muotoile solua, muussa tapauksessa älä tee mitään.

=JA(A3>B2,A3<C2)

Jos A3 on suurempi kuin B2 JA A3 on pienempi kuin C2, muotoile solua, muussa tapauksessa älä tee mitään.

=TAI(A4>B2,A4<B2+60)

Jos A4 on suurempi kuin B2 TAI A4 on pienempi kuin B2 plus 60 (päivää), muotoile solua, muussa tapauksessa älä tee mitään.

=EI(A5>B2)

Jos A5 ei ole suurempi kuin B2, Muotoile solua, muuten ei mitään. Tässä tapauksessa A5 on suurempi kuin B2, jotta tulos palauttaa arvon EPÄTOSI. Jos haluat muuttaa kaavan =NOT(B2>A5) , se palauttavat arvon TRUE ja solu muotoilla.

Huomautus: Yleinen virhe on voit kirjoittaa kaavan ehdollisen muotoilun ilman yhtäläisyysmerkki (=). Jos teet tämän näet, että ehdollinen muotoilu-valintaikkuna Lisää yhtäläisyysmerkki ja tarjousten - kaava = ”OR(A4>B2,A4<B2+60)”, joten sinun on poistettava lainausmerkkejä ennen kaavan vastaa oikein.

Sivun alkuun

Tarvitsetko lisätietoja?

Voit aina kysyä neuvoa Excel Tech Community -yhteisön asiantuntijalta, saada tukea yhteisön vastauksista tai ehdottaa uutta ominaisuutta tai parannusta Excel User Voice -sivustolla.

Katso myös

Katso video Jos-funktion käyttäminen

Opettele käyttämään sisäisiä funktioita kaavassa

JOS-funktio

JA-funktio

TAI-funktio

EI-funktio

Yleiskuva kaavoista Excelissä

Viallisten kaavojen ratkaiseminen

Kaavoissa esiintyvien virheiden etsiminen

Excel for Windowsin pikanäppäimet

Excel for Macin pikanäppäimet

Loogiset funktiot (hakemisto)

Excelin funktiot (aakkosjärjestyksessä)

Excelin funktiot (luokittain)

Kehitä Office-taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×