JOS-funktion käyttäminen sen tarkistamiseen, onko solu tyhjä

Huomautus: Microsoft haluaa tarjota sinulle ajantasaisinta ohjesisältöä mahdollisimman nopeasti omalla kielelläsi. Tämä sivu on käännetty automaation avulla, ja siinä saattaa olla kielioppivirheitä tai epätarkkuuksia. Tarkoitus on, että sisällöstä on sinulle hyötyä. Kertoisitko sivun alareunassa olevan toiminnon avulla, oliko tiedoista hyötyä? Tästä pääset helposti artikkelin englanninkieliseen versioon.

Joskus pitää tarkistaa, onko solu tyhjä. Yleensä näin on, jos et halua kaavan näyttävän tulosta ilman syöttöä.

Kaava solussa E2 on =JOS(D2=1;"Kyllä";JOS(D2=2;"Ei";"Ehkä"))

Tässä tapauksessa JOS-funktiota käytetään yhdessä ONTYHJÄ-funktion kanssa:

  • =JOS(ONTYHJÄ(D2),"Tyhjä","Ei tyhjä")

Tämä tarkoittaa JOS(D2 on tyhjä, palauta "Tyhjä", muussa tapauksessa palauta "Ei tyhjä"). Voit yhtä hyvin käyttää omaa kaavaasi "Ei tyhjä" -ehdon sijaan. Seuraavassa esimerkissä käytetään "" ONTYHJÄ-ehdon sijaan. "" tarkoittaa käytännössä "ei mitään".

Tarkistaa, onko solu tyhjä - Solun E2 kaava on =JOS(ONTYHJÄ(D2),"Tyhjä","Ei tyhjä")

=JOS(D3="","Tyhjä","Ei tyhjä")

Tämä kaava tarkoittaa JOS(D3 on ei mitään, palauta "Tyhjä", muussa tapauksessa palauta "Ei tyhjä"). Tässä on esimerkki hyvin yleisestä menetelmästä, jossa "" käytetään estämään kaavan laskeminen, jos seuraajasolu on tyhjä:

  • =JOS(D3="","",Kaavasi())

    Jos (D3 ei mitään, ja valitse Palauta mitään, muuten Laske kaava).

Kehitä Office-taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×