Kaavat ja funktiot

JOS-funktio

JOS-funktio

Huomautus: Microsoft haluaa tarjota sinulle ajantasaisinta ohjesisältöä mahdollisimman nopeasti omalla kielelläsi. Tämä sivu on käännetty automaation avulla, ja siinä saattaa olla kielioppivirheitä tai epätarkkuuksia. Tarkoitus on, että sisällöstä on sinulle hyötyä. Kertoisitko sivun alareunassa olevan toiminnon avulla, oliko tiedoista hyötyä? Tästä pääset helposti artikkelin englanninkieliseen versioon.

Jos-funktio on Excelin suosituimpia funktioita ja sen avulla voit tehdä looginen arvo väliltä vastaa odotuksiasi vertailuja.

JOS-lausekkeella voi näin olla kaksi tulosta. Ensimmäinen tulos on se, että vertailu on Tosi, ja toinen, että vertailu on Epätosi.

Esimerkiksi =JOS(C2=”Kyllä”;1;2) tarkoittaa, että JOS(C2 = Kyllä, palauta arvo 1, muutoin palauta arvo 2).

Selaimesi ei tue videotoimintoa. Asenna Microsoft Silverlight, Adobe Flash Player tai Internet Explorer 9.

JOS-funktiolla, joka on looginen funktio, voit palauttaa yhden arvon, jos ehto on tosi, ja toisen arvon, jos ehto on epätosi.

JOS(looginen_testi, arvo_jos_tosi, [arvo_jos_epätosi])

Esimerkki:

  • =JOS(A2>B2;"Ylittää budjetin";"OK")

  • =JOS(A2=B2;B4-A4;"")

Argumentin nimi

Kuvaus

looginen_testi    (pakollinen)

Testattava ehto.

arvo_jos_tosi    (pakollinen)

Palautettava arvo, jos loogisen_testin tulos on TOSI.

arvo_jos_epätosi    (valinnainen)

Palautettava arvo, jos loogisen_testin tulos on EPÄTOSI.

Yksinkertaisia JOS-esimerkkejä

Solussa D2 on kaava =JOS(C2="Kyllä";1;2)
  • =JOS(C2="Kyllä";1;2)

Edellisessä esimerkissä solu D2 kertoo seuraavaa: JOS(C2 = Kyllä, anna arvoksi 1, muutoin anna arvoksi 2)

Solussa D2 on kaava =JOS(C2=1;"KYLLÄ";"EI")
  • =JOS(C2=1;"Kyllä";"Ei")

Tässä esimerkissä D2-solun kaava kertoo: IF(C2 = 1, then return Yes, otherwise return No)huomaamaan, jos-funktion avulla voidaan laskea teksti ja arvot. Se voidaan myös arvioida virheitä. Et ole rajoitettu tarkistuksen vain, jos kuitenkaan on yhtä kuin toiseen ja joka palauttaa yhden tuloksen, voit myös käyttää matemaattisia operaattoreita ja muita laskutoimituksia ehtojen mukaan. Voit myös sisällyttää useita Jos-funktioita yhdessä jotta voit suorittaa useita vertailuja.

Kaava solussa D2 on =JOS(C2>B2;"Ylittää budjetin";"Budjetin puitteissa")
  • =JOS(C2>B2;"Ylittää budjetin";"Budjetin puitteissa")

Edellisessä esimerkissä JOS-funktio solussa D2 kertoo, että JOS(C2 on suurempi kuin B2, anna arvoksi "Ylittää budjetin", muutoin anna arvoksi "Budjetin puitteissa")

Kaava solussa E2 on =JOS(C2>B2;C2-B2;"")
  • =JOS(C2>B2,C2-B2,0)

Yllä olevassa kuvassa oleva funktio antaa arvoksi matemaattisen laskutoimituksen tekstin sijaan. Solussa E2 oleva kaava siis kertoo, että JOS(Todellinen on suurempi kuin Budjetoitu, vähennä Budjetoitu summa Todellisesta summasta, muutoin älä anna arvoksi mitään).

Kaava solussa F7 on JOS(E7="Kyllä";F5*0,0825;0)
  • =JOS(E7="Kyllä"F5*0,0825;0)

Tässä esimerkissä solussa F7 oleva kaava kertoo, että JOS(E7 = "Kyllä", laske kokonaissumma F5 * 8,25 %, muutoin ei arvonlisäveroa, joten anna arvoksi 0)

Huomautus: Jos aiot käyttää kaavoissa tekstiä, sinun on kirjoitettava teksti lainausmerkkeihin (esimerkiksi "Teksti"). Ainoa poikkeus tähän ovat sanat TOSI tai EPÄTOSI, jotka Excel ymmärtää automaattisesti.

Yleisiä ongelmia

Ongelma

Mikä meni vikaan

0 (nolla) solussa

Arvo_jos_tosi - tai arvo_jos_epätosi-argumenteille ei löytynyt argumenttia. Jotta oikea arvo palautetaan, lisää argumenttiteksti kahteen argumenttiin tai lisää argumenttiin TOSI tai EPÄTOSI.

#NIMI? solussa

Tämä tarkoittaa yleensä, että kaavassa on kirjoitusvirhe.

Tarvitsetko lisätietoja?

Voit aina kysyä neuvoa Excel Tech Community -yhteisön asiantuntijalta, saada tukea yhteisön vastauksista tai ehdottaa uutta ominaisuutta tai parannusta Excel User Voice -sivustolla.

Katso myös

Operaattorit ja ohittaa Excelissä

Käytä kaavassa Sisäkkäisiä funktioita

Jos avulla voit tarkistaa, onko solu on tyhjä

Jos avulla voit tarkistaa, onko solu on tyhjä

Video: edistyneet Jos-Funktiot

IFS toimi (Office 365-Excel 2016 ja uudempi versio)

Edistyneet Jos - funktioita sisäkkäisen kaavojen käyttämisestä ja ilman käsitellään

Koulutus videot: edistyneet Jos-Funktiot

Laske.Jos-funktio yhden ehdon perustuvien arvojen laskeminen

Laske.Jos.joukko-funktio useita ehtoja perustuvien arvojen laskeminen

Summa.Jos-funktio laskee yhteen arvojen yhden ehdon perusteella

Summa.Jos.joukko-funktio laskee yhteen useiden ehtojen perusteella arvot

AND-funktio

Tai-funktio

PHAKU-funktio

Yleiskuva Excelin kaavoista

Viallisten kaavojen ratkaiseminen

Vianmäärityksen kaavojen virheiden korjaaminen vianmäärityksen avulla

Loogiset Funktiot

Excelin Funktiot (aakkosjärjestyksessä)

Excelin Funktiot (luokittain)

Kehitä Office-taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×