Kaavat ja funktiot

JOS-funktio

JOS-funktio

JOS-funktio on Excelin käytetyimpiä funktioita, ja sen avulla voit tehdä loogisia vertailuja arvon ja odotettujen arvojen välillä.

JOS-lausekkeella voi näin olla kaksi tulosta. Ensimmäinen tulos on se, että vertailu on Tosi, ja toinen, että vertailu on Epätosi.

Esimerkiksi =JOS(C2=”Kyllä”;1;2) tarkoittaa, että JOS(C2 = Kyllä, palauta arvo 1, muutoin palauta arvo 2).

Selaimesi ei tue videotoimintoa. Asenna Microsoft Silverlight, Adobe Flash Player tai Internet Explorer 9.

JOS-funktiolla, joka on looginen funktio, voit palauttaa yhden arvon, jos ehto on tosi, ja toisen arvon, jos ehto on epätosi.

JOS(looginen_testi, arvo_jos_tosi, [arvo_jos_epätosi])

Esimerkki:

  • =JOS(A2>B2;"Ylittää budjetin";"OK")

  • =JOS(A2=B2;B4-A4;"")

Argumentin nimi

Kuvaus

looginen_testi    (pakollinen)

Testattava ehto.

arvo_jos_tosi    (pakollinen)

Palautettava arvo, jos loogisen_testin tulos on TOSI.

arvo_jos_epätosi    (valinnainen)

Palautettava arvo, jos loogisen_testin tulos on EPÄTOSI.

Yksinkertaisia JOS-esimerkkejä

Solussa D2 on kaava =JOS(C2="Kyllä";1;2)
  • =JOS(C2="Kyllä";1;2)

Edellisessä esimerkissä solu D2 kertoo seuraavaa: JOS(C2 = Kyllä, anna arvoksi 1, muutoin anna arvoksi 2)

Solussa D2 on kaava =JOS(C2=1;"KYLLÄ";"EI")
  • =JOS(C2=1;"Kyllä";"Ei")

Tässä esimerkissä solussa D2 oleva kaava kertoo seuraavaa: JOS(C2 = 1, anna arvoksi Kyllä, muutoin anna arvoksi Ei) Kuten näet, JOS-funktion avulla voidaan vertailla sekä tekstiä että arvoja. Sen avulla voidaan myös arvioida virheitä. Voit paitsi tarkistaa, vastaako jokin asia toista ja antaa vain yhden tuloksen, myös käyttää matemaattisia operaattoreita ja suorittaa lisälaskutoimituksia määrittämiesi ehtojen perusteella. Voit myös käyttää useita sisäkkäisiä JOS-funktioita yhdessä ja siten suorittaa useita vertailuja.

Kaava solussa D2 on =JOS(C2>B2;"Ylittää budjetin";"Budjetin puitteissa")
  • =JOS(C2>B2;"Ylittää budjetin";"Budjetin puitteissa")

Edellisessä esimerkissä JOS-funktio solussa D2 kertoo, että JOS(C2 on suurempi kuin B2, anna arvoksi "Ylittää budjetin", muutoin anna arvoksi "Budjetin puitteissa")

Kaava solussa E2 on =JOS(C2>B2;C2-B2;"")
  • =JOS(C2>B2,C2-B2,0)

Yllä olevassa kuvassa oleva funktio antaa arvoksi matemaattisen laskutoimituksen tekstin sijaan. Solussa E2 oleva kaava siis kertoo, että JOS(Todellinen on suurempi kuin Budjetoitu, vähennä Budjetoitu summa Todellisesta summasta, muutoin älä anna arvoksi mitään).

Kaava solussa F7 on JOS(E7="Kyllä";F5*0,0825;0)
  • =JOS(E7="Kyllä"F5*0,0825;0)

Tässä esimerkissä solussa F7 oleva kaava kertoo, että JOS(E7 = "Kyllä", laske kokonaissumma F5 * 8,25 %, muutoin ei arvonlisäveroa, joten anna arvoksi 0)

Huomautus: Jos aiot käyttää kaavoissa tekstiä, sinun on kirjoitettava teksti lainausmerkkeihin (esimerkiksi "Teksti"). Ainoa poikkeus tähän ovat sanat TOSI tai EPÄTOSI, jotka Excel ymmärtää automaattisesti.

Yleisiä ongelmia

Ongelma

Mikä meni vikaan

0 (nolla) solussa

Arvo_jos_tosi - tai arvo_jos_epätosi-argumenteille ei löytynyt argumenttia. Jotta oikea arvo palautetaan, lisää argumenttiteksti kahteen argumenttiin tai lisää argumenttiin TOSI tai EPÄTOSI.

#NIMI? solussa

Tämä tarkoittaa yleensä, että kaavassa on kirjoitusvirhe.

Tarvitsetko lisätietoja?

Voit aina kysyä neuvoa Excel Tech Community -yhteisön asiantuntijalta, saada tukea yhteisön vastauksista tai ehdottaa uutta ominaisuutta tai parannusta Excel User Voice -sivustolla.

Katso myös

Laskentaoperaattorit ja järjestys Excelissä

Sisäkkäisten funktioiden käyttö kaavassa

JOS-funktion käyttäminen sen tarkistamiseen, onko solu tyhjä

JOS-funktion käyttäminen sen tarkistamiseen, onko solu tyhjä

Video: Edistyneet JOS-funktiot

JOS.JOUKKO-funktio (Office 365, Excel 2016 ja uudempi versio)

Edistyneet JOS-funktiot – Sisäkkäisten kaavojen kanssa työskentely ja ongelmien välttäminen

Koulutusvideot: Edistyneet JOS-funktiot

LASKE.JOS-funktio laskee arvoja yhden ehdon perusteella

LASKE.JOS.JOUKKO-funktio laskee arvoja usean ehdon perusteella

SUMMA.JOS-funktio laskee arvot yhteen yhden ehdon perusteella

SUMMA.JOS.JOUKKO-funktio laskee arvot yhteen usean ehdon perusteella

JA-funktio

TAI-funktio

PHAKU-funktio

Yleiskuva kaavoista Excelissä

Viallisten kaavojen ratkaiseminen

Kaavoissa esiintyvien virheiden etsiminen

Loogiset funktiot

Excelin funktiot (aakkosjärjestyksessä)

Excelin funktiot (luokittain)

Kehitä Office-taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×