JA-funktio

JA-funktio, yksi loogisista funktioista, auttaa selvittämään testin ehtojen täyttymistä.

Esimerkki

Esimerkkejä JA-funktiosta

JA-funktio palauttaa arvon TOSI, jos kaikkien argumenttien arvo on TOSI, ja arvon EPÄTOSI, jos vähintään yhden argumentin arvo on EPÄTOSI.

Yksi yleisimmistä JA-funktion käyttötavoista on toimia muiden totuusarvotestejä suorittavien funktioiden ominaisuuksia laajentavana lisänä. Esimerkiksi JOS-funktio suorittaa totuusarvotestin ja palauttaa yhden arvon, jos testin arvo on TOSI, ja toisen arvon, jos testin arvo on EPÄTOSI. Käyttämällä JA-funktiota JOS-funktion totuus_testi-argumenttina voit testata useita erilaisia ehtoja vain yhden asemesta.

Syntaksi

JA(totuus1; [totuus2], ...)

JA-funktion syntaksissa on seuraavat argumentit:

Argumentti

Kuvaus

Totuus1

Pakollinen. Ensimmäinen ehto, jota haluat testata ja jonka arvo voi olla joko TOSI tai EPÄTOSI.

Totuus2, ...

Valinnainen. Lisäehdot, joita haluat testata ja joiden arvo voi olla joko TOSI tai EPÄTOSI. Voit testata enintään 255 ehtoa.

Huomautuksia

  • Argumenttien on oltava totuusarvoja (kuten TOSI tai EPÄTOSI) tai niiden on oltava matriiseja tai viittauksia, jotka sisältävät totuusarvoja.

  • Jos matriisi tai viittaus sisältää tekstiä, lukuja tai tyhjiä soluja, näitä arvoja ei oteta huomioon.

  • Jos määritetyllä alueella ei ole totuusarvoja, JA-funktio palauttaa #ARVO!-virheen.

Esimerkkejä

Seuraavassa on yleisiä esimerkkejä JA-funktion käytöstä itsenäisesti ja JOS-funktion kanssa.

Esimerkkejä JOS-funktioiden käytöstä JA-funktion kanssa

Kaava

Kuvaus

=JA(A2>1,A2<100)

Antaa tulokseksi TOSI, jos solun A2 arvo on suurempi kuin 1 JA pienempi kuin 100. Muussa tapauksessa antaa tulokseksi EPÄTOSI.

=JOS(JA(A2<A3,A2<100),A2,"Arvo on alueen ulkopuolella")

Näyttää solun A2 arvon, jos se on pienempi kuin A3 JA pienempi kuin 100. Muussa tapauksessa näyttää viestin "Arvo on alueen ulkopuolella".

=JOS(JA(A3>1,A3<100),A3,"Arvo on alueen ulkopuolella")

Näyttää solun A3 arvon, jos se on suurempi kuin 1 JA pienempi kuin 100. Muussa tapauksessa näyttää viestin. Voit korvata viestin haluamallasi viestillä.

Bonuslaskelma

Tässä on melko tavallinen esimerkki, jossa JOS- ja JA-funktioiden avulla lasketaan, ovatko henkilöt oikeutettuja bonukseen.

Esimerkki myyntibonuksen laskemisesta JOS- ja JA-funktioiden kanssa.  Solun E14 kaava on = JOS(JA(B14>=$B$7,C14>=$B$5),B14*$B$8,0)
  • =JOS(JA(B14>=$B$7,C14>=$B$5),B14*$B$8,0)JOS kokonaismyynti on suurempi tai yhtä suuri kuin (>=) myyntitavoite JA Tilit on suurempi tai yhtä suuri (>=) kuin tavoitetili, kokonaismyynti kerrotaan bonusprosentilla. Muussa tapauksessa palauttaa 0.

Tarvitsetko lisätietoja?

Voit aina kysyä neuvoa Excel Tech Community -yhteisön asiantuntijalta, saada tukea yhteisön vastauksista tai ehdottaa uutta ominaisuutta tai parannusta Excel User Voice -sivustolla.

Aiheeseen liittyvät artikkelit

Video: Edistyneet JOS-funktiot
Lue, miten voit käyttää sisäkkäisiä funktioita kaavassa
JOS-funktio
TAI-funktio
EI-funktio
Yleiskuva kaavoista Excelissä
Viallisten kaavojen välttäminen
Kaavoissa esiintyvien virheiden etsiminen virheentarkistuksen avulla
Excel 2016 for Windowsin pikanäppäimet
Excel 2016 for Macin näppäinoikotiet
Loogiset funktiot (hakemisto)
Excelin funktiot (aakkosjärjestyksessä)
Excelin funktiot (luokittain)

Kehitä Office-taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×