Funktioiden ja sisäkkäisten funktioiden käyttäminen Excel-kaavoissa

Funktiot ovat ennalta määritettyjä kaavoja, jotka suorittavat laskutoimituksia käyttämällä erityisiä arvoja eli argumentteja tietyssä järjestyksessä tai tietyssä rakenteessa. Funktioilla voi suorittaa sekä yksinkertaisia että monimutkaisia laskutoimituksia. Excelin kaikki funktiot ovat valintanauhan Kaavat-välilehdellä:

Valintanauhan Excel-kaavat-välilehti
  • Excelin funktion syntaksi

    Seuraava esimerkki solussa A10 olevan luvun pyöristämisestä PYÖRISTÄ-funktiolla kuvaa funktion syntaksia.

    Funktion rakenne

    1. Rakenne. Funktiossa on ensimmäisenä yhtäläisyysmerkki (=), ja sen jälkeen tulevat funktion nimi, vasen kaarisulje, funktion argumentit puolipistein erotettuina ja oikea kaarisulje.

    2. Funktion nimi. Saat luettelon käytettävissä olevista funktioista napsauttamalla solua ja painamalla näppäinyhdistelmää VAIHTO+F3, jolloin Funktion lisääminen -valintaikkuna avautuu.

    Excel-kaavat – Lisää funktio -valintaikkuna

    3. Argumentit. Argumentit voivat olla lukuja, tekstiä, totuusarvoja (kuten TOSI tai EPÄTOSI), matriiseja, virhearvoja (kuten #PUUTTUU!), tai soluviittauksia. Määrittämäsi argumentin on tuotettava kelvollinen arvo kyseiselle argumentille. Argumentit voivat olla myös vakioita, kaavoja tai muita funktioita.

    4. Argumenttityökaluvihje. Kun kirjoitat funktiota, esiin tulee funktion syntaksin ja argumentit näyttävä työkaluvihje. Saat työkaluvihjeen näkyviin kirjoittamalla esimerkiksi =PYÖRISTÄ(. Vain ohjelman omiin funktioihin liittyy työkaluvihje.

    Huomautus: Sinun ei tarvitse kirjoittaa funktioita isoilla kirjaimilla, kuten =PYÖRISTÄ, sillä Excel muuttaa funktion nimen kirjaimet automaattisesti isoiksi, kun painat Enter-näppäintä. Jos kirjoitat funktion nimen väärin ja kirjoitat esimerkiksi =SUMME(A1:A10) sen sijaan, että kirjoittaisit =SUMMA(A1:A10), Excel palauttaa #NIMI?-virheen.

  • Excel-funktioiden kirjoittaminen

    Kun luot funktion sisältävän kaavan, Funktion lisääminen -valintaikkuna auttaa laskentataulukon funktioiden kirjoittamisessa. Kun valitset funktion Funktion lisääminen -valintaikkunasta, Excel avaa ohjatun funktion luomisen, joka näyttää funktion nimen, sen kaikki argumentit, funktion ja sen argumenttien kuvauksen, funktion nykyisen tuloksen ja koko kaavan nykyisen tuloksen.

    Ohjattu Excel-funktio-toiminto

    Voit helpottaa kaavojen luomista ja muokkaamista sekä vähentää kirjoitus- ja syntaksivirheitä käyttämällä kaavan automaattista täydennystä. Kun kirjoitat =-merkin (yhtäläisyysmerkin) ja funktion ensimmäiset kirjaimet, Excel näyttää avattavan luettelon, joka sisältää kyseisiä kirjaimia vastaavat funktiot, argumentit ja nimet. Voit valita yhden kohteen luettelosta ja Excel kirjoittaa sen puolestasi.

    Excel-kaavan automaattinen täydennys

  • Excel-funktioiden sisentäminen

    Funktioita voi tarvittaessa käyttää toisten funktioiden argumentteina. Esimerkiksi seuraavassa kaavassa käytetään sisennettyä KESKIARVO-funktiota, ja tuloksia verrataan arvoon 50.

    Sisäkkäiset funktiot

    1. KESKIARVO- ja SUMMA-funktiot ovat sisäkkäin JOS-funktiossa.

    Kelvolliset palautetut arvot    Kun sisennettyä funktiota käytetään argumenttina, sen on palautettava arvo, joka on tyypiltään samanlainen kuin argumentin käyttämä arvo. Jos argumentti palauttaa esimerkiksi arvon TOSI tai EPÄTOSI, sisäkkäisen funktion on palautettava arvo TOSI tai EPÄTOSI. Jos funktio ei palauta oikeantyyppistä arvoa, Excel näyttää #ARVO! ‑virhearvon.

    Sisennystasojen enimmäismäärä    Kaavassa voi olla sisäkkäisiä funktioita enintään seitsemässä tasossa. Kun funktiota B käytetään funktion A argumenttina, funktio B on toisen tason funktio. Esimerkiksi KESKIARVO- ja SUMMA-funktiot ovat toisen tason funktioita, jos niitä käytetään JOS-funktion argumentteina. Jos KESKIARVO-funktiolla olisi sisäkkäisiä funktioita, ne olisivat kolmannen tason funktioita, ja niin edelleen.

Kehitä Office-taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×