Office
Kirjaudu sisään

Automaattinen tallentaminen

Automaattinen tallennus

Tallenna ajoissa ja tallenna usein -ohjeen voi onneksi nykyään heittää romukoppaan. Nyt Automaattinen tallennus tallentaa tiedostot muutaman sekunnin välein puolestasi.

Automaattinen tallennus otetaan käyttöön, kun tallennat tiedoston OneDriveen, OneDrive for Businessiin tai SharePoint Onlineen. Se tallentaa tekemäsi muutokset automaattisesti pilveen työskennellessäsi. Jos muut käsittelevät samaa tiedostoa, he näkevät automaattisen tallennuksen ansiosta tekemäsi muutokset muutamassa sekunnissa.

Huomautus: Valitsetko Tiedosto > Tallenna nimellä tehtyäsi muutoksia alkuperäiseen asiakirjaan tai malliin? Siinä tapauksessa kannattaa valita Tiedosto > Tallenna kopio ennen muutosten tekemistä. Tällöin automaattinen tallennus ei korvaa alkuperäistä tiedostoa muutoksilla. Jos automaattinen tallennus korvasi tiedoston muutoksilla, lue lisää kohdasta En halunnut tallentaa muutoksia, miten siirryn takaisin?

Windowsissa automaattinen tallennus on Office 365 -tilaajien käytettävissä Excel 2016:ssa, Word 2016:ssa ja PowerPoint 2016:ssa. Seuraavassa on joitakin sitä koskevia usein kysyttyjä kysymyksiä.

Automaattinen tallennus on Windowsin uusi toiminto, joka on Office 365 -tilaajien käytettävissä Excel 2016:ssa, Word 2016:ssa ja PowerPoint 2016:ssa. Se tallentaa tiedoston automaattisesti puolestasi.

Automaattinen tallennus toimii muutaman sekunnin välein. Aika voi vaihdella käsiteltävän kohteen mukaan.

Voit palauttaa tiedoston aiemman version. Näin vanhempi versio palautetaan nykyiseksi versioksi.

Tiedostoa napsauttava kohdistin, näytä kaikki versiot

Napsauta tiedoston nimeä ikkunan yläreunassa ja napsauta sitten Näytä kaikki versiot. Tarkista päivämäärät ja kellonajat, jotta löydät palautettavan version, ja napsauta sitten Avaa versio. Esiin avautuu toinen ikkuna. Voit palata tähän versioon napsauttamalla Palauta-painiketta. Katso lisätietoja versiohistoriasta artikkelista Näytä Office-tiedostojen aiemmat versiot.

Jos olet tiedoston omistaja, voit lisätä Excel- ja Word-tiedostoihin asetuksen nimeltä ”Suositellaan vain luku”. Kun käyttäjät avaavat tiedoston tällä asetuksella, esiin tulevassa kehotteessa ilmoitetaan, että tekijä suosittelee tiedoston avaamista vain luku -tilassa. Voit ottaa tämän asetuksen käyttöön tiedostolle siirtymällä kohtaan Tiedosto > Tallenna kopio > Selaa. Napsauta sitten Työkalut > Yleisasetukset, ja valitse Suositellaan vain luku -valintaruutu. Napsauta OK, ja tallenna tiedosto sitten eri nimellä tai korvaa nykyinen tiedosto.

Voit suojata tiedostoa muokkaukselta myös muilla tavoilla. Jos tiedosto on OneDrivessä, voit muuttaa tiedoston käyttöoikeuksia. Jos tiedosto on SharePointissa, voit määrittää kirjaston edellyttämään uloskirjausta.

Tiedosto > Tallenna kopio

Tallenna nimellä -toimintoa ei löydy Tiedosto-valikosta, kun avaat tiedoston OneDrivesta, OneDrive for Businessista tai SharePoint Onlinesta. Näissä tapauksissa näet Tiedosto-valikossa sen sijaan Tallenna kopio -toiminnon.

Käytätkö Tallenna nimellä -toimintoa paljon? Monet ihmiset ovat tottuneet siihen, että työstäessään tiedostoa he valitsevat Tiedosto-valikosta Tallenna nimellä -toiminnon tallentaakseen muutokset kopioon, ei alkuperäiseen. Kun automaattinen tallennus on käytössä, muutoksesi tallennetaan kuitenkin aina alkuperäiseen. Siksi suosittelemme, että käytät Tiedosto > Tallenna kopio -toimintoa heti, jos haluat tallentaa muutoksesi kopioon alkuperäisen sijasta.

Tallenna-toimintoa ei löydy Tiedosto-valikosta, kun avaat tiedoston OneDrivesta, OneDrive for Businessista tai SharePoint Onlinesta. Näissä tilanteissa automaattinen tallennus on automaattisesti käytössä, joten sinun ei tarvitse valita Tiedosto-valikosta Tallenna. Automaattinen tallennus tallentaa tiedostot puolestasi.

Jos olet Office 365 -tilaaja ja sinulla on asennettuina uusimmat Excel-, Word- ja PowerPoint 2016 for Windows -versiot, näet automaattisen tallennuksen vasemmassa yläkulmassa. Ota huomioon, että jos sinulla on työpaikan tai oppilaitoksen tili, järjestelmänvalvoja voi määrittää, minkä Office-version voit asentaa, ja se ei välttämättä ole uusin versio. Katso lisätietoja artikkelista Milloin saan uusimmat ominaisuudet käyttööni Office 365:n Office 2016:ssa?. Jos käytät Office 2016 for Windowsia, syynä voi olla se, että yrityksesi tai oppilaitoksesi käyttää osavuosittaista päivityskanavaa. Näet, käytätkö tätä kanavaa, valitsemalla Tiedosto > Tili. Jos näytössä näkyy Osavuosittainen kanavaTietoja-kohdan vieressä, yhteismuokkaaminen ei ole vielä käytettävissäsi.

Jos et ole tilaaja, älä huoli. Voit silti käyttää automaattista palautusta. Automaattinen palautus suojaa tiedostojasi kaatumisen yhteydessä. Jos avaat tiedoston uudelleen kaatumisen jälkeen, näet viimeisimmät muutoksesi sisältävän tiedoston Asiakirjan palautus -ruudussa. Katso lisätietoja tämän toiminnon käyttöönotosta artikkelista Tiedostojen suojaaminen kaatumisen varalta.

Automaattinen tallennus on käytössä, kun työstettävänä on tiedosto, joka on tallennettu OneDriveen, OneDrive for Businessiin tai SharePoint Onlineen. Jos tiedosto on tallennettu jonnekin muualle, automaattinen tallennus on poissa käytöstä. Näin tapahtuu, jos tiedosto on paikallisessa SharePoint-sivustossa, tiedostopalvelimella tai paikallisen, esim. C:\-alkuisen, polun päässä.

Automaattisen tallennuksen käytöstä poistamiseen voi olla muitakin syitä. Seuraavassa on yleisiä syitä siihen, miksi se on poissa käytöstä:

  • Tiedosto on vanhassa tiedostomuodossa, kuten .xls, .ppt tai .doc.

  • Tiedosto on paikallisessa OneDrive-kansiossa ja OneDrive on pysäytettynä.

  • Vanha OneDrive-synkronointiohjelman versio synkronoi juuri tiedostoa. Lisätietoja OneDriven päivittämisestä on artikkelissa Uuden OneDrive-synkronointiohjelman käytön aloittaminen Windowsissa.

  • Tiedoston on upotettu toisen Office-tiedoston sisälle.

  • Esitys on diaesitystilassa.

Jos käytät Exceliä ja kokeilit yllä olevia ohjeita, tiedostosi saattaa sisältää ominaisuuksia, jotka eivät tue automaattista tallennusta. Voit ottaa sen käyttöön toimimalla seuraavasti:

  • Poista käytöstä Jaettu työkirja -ominaisuus. Tämä ominaisuus on vanha jakamistapa. Siinä on monia rajoituksia, ja se on korvattu yhteismuokkaamisella.

  • Poista salasanasuojaus tiedostosta, jos sitä ei tarvita: Valitse Tiedosto > Tiedot > Suojaa työkirja. Poista sitten salasana ja valitse OK.

  • Poista käyttöoikeuksien rajoitus, jos sitä ei tarvita: Valitse Tiedosto > Tiedot > Suojaa työkirja > Rajoita käyttöoikeuksia ja valitse Rajoittamaton käyttö.

  • Jos avaat työkirjan tilannevedoksen SharePointista, avaa tiedosto tilannevedoksen sijaan.

  • Poista käytöstä Päivitä tiedot tiedostoa avattaessa -asetus kaikissa tiedostossa olevissa taulukoissa ja Pivot-taulukoissa. Valitse taulukko tai pivot-taulukko ja valitse sitten Taulukkotyökalut Rakenne > Päivitä > Yhteyden ominaisuudet. Poista sitten käytöstä asetus Päivitä tiedot tiedostoa avattaessa.

  • Poista aktivointi apuohjelmasta, jonka takia automaattinen tallennus ei ole käytössä. Valitse Tiedosto > Asetukset > Apuohjelmat > Excel-apuohjelmat > Siirry ja poista valintaruudun valinta apuohjelman kohdalta.

Tämän voi tehdä kahdella eri tavalla: Voit valita Tiedosto > Tallenna kopio ja tallentaa tiedoston toiseen sijaintiin. Näin voit työstää täysin erillistä kopiota tiedostosta.

Toinen tapa on poistaa automaattinen tallennus käytöstä ennen muutosten tekemistä. Jos muutokset on tarkoitettu tilapäisiksi eikä tallennettaviksi, sulje tiedosto. Valitse sitten Ei, kun sinua pyydetään tallentamaan.

Jos et halua tallentaa jatkuvasti ja näyttää tekemiäsi muutoksia muille, voit poistaa automaattisen tallennuksen käytöstä. Kun olet valmis, valitse Tallenna. Tekemäsi muutokset näkyvät muille tätä tiedostoa käyttäville henkilöille vasta tämän jälkeen. (Voit myös ottaa Automaattisen tallennuksen taas käyttöön ja tallentaa ja jakaa muutoksesi.)

Automaattinen tarkistus on oletusarvoisesti aina käytössä pilveen tallennetuilla tiedostoilla. Jos kuitenkin otat automaattisen tallennuksen pois käytöstä tietyllä tiedostolla, ohjelma muistaa tämän ja pitää sen poissa toiminnasta aina kun avaat tiedoston uudestaan. Jos vaihdat sen takaisin käyttöön kyseiselle tiedostolle, ohjelma muistaa tämän ja pitää sen toiminnassa tällä tiedostolla.

Ei. Automaattisen tallennuksen ollessa poissa käytöstä automaattinen palautus pysyy toiminnassa. Katso lisätietoja kohdasta Tiedostojen suojaaminen kaatumisen varalta. Kun automaattinen tallennus on käytössä, automaattinen palautus ei ole toiminnassa, mutta tästä ei ole syytä huolestua. Tiedosto tallennetaan muutaman sekunnin välein pilvipalveluun. Jos ohjelma kaatuu käyttäessäsi pilvipalvelussa olevaa tiedostoa, sinun tarvitsee vain avata tiedosto uudelleen.

Jos poistat käytöstä automaattisen tallennuksen tietyssä tiedostossa, ohjelma muistaa sen ja pitää automaattisen tallennuksen poissa käytöstä aina, kun avaat tiedoston uudelleen. Jos otat sen takaisin käyttöön tietyssä tiedostossa, ohjelma muistaa sen ja pitää sen käytössä kyseisessä tiedostossa.

Jos haluat poistaa automaattisen tallennuksen käytöstä kaikissa tiedostoissa, valitse Tiedosto > Asetukset > Tallenna ja poista kohdan Tallenna automaattisesti OneDriven ja SharePoint Onlinen tiedostot oletusarvoisesti Wordissa vieressä olevan valintaruudun valinta.

Tiedosto > Asetukset > Tallenna-valintaikkuna, jossa näkyy valintaruutu automaattisen tallennuksen käyttöönottoa tai käytöstä poistoa varten

Käynnistä Word (tai muu käyttämäsi sovellus) uudelleen, niin muutos tulee voimaan.

Huomautukset: 

  • Jos haluat poistaa automaattisen tallennuksen käytöstä oletusarvoisesti kaikissa Office-sovelluksissa, kuten PowerPointissa ja Excelissä, sinun täytyy toistaa nämä vaiheet jokaista haluamaasi ohjelmaa varten.

  • Jos haluat, että yksittäiset tiedostot tallennetaan edelleen automaattisesti, voit avata kyseiset tiedostot ja ottaa automaattisen tallennuksen uudelleen käyttöön manuaalisesti kyseisissä tiedostoissa.

Aiheeseen liittyvät artikkelitpacteralocked100mathced

Excel-työkirjojen yhteiskäyttö
PowerPoint-esitysten yhteiskäyttö
Word-asiakirjojen yhteiskäyttö

Macissa automaattinen tallennus on Office 365 -tilaajien käytettävissä Excel 2016:ssa, Word 2016:ssa ja PowerPoint 2016:ssa. Seuraavassa on joitakin sitä koskevia usein kysyttyjä kysymyksiä.

Automaattinen tallennus on Macin uusi toiminto, joka on Office 365 -tilaajien käytettävissä Excel 2016:ssa, Word 2016:ssa ja PowerPoint 2016:ssa. Se tallentaa tiedoston automaattisesti puolestasi.

Automaattinen tallennus toimii muutaman sekunnin välein. Aika voi vaihdella käsiteltävän kohteen mukaan.

Voit palauttaa tiedoston aiemman version. Näin vanhempi versio palautetaan nykyiseksi versioksi. Valitse Tiedosto > Palauta > Selaa versiohistoriaa. Etsi Versiohistoria-ruudusta päivämäärien ja kellonaikojen perusteella se versio, jonka haluat palauttaa, ja valitse sitten Avaa versio. Näyttöön avautuu toinen ikkuna. Jos haluat palata tähän versioon, napsauta Palauta-painiketta.

Jos tiedosto on OneDrivessa, voit muuttaa tiedoston käyttöoikeuksia. Jos tiedosto on SharePointissa, voit määrittää kirjaston edellyttämään uloskirjausta.

Tallenna nimellä -toimintoa ei löydy Tiedosto-valikosta, kun avaat tiedoston OneDrivesta, OneDrive for Businessista tai SharePoint Onlinesta. Näissä tapauksissa näet Tiedosto-valikossa sen sijaan Tallenna kopio -toiminnon.

Käytätkö Tallenna nimellä -toimintoa paljon? Monet ihmiset ovat tottuneet siihen, että työstäessään tiedostoa he valitsevat Tiedosto-valikosta Tallenna nimellä -toiminnon tallentaakseen muutokset kopioon, ei alkuperäiseen. Kun automaattinen tallennus on käytössä, muutoksesi tallennetaan kuitenkin aina alkuperäiseen. Siksi suosittelemme, että käytät Tiedosto > Tallenna kopio -toimintoa heti, jos haluat tallentaa muutoksesi kopioon alkuperäisen sijasta.

Jos olet Office 365 -tilaaja ja sinulla on asennettuna Macin uusin Excel-, Word- ja PowerPoint 2016 -versio, näet automaattisen tallennuksen vasemmassa yläkulmassa. Ota huomioon, että jos sinulla on työpaikan tai oppilaitoksen tili, järjestelmänvalvoja voi määrittää, minkä Office-version voit asentaa, ja se ei välttämättä ole uusin versio. Katso lisätietoja artikkelista Milloin saan uusimmat ominaisuudet käyttööni Office 365:n Office 2016:ssa?

Jos et ole tilaaja, älä huoli. Voit silti käyttää automaattista palautusta. Automaattinen palautus suojaa tiedostojasi kaatumisen yhteydessä. Jos avaat tiedoston uudelleen kaatumisen jälkeen, näet viimeisimmät muutoksesi sisältävän tiedoston Asiakirjan palautus -ruudussa. Katso lisätietoja tämän toiminnon käyttöönotosta artikkelista Tiedostojen automaattinen tallentaminen ja palauttaminen.

Automaattinen tallennus on käytössä, kun työstettävänä on tiedosto, joka on tallennettu OneDriveen, OneDrive for Businessiin tai SharePoint Onlineen. Jos tiedosto on tallennettu jonnekin muualle, automaattinen tallennus on poissa käytöstä. Näin tapahtuu, jos tiedosto on paikallisessa SharePoint-sivustossa, tiedostopalvelimella tai paikallisessa tietokoneen kansiossa.

Sinun on lisäksi avattava tiedosto Wordin, Excelin tai PowerPointin Tiedosto-valikosta, jotta automaattinen tallennus aktivoituu.

Huomautus: Jos Tiedosto > Avaa -valintasi näyttää samalta kuin alla olevassa kuvassa, sinun on napsautettava Verkkosijainnit-painiketta ja valittava OneDrive- tai SharePoint-tiedosto sieltä, jotta automaattinen tallennus toimii. Avaa tiedosto -valikko, jossa on Omassa Mac-tietokoneessa -näkymä.

Automaattisen tallennuksen käytöstä poistamiseen voi olla muitakin syitä. Seuraavassa on yleisiä syitä siihen, miksi se on poissa käytöstä:

  • Tiedosto on vanhassa tiedostomuodossa, kuten .xls, .ppt tai .doc.

  • Tiedosto on paikallisessa OneDrive-kansiossa ja OneDrive on pysäytettynä.

  • Tiedoston on upotettu toisen Office-tiedoston sisälle.

  • Esitys on diaesitystilassa.

Jos käytät Exceliä ja kokeilit yllä olevia ohjeita, tiedostosi saattaa sisältää ominaisuuksia, jotka eivät tue automaattista tallennusta. Voit ottaa sen käyttöön toimimalla seuraavasti:

  • Poista käytöstä Jaettu työkirja -ominaisuus. Tämä ominaisuus on vanha jakamistapa. Siinä on monia rajoituksia, ja se on korvattu yhteismuokkaamisella.

  • Poista salasanasuojaus tiedostosta, jos sitä ei tarvita: Valitse Tarkista-välilehdessä Suojaa työkirja. Poista sitten salasana ja valitse OK.

  • Poista käyttöoikeuksien rajoitus, jos sitä ei tarvita: Valitse Tiedosto > Rajoita käyttöoikeuksia > Ei rajoituksia.

  • Jos avaat työkirjan tilannevedoksen SharePointista, avaa tiedosto tilannevedoksen sijaan.

  • Poista käytöstä Päivitä tiedot tiedostoa avattaessa -asetus kaikissa tiedostossa olevissa taulukoissa ja pivot-taulukoissa. Valitse taulukko tai pivot-taulukko ja siirry sitten Taulukko-välilehteen. Valitse Päivitä > Yhteyden ominaisuudet. Poista käytöstä asetus Päivitä tiedot tiedostoa avattaessa.

  • Poista aktivointi apuohjelmasta, jonka takia automaattinen tallennus ei ole käytössä. Valitse Työkalut > Excel-apuohjelmat ja poista valintaruudun valinta apuohjelman kohdalta.

Tämän voi tehdä kahdella eri tavalla: Voit valita Tiedosto > Tallenna kopio ja tallentaa tiedoston toiseen sijaintiin. Näin voit työstää täysin erillistä kopiota tiedostosta.

Toinen tapa on poistaa automaattinen tallennus käytöstä ennen muutosten tekemistä. Jos muutokset on tarkoitettu tilapäisiksi eikä tallennettaviksi, sulje tiedosto. Valitse sitten Ei, kun sinua pyydetään tallentamaan.

Jos et halua tallentaa jatkuvasti ja näyttää tekemiäsi muutoksia muille, voit poistaa automaattisen tallennuksen käytöstä. Kun olet valmis, valitse Tallenna. Tekemäsi muutokset näkyvät muille tätä tiedostoa käyttäville henkilöille vasta tämän jälkeen. (Voit myös ottaa Automaattisen tallennuksen taas käyttöön ja tallentaa ja jakaa muutoksesi.)

Automaattinen tarkistus on oletusarvoisesti aina käytössä pilveen tallennetuilla tiedostoilla. Jos kuitenkin otat automaattisen tallennuksen pois käytöstä tietyllä tiedostolla, ohjelma muistaa tämän ja pitää sen poissa toiminnasta aina kun avaat tiedoston uudestaan. Jos vaihdat sen takaisin käyttöön kyseiselle tiedostolle, ohjelma muistaa tämän ja pitää sen toiminnassa tällä tiedostolla.

Ei. Automaattisen tallennuksen ollessa poissa käytöstä automaattinen palautus pysyy toiminnassa. Katso lisätietoja kohdasta Tiedostojen automaattinen tallentaminen ja palauttaminen. Kun automaattinen tallennus on käytössä, automaattinen palautus ei ole toiminnassa, mutta tästä ei ole syytä huolestua. Tiedosto tallennetaan muutaman sekunnin välein pilvipalveluun. Jos ohjelma kaatuu käyttäessäsi pilvipalvelussa olevaa tiedostoa, sinun tarvitsee vain avata tiedosto uudelleen.

Et, voit kuitenkin poistaa automaattisen tallennuksen käytöstä tietyssä tiedostossa: ohjelma muistaa tämän ja pitää automaattisen tallennuksen poissa käytöstä aina, kun avaat tiedoston uudestaan. Jos otat sen takaisin käyttöön kyseisessä tiedostossa, ohjelma muistaa tämän ja pitää sen käytössä tässä tiedostossa.

Kehitä Office-taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×