Office
Kirjaudu sisään

Arvon esiintymiskertojen laskeminen

Laskentataulukossa on useita toimintoja, joilla voit laskea, kuinka monta kertaa tietty teksti- ja numeroarvo esiintyy solualueella. Voit esimerkiksi laskea LASKE.JOS-funktiolla seuraavan esimerkin tavoin, kuinka monta kertaa yksittäinen arvo esiintyy.

Esimerkki

Myyjä

Lasku

Larsson

15 000

Larsson

9 000

Lidman

8,000

Lidman

20 000

Larsson

5 000

Suominen

22 500

Kaava

Kuvaus

Tulos

=LASKE.JOS(A2:A7,"Larsson")

Larssonin merkintöjen määrä (3)

3

=LASKE.JOS(A2:A7,A4)

Lidmanin merkintöjen määrä (2)

2

=LASKE.JOS(B2:B7,"< 20000")

Laskuarvojen määrä pienempi kuin 20 000 (4)

4

=LASKE.JOS(B2:B7,">="&B5)

Laskuarvojen määrä suurempi tai yhtä suuri kuin 20 000 (2)

2

Useisiin ehtoihin perustuvien arvojen laskeminen LASKE.JOS.JOUKKO-funktiolla

LASKE.JOS.JOUKKO-funktio on yhtä tärkeää poikkeusta lukuun ottamatta samanlainen kuin LASKE.JOS-funktio. LASKE.JOS.JOUKKO-funktio sallii ehtojen käyttämisen useiden alueiden soluissa ja laskee, montako kertaa kaikki ehdot täyttyvät. Voit käyttää jopa 127 alue/ehto-paria LASKE.JOS.JOUKKO-funktiolla. Funktion syntaksi näyttää tältä:

LASKE.JOS.JOUKKO(ehtoalue1, ehto1, [ehtoalue2, ehto2],…)

Esimerkki

Työntekijätunnus

Aluenumero

Osasto

20552

2

Myynti

21268

2

Talous

23949

1

Hallinto

24522

4

Hallinto

28010

3

IT

29546

4

Myynti

31634

3

IT

32131

1

IT

35106

4

Talous

40499

1

Henkilöstö

42051

1

Myynti

43068

2

Henkilöstö

45382

2

Talous

47971

1

IT

Kaava

Kuvaus

Tulos

=LASKE.JOS(B2:B15,"2",C2:C15,"Talous")

Alueen 2 ja talousosaston työntekijöiden määrä

2

Ensimmäinen ehtoalue sisältää kaikki alueiden numerot ja toinen ehtoalue sisältää kaikkien osastojen nimet. Ensimmäiseen ehtoalueeseen sovellettava ehto on "2", ja toiseen ehtoalueeseen sovellettava ehto on "Talous". LASKE.JOS-funktio tarkastaa, että molemmat ehdot täyttyvät.

Kehitä Office-taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×