Yhteenveto Excel-tietojen lisäämis- ja laskemistavoista

Yhteenveto Excel-tietojen lisäämis- ja laskemistavoista

Laske- ja Summa-funktion ero
Summien laskeminen (arvojen yhteenlasku) on olennainen osa tietoanalyysia riippumatta siitä, millaisia tietoja analysoit. Excel tarjoaa useita eri tekniikoita summien laskemiseen.

Tämä artikkeli sisältää kattavan yhteenvedon näistä eri tekniikoista sekä lisätietoja, joiden avulla voit päättää käytettävän tekniikan nopeasti. Lisäksi artikkeli sisältää linkkejä tarkempiin ohjeartikkeleihin.

Summan laskemista ei pidä sekoittaa lukumäärien laskemiseen. Jos haluat lisätietoja solujen, sarakkeiden tai rivien lukumäärien laskemisesta, tutustu Tietoa sisältävien solujen, rivien tai sarakkeiden laskemiseen.

Artikkelin sisältö

Yksinkertaiset yhteen- ja vähennyslaskut

Voit tehdä lukujen yhteen- ja vähennyslaskuja yksinkertaisella kaavalla, napsauttamalla painiketta tai taulukon funktiolla.

Solun arvojen yhteenlaskeminen yksinkertaisella kaavalla

Jos tarvitset tuloksen nopeasti, voit käyttää Exceliä myös laskukoneena. Voit tehdä tämän hyödyntämällä plusmerkkiä (+) aritmeettisena operaattorina. Jos esimerkiksi kirjoitat soluun kaavan =5+10, Excel näyttää tuloksena 15.

Jos haluat lisätietoja aritmeettisten operaattoreiden käytöstä kaavoissa, lue ohjeartikkeli Excelin käyttö laskimena.

Sivun alkuun

Solun arvojen vähennyslasku yksinkertaisella kaavalla

Voit tehdä tämän hyödyntämällä miinusmerkkiä (-) aritmeettisena operaattorina. Esimerkiksi kaava =12-9 antaa tulokseksi 3.

Jos haluat lisätietoja aritmeettisten operaattoreiden käytöstä kaavoissa, lue ohjeartikkeli Excelin käyttö laskimena.

Sivun alkuun

Sarakkeen tai rivin arvojen yhteenlasku painiketta painamalla

Voit laskea yhteen alueen, sarakkeen tai rivin lukujen summan nopeasti Automaattinen summa -painikkeella. Napsauta tyhjää solua sarakkeen lukujen alapuolella tai rivin lukujen oikealla puolella ja napsauta sitten Automaattinen summa -painiketta. Excel valitsee todennäköisimmän tietoalueen. Voit hyväksyä Excelin valitseman tietoalueen napsauttamalla Automaattinen summa -painiketta uudelleen. Voit myös valita itse haluamasi alueen ja napsauttaa sitten Automaattinen summa -painiketta.

Tietorivin arvojen summan lisääminen nopeasti Summa-painikkeen avulla

Jos haluat lisätietoja automaattisen summan käytöstä, lue ohjeartikkeli Excelin käyttö laskimena.

Sivun alkuun

Alueen arvojen yhteenlasku funktiolla

SUMMA-funktiolla voit tehdä helposti eri alueiden arvojen yhteen- ja vähennyslaskuja ja yhdistää lukuarvoja lukualueisiin. SUMMA-funktiolla voit laskea yhteen kaikki parametrit, jotka määrität funktion aloittavan ja sulkevan sulkumerkin väliin. Jokainen argumentti voi olla alue, soluviittaus tai positiivinen tai negatiivinen numeroarvo.

Jos haluat määrittää yksinkertaisen kaavan, kirjoita soluun =SUMMA ja sen perään funktion aloittava sulkumerkki. Kirjoita sen perään haluamasi luvut, soluviittaukset tai solualueet pilkuin erotettuina. Kirjoita tämän jälkeen funktion lopettava sulkumerkki. Paina sitten Enteriä nähdäksesi tuloksen. Voit valita haluamasi tiedot sisältävät solut yhteenlaskettavaksi myös hiirellä.

1

2

3

A

Yleisömäärä

4823

12335

Esimerkiksi edellä olevassa taulukon mukaisesti kaikki alla mainitut kaavat käyttävät SUMMA-funktiota, jonka perusteella ne antavat saman tuloksen (17158).

  • =SUMMA(4823,12335)

  • =SUMMA(A2;A3)

  • =SUMMA(A2:A3)

  • =SUMMA(A2,12335)

Seuraavassa kuvassa näet kaavan, jossa lasketaan yhteen solun A2-arvo ja luku 12335 SUMMA-funktiolla. Kaavan alla näet kohdeohjeen, joka antaa ohjeita SUMMA-funktion käyttöön.

Solun ja arvon laskeminen yhteen SUMMA-funktion avulla.

Huomautukset: 

  • Excelissä ei ole VÄHENNÄ-funktiota. Jos haluat vähentää arvoja funktion avulla, käytä negatiivisia numeroarvoja SUMMA-funktiossa. Esimerkiksi kaava =SUMMA(30,A3,-15,-B6) lisää 30 ja solun A3 arvon, vähentää 15 ja vähentää myös solussa B6 olevan arvon.

  • Voit sisällyttää SUMMA-funktioon argumentteina enintään 255 numeerista arvoa tai solu- tai alueviittauksia kaikenlaisina yhdistelminä.

Saat lisätietoja SUMMA-funktioon liittyvästä artikkelista.

Sivun alkuun

Alueen arvojen vähennyslasku funktiolla

SUMMA-funktiolla voit tehdä lukujen vähennyslaskuja, kun annat haluamasi luvut kaavaan negatiivisina lukuina.

1

2

3

A

Yleisömäärä

29072

12335

Edellä olevassa taulukossa kaikki alla mainitut kaavat käyttävät SUMMA-funktiota, jonka perusteella ne antavat saman tuloksen (16737).

  • =SUMMA(29072,-12335)

  • =SUMMA(A2,-A3)

  • =SUMMA(A2,-12335)

  • =SUMMA(A2,(-1*(A3)))

Sivun alkuun

Tietojen yhteenlaskeminen ryhmittelyn ja Pivot-toimintojen avulla

Voit ryhmitellä tietoja ja tehdä niiden yhteenvetoja jäsennyksen ja Pivot-taulukkoraportin avulla.

Sarakkeen arvojen yhteenlasku jäsennyksen avulla

Jos tiedot on järjestetty luetteloksi ja voit ryhmitellä sarakearvoja loogisesti, voit ryhmitellä tietoja ja tehdä niiden yhteenvetoja luomalla jäsennyksen. Jäsennyksen avulla voit tehdä tiedoista yhteenvedon lisäämällä välisummia ja loppusummia. Oletetaan, että sinulla on seuraavat myyntiluvut alueen ja kuukauden mukaan järjestettynä.

1

2

3

4

5

6

7

A

B

C

Alue

Kuukausi

Myynti

Itä

Tammikuu

18 000 €

Itä

Helmikuu

23 000 €

Itä

Maaliskuu

19 000 €

Länsi

Tammikuu

17 000 €

Länsi

Helmikuu

27 000 €

Länsi

Maaliskuu

21 000 €

Seuraavassa kuvassa näet alueen mukaan ryhmitellyn jäsennyksen, jossa on välisummat ja loppusumma.

Jäsennys, jossa on välisummat ja kokonaissumma

Luo jäsennys, välisummat ja loppusumma Välisumma-komennolla (Tiedot -välilehden Jäsennys-ryhmässä).

Alkuperäisissä tiedoissa oli kolme riviä Itä-alueen tiedoille ja kolme riviä Länsi-alueen tiedoille (rivit 2–7). Ota huomioon, että välisummatoiminto lisäsi idän kokonaissumman riville 5, idän viimeisen tietorivin ja lännen ensimmäisen tietorivin väliin.

Jos napsautat solua A4 ja sitten Välisumma-komentoa, Excel luo jäsennyksen ja lisää rivit idän kokonaissummalle, lännen kokonaissummalle sekä kokonaissummalle. Lisäksi se lisää nämä summat Myynti-sarakkeen soluihin.

Lisätietoja on seuraavissa artikkeleissa:

Jäsennyksen luominen laskentataulukon tiedoista

Välisummien lisääminen laskentataulukon tietojen luetteloon

Sivun alkuun

Luettelon tai Excel-taulukon sarakkeen arvojen yhteenlaskeminen funktiolla

Jos tarvitset Välisumma-komentoa joustavampaa ratkaisua, voit käyttää VÄLISUMMA-funktiota. Sillä voit laskea välisummat ja kokonaissummat luetteloista ja Excel-taulukoista, joissa on piilotettuja rivejä ja sarakkeita. VÄLISUMMA-funktiossa määrität argumentin, joka joko sisällyttää piilotetut arvot tai jättää ne pois.

Huomautus: VÄLISUMMA-funktiolla voit hallita sitä, sisällytetäänkö piilotetut rivit tuloksiin. Lisäksi se jättää aina huomiotta pois suodatetut rivit.

Oletetaan, että haluat esimerkiksi laskea välisummat ja kokonaissumman tiedoille soluista C2–C7, mutta haluat jättää pois rivien 3 ja 6 piilotetut tiedot. Voit tehdä tämän seuraavalla funktiolla:

= VÄLISUMMA( 109,C2:C7)

Ensimmäinen argumentti (109) määrittää, että haluat laskea alueen arvot yhteen ja ohittaa piilotetut arvot. Jos haluat sen sijaan sisällyttää piilotetut arvot mukaan, käytä ensimmäisenä argumenttina lukua 9.

Tarkempia tietoja on artikkeleissa VÄLISUMMA-funktio ja Excel-taulukon tietojen laskeminen yhteen.

Sivun alkuun

Tietojen yhteenlaskeminen ja tietojen analysointi eri perspektiiveistä

Kun laskentataulukko sisältää satoja tai jopa tuhansia samankaltaisia tietorivejä, luvuista voi olla vaikea johtaa merkityksiä. Voit luoda Excelissä näistä tiedoista Pivot-taulukkoraportin, jossa näytetään välisummat ja loppusummat ja jossa voit tehdä tiedoista yhteenvetoja määrittämiesi luokkien perusteella.

Voit luoda Pivot-taulukon nopeasti valitsemalla solun tietoalueesta tai Excel-taulukosta ja valitsemalla sitten Lisää-välilehden Taulukot-ryhmästä Pivot-taulukko.

Ota huomioon, että seuraavassa esimerkissä Pivot-taulukossa on myyntitietoja useilla riveillä (itse asiassa tietoja on 40 riviä, mutta kuvassa näkyy vain osa). Tällä tavalla haluamme esitellä Pivot-taulukoiden tehokkaita toimintoja. Lisäksi tiedoista ei ole tehty yhteenvetoja eikä niissä näytetä välisummia ja kokonaissummaa.

Pivot-taulukkoraportissa käytetyt tiedot

Samoihin tietoihin perustuva Pivot-taulukkoraportti näyttää välisummat ja kokonaissumman. Lisäksi se tarjoaa tiiviin yhteenvedon yhdellä vilkaisulla.

Pivot-taulukkoraportissa näkyvät summat ja tietojen yhteenveto

Pivot-taulukoiden luominen ja käsittely saattaa edellyttää jonkin verran tietojen esivalmistelua ja tiettyjen käsitteiden tuntemista.

Saat tarkemmat ohjeet, joilla pääset alkuun, tutustumalla seuraaviin ohjeartikkeleihin:

Arvojen laskeminen Pivot-taulukkoraportissa

Välisumma- ja summakentät Pivot-taulukkoraportissa

Sivun alkuun

Tietojen yhteenlaskeminen ehdon tai ehtojen perusteella

Laskentataulukkofunktioiden avulla voit käyttää ehtoja, joiden perusteella lasketaan yhteen vain määrittämäsi ehdot täyttävät tiedot.

Alueen arvojen yhteenlaskeminen yhden ehdon perusteella yhden funktion tai useiden funktioiden avulla

Käytä joko SUMMA.JOS-funktiota tai aseta SUMMA-funktio JOS-funktioon sisään.

Voit lisätä lukuja yhden ehdon perusteella SUMMA.JOS-funktiolla tai SUMMA- ja JOS-funktioiden yhdistelmällä.

Esimerkiksi kaava =SUMMA.JOS(A2:A6,">20") laskee yhteen alueelta A2–A6 vain ne luvut, jotka ovat suurempia kuin 20.

Huomautus: Seuraavat tiedot ovat melko teknisiä, mutta ne kannattaa silti opetella tuntemaan.

Jos SUMMA.JOS-funktiota ei olisi, saisit silti saman tuloksen yhdistämällä JOS- ja SUMMA-funktioita. Tämä tarkoittaa sitä, että asetat nämä kaksi funktiota sisäkkäin.

Jos haluat luoda SUMMA.JOS-funktion toimintaa jäljittelevän kaavan, määritä kaava, joka käsittelee soluja A2–A6 matriisina. Tämä tarkoittaa sitä, että aluetta käsitellään yhtenä kokonaisuutena, joka sisältää viisi solua.

Kaava näyttää seuraavalta: {=SUMMA(JOS(A2:A6>20,A2:A6))}. Kaavaa ympäröivät aaltosulkeet osoittavat, että tämä on matriisikaava. Matriisikaava edellyttää vähän erityiskäsittelyä: Sen sijaan, että kirjoitat aaltosulkeet itse, sinun täytyy painaa CTRL + VAIHTO + ENTER. Tällöin Excel lisää kaavan =SUMMA(JOS(A2:A6>20,A2:A6)) ympärille aaltosulkeet. Jos kirjoitat aaltosulkeet itse, et luo matriisikaavaa.

Kokeile seuraavaa!    

Kopioi tiedot seuraavasta taulukosta laskentataulukon soluun A1. Kun olet liittänyt tiedot, näet, että solussa A10 on #ARVO!-virhe. Tämä tarkoittaa sitä, että sinun täytyy muuntaa solu A10 matriisikaavaksi. Voit tehdä tämän painamalla F2-näppäintä ja painamalla sitten CTRL + VAIHTO + ENTER. Excel näyttää tuloksen (65) soluissa A8 ja A10.

Esimerkkilaskentataulukon tietojen kopioiminen

  • Luo tyhjä työkirja tai laskentataulukko.

  • Valitse esimerkki ohjeaiheesta.

    Huomautus: Älä valitse rivi- tai sarakeotsikoita.

    Esimerkin valitseminen ohjeesta
    Esimerkin valitseminen ohjeesta
  • Paina näppäinyhdistelmää CTRL+C.

  • Valitse taulukosta solu A1 ja paina CTRL+V.

  • Voit vaihdella tulosten ja kaavojen näyttämisen välillä painamalla näppäinyhdistelmää CTRL + ` (gravis-aksentti).

1

2

3

4

5

6

7

8

9

10

A

Paino

18

29

36

11

16

SUMMA.JOS-funktion käyttäminen

=SUMMA.JOS(A2:A6,">20")

SUMMA- ja JOS-funktioiden käyttäminen

=SUMMA(JOS(A2:A6>20,A2:A6))

Tutustu myös Knowledge Base -artikkeliin XL: Milloin kannattaa käyttää SUMMA(JOS())-funktiota LASKE.TYHJÄT()-funktion asemesta, josta saat lisätietoja siitä, milloin SUMMA.JOS-funktiota kannattaa käyttää.

Sivun alkuun

Sarakkeen arvojen yhteenlaskeminen yhden ehdon tai useiden ehtojen perusteella funktion avulla

TSUMMA-funktiolla voit laskea yhteen luettelon tietuekentästä (sarake) tai tietokannasta yhteen lukuja, jotka täyttävät määrittämäsi ehdot.

Voit käyttää TSUMMA-funktiota, kun sinulla on sarakeluettelo ja kun mielestäsi on helpompaa määrittää ehdot erilliselle solualueelle kuin käyttää sisäkkäistä funktiota.

Saat lisätietoja TSUMMA-funktion omasta ohjeartikkelista.

Sivun alkuun

Alueen arvojen yhteenlaskeminen useiden ehtojen perusteella ohjatun toiminnon avulla (vain Excel 2007)

Voit käyttää ohjattua ehdollista summaa (Kaavat > Ratkaisut > Ehdollinen summa), jos haluat laskea yhteen useisiin ehtoihin perustuvia arvoja.

Tärkeää: Ohjattu ehdollinen summa on käytettävissä vain Excel 2007 -ohjelmassa ja aikaisemmissa versioissa. Lisätietoja on artikkelissa Mitä on tapahtunut Ohjattu ehdollinen summa -apuohjelmalle?.

Jos komento ei ole käytettävissä (Ratkaisut-ryhmä ei myöskään välttämättä ole näkyvissä), asenna ja lataa Analyysityökalut-apuohjelma.

Analyysityökalujen lataaminen

Valitse Microsoft Office -painike Office-painikkeen kuva , valitse Excelin asetukset ja sitten Apuohjelmat-luokka.

  1. Valitse Hallinta-luettelosta Excel-apuohjelmat ja valitse sitten Siirry.

  2. Valitse Käytettävissä olevat apuohjelmat -luettelon Analyysityökalut-ruutu ja valitse sitten OK.

  3. Jos ohjattu toiminto näkyy Passiiviset sovellusapuohjelmat -luettelossa, valitse ohjattu toiminto ja aktivoi se napsauttamalla Siirry.

  4. Noudata tarvittaessa asennusohjelman ohjeita.

Jos haluat käyttää ohjattua ehdollista summaa, valitse tietoalue ja napsauta Ehdollinen summa -komentoa (Kaavat-välilehden Ratkaisut-ryhmässä). Viimeistele ohjattu toiminto seuraamalla vaiheita 1–4. Seuraavassa kuvassa näytetään ohjatun toiminnon 2. vaihe, jossa on yksi ehto: Yhteen laskettavien arvojen on oltava suurempia kuin 100.

Ohjattu ehdollinen summa: vaihe 2/4

Sivun alkuun

Alueen arvojen yhteenlaskeminen useiden ehtojen perusteella yhden funktion tai useiden funktioiden avulla

Käytä SUMMA.JOS.JOUKKO-funktiota. Anna alue, jonka arvot haluat laskea yhteen, alue, joka sisältää ehtoja, ja ehdot, joita käytetään ehtoalueella. Voit vaihtoehtoisesti käyttää myös sisäkkäisiä SUMMA- ja JOS-funktioita.

Saat lisätietoja SUMMA.JOS.JOUKKO-funktioon liittyvästä ohjeartikkelista.

Saat lisätietoja myös seuraavista Knowledge Base -artikkeleista:

Sivun alkuun

Potenssiarvojen ja matriisiarvojen yhteenlaskeminen

Laskentataulukkofunktioilla voit laskea yhteen vastaavia arvoja kahdesta tai useammasta sarakkeesta. Tällainen toiminto voi olla yksinkertainen, kuten painotetun keskiarvon määrittäminen (katso seuraava esimerkki keskiarvon laskemisesta), tai hyvinkin monimutkainen tilastollinen laskutoimitus tai muu vastaava laskutoimitus.

Vähintään yhden matriisin toisiaan vastaavien arvojen tulojen summan laskeminen

Käytä TULOJEN.SUMMA-funktiota. Voit laskea esimerkiksi oppilaan arvosanojen keskiarvon hyödyntämällä ensin TULOJEN.SUMMA-funktiota ja jakamalla sitten sen antaman tuloksen opintopisteiden määrällä, kuten seuraavassa esimerkissä.

Kahden matriisin vastaavien arvojen kertominen

Kaava =TULOJEN.SUMMA(A2:A6,B2:B6)/SUM(B2:B6) kertoo kunkin kurssin arvosanan sen opintopisteiden määrällä, laskee nämä tulokset yhteen (61,3), jakaa summan opintopisteiden kokonaismäärällä (18) ja laskee sitten keskiarvon (3,41). Tätä kutsutaan painotetuksi keskiarvoksi.

TULOJEN.SUMMA-funktiolla voit suorittaa myös vaativampia matemaattisia laskutoimituksia kertomalla useita matriiseja.

TULOJEN.SUMMA-funktiota on helppo käyttää sellaisten matriisien kanssa, joissa on samat dimensiot, mutta voit myös käyttää SUMMA-funktiota kohteessa matriisikaava, jos tarvitset joustavampaa ratkaisua.

Saat tarkempia tietoja TULOJEN.SUMMA-funktion omasta ohjeartikkelista.

Seuraavaa neljää funktiota käytetään yleensä vain vaativissa tilastollisissa tai matemaattisissa laskutoimituksissa, joten niistä annetaan vain lyhyt kuvaus. Saat tarkempia tietoja kustakin funktiosta napsauttamalla sen nimeä. Näin pääset funktion omaan ohjeartikkeliin.

Sivun alkuun

Erityistapaukset (juokseva summa, yksilölliset arvot)

Laskentataulukkofunktioilla voit luoda summia, jotka päivitetään automaattisesti lisätessäsi tietoja alueeseen tai taulukkoon, tai lisätä vain yksilölliset arvot, jotka löytyvät alueesta tai taulukosta.

Juoksevan summan luominen funktiolla

Käytä SUMMA-funktiota. Luo taulukkoon esimerkiksi seuraavat sarakeotsikot: Panot, Nostot ja Saldo.

  1. Kirjoita Saldo-sarakkeen ensimmäiseen soluun alkusaldosi.

  2. Kirjoita suoraan saldon alapuolella olevaan soluun (tässä tapauksessa C3) kaava, joka laskee sen kanssa yhteen Panot-sarakkeen saman rivin arvon ja vähentää tämän laskutoimituksen tuloksesta Nostot-sarakkeen saman rivin arvon: (=SUMMA(C2,A3,-B3).

  3. Vedä tätä kaavaa alaspäin kaikille lisäämillesi uusille riveille. Seuraavassa esimerkissä se vedetään riville 4.

    Esimerkkiä on ehkä helpompi tarkastella, jos kopioit sen tyhjään laskentataulukkoon.

    Esimerkin kopioiminen

    • Luo tyhjä työkirja tai laskentataulukko.

    • Valitse esimerkki ohjeaiheesta.

      Huomautus: Älä valitse rivi- tai sarakeotsikoita.

      Esimerkin valitseminen ohjeesta

      Esimerkin valitseminen ohjeesta

    • Paina näppäinyhdistelmää CTRL+C.

    • Valitse taulukosta solu A1 ja paina CTRL+V.

    • Voit vaihdella tulosten ja tuloksia palauttavien kaavojen tarkastelemisen välillä painamalla CTRL+` (gravis) tai napsauttamalla Kaavat-välilehdessä Kaavan tarkistaminen -ryhmän Näytä kaavat -painiketta.

1

2

3

4

A

B

C

Panot

Nostot

Saldo

500

1000

625

=SUMMA(C2,A3,-B3)

1000

740

=SUMMA(C3,A4,-B4)

Juoksevan saldon avulla voit seurata solujen arvojen suurenemista ja pienenemistä, kun lisäät uusia kohteita ja arvoja ajan myötä.

Katso lisätietoja juoksevan saldon laskemista käsittelevästä artikkelista.

Sivun alkuun

Yksilöllisten arvojen lisääminen alueeseen yhdistelmäkaavalla

Anna sarakkeeseen arvoluettelo, jossa on identtisiä arvoja, ja käytä sitten SUMMA-, JOS- ja TAAJUUS-funktioita, joilla voit laskea yhteen vain alueelta löytyvät yksilölliset arvot.

Sivun alkuun

Muiden laskentataulukoiden tai työkirjojen arvojen sisällyttäminen kaavaan

Voit tehdä yhteen- ja vähennyslaskuja soluille tai tietoalueille, jotka ovat peräisin muista taulukoista tai työkirjoista. Voit tehdä tämän kaavalla, johon lisäät viittauksen näihin. Jos haluat viitata soluun tai alueeseen toisessa taulukossa tai työkirjassa, toimi seuraavan taulukon ohjeiden mukaisesti.

Viitattava kohde:

Kirjoita tämä

Esimerkkejä

Solu tai alue saman työkirjan muussa laskentataulukossa

Kirjoita laskentataulukon nimi, sen perään huutomerkki ja tämän jälkeen soluviittaus tai alueen nimi.

Taul2!B2:B4
Taul3!Myyntiluvut

Solu tai alue toisessa tällä hetkellä auki olevassa työkirjassa

Kirjoita työkirjan nimi hakasulkeissa ([]), sen perään laskentataulukon nimi, tämän perään huutomerkki ja tämän jälkeen soluviittaus tai alueen nimi.

[Omatyökirja.xlsx]Taul1!A7

Solu tai alue toisessa työkirjassa, joka ei ole sillä hetkellä auki

Kirjoita työkirjan koko polku ja tiedostonimi hakasulkeissa ([]), sen perään laskentataulukon nimi, tämän perään huutomerkki ja tämän jälkeen soluviittaus tai alueen nimi. Jos täydellisessä polussa on välilyöntejä, aloita koko polku puolilainausmerkeillä ja lopeta ne laskentataulukon nimen perään (katso esimerkki).

['C:\Omat tiedostot\[Omatyökirja.xlsx]Taul1'!A2:A5

Sivun alkuun

Päivämäärä- ja kellonaika-arvojen yhteen- ja vähennyslaskeminen

Päivämäärä- ja kellonaikafunktioilla ja yksinkertaisilla yhteen- ja vähennyslaskuilla voit laskea kuluneen ajan, arvioida projektien valmistumispäiviä ja paljon muuta. Seuraavasta taulukosta näet joitain kaavoja, joilla voit laskea kulunutta aikaa ja kuluneita päiviä. Ota huomioon, että jos päivämäärän tai kellonajan vähennyslaskun tulos on negatiivinen, Excel näyttää kaavan sisältämässä solussa tulokseksi ###.

Esimerkkiä on ehkä helpompi tarkastella, jos kopioit sen tyhjään laskentataulukkoon.

Esimerkin kopioiminen

  • Luo tyhjä työkirja tai laskentataulukko.

  • Valitse esimerkki ohjeaiheesta.

    Huomautus: Älä valitse rivi- tai sarakeotsikoita.

    Esimerkin valitseminen ohjeesta

    Esimerkin valitseminen ohjeesta

  • Paina näppäinyhdistelmää CTRL+C.

  • Valitse taulukosta solu A1 ja paina CTRL+V.

  • Voit vaihdella tulosten ja tuloksia palauttavien kaavojen tarkastelemisen välillä painamalla CTRL+` (gravis) tai napsauttamalla Kaavat-välilehdessä Kaavan tarkistaminen -ryhmän Näytä kaavat -painiketta.

1

2

3

4

5

A

B

C

Aloitusaika

Päättymisaika

Kuluneen ajan kaava

Kuvaus (tulos)

11.55.24

14.48.13

=B2-A2

Näyttää kuluneen ajan tunnit, minuutit ja sekunnit. Tässä tapauksessa Excel näyttää tuloksena 2.52.49. 12 tunnin kellossa käytetään ip- ja ap-muotoja erottamaan alle ja yli 12 tunnin erot toisistaan.

Aloituspäivä

Lopetuspäivä

Kuluneiden päivien kaava

Kuvaus (tulos)

28.5.2008

3.6.2008

=B5-A5

Näyttää kuluneet päivät lukuna (6).

Päivämäärä ja aika-arvojen käyttäminen voi aiheuttaa odottamattomia tuloksia, joten etene huolellisesti.

Sivun alkuun

Laskutoimituksien näyttäminen Excelin tilarivillä

Jos haluat nähdä laskentataulukossa valittujen solujen summat nopeasti, katso Excelin tilariviä (se on ikkunan alareunassa).

Kun olet valinnut yhden tai useamman solun, niiden tiedot näytetään Excelin tilarivillä. Jos valitset taulukosta esimerkiksi neljä solua, jotka sisältävät luvut 2 ja 3, tekstimerkkijonon (esimerkiksi pilvi) ja luvun 4, tilarivillä voidaan näyttää kaikki seuraavista arvoista samanaikaisesti: keskiarvo, määrä, lukuarvosolujen määrä, pienin arvo, suurin arvo ja summa. Voit näyttää tai piilottaa minkä tahansa arvon tai kaikki arvot napsauttamalla tilariviä hiiren kakkospainikkeella. Nämä arvot näytetään kuten kuvassa.

Tilarivi, joka näyttää valittujen solujen laskelmat ja määrät

Sivun alkuun

Kehitä taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×