Yhdistämisen luominen

Tärkeää: Tämä on artikkeli on käännetty koneellisesti. Lue vastuuvapauslauseke. Tämän artikkelin englanninkielinen versio on täällä .

Yhdistämisen avulla voit luoda suuria määriä asiakirjoja, jotka ovat lähes samanlaisia mutta eroavat tiedoiltaan hieman toisistaan. Yhdistämistoiminnolla voit luoda esimerkiksi yksilöllisesti mukautettuja julkaisuja, jotka sisältävät henkilökohtaisia huomautuksia. Voit myös luoda tuotetarjouksen lähetettäväksi sadalle tärkeimmälle asiakkaallesi. Julkaisun teksti pysyy samana, mutta julkaisussa on kunkin asiakkaan yksilölliset nimi- ja osoitetiedot.

Yhdistäminen-tehtäväruutu sisältää ohjeet yhdistämisasiakirjan luomista varten. Voit avata Yhdistäminen-tehtäväruudun nykyisessä tai uudessa julkaisussa valitsemalla Työkalut-valikon, osoittamalla hiirellä Yhdistäminen ja luetteloyhdistäminen -vaihtoehtoa ja valitse sitten Yhdistäminen.

Tämän artikkelin sisältö

Luo tai vastaanottajaluettelon yhdistäminen

Julkaisun valmisteleminen

Yhdistetyn julkaisun luominen

Yhdistämisen peruuttaminen

Vastaanottajaluettelon luominen tai yhteyden muodostaminen siihen

Yhdistämistä varten on avattava uusi tai aiemmin luotu julkaisu ja muodostettava yhteys tietolähteeseen eli tiedostoon, joka sisältää julkaisuun lisättävät yksilölliset tiedot. Datatiedosto voi sisältää nimi- ja osoiteluettelon, tuotetietoja tai kuvia. Datatiedoston muoto voi olla esimerkiksi jokin seuraavista:

  • Microsoft Office Outlook -yhteystietoluettelo

  • Microsoft Office Excel -laskentataulukko

  • Microsoft Office Word -taulukko

  • Microsoft Office Access -tietokantataulukko

  • tekstitiedosto, jossa sarakkeet erottaa toisistaan pilkku tai sarkain ja rivien erottimena on rivinvaihto.

Voit yhdistää aiemmin luotuun luetteloon tai tietolähteeseen tai voit luoda uuden vastaanottajaluettelon. Jos haluat käyttää vain osaa luettelon tietueista, voit suodattaa luettelon tietyn ehdon mukaan. Voit myös järjestää kohteet aakkosjärjestykseen.

Huomautus: Jos haluat yhdistää julkaisuun kuvia, tietolähteen on sisällettävä joko yhdistettävien kuvatiedostojen nimet tai polut. Älä tallenna itse kuvia tietolähteeseen.

Nykyisen luettelon käyttäminen

  1. Valitse Luo vastaanottajaluettelo -kohdasta Käytä nykyistä luetteloa ja valitse sitten Seuraava: Luo vastaanottajaluettelo tai muodosta siihen yhteys.

    Oletusarvon mukaan Microsoft Publisher tallentaa tietolähteet Omat tietolähteet -kansioon. Saatat joutua etsimään tietolähteen sijainnin.

  2. Valitse Valitse tietolähde -valintaikkunasta haluamasi tietolähde.

  3. Valitse Avaa.

    Sen mukaan, minkä tyyppisen tietolähteen valitset, näyttöön saattaa tulla muita valintaikkunoita, joissa pyydetään lisätietoja.

    Jos tietolähde on esimerkiksi Microsoft Office Excel -työkirja, jossa on useita laskentataulukoita, valitse se laskentataulukko, jossa haluamasi tiedot ovat, ja valitse sitten OK.

Outlookin yhteystietojen käyttäminen

  1. Valitse Luo vastaanottajaluettelo -kohdasta Valitse Outlook-yhteystiedoista ja valitse sitten Seuraava: Luo vastaanottajaluettelo tai muodosta siihen yhteys.

  2. Jos ohjelma pyytää valitsemaan sähköpostiprofiilin, valitse haluamasi profiili ja valitse sitten OK.

  3. Valitse haluamasi yhteystietoluettelo Yhteystietojen valitseminen -valintaikkunassa ja valitse OK.

    Kaikki kansion yhteystiedot tulevat näkyviin Yhdistämisen vastaanottajat -valintaikkunaan, jossa voit suodattaa ja lajitella yhdistämisessä käytettävää vastaanottajien luetteloa.

Uuden luettelon kirjoittaminen

Jos käytössäsi ei ole aiemmin luotua luetteloa, johon voisit muodostaa yhteyden, voit luoda uuden luettelon.

  1. Valitse Luo vastaanottajaluettelo -kohdasta Kirjoita uusi luettelo ja valitse sitten Seuraava: Luo vastaanottajaluettelo tai muodosta siihen yhteys.

  2. Kirjoita Uusi osoiteluettelo -valintaikkunassa ensimmäisen osoitteen tiedot vastaaviin kenttiin. Kaikkia kenttiä ei tarvitse täyttää.

  3. Kun olet kirjoittanut ensimmäisen tietueen tiedot, valitse Uusi tietue.

  4. Toista vaiheet 2 ja 3, kunnes olet lisännyt haluamasi tiedot, ja valitse sitten OK.

  5. Kirjoita osoiteluettelon nimi Tallenna osoiteluettelo -valintaikkunan Tiedostonimi-ruutuun ja valitse kansio, johon haluat tallentaa osoiteluettelon.

    Oletusarvon mukaan Microsoft Publisher tallentaa osoiteluettelot Omat tietolähteet -kansioon. On parasta pitää osoiteluettelo tässä kansiossa, koska se on myös oletuskansio, josta Publisher etsii tietolähteitä.

    Kaikki uuden luettelon yhteystiedot tulevat näkyviin Yhdistämisen vastaanottajat -valintaikkunaan, jossa voit suodattaa ja lajitella yhdistämisessä käytettävää vastaanottajien luetteloa.

Vastaanottajien valitseminen

Valitse yhdistämiseen sisällytettävät vastaanottajat Yhdistämisen vastaanottajat -valintaikkunassa. Valitse niiden vastaanottajien valintaruudut, jotka haluat sisällyttää yhdistämiseen, ja poista muiden vastaanottajien valintaruutujen valinnat.

Jos haluat käyttää vain luettelon tiettyjä tietueita, voit suodattaa luettelon tietyn kentän tai ehdon mukaan. Kun olet suodattanut luettelon, voit vielä valita ja jättää pois tietueita valintaruutujen avulla.

Luettelon kohteiden suodattaminen

  1. Napsauta suodatusperusteena olevan sarakkeen otsikon vieressä olevaa nuolta.

  2. Valitse jokin seuraavista:

    • (Tyhjät) tuo näyttöön kaikki tietueet, joissa vastaava kenttä on tyhjä.

    • (Ei tyhjät) tuo näyttöön kaikki tietueet, joissa vastaavassa kentässä on tietoja.

    • (Lisäasetukset) avaa Suodattaminen ja lajitteleminen -valintaikkunan, jossa voit määrittää useita suodatusehtoja. Voit myös avata Suodattaminen ja lajitteleminen -valintaikkunan valitsemalla Yhdistämisen vastaanottajat -valintaikkunassa Muokkaa vastaanottajaluetteloa -kohdasta Suodata.

      Vihje: Jos tietolähde sisältää tietueita, joissa on jokin yhteinen tieto, ja sarakkeessa on enintään kymmenen erilaista arvoa, voit suodattaa tietyn tiedon mukaan. Jos esimerkiksi luettelossa on useita osoitteita, joiden Maa-kentässä on arvo Australia, voit suodattaa arvon Australia mukaan.

      Yhdistämisen vastaanottajat -valintaikkunassa näkyvät vain määritetyt tietueet. Jos haluat kaikki tietueet taas näkyviin, valitse (Kaikki).

Jos haluat tarkastella kohteita aakkosjärjestyksessä, voit lajitella luettelon.

Luettelon kohteiden lajitteleminen

  • Valitse lajittelussa käytettävä ehto Yhdistämisen vastaanottajat -valintaikkunasta napsauttamalla sarakkeen otsikkoriviä.

    Jos esimerkiksi haluat järjestää luettelon aakkosjärjestykseen sukunimen perusteella, napsauta Sukunimi-sarakkeen otsikkoa.

  • Voit valita kaikki kohteet tai poistaa kaikkien kohteiden valinnan nopeasti valitsemalla otsikon valintaruudun tai poistamalla sen valinnan.

  • Voit käyttää useita lajitteluehtoja valitsemalla Yhdistämisen vastaanottajat -valintaikkunassa Muokkaa vastaanottajaluetteloa -kohdasta Suodata. Valitse Suodattaminen ja lajitteleminen -valintaikkunassa lajitteluehto.

Voit palata Yhdistäminen-tehtäväruutuun valitsemalla OK.

Sivun alkuun

Julkaisun valmisteleminen

Yhdistämistoiminto yhdistää asiakirjan, joka sisältää jokaiselle kopiolle yhteiset tiedot, ja paikkamerkit kunkin kopion yksilöllisiä tietoja varten. Kun luot julkaisun, lisää teksti (kuten tervehdys), jonka haluat näkyvät kaikissa yhdistetyn julkaisun versioissa, ja lisää paikkamerkit yksilöllisiä tietoja, kuten osoitteita, varten.

Jos haluat, voit tässä vaiheessa lisätä tekstikehyksen, kirjoittaa tekstin, jonka haluat näkyvän kaikissa yhdistetyn julkaisun versioissa, ja lisätä paikkamerkit yksilöllisiä tietoja varten.

Tekstikehyksen lisääminen

  1. Valitse objektit -työkalurivin Tekstiruudun Painikkeen kuva .

  2. Siirrä hiiriosoitin julkaisun kohtaan, johon haluat sijoittaa tekstikehyksen, ja vedä vinosti alaspäin, kunnes kehys on haluamasi kokoinen.

Kaikille versioille yhteisen tekstin lisääminen

  • Napsauta tekstikehystä ja kirjoita teksti, jonka haluat näkyvän kaikissa yhdistetyissä julkaisuissa.

Tietokenttien lisääminen julkaisuun

  1. Napsauta yhdistetyn julkaisun tekstikehystä, johon haluat lisätä tietokenttä.

  2. Lisää jokin seuraavista kentistä:

    Osoitelohko, joka sisältää nimen, osoitteen ja muita tietoja

    1. Valitse Yhdistäminen-tehtäväruudun (Vaihe 2: Julkaisun valmisteleminen) Lisää kohteita -kohdasta Osoitelohko.

    2. Valitse haluamasi osoitteen osat Osoitelohkon lisääminen -valintaikkunasta ja valitse sitten OK.

      Huomautus: Jos tietolähteen tietokenttä nimet eivät ole samat kuin Publisherin käyttämien kenttien nimet, sinun on ehkä valittava Osoitelohkon lisääminen -valintaikkunasta Täsmää kentät. Valitse Kenttien täsmääminen -valintaikkunan luetteloruuduista Publisherin kenttien nimiä vastaavat tietolähteen kentät.

    Tervehdysteksti

    1. Valitse Yhdistäminen -tehtäväruudun (Vaihe 2: Julkaisun valmisteleminen) Lisää kohteita -kohdasta Tervehdysteksti.

    2. Valitse Tervehdysteksti-valintaikkunasta tervehdystekstin muoto, joka sisältää tervehdyksen, nimen muodon ja seuraavan välimerkin.

    3. Valitse teksti, jonka haluat näkyvän siinä tapauksessa, että Publisher ei voi tulkita vastaanottajan nimeä. Näin tapahtuu esimerkiksi silloin, kun tietolähde ei sisällä vastaanottajan etu- tai sukunimeä, vaan ainoastaan yrityksen nimen.

    4. Valitse OK.

      Huomautus: Jos tietolähteen tietokenttien nimet eivät ole samat kuin Publisherin käyttämien kenttien nimet, sinun on ehkä valittava Tervehdysteksti-valintaikkunasta Täsmää kentät. Valitse Kenttien täsmääminen -valintaikkunan avattavista luetteloruuduista Publisherin kenttiä vastaavat tietolähteen kentät.

    Osoite-kentät

    1. Valitse Yhdistäminen -tehtäväruudun (Vaihe 2: Julkaisun valmisteleminen) Lisää kohteita -kohdasta Osoitekentät.

    2. Valitse Lisää osoitekenttä -valintaikkunasta haluamasi osoitteen osat.

      Huomautus: Jos tietolähteen tietokenttien nimet eivät ole samat kuin Publisherin käyttämien kenttien nimet, sinun on ehkä valittava Osoitekenttien lisääminen -valintaikkunasta Täsmää kentät. Valitse Kenttien täsmääminen -valintaikkunan avattavista luetteloruuduista Publisherin kenttiä vastaavat tietolähteen kentät.

    Muut tietokentät

    Vedä hiirellä Yhdistäminen-tehtäväruudun (Vaihe 2: Julkaisun valmisteleminen) Valmistele julkaisu -kohdan luetteloruudussa kenttää, jonka haluat liittää sitä varten luotuun tekstikehykseen.

Tietokenttien muotoilu

Voit halutessasi muuttaa yhdistettyjen tietojen ulkoasua muotoilemalla tietokenttiä ja mitä tahansa lisäämääsi tekstiä (kuten tervehdystä Hei tai puhuttelua Hyvä...). Voit muotoilla yhdistettyjä tietoja vain muotoilemalla yhdistetyn julkaisun tietokenttiä.

  1. Valitse yhdistetystä julkaisusta kenttä, jonka sisältämät tiedot haluat muotoilla.

  2. Valitse Muotoile-valikosta Fontit ja määritä haluamasi asetukset.

Julkaisun tietokenttien vastaanottajatietojen esikatselu

Voit nyt tarkistaa esikatselussa, miltä julkaisu näyttää, kun yhdistetyissä kentissä on oikeat tiedot.

  1. Voit esikatsella julkaisua jollakin seuraavista tavoista:

    • Voit esikatsella tietueita järjestyksessä napsauttamalla siirtymisruudun painikkeiden Seuraava-painike Edellinen-painike : näet jokaisen merkinnän näkymisen yhdistetyssä julkaisussa.

      Tietolähteen ensimmäisen tietueen tiedot näkyvät yhdistämiskentissä. Et voi muokata tietolähteen tietueita julkaisun sivuilla, mutta voit muotoilla, siirtää tai poistaa tietokenttiä.

    • Jos haluat etsiä ja tarkastella tietolähteen tietyn tietueen tietoja, valitse Etsi vastaanottaja ja kirjoita hakuehto Tietueen etsiminen -valintaikkunaan.

  2. Tee tarvittaessa muutoksia vastaanottajaluettelon. Tee jokin seuraavista:

    • Jos haluat poistaa jonkin vastaanottajan yhdistämisestä, valitse Poista tämä vastaanottaja.

    • Jos haluat muuttaa vastaanottajaluetteloa, valitse Muokkaa luetteloa ja tee muutokset Yhdistämisen vastaanottajat -valintaikkunassa.

  3. Kun olet viimeistellyt yhdistämisjulkaisun ja lisännyt kaikki yhdistämiskentät, valitse Tiedosto-valikosta Tallenna nimellä. Kirjoita julkaisun nimi Tiedostonimi-ruutuun ja valitse sitten Tallenna.

  4. Valitse Seuraava: Luo yhdistetyt julkaisut.

Sivun alkuun

Yhdistetyn julkaisun luominen

Yhdistäminen-tehtäväruudun Luo yhdistetyt julkaisut -kohdassa voit

  • tulostaa yhdistetyn julkaisun (esimerkiksi postitusta varten)

  • tarkastella yhdistettyä julkaisua esikatselussa (jotta voit tarkistaa sen ennen kaikkien versioiden tulostusta ja ratkaista mahdolliset ongelmat)

  • tallentaa yhdistetyn julkaisun myöhempää käyttöä varten

  • lisätä yhdistetyt sivut toiseen julkaisuun.

Yhdistetyn julkaisun esikatselu

  • Valitse Esikatselu.

Yhdistetyn julkaisun tulostaminen

  1. Valitse Tulosta.

  2. Valitse Tulosta-valintaikkunasta haluamasi asetukset ja valitse sitten OK.

    Tärkeää: Jos haluat tulostaa kullekin paperiarkille erilaisia yhdistettyjä tietolohkoja, kuten eri nimiä ja osoitteita, valitse Tulostusasetukset-kohdassa Useita sivuja arkilla. Jos valitset Monta kopiota arkille, kullekin paperiarkille tulostetaan useita kopioita samoista tiedoista.

    Tulosta-valintaikkuna ja Useita sivuja arkilla -vaihtoehto

Yhdistetyn julkaisun tallentaminen myöhempää käyttöä varten

Jos haluat muokata yhdistettyjä sivuja, tallentaminen myöhempää käyttöä varten ja tulostaa ne myöhemmin, voit kerätä ja tallentaa kaikki yhdistetyn sivu yksittäinen yhdistetty uusi julkaisu, joka sisältää todellisten tietojen, kuten nimiä ja osoitteita, yhdistämiskenttien sijaan.

  1. Valitse Yhdistä uudeksi julkaisuksi.

    Publisher luo uuden julkaisun, joka sisältää yhdistetyt sivut.

  2. Valitse uudessa julkaisussa Yhdistäminen-tehtäväruudusta Tallenna julkaisu. Kirjoita uuden julkaisun nimi Tiedostonimi-ruutuun ja valitse Tallenna.

Yhdistettyjen sivujen lisääminen aiemmin luotuun julkaisuun

Jos haluat lisätä yhdistetyt sivut aiemmin luodun julkaisun loppuun, varmista, että seuraavat ominaisuudet ovat luetteloyhdistämisen mallissa samat kuin kyseisessä julkaisussa:

  • Sivun koko (korkeus ja leveys)

  • Sivunäkymä (yhden sivun aukeama tai kahden sivun aukeama)

  • Julkaisulaji (Web tai tulostettava)

  • Sivujärjestys (vasemmalta oikealle tai oikealta vasemmalle).

Publisher lisää yhdistetyt sivut uuteen tai aiemmin luotuun julkaisuun, mutta se ei voi lisätä sivuja avoinna olevaan julkaisuun. Jos julkaisu, johon haluat yhdistää sivut, on avoinna, tallenna ja sulje julkaisu ennen yhdistämistä.

  1. Valitse Lisää aiemmin luotuun julkaisuun.

  2. Etsi Avaa julkaisu -valintaikkunasta julkaisu, johon haluat lisätä yhdistetyt sivut, ja valitse Avaa.

    Publisher lisää yhdistetyt sivut aiemmin luotuun julkaisuun.

  3. Tallenna päivitykset valitsemalla aiemmin luodussa julkaisussa Yhdistäminen-tehtäväruudusta Tallenna julkaisu.

Yhdistetyn julkaisun tallentaminen

Jos lisäksi tallennat julkaisun, joka sisältää yhdistämiskenttiä, voit palata takaisin ja muokata yhdistämiskenttiä ja luoda sitten uuden yhdistetyn julkaisun, joka sisältää uudet yhdistämiskentät tai päivitetyn vastaanottajaluettelon. Voit tallentaa yhdistetyn julkaisun seuraavasti:

  1. Varmista, että yhdistetty julkaisu on aktiivisena.

  2. Valitse Tiedosto-valikosta Tallenna.

  3. Nimeä yhdistetty julkaisu ja valitse Tallenna.

Sivun alkuun

Yhdistämisen peruuttaminen

Voit peruuttaa yhdistämisen ja katkaista yhdistämisjulkaisun tai luetteloyhdistämisen mallin ja tietolähde välisen yhteyden.

  1. Valitse Työkalut-valikosta Yhdistäminen ja luetteloyhdistäminen ja valitse sitten Peruuta yhdistäminen.

  2. Kun sinulta kysytään, haluatko peruuttaa yhdistämisen, valitse Kyllä.

Julkaisun yhteys tietolähteeseen katkeaa.

Huomautus: Jos peruutat yhdistämisen, kaikki muut kentät paitsi osoitekentät, tervehdystekstit ja osoitelohkot muutetaan tavalliseksi tekstiksi.

Sivun alkuun

Huomautus: Konekäännöksestä ilmoittava vastuusvapauslauseke: Tämä artikkeli on käännetty tietokonejärjestelmällä, eikä kieliasiantuntija ole muokannut sitä. Microsoft tarjoaa nämä konekäännökset avuksi muille kuin englantia puhuville käyttäjille, jotta he saavat lisätietoja Microsoftin tuotteista, palveluista ja tekniikoista. Koska artikkeli on koneellisesti käännetty, se saattaa sisältää sanasto-, lauseoppi- ja kielioppivirheitä.

Kehitä taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×