Word-asiakirjan muuntaminen InfoPath-lomakemalliksi

Vaikka Microsoft Office Wordilla voi luoda lomaketta muistuttavan asiakirjan, Word toimii parhaiten tekstinkäsittelyohjelmana eikä lomakkeen suunnitteluohjelmana. Microsoft Office InfoPath on luotu sen sijaan erityisesti sähköisten lomakkeiden suunnittelemista ja täyttämistä varten. Jos haluat muuntaa aiemmin luotuja Word-asiakirjoja InfoPath-lomakemalleiksi, voit käyttää siihen InfoPathin ohjattua tuontitoimintoa. Sen jälkeen voit hyödyntää InfoPathin eri ominaisuuksia lomakkeiden suunnitteluun, julkaisuun ja täyttämiseen. Myyntiraporttilomakemallissa voit esimerkiksi ottaa automaattisesti käyttöön punaisen taustavärin lukujen alittaessa myyntilaskelmat käyttämällä ehdollinen muotoilu. Voit ottaa samassa lomakemallissa käyttöön sääntö, jonka mukaan kyseiseen lomakemalliin perustuvat lomakkeet lähetetään sähköpostiviestin liitteenä, kun joku napsauttaa lähetyspainiketta. Voit lisäksi antaa lomakemallin entistä useamman ihmisen käyttöön luomalla selainkäyttöinen lomakemalli.

Kun muunnat Word-asiakirjan InfoPath-lomakemalliksi, tuloksena oleva lomakemalli vastaa Word-asiakirjan asettelua. Lisäksi Word-asiakirjan tiettyjä ehtoja vastaavat kohteet muunnetaan automaattisesti sopiviksi ohjausobjekteiksi, joihin käyttäjät voivat kirjoittaa tietoja. Jos Word-asiakirja sisältää esimerkiksi hakasulkeet useiden välilyöntien ympärillä, InfoPath olettaa, että hakasulkeilla ympäröityä aluetta on käytetty tekstinsyöttökenttänä, ja muuttaa sen tekstikehysohjausobjektiksi tuloksena olevassa lomakemallissa. Kaikki Wordin lomakekentät muunnetaan vastaaviksi ohjausobjekteiksi InfoPathissa.

Voit muuttaa Word-asiakirjan InfoPath-lomakemalliksi muuntamisen asetuksia käyttämällä Tuomisen asetukset -valintaikkunan asetuksia.

Tässä artikkelissa selitetään Word-asiakirjan InfoPath-lomakemalliksi muuntamisen perusajatus ja muunnosmenetelmä, mukaan lukien ominaisuudet ja asetukset, joita ei tueta muunnosprosessissa.

Tässä artikkelissa käsiteltävät aiheet

Tietoja Word-asiakirjan muuntamisesta InfoPath-lomakemalliksi

Wordin ominaisuudet ja asetukset, joita ei täysin tueta muunnoksen aikana

Word-asiakirjan muuntaminen InfoPath-lomakemalliksi

Asettelutaulukon muuttaminen toistuvaksi taulukoksi

Valintaruutujen muuttaminen valintanappiryhmäksi

Muunnosongelmien tarkasteleminen Rakenteen tarkistaminen -tehtäväruudussa

Tietoja Word-asiakirjan muuntamisesta InfoPath-lomakemalliksi

Kun Word-asiakirja muunnetaan InfoPath-lomakemalliksi, asiakirjaa käytetään luonnoksena, jonka avulla luodaan uusi lomakemalli. Asiakirjan perusrakenne luodaan uudelleen mahdollisimman tarkasti lomakemallissa. Word-asiakirjassa "lomakekenttä" on sijainti, johon tallennetaan tietyntyyppisiä tietoja, kuten nimi tai osoite. Jos haluat sisällyttää asiakirjan muunnokseen Wordin lomakekenttiä, tekstikehys-, valintaruutu- ja avattavat luetteloruutuohjausobjektit lisätään InfoPath-lomakemalliin sijaintiin, joka vastaa Word-asiakirjan kenttien sijaintia. Lisäksi InfoPath havaitsee automaattisesti Word-asiakirjan osat, jotka voivat toimia sekä toistuvina taulukoina että RTF-ruutuina, ja muuntaa ne sopiviksi ohjausobjekteiksi. Jos kuluraporttiasiakirja esimerkiksi sisältää tyhjän, alleviivatun alueen, johon käyttäjät voivat kirjoittaa huomautuksia tietystä kulusta, InfoPath muuntaa kyseisen alueen RTF-ruuduksi. Käyttäjät voivat sitten kirjoittaa useita rivejä tekstiä RTF-ruutuun ja muotoilla tekstin haluamallaan tavalla.

Ymmärrät paremmin suhteen sen Word-tiedoston, jonka muunnat InfoPathin ohjatulla tuontitoiminnolla, ja toiminnon avulla luotavan InfoPathin lomakemallin välillä seuraavan esimerkin avulla: Kuvittele, että organisaatiosi on käyttänyt jo vuosia Word-tiedostoa Kuluraportti.doc, jolla se on kerännyt kuluraporttitietoja työntekijöiltä. IT-osasto haluaa muuntaa tiedoston InfoPathin lomakemalliksi, jotta lomakkeen tiedot voidaan lähettää XML-muodossa kirjanpitojärjestelmään.

Jos muunnat Kuluraportti.doc-asiakirjan lomakemalliksi käyttämällä ohjattua tuomista, InfoPath luo lomakemallin nimeltä Kuluraportti.xsn. Seuraavassa esimerkissä Word-asiakirjan kulutietojen taulukko on muunnettu toistuvaksi taulukoksi tuloksena olevassa Infopath-lomakemallissa. Toistuvien taulukoiden avulla käyttäjät voivat lisätä tai poistaa kuluja tarpeen mukaan napsauttamalla pikavalikon komentoja.

Word-taulukko, joka on muunnettu InfoPathin toistuvaksi taulukoksi

Kun Word-asiakirja muunnetaan InfoPath-lomakemalliksi, asettelu ja muut elementit säilytetään ennallaan. Oletusarvon mukaan tyhjien rivien lukumäärä Infopathin toistuvassa taulukossa vastaa Word-taulukon tyhjien rivien lukumäärää. Voit kuitenkin säästää lomakemallin tilaa näyttämällä oletusarvoisesti vain yhden rivin tai kaksi riviä.

Tämä uusi lomakemalli sisältää elementtejä, jotka vastaavat Word-asiakirjassa olevia elementtejä, kuten taulukon kulutietojen keräämiseen. Ohjatussa tuomisessa valitsemiesi asetuksien mukaan jotkut ominaisuudet saattavat kuitenkin olla erilaisia tuloksena olevassa lomakemallissa.

  • Jos tuot Word-asiakirjan ohjatun tuomisen avulla ja säilytät vain asettelun    Tuloksena oleva lomakemalli sisältää toistuvan taulukon rivikohteiden kirjoittamista varten kuluraportissa. Kaikki alkuperäisen asiakirjan lomakekentät, kuten Nimi-tekstikehys, avattava Osasto-luettelo ja Yksikkö-valintaruudut, poistetaan kuitenkin tuloksena olevasta lomakemallista.

  • Jos tuot Word-asiakirjan ohjatun tuomisen avulla ja säilytät asettelun ja muunnat Wordin lomakekentät ohjausobjekteiksi (oletus)    Tuloksena oleva lomakemalli sisältää toistuvan taulukon rivikohteiden kirjoittamista varten kuluraportissa. Kaikki alkuperäisen asiakirjan lomakekentät, kuten Nimi-tekstikehys, avattava Osasto-luettelo ja Yksikkö-valintaruudut, muunnetaan vastaaviksi InfoPath-ohjausobjekteiksi.

  • Jos tuot Word-asiakirjan ohjatun tuomisen avulla ja säilytät asettelun ja muunnat lomakekentät ohjausobjekteiksi (mukautettu)    Voit päättää, mitkä kentät muunnetaan kuluraportin tuomisen aikana. Voit esimerkiksi poistaa käytöstä asetuksen, jonka mukaan asiakirjan tyhjät taulukon solut muunnetaan tekstikehysohjausobjekteiksi tuloksena olevassa lomakemallissa.

Sivun alkuun

Wordin ominaisuudet ja asetukset, joita ei täysin tueta muunnoksen aikana

Joitakin Word-asiakirjan asetuksia ja muotoiluja ei tueta InfoPath-lomakemalleissa. Kun muunnat Word-asiakirjan, joka sisältää sellaisia asetuksia, tuloksena oleva InfoPath-lomakemalli ei sisällä kyseisiä ominaisuuksia tai asetuksia. Jos esimerkiksi Word-asiakirjassa on muokkausmerkintöjä, ne jätetään pois tuloksena olevasta lomakemallista, koska InfoPath ei tue tätä ominaisuutta.

Voit etsiä muunnoksessa esiintyviä ongelmia käyttämällä Rakenteen tarkistaminen -tehtäväruutua suunnittelutila. Sen jälkeen voit korjata kyseiset ongelmat.

Seuraavassa on luettelo ominaisuuksista ja asetuksista, joita ei säilytetä, kun muunnat Word-asiakirjan InfoPath-lomakemalliksi. Joissakin tapauksissa muotoilu poistetaan, mutta pohjana oleva teksti säilytetään. Jos sinulla on esimerkiksi tiedotetyyppisiä sarakkeita, InfoPath jättää sarakkeet pois, mutta tuo kyseisissä sarakkeissa olevan tekstin.

  • Kirjanmerkit

  • Animoitu teksti

  • Teemat

  • Vesileimat

  • Rivien numerointi

  • Sivunreunaviivat

  • Alaviitteet ja loppuviitteet

  • Tiedotetyyppiset sarakeasettelut

  • Liitetiedostot

  • Linkitetyt tai upotetut objektit, kuten Microsoft Office Excel -laskentataulukot ja Microsoft Office Visio -piirrokset

  • Piirrosobjektit (mukaan lukien automaattiset muodot, käyrät, viivat ja WordArt)

  • Merkkiväli (mukaan lukien skaalaus, laajennettu tai tiivistetty väli, korotettu tai alennettu teksti ja parivälistys fonttikokoon)

  • ActiveX-komponentit

  • Kommentit ja jäljitetyt muutokset (mukaan lukien lisäykset, poistot ja muotoilumuutokset)

  • Jotkin toiminnot ja ominaisuudet sisältyvät vain versioon Microsoft Office Word 2007 (mukaan lukien rakenneosat ja sisältöohjausobjektit).

  • Jotkut tulostusasetukset (mukaan lukien sekamerkkimuotoilu ylä- ja alatunnisteissa, erilaiset parittomat ja parilliset ylä- ja alatunnisteet, erilaiset ensimmäisen sivun ylä- ja alatunnisteet, reunusasetukset, ylä- ja alareunusten negatiiviset arvot, erilaiset sivun suunnat ja yksittäiset osien asetukset)

Huomautus: Joitain Word-tiedostoja ei voi muokata ilman salasanaa. Jos tiedostosi on suojattu salasanalla, et voi tuoda sitä InfoPathiin. Voit korjata ongelman poistamalla tiedoston salasanasuojauksen ennen sen tuomista. Lisäksi jotkin tiedostot saattavat estää tietyt muokkaustoiminnot käyttäjiltä, esimerkiksi tietojen antamisen lomakekenttiin. Jos tiedostosi on suojattu salasanalla, et voi tuoda sitä InfoPathiin. Voit korjata ongelman poistamalla tiedoston muokkausrajoitukset ennen sen tuomista.

Seuraavassa luettelossa on lueteltu toiminnot, ominaisuudet ja asetukset, joita tuetaan osittain, kun muunnat Word-tiedoston InfoPath-lomakemalliksi:

Pystysuora teksti    InfoPath säilyttää Word-asiakirjan pystysuoran tekstimuotoilun, kun pystysuora teksti on taulukon solussa. InfoPath jättää pois pystysuoran tekstimuotoilun Word-asiakirjaa muunnettaessa, jos pystysuora teksti on taulukon solun ulkopuolella, Word-asiakirjan toisessa osassa.

Tekstikehykset    Word-asiakirjoissa tekstikehykset sisältävät tekstiä, joka voidaan asettaa yhdelle sivulle. Jos Word-asiakirja sisältää tekstikehyksen, kyseinen tekstikehys muunnetaan taulukon soluksi tuloksena olevassa lomakemallissa. Kaikki tekstikehyksen teksti näkyy tuloksena olevan lomakemallin taulukon solussa.

Alleviivattu teksti    InfoPath-lomakemallit tukevat alleviivausta. Word-asiakirjan koristeelliset tai kaksinkertaiset alleviivaukset muunnetaan kuitenkin yksinkertaisiksi alleviivauksiksi tuloksena olevassa lomakemallissa.

Hyperlinkit, jotka viittaavat ei-tuettuihin protokolliin     Kaikki hyperlinkit muunnetaan, mutta jos hyperlinkki käyttää jotakin muuta kuin HTTP-, HTTPS-, FILE-, FTP- tai MAILTO-protokollaa, hyperlinkki ei toimi, kun käyttäjä napsauttaa linkkiä tuloksena olevassa lomakemallissa.

Merkkityylit ja tekstitehosteet    Yläindeksi-, alaindeksi- ja yksinkertainen yliviivaus -muotoilutyylit säilytetään muunnosprosessin aikana. Muut muotoilutyylit ja -tehosteet, mukaan lukien ääriviivateksti, piilotettu teksti ja varjostuksen muotoilu, jätetään pois muunnosprosessin aikana. Kohoteksti tai kaiverrusteksti muunnetaan harmaaksi tekstiksi tuloksena olevassa lomakemallissa.

Osien asetukset    Wordissa osia käytetään asiakirjan asettelun muuttamissa yhdellä sivulla tai sivujen välillä. InfoPath ei tue tämäntyyppisiä osia, ja ne poistetaan muunnosprosessin aikana. Kaikkia Word-asiakirjan ensimmäisessä osassa käytettyjä asetuksia käytetään tuloksena olevassa InfoPath-lomakemallissa.

Ylä- ja alatunnisteen muotoilu    Word-asiakirjan ylä- ja alatunnisteteksti muunnetaan ylä- ja alatunnistetekstiksi tuloksena olevassa InfoPath-lomakemallissa. Jotkut merkkimuotoilut jätetään pois muunnosprosessin aikana. Jos esimerkiksi Word-asiakirjan ylätunnisteessa on käytetty sekä lihavointia että kursivointia, InfoPath käyttää ensimmäistä kohtaamaansa muotoilutyyliä tuloksena olevassa lomakemallissa ja poistaa muun muotoilun. Samalla tavalla kaikkia Word-asiakirjan ensimmäisessä ylä- tai alatunnisteosassa käytettyjä asetuksia käytetään tuloksena olevan InfoPath-lomakemallin ylä- tai alatunnistetekstissä.

Fonttimuunnos    Vaikka InfoPath tuo fontit Word-asiakirjasta uutta lomakemallia luotaessa, lomakemallille valitaan automaattisesti vaihtoehtoiset fontit, jos asiakirjan fontit eivät ole käytössä tietokoneessa, jossa tuonti suoritetaan.

Negatiiviset sivun reunukset    Negatiiviset ylä- ja alareunukset tuodaan nollana.

Negatiiviset reunukset, täyttäminen ja sisennysasetukset    Negatiiviset reunukset, täyttäminen ja sisennysasetukset tuodaan nollana.

Sivun alkuun

Word-asiakirjan muuntaminen InfoPath-lomakemalliksi

  1. Jos Word-asiakirja, jonka haluat tuoda, on avoinna, sulje se.

  2. Valitse suunnittelutilassa Tiedosto-valikosta Tuo lomake.

  3. Valitse ohjatussa tuomisessa Word-asiakirjojen InfoPath-tuonti ja sitten Seuraava.

  4. Valitse Selaa.

  5. Paikanna ja valitse Word-asiakirja, jonka haluat muuntaa, ja valitse sitten Avaa.

    Huomautus: Jos tuot Word-asiakirjan, jonka käyttöoikeudet on rajoitettu, sinulla on oltava täydet käyttöoikeudet asiakirjaan. Jos sinulla on vain luku- tai muutosoikeus asiakirjaan, näkyviin tulee virhesanoma, kun tuot asiakirjan.

  6. Jos haluat muuttaa oletustuontitoimintaa, valitse Asetukset ja sen jälkeen haluamasi asetukset.

  7. Valitse Valmis.

Sivun alkuun

Asettelutaulukon muuttaminen toistuvaksi taulukoksi

Jos Word-asiakirja sisältää taulukon, InfoPath muuntaa sen asettelutaulukko tai toistuvaksi taulukoksi tuloksena olevassa lomakemallissa. Valittu taulukon tyyppi riippuu Word-asiakirjassa tekemistäsi rakennepäätöksistä. Voit muuttaa muunnetun asettelutaulukon toistuvaksi taulukoksi nopeasti käyttämällä seuraavaa menetelmää.

Toistuvien taulukoiden avulla voit tarjota käyttäjille lisäjoustavuutta lomakkeiden täyttämiseen. Toistuvia taulukoita käytettäessä lomakemallin ei tarvitse näyttää useita tyhjiä rivejä, kun käyttäjä avaa lomakkeen ensimmäisen kerran. Sen sijaan käyttäjä näkee yleensä vain yhden rivin ja lisärivejä tulee näkyviin vain tarvittaessa. Tämä säästää tilaa lomakkeessa ja tarjoaa käyttäjille lisämahdollisuuksia mukauttamiseen.

  1. Napsauta lomakemallissa hiiren kakkospainikkeella missä tahansa sen asettelutaulukon kohdassa, jonka haluat muuntaa.

  2. Valitse pikavalikosta Muuta ja valitse sitten Toistuva taulukko.

  3. Toimi Muuta toistuvaksi taulukoksi -valintaikkunassa seuraavasti:

    • Voit määrittää toistuvan taulukon otsikkorivit kirjoittamalla arvon Taulukon otsikkorivien määrä -ruutuun. Otsikkoriviä käytetään tavallisesti sarakeotsikoita varten.

    • Voit määrittää toistuvan taulukon alatunnisterivit kirjoittamalla arvon Taulukon alatunnisteen rivien määrä -ruutuun. Monissa taulukoissa ei ole alatunnisterivejä.

    • Voit määrittää käytettävien tietorivien määrän kirjoittamalla arvon Toistuvien rivien määrä lomaketta täytettäessä -ruutuun. Tietorivi on rivi, joka voi toistua lomakkeessa niin monta kertaa kuin on tarpeen

  4. Valitse Lisää-valikosta Lisää ohjausobjekteja tai paina ALT+I, C.

  5. Lisää taulukon soluihin haluamasi ohjausobjektit.

Sivun alkuun

Valintaruutujen muuttaminen valintanappiryhmäksi

Jos Word-asiakirjassa on käytetty useita valintaruutuja, InfoPath tuo ne valintaruutuina tuloksena olevaan InfoPath-lomakemalliin. Jos haluat mieluummin käyttää valintanappiryhmää, muunna valintaruudut valintanapeiksi lomakemallissa noudattamalla seuraavia vaiheita.

Voit käyttää valintanappien ryhmää Microsoft Office InfoPathin lomakemallissa, kun haluat, että käyttäjät voivat valita vain yhden vaihtoehdon rajoitettujen vaihtoehtojen joukosta.

  1. Napsauta lomakemallissa yhtä muunnettavista valintaruuduista. Paina sitten CTRL-näppäintä pitkään ja napsauta muita muunnettavia valintaruutuja.

  2. Valitse Muokkaa-valikosta Muuta muotoon ja valitse sitten Valintanappi.

    Valintanappiryhmä näkyy nyt valintaruutuja tilalla lomakemallissa. Jokainen valintanappi on sidottu samaan kenttään tietolähteessä. Kun käyttäjä valitsee valintanapin, kyseiseen valintanappiin liitetty arvo tallentuu kenttään.

Sivun alkuun

Muunnosongelmien tarkasteleminen Rakenteen tarkistaminen -tehtäväruudussa

Joskus alkuperäisen Word-asiakirjan elementit joko eivät näy odotetulla tavalla tuloksena olevassa InfoPath-lomakemallissa tai ne on poistettu muunnosprosessin aikana. InfoPath ei esimerkiksi tue Wordin WordArt-ominaisuutta ja korvaa WordArt-objektit paikkamerkkikuvina tuloksena olevassa lomakemallissa.

Jos InfoPath havaitsee ongelmia muunnosprosessin aikana, Rakenteen tarkistaminen -tehtäväruutu aukeaa automaattisesti, kun suljet ohjatun tuomisen. Tehtäväruudussa voit tarkastella ongelmaluetteloa ja korjata ongelmat suorittamalla vaadittavat toimet.

  1. Jos Rakenteen tarkistaminen -tehtäväruutu ei tule näkyviin, valitse Työkalut-valikosta Rakenteen tarkistaminen.

    Jos lomakemallissa on ongelmia, tehtäväruudussa on sanomia.

  2. Napsauta Rakenteen tarkistaminen -tehtäväruudussa sen sanoman tekstiä, jota haluat tarkastella.

    Valintaikkunassa näkyy lisätietoja ongelmasta.

    Huomautus: Jos Word-asiakirja sisältää objektin, jota InfoPath ei tue, kuten Word-piirrosobjektin, InfoPath lisää silloin tuloksena olevaan lomakemalliin paikkamerkkikuvan, joka ilmoittaa objektin alkuperäisen sijainnin Word-asiakirjassa. Lisätietoja objektista saat napsauttamalla hiiren kakkospainikkeella lomakemallin paikkamerkkikuvaa ja valitsemalla sitten Lisätietoja pikavalikosta.

  3. Korjaa lomakemallin ongelmat tarpeen vaatiessa. Haluat ehkä esimerkiksi poistaa sellaiset paikkamerkkikuvat, joita ei ole tarkoitus käyttää valmiissa lomakemallissa.

Huomautus: Saatat huomata, että Rakenteen tarkistaminen -tehtäväruudussa on Päivitä-painike. Päivitä-painikkeen napsauttaminen ei päivitä viestejä, jotka näkyvät Word-tiedoston InfoPathiin tuomisen vuoksi. Jos haluat poistaa viestien tuomisen Rakenteen tarkistaminen -tehtäväruudusta, sinun on avattava Resurssitiedostot-valintaikkuna (Työkalut-valikko) ja poistettava sitten tiedosto nimeltä ImportErrors.xml. Tämä tiedosto luodaan automaattisesti, kun tuot Word-tiedoston InfoPathiin. Kun olet poistanut ImportErrors.xml-tiedoston, napsauta PäivitäRakenteen tarkistaminen -tehtäväruudussa, jos haluat poistaa viestien tuomisen pysyvästi. ImportErrors.xml-tiedostoa ei tarvita, jotta lomakemalli toimisi oikein. Itse asiassa turvallisuussyistä tämä tiedosto kannattaa poistaa ennen lomakemallin julkaisemista.

Sivun alkuun

Kehitä taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×