Windows XP -käyttöliittymän mallielementit

Tärkeää: Tämä on artikkeli on käännetty koneellisesti. Lue vastuuvapauslauseke. Tämän artikkelin englanninkielinen versio on täällä .

Käytä Windows XP -käyttöliittymä -mallia luodessasi mallikäyttöliittymiä, joiden muodot on kehitetty Microsoft Windows XP -ohjeiden mukaisesti. Muotoja ovat käyttöliittymissä usein käytetyt elementit, kuten sovellusikkunan perustana oleva tyhjä lomake, ohjatun toiminnon sivut, työkalurivien ja valikoiden muodot sekä ohjausobjektien muodot.

Voit tehdä monimutkaiseen monimutkaisia sovellusikkuna tai valintaikkuna yksinkertaisen sanomaruudun tai yhdellä painikkeella muodot.

Valitse haluamasi toimet

Yksittäisen valintaikkunan luominen

Välilehtiä sisältävän valintaikkunan luominen

Sovellusikkunan luominen

Valikoiden ja työkalurivien muodostaminen

Yksittäisen valintaikkunan luominen

  1. Vedä Ikkunat ja valintaikkunat -kohdasta Tyhjä lomake -muoto piirustussivulle.

  2. Kun olet valinnut muodon, kirjoita valintaikkunan otsikko.

  3. Vedä Windows-painikkeet-muoto otsikkorivin oikeaan päähän ja valitse painikkeen tyyppi. Niitä ovat tyypillisesti Ohje-painike ja Sulje-painike vasemmalta oikealle järjestettyinä.

  4. Lisää komentopainikkeita, joita ovat esimerkiksi OK, Peruuta ja Käytä, Tyhjä lomake -muodon oikeaan alakulmaan.

    how

    1. Vedä Yleiset ohjausobjektit -kohdasta Komentopainike-muodot Tyhjä lomake -muodon oikeaan alareunaan.

    2. Valitse kukin painike ja kirjoita ohjausobjektin nimi.

  5. Vedä oikeat ohjausobjektit Tyhjä lomake -muotoon. Valitse sopivat asetukset napsauttamalla muotoja hiiren kakkospainikkeella.

    Saat ohjeita tietystä ohjausobjektimuodosta napsauttamalla muotoa hiiren kakkospainikkeella ja valitsemalla Ohje.

    Jos käytät tekstityökalua ja luot omaa tekstiä Tyhjä lomake -muotoon, muotoile tekstiä fontilla Tahoma 8 pt.

  6. Ryhmitä komennot loogisiksi ryhmiksi.

  7. Vetämällä Ryhmän kehys- ja Ryhmäviiva-muodot Tyhjä lomake -muotoon voit erottaa ryhmät visuaalisesti.

    Tasaa ohjausobjektit käyttämällä apuviivoja.

    Tiedosto-valikon alla oleva Tulostus-valintaikkuna on hyvä esimerkki valintaikkunasta, joka sisältää monia kaikkein tavallisimmista elementeistä.

Sivun alkuun

Välilehtiä sisältävän valintaikkunan luominen

  1. Vedä Ikkunat ja valintaikkunat -kohdasta Tyhjä lomake -muoto piirustussivulle.

  2. Kun olet valinnut muodon, kirjoita valintaikkunan otsikko.

  3. Vedä Windows-painikkeet-muoto otsikkorivin oikeaan päähän ja valitse painikkeen tyyppi. Niitä ovat tyypillisesti Ohje-painike ja Sulje-painike vasemmalta oikealle järjestettyinä.

  4. Lisää komentopainikkeita, joita ovat esimerkiksi OK, Peruuta ja Käytä, Tyhjä lomake -muodon oikeaan alakulmaan.

    how

    1. Vedä Yleiset ohjausobjektit -kohdasta Komentopainike-muodot Tyhjä lomake -muodon oikeaan alareunaan.

    2. Valitse kukin painike ja kirjoita ohjausobjektin nimi.

  5. Vedä Välilehti-ohjain (pääsivu) -muoto Tyhjä lomake -muotoon ja muuta sen kokoa niin, että se mahtuu muotoon ja jättää tilaa välilehdille.

  6. Vedä Välilehti-ohjain (välilehdet) -muoto ja liimaa se Välilehti-ohjain (pääsivu) -muodon yläreunaan.

  7. Kun olet valinnut Välilehti-ohjain (välilehdet) -muodon, kirjoita välilehden nimi.

  8. Toista vaiheet 6 ja 7 kullekin välilehdelle ja liimaa välilehdet toisiinsa sekä Välilehti-ohjain (pääsivu) -muotoon.

  9. Napsauta hiiren kakkospainikkeella välilehteä, jonka haluat näkyvän ensimmäisenä välilehtenä, valitse Etumainen välilehti ja anna muille määritykseksi Takimmainen välilehti.

  10. Vedä oikeat ohjausobjektit Tyhjä lomake -muotoon. Valitse sopivat asetukset napsauttamalla muotoja hiiren kakkospainikkeella.

    Saat ohjeita tietystä ohjausobjektimuodosta napsauttamalla muotoa hiiren kakkospainikkeella ja valitsemalla Ohje.

    Jos käytät tekstityökalua ja luot omaa tekstiä Tyhjä lomake -muotoon, muotoile tekstiä fontilla Tahoma 8 pt.

  11. Ryhmitä komennot loogisiksi ryhmiksi.

  12. Vetämällä Ryhmän kehys- ja Ryhmäviiva-muodot Tyhjä lomake -muotoon voit erottaa ryhmät visuaalisesti.

    Tasaa ohjausobjektit käyttämällä apuviivoja.

    Tiedosto-valikon alla oleva Sivun asetukset -valintaikkuna on hyvä esimerkki valintaikkunasta, joka sisältää monia kaikkein tavallisimmista elementeistä.

Sivun alkuun

Sovellusikkunan luominen

  1. Vedä Ikkunat ja valintaikkunat -kohdasta Tyhjä lomake -muoto piirustussivulle.

  2. Kun muoto on valittuna, kirjoita otsikko sovellusikkunaan.

  3. Voit lisätä kuvakkeen otsikkoriviin tekstin vasemmalle puolelle napsauttamalla Tyhjä lomake -muotoa hiiren kakkospainikkeella ja valitsemalla Tilaa kuvakkeelle -valintaruudun.

  4. Vedä Windows-painikkeet -muoto otsikkorivin oikeaan reunaan ja valitse painiketyyppi. Painikkeita on yleensä kolme: Pienennä-painike, Suurenna- tai Palauta -painike ja Sulje-painike (vasemmalta oikealle).

  5. Vedä Työkalurivit ja valikot -kohdasta Valikkorivi-muoto Tyhjä lomake -muotoon, liimaa se otsikkorivin alareunaan ja lisää sitten valikon osia.

    how

    1. Vedä Ylätason valikon osa -muoto sivulle ja liimaa se Valikkorivin vasempaan reunaan.

      Voit sijoittaa kuvakkeen ensimmäisen valikkovaihtoehdon vasemmalle puolelle.

    2. Kun muoto on valittuna, kirjoita nimi. Jos valikon osalla on pikanäppäin, alleviivaa oikea kirjain.

    3. Toista tarvittaessa vaiheet 1 ja 2.

      Muotoon liittyviä ohjeita saat napsauttamalla sitä hiiren kakkospainikkeella ja valitsemalla Ohje.

      Voit piilottaa yhteyspisteet Yhteyspisteen kuva – sininen X valitsemalla Näytä-valikosta Yhteyspisteet.

      Sarakkeen kohteiden on oltava leveydeltään yhtä suuria kuin sarakkeen levein kohde.

    Voit näyttää valikkorivin vasemman reunan tartuntapisteen napsauttamalla muotoa hiiren kakkospainikkeella ja poistamalla Lukitse valikkorivi -valintaruudun valinnan.

  6. Vedä Työkalurivit ja valikot -kohdasta Työkalurivi-muoto Tyhjä lomake -muotoon, liimaa sen otsikkorivin alareunaan ja lisää sitten työkalupainikkeita.

    how

    1. Vedä yksi Työkalupainikkeet-muodoista sivulle ja liimaa se Työkalurivi-muodon vasempaan reunaan.

    2. Valitse Muodon tiedot -valintaikkunassa haluamasi painiketyyppi. Jos haluat myöhemmin vaihtaa painikkeen, napsauta muotoa hiiren kakkospainikkeella ja avaa Muodon tiedot -valintaikkuna uudelleen valitsemalla Aseta painikkeen tyyppi.

    3. Vedä tarvittaessa lisää Työkalurivin painikkeet- ja Painike-erotin-muotoja ja liimaa ne toisiinsa.

      Muotoon liittyviä ohjeita saat napsauttamalla sitä hiiren kakkospainikkeella ja valitsemalla Ohje.

      Voit piilottaa yhteyspisteet Yhteyspisteen kuva – sininen X valitsemalla Näytä-valikosta Yhteyspisteet.

    Voit näyttää valikkorivin vasemman reunan tartuntapisteet napsauttamalla muotoa hiiren kakkospainikkeella ja poistamalla Lukitse työkalurivi -valintaruudun valinnan.

  7. Vedä Yleiset ohjausobjektit -kohdasta tarvitsemasi pysty- ja vaakasuuntaiset vierityspalkit Tyhjä lomake -muodon oikeaan reunaan ja alareunaan.

  8. Napsauta vierityspalkkeja hiiren kakkospainikkeella ja näytä, miten pitkälle sivua voi vierittää, valitsemalla Aseta vierityspalkin koko.

    Jos haluat ilmaista, että vain pieni osa asiakirjasta on näkyvissä, aseta vieritysnapin koko pieneksi. Jos haluat ilmaista, että asiakirjasta näkyy suurin osa, aseta vieritysnapin koko suureksi.

  9. Vedä Tilarivi-muoto sovellusikkunan alareunaan ja muotoile sitä haluamallasi tavalla.

    how

    1. Vedä Tilarivin jakoviiva -muoto sivulle ja liimaa se Tilarivi-muodon hallintakahvaan Hallintakahva .

      Hallintakahvoissa voi liimata Tilarivin jakoviiva -muodon Tilariviin tai toiseen Tilarivin jakoviiva -muotoon.

      Jos et näe Tilarivin jakoviiva -muotoa liimattuasi sen Tilarivi-muotoon, valitse Tilarivi-muoto ja valitse Muoto-valikosta Järjestys ja valitse sitten Siirrä taaksepäin.

    2. Vedä Ikkunan koon muuttaminen -muoto tilarivin oikeaan reunaan, jos haluat ilmaista, että ikkunan kokoa voi muuttaa.

Sivun alkuun

Valikoiden ja työkalurivien luominen

Windows XP -muotojen avulla voit luoda vakiomuotoisia valikoita, avattavia luetteloita ja työkalurivejä.

Valikon muodostaminen

  1. Vedä Työkalurivit ja valikot -kohdasta Valikkorivi-muoto piirustussivulle. Voit näyttää valikkorivin vasemman reunan tartuntapisteen napsauttamalla muotoa hiiren kakkospainikkeella ja poistamalla Lukitse valikkorivi -valintaruudun valinnan.

  2. Vedä esiin Ylätason valikon osa -muoto ja liimaa se Valikkorivin vasempaan reunaan.

    Vihje: Voit sijoittaa kuvakkeen ensimmäisen valikon osan vasemmalle puolelle.

  3. Kun muoto on valittuna, kirjoita nimi. Jos valikon osalla on pikanäppäin, alleviivaa oikea kirjain.

  4. Toista tarvittaessa vaiheet 2 ja 3.

    Muotoon liittyviä ohjeita saat napsauttamalla sitä hiiren kakkospainikkeella ja valitsemalla Ohje.

    Voit piilottaa yhteyspisteet Yhteyspisteen kuva – sininen X valitsemalla Näytä-valikosta Yhteyspisteet.

    Sarakkeen kohteiden on oltava leveydeltään yhtä suuria kuin sarakkeen levein kohde.

Avattavan valikon muodostaminen

  1. Vedä Ylätason valikon osa -muoto piirustussivulle.

  2. Kun muoto on valittuna, kirjoita nimi. Jos valikon osalla on pikanäppäin, alleviivaa oikea kirjain.

  3. Vedä Avattava valikon osa -muoto, liimaa se Ylätason valikon osa -muodon alareunaan ja kirjoita nimi.

  4. Toista vaihe 3 kaikille sarakkeessa oleville avattaville valikon osille.

  5. Muuta kaikkien Avattavien valikon osien kokoa niin, että ne ovat leveydeltään yhtä suuria kuin niiden levein osa.

  6. Napsauta hiiren kakkospainikkeella kutakin Avattava valikon osa -muotoa, valitse Valikon osan ominaisuudet ja valitse haluamasi asetukset.

    Muotoon liittyviä ohjeita saat napsauttamalla sitä hiiren kakkospainikkeella ja valitsemalla Ohje.

    Voit piilottaa yhteyspisteet Yhteyspisteen kuva – sininen X valitsemalla Näytä-valikosta Yhteyspisteet.

Työkalurivin muodostaminen

  1. Vedä Työkalurivit ja valikot -kohdasta Työkalurivi-muoto piirustussivulle. Voit näyttää valikkorivin vasemman reunan tartuntapisteet napsauttamalla muotoa hiiren kakkospainikkeella ja poistamalla Lukitse työkalurivi -valintaruudun valinnan.

  2. Vedä Työkalurivin painike -muotoa ja liimaa se Työkalurivi-muodon vasempaan reunaan.

  3. Valitse Muodon tiedot -valintaikkunassa haluamasi painiketyyppi. Jos haluat myöhemmin vaihtaa painikkeen, napsauta muotoa hiiren kakkospainikkeella ja avaa Muodon tiedot -valintaikkuna uudelleen valitsemalla Aseta painikkeen tyyppi.

  4. Vedä tarvittaessa lisää Työkalurivin painikkeet- ja Painike-erotin-muotoja ja liimaa ne toisiinsa.

    Muotoon liittyviä ohjeita saat napsauttamalla sitä hiiren kakkospainikkeella ja valitsemalla Ohje.

    Voit piilottaa yhteyspisteet Yhteyspisteen kuva – sininen X valitsemalla Näytä-valikosta Yhteyspisteet.

Sivun alkuun

Huomautus: Konekäännöksestä ilmoittava vastuusvapauslauseke: Tämä artikkeli on käännetty tietokonejärjestelmällä, eikä kieliasiantuntija ole muokannut sitä. Microsoft tarjoaa nämä konekäännökset avuksi muille kuin englantia puhuville käyttäjille, jotta he saavat lisätietoja Microsoftin tuotteista, palveluista ja tekniikoista. Koska artikkeli on koneellisesti käännetty, se saattaa sisältää sanasto-, lauseoppi- ja kielioppivirheitä.

Kehitä taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×