WBS-koodien luominen

Lyhyesti sanottuna työrakenne (WBS) -koodit ovat jäsennysnumeroita, joita voit käyttää tehtävissä ja muokata vastaamaan liiketoimintasi tarpeita. Project antaa kullekin tehtävälle automaattisesti jäsennysnumerot, mutta voit käyttää omia mukautettuja jäsennysmalleja projektissa milloin tahansa.

Seuraava osa koskee vain Microsoft Project 2016:ta, 2013:a ja 2010:tä.

Sisältö

Mukautettujen WBS-koodien luominen

WBS-koodien numeroiminen uudelleen

Perusjäsennysnumeroiden käyttäminen

Mukautettujen WBS-koodien luominen

  1. Valitse Näytä ja valitse sitten taulukkonäkymä, kuten Tehtävätaulukko tai Resurssitaulukko.

  2. Valitse Projekti. Valitse Ominaisuudet-ryhmässä WBS ja valitse sitten Määritä koodi.

    WBS-painikkeen Määritä koodi -vaihtoehdon kuva.

  3. Voit luoda projektikohtaisen koodin Projektikoodin etuliite -ruudussa. Voit käyttää numeroita, isoja ja pieniä kirjaimia ja muita merkkejä.

WBS-koodimääritys-valintaikkunan kuva

  1. Voit määrittää koodin ensimmäisen tason tehtäville valitsemalla Järjestys-sarakkeen ensimmäisellä rivillä merkkityypin avattavasta luettelosta. Voit valita lukuja, isoja ja pieniä kirjaimia tai lukujen, kirjaimien ja muiden merkkien sekoituksen.

  2. Aseta Pituus-sarakkeessa merkkimäärä koodimerkkijonon kullekin tasolle. Valitse Mikä tahansa, jos haluat sallia minkä tahansa merkkimäärän kyseisellä tasolla.

  3. Valitse Erotin-sarakkeessa merkki, jonka haluat erottavan eri tasojen koodimerkkijonot toisistaan.

    Oletuserotinmerkki on piste. Voit valita muita erottimia tai olla käyttämättä erotinmerkkiä.

    Huomautus: Erotinmerkkiä ei voi käyttää osana koodia.

  4. Määritä yksi koodimerkkijono kutakin jäsennyksessä sisennettynä näkyvää tehtävätasoa kohden.

    Voit määrittää erillisen koodimerkkijonon kullekin tasolle napsauttamalla seuraavaa riviä ja määrittämällä Järjestys-, Pituus- ja Erotin-sarakkeiden tiedot.

  5. Jos et halua, että Project määrittää WBS-koodin automaattisesti aina, kun määrität uuden tehtävän, poista Luo uuden tehtävän WBS-koodi -valintaruudun valinta.

  6. Jos haluat sallia saman WBS-koodin käyttämisen useassa tehtävässä, poista Vahvista uusien WBS-koodien yksiselitteisyys -valintaruudun valinta.

WBS-koodien numeroiminen uudelleen

Kun siirrät tai poistat tehtäviä, Project ei numeroi WBS-koodeja automaattisesti uudelleen, koska saatat käyttää niitä tiedostoissa tai muissa järjestelmissä, joita ei ole linkitetty projektitiedostoon. Tämä tarkoittaa, että jäljellä olevien tehtävien koodit ovat todennäköisesti vääriä. Voit numeroida kaikkien tai valittujen tehtävien WBS-koodit seuraavasti:

  1. Valitse Näytä ja valitse sitten taulukkonäkymä (kuten Tehtävätaulukko), joka sisältää tehtävän, jonka haluat numeroida uudelleen.

  2. Valitse tehtävät, jotka haluat numeroida uudelleen. Ensimmäistä valittua tehtävää ei numeroida uudelleen.

    Jos haluat numeroida uudelleen kaikkien tehtävien WBS-koodit, älä valitse mitään tehtäviä.

  3. Valitse Projekti. Valitse Ominaisuudet-ryhmässä WBS ja valitse sitten Numeroi uudelleen.

    Projekti-välilehden, WBS-painikkeen, Numeroi uudelleen -komennon kuva avattavassa valikossa.

  4. Valitse Valitut tehtävät numeroidaksesi uudelleen valitsemiesi tehtävien koodit.

    Valitse Koko projekti numeroidaksesi uudelleen projektin kaikkien tehtävien koodit.

    WBS-uudelleennumerointi -valintaikkunan kuva

Perusjäsennysnumeroiden käyttäminen

Jos et tarvitse WBS-koodien yksityiskohtaista rakennetta, voit käyttää perusjäsennystä.

Project luo automaattisesti jäsennysnumeron kullekin tehtävälle sen mukaan, missä kohtaa tehtäväluettelon rakennetta tehtävä näkyy. Esimerkiksi tehtäväluettelon ensimmäisen tehtävän numero on 1. Jos kyseinen tehtävä sisältää kolme alitehtävää, alitehtävien numerot ovat 1.1, 1.2 ja 1.3.

Jäsennysnumerot sisältävät vain lukuja eikä niitä voi muokata. Ne kuitenkin muuttuvat automaattisesti, kun tehtäviä siirretään ylös- tai alaspäin tehtäväluettelossa tai kun tehtäviä sisennetään tai ulonnetaan.

Jos haluat näyttää jäsennysnumerot, lisää Jäsennysnumero-kenttä taulukko tai taulukko. Voit myös lisätä jäsennysnumeroita suoraan tehtävien nimiin seuraavasti:

  1. Siirry Gantt-kaavioon tai Tehtävätaulukkoon.

  2. Valitse Muoto ja tarkista sitten Näytä tai piilota -ryhmässä Jäsennysnumero.

Sivun alkuun

Tämä osa koskee vain Microsoft Project 2007:ää.

Sisältö

Lisätietoja WBS-koodeista

Mukautettujen WBS-koodien määrittäminen

WBS-koodien numeroiminen uudelleen

Lisätietoja WBS-koodeista

Microsoft Office Projectissa on kahdenlaisia WBS-koodeja: jäsennysnumeroita ja mukautettuja WBS-koodeja. Lue lisätietoja seuraavista osista.

Jäsennysnumerot

Jäsennysnumerot ovat WBS-koodauksen yksinkertaisin tyyppi. Microsoft Office Project laskee automaattisesti kunkin tehtävän jäsennysnumeron tehtäväluettelon jäsennysrakenteen mukaan. Esimerkiksi tehtäväluettelon ensimmäisen tehtävän numero on 1. Jos kyseinen tehtävä sisältää kolme alitehtävää, alitehtävien numerot ovat 1.1, 1.2 ja 1.3.

Jäsennysnumerot koostuvat ainoastaan numeroista (ei kirjaimista) ja niitä ei voi muokata. Ne kuitenkin muuttuvat automaattisesti, kun tehtäviä siirretään ylös- tai alaspäin tehtäväluettelossa tai kun tehtäviä sisennetään tai ulonnetaan. Jos alitehtävän nykyinen jäsennysnumero on esimerkiksi 3.5.4 ja siirrät sitä yhden rivin ylöspäin luettelossa, jäsennysnumero päivittyy automaattisesti lukuun 3.5.3. Jos sitten ulonnat saman alitehtävän, jäsennysnumero päivittyy automaattisesti lukuun 3.6.

Vihje: Voit näyttää jäsennysnumerot lisäämällä Jäsennysnumero-kentän taulukko- tai taulukkonäkymään tai voit halutessasi näyttää jäsennysnumerot tehtävien nimien vieressä. Jos haluat näyttää jäsennysnumerot tehtävien nimien vieressä, valitse Työkalut-valikossa Asetukset ja valitse sitten Näytä-välilehti. Valitse Jäsennysasetukset-kohdassa Näytä jäsennysnumero -valintaruutu.

Mukautetut WBS-koodit

Jos projektisi hyötyisi yksityiskohtaisista WBS-koodeista, jotka muodostuvat tietyn pituisista numero- ja kirjainsarjoista, määritä projektille yksittäinen mukautettu WBS-koodipeite. (Projektissa voi olla enintään yksi mukautettu koodipeite.) Mukautettu WBS-koodi tallennetaan WBS-kenttään.

Kuten jäsennysnumeroissa mukautetun WBS-koodin kukin taso edustaa tehtäväluettelon jäsennystasoa. Voit käyttää yksilöllistä muotoa koodin kullakin tasolla, ja kukin taso näkyy koodissa tehtävien, yhteenvetotehtävien ja alitehtävien hierarkian mukaan.

Jos suunnittelet esimerkiksi vaiheittaisia projekteja, jotka sopivat organisaation tulevan tilikauden direktiiveihin, voit luoda kutakin tehtävää edustavan mukautetun WBS-koodipeitteen käyttämällä vastaavaa direktiiviä, vuosineljännestä ja projektia. Kun käytät tätä koodia, sinulla saattaa olla tehtävä, jonka mukautettu WBS-koodi on CustSat.Q3.CSTools.11. Tämä tarkoittaa sitä, että kyseessä on Customer Support Tools Upgrade -projektin tehtävä 11, joka alkaa kolmannella neljänneksellä ja joka tukee suunnitellun tilikauden Customer Satisfaction -direktiiviä.

Sivun alkuun

Mukautettujen WBS-koodien määrittäminen

  1. Valitse Näytä-valikossa taulukkonäkymä, kuten Tehtävätaulukko-näkymä.

    Jos haluat valita näkymän, jota ei ole Näytä-valikossa, valitse Lisää näkymiä, valitse sitten haluamasi näkymä Näkymät-luettelosta ja valitse Käytä.

  2. Valitse Projekti-valikossa WBS ja valitse sitten Määritä koodi.

  3. Erotat tämän projektin tehtävät muiden projektien tehtävistä kirjoittamalla projektikohtaisen koodin etuliitteen Projektikoodin etuliite -ruutuun.

    Tämän etuliitteen avulla tunnistat projektin WBS-koodin ylimmällä tasolla. Etuliitteen avulla tunnistat myös pääprojektin aliprojektit, ja se on hyödyllinen myös silloin, kun luot riippuvuuksia projektien tehtävien välille.

    Voit käyttää mitä tahansa numeroiden, isojen ja pienien kirjaimien sekä symbolien yhdistelmää projektikoodin etuliitteenä.

  4. Määritä ensimmäisen tason tehtävien koodimerkkijono napsauttamalla Järjestys-sarakkeen ensimmäisellä rivillä sitä merkkityyppiä, jota haluat käyttää tällä tasolla:

    • Valitse Numerot (järjestyksessä), jos haluat määrittää numeeriset WBS-koodit tälle tasolle (esimerkiksi 1, 2 ja 3 projektin kolmelle ensimmäiselle yhteenvetotehtävälle).

    • Valitse Isot kirjaimet (järjestyksessä), jos haluat valita isoilla kirjaimilla kirjoitetut, aakkostetut WBS-koodit (esimerkiksi A, B ja C projektin kolmelle ensimmäiselle yhteenvetotehtävälle).

    • Valitse Pienet kirjaimet (järjestyksessä), jos haluat valita pienillä kirjaimilla kirjoitetut, aakkostetut WBS-koodit (esimerkiksi a, b ja c projektin kolmelle ensimmäiselle yhteenvetotehtävälle).

    • Valitse Merkit (ei järjestyksessä), jos haluat valita minkä tahansa numeroiden sekä isojen ja pienien kirjaimien yhdistelmän (esimerkiksi Arch1, Const1 ja Insp1 projektin kolmelle ensimmäiselle yhteenvetotehtävälle).

      Kun valitset tämän vaihtoehdon, voit vapaammin valita mukautetun WBS-koodin. Project näyttää tähden (*) WBS-kentässä, kunnes kirjoitat merkkijonon WBS-koodin tälle tasolle.

  5. Kirjoita tai valitse kunkin tason koodimerkkijonon merkkien määrä Pituus-sarakkeessa. Voit joko kirjoittaa tarkan merkkimäärän tai valita Mikä tahansa, jolloin voit valita minkä tahansa merkkimäärän kyseisellä kooditasolla.

    Voit kirjoittaa esimerkiksi 3, jos haluat, että WBS-koodin yhden tason pakollinen merkkimäärä on kolme. WBS-koodin kokonaispituus voi olla 1–255 merkkiä.

  6. Kirjoita tai valitse Erotin-sarakkeessa merkki, jonka haluat erottavan eri tasojen koodimerkkijonot toisistaan.

    Oletusarvoisesti erotinmerkkinä käytetään pistettä. Voit käyttää eri erotinmerkkiä kullakin kooditasolla.

    Voit myös valita, että et käytä mitään erotinmerkkiä kooditasojen välillä. Poista erotinmerkki Erotin-kentästä.

  7. Määritä yksi koodimerkkijono kutakin jäsennyksessä sisennettynä näkyvää tehtävätasoa kohden.

    Voit määrittää erillisen koodimerkkijonon kullekin tasolle napsauttamalla seuraavaa riviä ja määrittämällä Järjestys-, Pituus- ja Erotin-sarakkeiden tiedot.

  8. Jos et halua, että Project määrittää WBS-koodin automaattisesti aina, kun määrität uuden tehtävän, poista Luo uuden tehtävän WBS-koodi -valintaruudun valinta.

  9. Jos haluat sallia saman WBS-koodin käyttämisen useassa tehtävässä, poista Vahvista uusien WBS-koodien yksiselitteisyys -valintaruudun valinta.

Huomautus: 

  • Et voi käyttää koodin osana merkkiä, jota käytät erottimena. Jos käytät esimerkiksi yhdysmerkkiä erottimena, et voi käyttää yhdysmerkkiä tehtävää edustavassa koodissa.

  • Et voi määrittää useampaa kuin yhden WBS-koodijoukon projektia kohti. Jos sinun on osoitettava tehtäville enemmän organisaatiorakennetta, voit luoda tai ottaa käyttöön erillisen koodijoukon käyttämällä mukautettuja kenttiä.

  • Sinun on lisättävä WBS-kenttä näkymääsi, jotta voit tarkastella WBS-koodeja.

  • Voit muuttaa yhteenvetotehtävän ja sen kaikkien alitehtävien WBS-koodit muuttamalla yhteenvetotehtävän aiemmin luodun WBS-koodin tai tähtijoukon toiseen merkkijoukkoon.

    Tietyn alitehtävän WBS-koodi on esimerkiksi Ph3.Prj5.Arch.Task3. Task3 edustaa Develop plans -alitehtävää ja Arch edustaa Architect solution -yhteenvetotehtävää. Yhteenvetotehtävän nimeksi muutetaan Design solution ja sinun on päivitettävä yhteenvetotehtävän ja sen kaikkien alitehtävien koodit. Voit muokata WBS-koodia niin, että Des edustaa yhteenvetotehtävää, jolloin Develop plans -alitehtävän WBS-koodi päivittyy automaattisesti muotoon Ph3.Prj5.Des.Task3.

WBS-koodien numeroiminen uudelleen

Kun siirrät tai poistat tehtäviä, niiden mukautetut WBS-koodit eivät ehkä enää ole oikeassa järjestyksessä. Project ei numeroi WBS-koodeja automaattisesti uudelleen, koska saatat käyttää kyseisiä WBS-koodeja tiedostoissa tai muissa järjestelmissä, joita ei ole linkitetty projektitiedostoon. Voit numeroida kaikkien tai valittujen tehtävien WBS-koodit uudelleen:

  1. Napsauta Näytä-valikossa sitä taulukkonäkymää, joka sisältää tehtävät, jotka haluat numeroida uudelleen (esimerkiksi Tehtävätaulukko).

    Jos haluat valita näkymän, jota ei ole Näytä-valikossa, valitse Lisää näkymiä, valitse sitten haluamasi näkymä Näkymät-luettelosta ja valitse Käytä.

  2. Valitse tehtävät, jotka haluat numeroida uudelleen. (Tehtävävalinnan ensimmäistä tehtävää ei numeroida uudelleen. Sitä käytetään muiden tehtävien uudelleennumeroinnin vertailupisteenä.)

    Jos haluat numeroida uudelleen kaikkien tehtävien WBS-koodit, älä valitse mitään tehtäviä.

  3. Valitse Projekti-valikossa WBS ja valitse sitten Numeroi uudelleen.

  4. Jos haluat muuttaa vain valittujen vierekkäisten tehtävien WBS-koodien järjestyksen, valitse Valitut tehtävät.

    Jos haluat muuttaa projektin kaikkien tehtävien WBS-koodien järjestyksen, valitse Koko projekti.

Huomautus: 

  • Jos projektissa on aliprojekteja, voit numeroida kunkin aliprojektin jotkut tai kaikki tehtävät uudelleen näyttämällä kaikki alitehtävät. Valitse Näytä Näytä ja valitse sitten Kaikki alitehtävät. (Project ei voi numeroida uudelleen sellaisten aliprojektien tehtäviä, joita ei näytetä.)

  • Pääprojektiin lisättyjen aliprojektien uudelleennumerointi muuttaa myös aliprojektin projektitason koodin.

  • Voit näyttää WBS-koodit lisäämällä WBS-sarakkeen taulukkonäkymään.

  • Voit muuttaa WBS-koodit, kun Project on laskenut ne, valitsemalla Projekti-valikossa WBS ja valitsemalla sitten Määritä koodi. Muuta Järjestys-sarakkeessa koodipeitteen minkä tahansa tason merkkityyppiä. Kun päivität koodin yhteenvetotehtävätasolla, kaikki kyseisen yhteenvetotehtävän alitehtävät päivitetään automaattisesti.

    Jos sinulla on ongelmia WBS-koodien muuttamisessa, syynä saattaa olla jokin seuraavista:

    • Yrität muuttaa WBS-koodia, jossa on koodipeite, koodin laskennan jälkeen     Jos loit WBS-koodipeitteen ja tehtävien WBS-koodit oli jo laskettu, voit muuttaa WBS-koodia vain määrittämällä koodipeitteen tasot uudelleen. Kun olet määrittänyt koodipeitteen tasot uudelleen, voit muuttaa minkä tahansa koodipeitteen tason. Voit valita Numerot (järjestyksessä), Isot kirjaimet (järjestyksessä), Pienet kirjaimet (järjestyksessä) tai Merkit (ei järjestyksessä).

    • Yrität muuttaa WBS-koodia alemmalla tasolla tehtäväluettelossa     Et voi muuttaa WBS-koodin merkkejä alitehtävän tasolla, voit muuttaa merkkejä vain yhteenvetotehtävätasolla, jossa WBS-koodin taso määritetään.

Sivun alkuun

Kehitä taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×