Vioittuneen työkirjan korjaaminen

Tärkeää: Tämä on artikkeli on käännetty koneellisesti. Lue vastuuvapauslauseke. Tämän artikkelin englanninkielinen versio on täällä .

Havaitessaan vioittuneen työkirjan sen avaamisen yhteydessä Microsoft Excel käynnistää tiedostonpalautustilan automaattisesti ja yrittää korjata työkirjan. Jos tiedostonpalautustila ei käynnisty, voit yrittää palauttaa työkirjan manuaalisesti:

  1. Valitse Tiedosto > Avaa.

  2. Napsauta sijaintia ja kansiota, joka sisältää vioittuneen työkirjan.

  3. Valitse vioittunut työkirja Avaa-valintaikkunassa.

  4. Napsauta Avaa-painikkeen vieressä olevaa nuolta ja valitse Avaa ja korjaa.

    Avaa ja korjaa -komento

  5. Palauttaaksesi mahdollisimman paljon työkirjan tietoja valitse Korjaa.

    Jos tietojen palauttaminen ei onnistu Korjaa-toiminnolla, poimi arvot ja kaavat työkirjasta valitsemalla Poimi tiedot.

Ellei automaattinen eikä manuaalinen korjaus toimi, tiedot voi olla mahdollista pelastaa muillakin menetelmillä. Voit myös ehkäistä tietojen katoamista tallentamalla työkirjasta varmuuskopion automaattisesti tai luomalla palautustiedoston aika ajoin.

Vioittuneen työkirjan tietojen palauttaminen

Työkirjan varmuuskopion automaattinen tallentaminen

Palautustiedoston luominen automaattisesti tietyin väliajoin

Vioittuneen työkirjan tietojen palauttaminen

Palauta tiedot jollakin seuraavista menetelmistä. Jos menetelmä ei toimi, kokeile jotakin toista menetelmää. Voit yrittää palauttaa työkirjan myös kolmannen osapuolen ohjelmistoratkaisulla.

Tärkeää: Jos levy- tai verkkovirhe estää työkirjan avaamisen, siirrä työkirja toiseen kiintolevyasemaan tai paikalliselle levylle ennen kuin yrität seuraavia palautusmenetelmiä.

Tietojen palauttaminen, kun työkirja on avattu Excelissä

  • Työkirjan palauttaminen viimeksi tallennettuun versioon    Jos olet muokkaamassa työkirjaa ja se vioittuu ennen kuin ehdit tallentaa tekemäsi muutokset, voit palauttaa työkirjan viimeksi tallennettuun versioon.

    1. Valitse Tiedosto > Avaa.

    2. Kaksoisnapsauta Excelissä avoinna olevan työkirjan nimeä.

    3. Avaa työkirja uudelleen valitsemalla Kyllä.

      Työkirja avautuu ilman tekemiäsi muutoksia, jotka saattoivat aiheuttaa työkirjan vioittumisen.

Tietojen palauttaminen, kun työkirjaa ei voi avata Excelissä

  • Laskentatavan määrittäminen Excelissä manuaalisesti    Yritä muuttaa laskentatapa automaattisesta manuaaliseksi. Koska työkirjaa ei lasketa uudelleen, se saattaa aueta.

    1. Valitse Tiedosto > Uusi.

    2. Valitse Uusi-kohdassa Tyhjä työkirja.

    3. Valitse Tiedosto > Asetukset.

    4. Valitse Kaavat-luokan Laskenta-asetukset -kohdassa Manuaalinen ja valitse sitten OK.

    5. Valitse Tiedosto > Avaa.

    6. Etsi vioittunut työkirja ja avaa sen sitten kaksoisnapsauttamalla.

  • Luo linkki vioittuneeseen työkirjaan käyttämällä ulkoisia viittauksia    Jos haluat palauttaa työkirjasta ainoastaan tiedot ilman kaavoja tai laskettuja arvoja, voit käyttää ulkoisia viittauksia ja luoda näin linkin vioittuneeseen työkirjaan.

    1. Valitse Tiedosto > Avaa.

    2. Siirry kansioon, jossa vioittunut työkirja on.

    3. Napsauta vioittuneen työkirjan nimeä hiiren kakkospainikkeella, valitse Kopioi ja valitse sitten Peruuta.

    4. Valitse Tiedosto > Uusi.

    5. Valitse Uusi-kohdassa Tyhjä työkirja.

    6. Kirjoita uuden työkirjan soluun A1 = Tiedostonimi! A1, jossa tiedostonimi nimestä vioittuneen työkirjan, joka on kopioitu vaiheessa 3, ja paina sitten Enter-näppäintä.

      Huomautus: Kirjoita vain työkirjan nimi– tunnistetta ei tarvitse kirjoittaa.

    7. Jos näkyviin tulee Päivitä arvot -valintaikkuna, valitse vioittunut työkirja ja sitten OK.

    8. Jos näkyviin tulee Valitse taulukko -valintaikkuna, valitse haluamasi taulukko ja valitse OK.

    9. Valitse solu A1.

    10. Valitse Aloitus > Kopioi tai paina Ctrl+C-näppäinyhdistelmää.

    11. Valitse solusta A1 alkaen alue, joka on suunnilleen saman kokoinen kuin solualue, joka sisältää tiedot vioittuneessa työkirjassa.

    12. Valitse Aloitus > Liitä tai paina Ctrl+V-näppäinyhdistelmää.

    13. Solualueen ollessa edelleen valittuna valitse Aloitus > Kopioi uudelleen tai paina Ctrl+C-näppäinyhdistelmää.

    14. Valitse Aloitus > napsauta nuolta Liitä-kohdan alapuolella ja valitse sitten Liitä arvot -kohdassa Arvot.

      Arvojen liittäminen poistaa vioittuneen työkirjan linkit ja jättää vain tiedot.

  • Poimi tiedot vioittuneesta työkirjasta käyttämällä makroa    Jos vioittuneeseen työkirjaan on linkitetty kaavio, voit poimia kaavion lähdetiedot käyttämällä makroa.

    1. Kopioi seuraava makrokoodi ja liitä se moduulitaulukkoon:

      Sub GetChartValues()

      Dim NumberOfRows kokonaislukuna

      Dim X objektina

      Laskuri = 2

      "Tietoriviä määrän laskeminen.

      NumberOfRows = UBound(ActiveChart.SeriesCollection(1). Arvot)

      Worksheets("ChartData"). Solut (1, 1) = "X-arvot"

      "Kirjoita x-akselin arvot laskentataulukkoon.

      Worksheets("ChartData") kanssa

      . Alue (. Solut (2, 1) _

      . Solut (NumberOfRows + 1, 1)) = _

      Application.Transpose(ActiveChart.SeriesCollection(1). Xarvot)

      Perässä

      "Kirjoita niiden arvot ja käy läpi kaavion kaikissa sarjoissa

      ' laskentataulukon.

      Kutakin x-ActiveChart.SeriesCollection

      Worksheets("ChartData"). Solut (1, laskuri) = X.Name

      Worksheets("ChartData") kanssa

      . Alue (. Solut (2, laskuri) _

      . Solut (NumberOfRows + 1, laskuri)) = _

      Application.Transpose(X.Values)

      Perässä

      Laskuri = laskuri + 1

      Seuraava

      End Sub

    2. Lisää uusi laskentataulukko työkirjaan, napsauta sen taulukonvalitsinta hiiren kakkospainikkeella ja määritä sen nimeksi ChartData.

    3. Valitse kaavio, josta haluat poimia pohjana olevat tietoarvot.

      Huomautus: Kaavio voi olla upotettu työkirjaan tai erillisessä kaaviotaulukossa.

    4. Suorita GetChartValues-makro.

    5. Kaavion tiedot lisätään ChartData-laskentataulukkoon.

Sivun alkuun

Työkirjan varmuuskopion automaattinen tallentaminen

Työkirjan varmuuskopion ansiosta tiedot ovat aina käytössäsi, jos työkirja poistetaan vahingossa tai se vioittuu.

  1. Valitse Tiedosto > Tallenna nimellä.

  2. Valitse Tietokone ja napsauta sitten Selaa-painiketta.

    Selaa-painike

  3. Napsauta Tallenna nimellä ‑valintaikkunan Työkalut-kohdan vieressä olevaa nuolta ja valitse Yleiset asetukset.

    Työkalut-valikon Yleiset asetukset

  4. Valitse Yleiset asetukset -valintaikkunassa Luo aina varmuuskopio -valintaruutu.

    Yleiset asetukset -valintaikkunan Luo aina varmuuskopio -asetus

Sivun alkuun

Palautustiedoston luominen automaattisesti tietyin väliajoin

Työkirjan palautustiedoston avulla voit varmistaa, että tiedot ovat käytössäsi, jos työkirja poistetaan vahingossa tai se vioittuu.

  1. Valitse Tiedosto > Asetukset.

  2. Valitse Tallenna-luokan Tallenna työkirjat -kohdassa Tee automaattinen tallennus x minuutin välein -valintaruutu ja kirjoita minuuttien määrä. (Oletusarvo on 10.)

    Excelin asetukset -valintaikkunan Tallenna-välilehden Automaattinen tallennus -asetus

  3. Kirjoita Automaattisen palautuksen tiedoston sijainti -ruutuun sijainti, johon haluat tallentaa palautustiedoston.

  4. Varmista, että Poista automaattinen palautus käytöstä vain tässä työkirjassa -valintaruutua ei ole valittu.

Sivun alkuun

Huomautus: Konekäännöksestä ilmoittava vastuusvapauslauseke: Tämä artikkeli on käännetty tietokonejärjestelmällä, eikä kieliasiantuntija ole muokannut sitä. Microsoft tarjoaa nämä konekäännökset avuksi muille kuin englantia puhuville käyttäjille, jotta he saavat lisätietoja Microsoftin tuotteista, palveluista ja tekniikoista. Koska artikkeli on koneellisesti käännetty, se saattaa sisältää sanasto-, lauseoppi- ja kielioppivirheitä.

Kehitä taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×