Viallisten kaavojen ratkaiseminen

Tärkeää: Tämä on artikkeli on käännetty koneellisesti. Lue vastuuvapauslauseke. Tämän artikkelin englanninkielinen versio on täällä .

Odottamattomia tuloksia tai virheitä näyttävät kaavat voivat olla turhauttavia, varsinkin jos et tiedä, mitä sinun kannattaisi tehdä seuraavaksi.

Viallisiin kaavoihin voi olla monia syitä. Kaavoissa voi esimerkiksi olla yhteensopimattomia sulkeita, kirjoitusvirheitä ja viittauksia tietoihin alueilla, joita ei ole. Seuraavien parhaiden käytäntöjen avulla voit välttää ja ratkaista yleisiä virheitä, kun luot tai korjaat kaavoja.

Paras käytäntö:

Vältä tämä yleinen virhe:

Jokaisen kaavan alussa on yhtäläisyysmerkki (=)

Jos kaavan alussa ei ole yhtäläisyysmerkkiä, se ei ole kaava eikä sitä voi laskea. Tämä on tavallinen virhe.

Kun esimerkiksi kirjoitat kaavan SUMMA(A1:A10), Excel Online näyttää tekstimerkkijonon SUMMA(A1:A10) kaavan tuloksen sijaan. Jos kirjoitat 2.11., näkyviin tulee päivämäärä, kuten 2.11. tai 2.11.2009.

Voit välttää odottamattomat tulokset kirjoittamalla ensin yhtäläisyysmerkin. Kirjoita esimerkiksi: =SUMMA(A1:A10) ja =2.11

Alkusulkeita ja loppusulkeita on yhtä paljon

Varmista, että kaikki sulkeet muodostavat parin. Funktiota käyttävässä kaavassa sulkumerkkien määrän on oltava parillinen, jotta funktio toimii oikein.

Esimerkiksi kaava =JOS(B5<0),"Ei kelpaa",B5*1.05) ei toimi, koska loppusulkeita on kaksi, mutta alkusulkeita on vain yksi.

Oikea kaava näyttää tältä: =JOS(B5<0;"Ei kelpaa";B5*1,05).

Kaikki tarvittavat argumentit on kirjoitettava

Useimmilla funktioilla on pakollisia argumentteja. Nämä arvot on annettava, jotta funktio toimii oikein. Vain harvat funktiot (kuten PII tai TÄMÄ.PÄIVÄ) eivät hyväksy mitään argumentteja. Varmista, että olet syöttänyt kaikki tarvittavat argumentit. Tarkista kaavasyntaksi, kun kirjoitat yhtäläisyysmerkkiä ja sitä seuraavaa funktiota.

Esimerkiksi ISOT-funktiossa voi käyttää vain yhtä tekstimerkkijonoa tai soluviittausta argumenttina: =ISOT("hei") tai =ISOT(C2)

Jotkin funktiot, kuten SUMMA, edellyttävät vain numeerisia argumentteja. Toiset funktiot, kuten KORVAA, puolestaan edellyttävät ainakin yhden argumentin tekstiarvon. Jos käytät väärää tietotyyppiä, jotkin funktiot voivat palauttaa odottamattomia tuloksia tai näyttää #ARVO!‑virheen.

Muotoilemattomien lukujen käyttäminen kaavoissa

Älä käytä kaavojen luvuissa dollarimerkkiä ($) tai puolipisteitä (;), koska dollarimerkeillä osoitetaan suorat viittaukset ja puolipisteet erottavat argumentit toisistaan. Muotoiltuja lukuja ei käytetä kaavan laskutoimituksissa. Kirjoita kaavaan arvon $1000 sijaan 1000.

Jos käytät argumenteissa muotoiltuja lukuja, saat odottamattomia laskutuloksia tai #LUKU! -virheen. Jos esimerkiksi haluat määrittää luvun -2134 itseisarvon ja kirjoitat kaavan käyttämällä pilkkua tuhaterottimena =ITSEISARVO(-2,134), Excel Online näyttää #LUKU! -virheen, koska ITSEARVO-funktio hyväksyy vain yhden argumentin.

Voit muotoilla kaavan tulosta desimaalierottimilla ja valuutan symboleilla sen jälkeen, kun olet syöttänyt kaavan muotoilemattomilla luvuilla käyttämällä lukumuotoilua.

Solun oikean tietotyypin käyttäminen

Kaava voi palauttaa odottamattomia tuloksia, jos solun tietotyyppiä ei voi käyttää laskutoimituksissa.

Jos esimerkiksi syötät tekstiksi muokattuun soluun kaavan =2+3, Excel Online ei voi laskea kaavan tietoja. Solussa näkyy vain =2+3.

Voit korjata tämän vaihtamalla solun Teksti-tietotyypin Yleiset-tietotyypiksi näin:

  1. Valitse solu.

  2. Napsauta Aloitus > Lukumuotoilu-nuolta ja valitse Yleiset.

  3. Aseta solu muokkaustilaan painamalla F2-näppäintä ja hyväksy kaava painamalla ENTER-näppäintä.

Soluun syötetty Luku-tietotyypin sisältävä päivämäärä voidaan näyttää numeerisena päivämääräarvona päivämäärän sijaan. Jos haluat näyttää luvun päivämääränä, valitse Lukumuotoilu-valikossa Päivämäärä-muoto.

Lukuja kerrottaessa käytetään *-symbolia

Kaavan kertolaskuoperaattorina on käytettävä asteriskia (*) x-merkin sijaan.

Jos käytät kaavassa x-merkkiä, Excel Online ei voi laskea tuloksia ja näyttää solussa kaavan. Solun ympärillä näkyvä punainen pisteviivareunus ilmaisee, että kaavassa on virhe.

Kaavoissa käytetään lainausmerkkejä tekstin ympärillä

Jos luot kaavan, jossa on tekstiä, kirjoita teksti lainausmerkkien sisään.

Esimerkiksi kaava ="Tänään on " & TEKSTI(TÄMÄ.PÄIVÄ();"pppp, p.k.") yhdistää tekstin "Tänään on " TEKSTI ja TÄMÄ.PÄIVÄ-funktioiden tuloksiin ja palauttaa soluun tekstin Tänään on maanantai, 30.5.

Kaavassa "Tänään on " on välilyönti ennen loppulainausmerkkiä. Tämän ansiosta sanojen Tänään on ja maanantai, 30.5. välissä on välilyönti. Jos tekstin ympärillä ei ole lainausmerkkejä, kaava voi näyttää #NIMI?‑virheen.

Kaavaan upotetaan enintään 64 funktiota

Voit käyttää kaavassa sisäkkäisiä funktioita enintään 64 tasolla.

Esimerkiksi kaavassa =JOS(NELIÖJUURI(PII())<2;"Vähemmän kuin kaksi!";"Enemmän kuin kaksi!") on kolme funktiotasoa: PII-funktio sisältyy NELIÖJUURI-funktioon, joka puolestaan sisältyy JOS-funktioon.

Vältä numeeristen arvojen jakamista nollalla

Jos solu jaetaan toisella solulla, jossa on nolla tai ei mitään arvoa, tuloksena on #JAKO/0! -virhe.

Voit välttää tämän virheen laittamalla jakolaskutoimituksen JOSVIRHE-funktion sisään. Voit esimerkiksi kirjoittaa kaksi seuraavaa kaavaa laskentataulukon soluihin:

=JOSVIRHE(3/0;0)

=JOSVIRHE(3/7;0)

Ensimmäinen kaava palauttaa arvon 0, koska JOSVIRHE-funktio tunnistaa, että nollalla jakaminen palauttaa virhearvon. Toinen kaava palauttaa arvon 3/7. Virhettä ei synny, koska lukua ei jaeta nollalla.

Kaavojen luomista helpottavia vinkkejä on artikkelissa Kaavavinkkejä.

Huomautus: Konekäännöksestä ilmoittava vastuusvapauslauseke: Tämä artikkeli on käännetty tietokonejärjestelmällä, eikä kieliasiantuntija ole muokannut sitä. Microsoft tarjoaa nämä konekäännökset avuksi muille kuin englantia puhuville käyttäjille, jotta he saavat lisätietoja Microsoftin tuotteista, palveluista ja tekniikoista. Koska artikkeli on koneellisesti käännetty, se saattaa sisältää sanasto-, lauseoppi- ja kielioppivirheitä.

Kehitä taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×