Vaihe 4 – Makron jakaminen muille

Tärkeää: Tämä on artikkeli on käännetty koneellisesti. Lue vastuuvapauslauseke. Tämän artikkelin englanninkielinen versio on täällä .

Jos haluat jakaa makroja, on tärkeää ymmärtää, että makro on tallennettu Office-tiedostoon, joten sinun on jaettava kyseinen tiedosto muille. Jos loit makron Wordissa, tiedosto on jaettava muodossa Word-malli, jossa on makrot käytössä (.dotm) tai Word-asiakirja, jossa on makrot käytössä (.docm). Jos loit makron Excelissä, tiedosto on jaettava muodossa Excel-työkirja (makrot käytössä) (.xlsm) tai Excel-malli (makrot käytössä) (.xltm).

Jos loit Word-makron, sen jakaminen edellyttää muutaman lisävaiheen tekemistä:

Tyhjän Word-mallin luominen

  1. Avaa uusi Word-asiakirja.

  2. Valitse Tiedosto-valikossa Tallenna nimellä.

  3. Anna tiedoston nimeksi global_macros.dotm.

  4. Valitse avattavasta Muoto-valikosta Muoto-asetukseksi Word-malli, jossa on makrot käytössä (.dotm).

  5. Valitse tiedoston tallennuspaikka verkossa.

  6. Valitse Tallenna ja sulje malli.

Word-makron vieminen asiakirjasta

Kun olet tallentanut makron vaiheessa 1, voit viedä sen seuraavien ohjeiden mukaisesti:

  1. Avaa vietävän makron sisältävä asiakirja tai malli.

  2. Valitse Työkalut-valikossa Makro ja sitten Makrot.

  3. Valitse vietävä makro ja valitse sitten Muokkaa. Valitse vietävä makro

  4. Valitse Visual Basic Editorissa Tiedosto > Vie tiedosto.

  5. Tallenna makro samaan kansioon, johon tallensit makroja käyttävän mallin global_macros.dotm.

Word-makron tuominen uuteen tyhjään malliin

  1. Avaa global_macros.dotm ja valitse Työkalut > Makro > Visual Basic Editor.

  2. Jos haluat tuoda makron, valitse Tiedosto > Tuo tiedosto, siirry kansioon, johon tallensit viedyn makron, valitse tiedosto ja valitse sitten Avaa.

  3. Tallenna moduuli, lopeta Visual Basic Editor ja lopeta sitten Word.

Nyt voit jakaa makron muille ja pyytää heitä asentamaan makron tietokoneisiinsa seuraavien ohjeiden mukaan.

Mallin asentaminen: Wordin määrittäminen käyttämään makroa

  1. Sijoita tiedosto global_macro.dotm tähän sijaintiin:

    • Word for Mac 2011: Macintosh HD/Käyttäjät/käyttäjänimi/Kirjasto/Ohjelmien tuki/Microsoft/Office/User Templates/My Templates

    • Word 2003 tai uudempi Windows-tietokoneissa: C:\Documents and Settings\käyttäjänimi\Application Data\Microsoft\Word\STARTUP

      Huomautus:  Käyttäjänimi on käyttäjän kirjautumisnimi.

  2. Valitse Wordissa Word > Asetukset….

Wordin asetukset

  1. Valitse Omat asetukset -osassa Oletuskansiot

  2. Valitse Oletuskansiot-luettelosta Käynnistys ja valitse sitten Muokkaa….

Tiedoston sijainti

  1. Tarkista, että Word käyttää Käynnistys-kansiona samaa kansiota, johon sijoitit global_macro.dotm-tiedoston.

  2. Sulje Valitse kansio -valintaikkuna valitsemalla Valitse ja sulje sitten Oletuskansiot-valintaikkuna valitsemalla OK.

Määritä lopuksi Word käyttämään global_macros.dotm-tiedostoa käynnistyksen yhteydessä.

  1. Valitse Wordissa Työkalut > Mallit ja apuohjelmat….

  2. Valitse global_macros.dotm-tiedosto luettelosta ja valitse OK.

    Vihje:  Jos et näe mallia luettelossa, global_macros.dotm-tiedosto ei ole Wordin käynnistyskansiossa. Palaa tämän osion vaiheeseen 1 ja tarkista, että Käynnistys-kansio on sama kuin se, johon kopioit global_macros.dotm-tiedoston.

Wordin asetusten yleinen malli

Vaihe 1 – Makron tallentaminen

Vaihe 2 – Koodin lukeminen ja ymmärtäminen

Vaihe 3 – Ohjelmoinnin perusteet

Vaihe 4 – Makron jakaminen muille

Vaihe 5 – Käytännön esimerkkejä

Huomautus: Konekäännöksestä ilmoittava vastuusvapauslauseke: Tämä artikkeli on käännetty tietokonejärjestelmällä, eikä kieliasiantuntija ole muokannut sitä. Microsoft tarjoaa nämä konekäännökset avuksi muille kuin englantia puhuville käyttäjille, jotta he saavat lisätietoja Microsoftin tuotteista, palveluista ja tekniikoista. Koska artikkeli on koneellisesti käännetty, se saattaa sisältää sanasto-, lauseoppi- ja kielioppivirheitä.

Kehitä taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×