VALITSE.INDEKSI (VALITSE.INDEKSI-funktio)

VALITSE.INDEKSI (VALITSE.INDEKSI-funktio)

Tässä artikkelissa kuvataan Microsoft Excelin VALITSE.INDEKSI-funktion kaavasyntaksi ja käyttö.

Kuvaus

Palauttaa arvoargumenttien luettelosta arvon käyttämällä indeksi_luku-argumenttia. VALITSE.INDEKSI-funktion avulla voit valita korkeintaan 254 arvoa indeksiluvun avulla. Jos esimerkiksi arvo1–arvo7 on määritetty viikonpäiviksi, VALITSE.INDEKSI-funktio palauttaa jonkin viikonpäivistä, kun lukua 1–7 käytetään indeksi_luku-argumenttina.

Syntaksi

VALITSE.INDEKSI(indeksi_luku; arvo1; [arvo2]; ...)

VALITSE.INDEKSI-funktion syntaksissa on seuraavat argumentit:

  • Indeksi_luku    Pakollinen. Määrittää, mikä arvoargumentti valitaan. Indeksi_luku-argumentin on oltava luku 1–255 tai kaava tai soluviittaus, joka sisältää luvun 1–254.

    • Jos indeksi_luku on 1, VALITSE.INDEKSI palauttaa arvo1-argumentin. Jos indeksi_luku on 2, VALITSE.INDEKSI palauttaa arvo2-argumentin ja niin edelleen.

    • Jos indeksi_luku on pienempi kuin 1 tai suurempi kuin luettelon viimeinen arvo, VALITSE.INDEKSI palauttaa #ARVO! -virhearvon.

    • Jos indeksi_luku ei ole kokonaisluku, se katkaistaan kokonaisluvuksi.

  • Arvo1, arvo2,…     Arvo1 on pakollinen, seuraavat arvot ovat valinnaisia. Arvoargumentit 1–254, joista VALITSE.INDEKSI valitsee arvon tai suoritettavan toiminnon indeksi_luku-argumentin perusteella. Argumentit voivat olla lukuja, soluviittauksia, määritettyjä nimiä, kaavoja, funktioita tai tekstiä.

Huomautuksia

  • Jos indeksi_luku on matriisi, kaikki arvot arvioidaan, kun VALITSE.INDEKSI arvioidaan.

  • VALITSE.INDEKSI-funktion arvoargumentit voivat olla alueviittauksia tai yksittäisiä arvoja.

    Esimerkiksi kaava

=SUMMA(VALITSE.INDEKSI(2;A1:A10;B1:B10;C1:C10))

antaa tulokseksi kaavan

=SUMMA(B1:B10)

joka palauttaa alueen B1:B10 arvoihin perustuvan arvon.

Funktio VALITSE.INDEKSI lasketaan ensin, jolloin se palauttaa viittauksen B1:B10. Siten SUMMA-funktiolle välittyy argumentiksi alue B1:B10.

Esimerkkejä

Kopioi esimerkkitiedot seuraavaan taulukkoon ja lisää se uuden Excel‑laskentataulukon soluun A1. Kaavat näyttävät tuloksia, kun valitset ne, painat F2-näppäintä ja sitten Enter-näppäintä. Voit säätää sarakkeiden leveyttä, että näet kaikki tiedot.

Tiedot

 

1.

Naulat

2.

Ruuvit

3.

Mutterit

Valmis

Pultit

Kaava

Kuvaus

Tulos

=VALITSE.INDEKSI(2;A2;A3;A4;A5)

Toisen luetteloargumentin arvo (solun A3 arvo)

2.

=VALITSE.INDEKSI(4;B2;B3;B4;B5)

Neljännen luetteloargumentin arvo (solun B5 arvo)

Pultit

=VALITSE.INDEKSI(3,"Leveä",115,"maailma",8)

Kolmannen luetteloargumentin arvo

maailma

Esimerkki 2

Tiedot

23

45

12

10

Kaava

Kuvaus (tulos)

Tulos

=SUMMA(A2:VALITSE.INDEKSI(2,A3,A4,A5))

Alueen A2:A4 summat. VALITSE.INDEKSI-funktio palauttaa A4:n SUMMA-funktion alueen toisena osana.

80

Kehitä taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×