Vähintään yhden matriisin toisiaan vastaavien arvojen tulojen summan laskeminen TULOJEN.SUMMA-funktiolla

Tärkeää: Tämä on artikkeli on käännetty koneellisesti. Lue vastuuvapauslauseke. Tämän artikkelin englanninkielinen versio on täällä .

TULOJEN.SUMMA-funktio käyttää solualueita (tai matriiseja) argumentteina, eli niinä kaavan osina, jotka saavat kaavan toimimaan. Se kertoo matriisien kohteet ja laskee tuloksen yhteen.

Tämä esimerkki on ostoslista, jossa yksi matriisi luetteloi kaikkien kohteiden kustannukset. Toinen matriisi luetteloi ostettavien tuotteiden lukumäärän.

Sarakkeessa A on tuoteluettelo. Sarakkeessa B (matriisi 1) on yksikköhinta. Sarakkeessa C (matriisi 2) on ostomäärä.

  1. Luo kaava kirjoittamalla =TULOJEN.SUMMA(B3:B6,C3:C6) ja painamalla Enter-näppäintä.

Jokainen solu sarakkeessa B kerrotaan sitä vastaavalla solulla samalla rivillä sarakkeessa C. Tulokset lasketaan yhteen. Ostosten loppusumma on $21,60.

  1. Voit pidemmällä kaavalla, saat saman tuloksen, kirjoita = B3 * C3 + B4 * C4 + B5 * C5 + B6 * C6 ja paina Enter-näppäintä.

Enterin painamisen jälkeen tulos on sama: $21,60. Solu B3 kerrotaan solulla C3 ja sen tulos lisätään tulokseen, joka saadaan kertomalla solu B4 solulla C4 ja niin edelleen. Jos rivejä on satoja tai tuhansia, on TULOJEN.SUMMA‑funktion käyttäminen helpottaa työskentelyä huomattavasti.

Huomautukset: 

  • Sarakkeiden tai rivien (matriisi) täytyy olla samanpituisia.

  • Jos solussa on numeron sijaan tekstiä, sitä kohdellaan lukuna nolla.

Esimerkki

Jos haluat harjoitella TULOJEN.SUMMA-funktion ja matriisien käyttöä esimerkkitiedoilla, ne ovat oheisessa Excel Online -työkirjassa.

Kopioi esimerkkitiedot seuraavaan taulukkoon ja lisää se uuden Excel‑laskentataulukon soluun A1. Kaavat näyttävät tuloksia, kun valitset ne, painat F2-näppäintä ja sitten Enter-näppäintä. Voit säätää sarakkeiden leveyttä, että näet kaikki tiedot.

-

B

:d

E

3

4

2

7

8

6

6

7

1

9

5

3

Kaava

Tulos

'=TULOJEN.SUMMA(A2:B4, D2:E4)

=TULOJEN.SUMMA(A2:B4, D2:E4)

Kertoo matriisien vastaavat arvot (A2:B4, D2:E4) keskenään ja laskee saadut tulot yhteen. Tulos saadaan siis seuraavalla laskutoimituksella: 3*2 + 4*7 + 8*6 + 6*7 + 1*5 + 9*3 (156).

Jos haluat saada kaikki toiminnot käyttöön, avaa tämä työkirja Excelissä. Napsauta työkirjan oikeassa alakulmassa olevaa Excel-kuvaketta  Excel Online -sovelluksen Excel-kuvake , tallenna tiedosto omaan tietokoneeseesi haluamaasi sijaintiin ja avaa tiedosto.

Sivun alkuun

Huomautus: Konekäännöksestä ilmoittava vastuusvapauslauseke: Tämä artikkeli on käännetty tietokonejärjestelmällä, eikä kieliasiantuntija ole muokannut sitä. Microsoft tarjoaa nämä konekäännökset avuksi muille kuin englantia puhuville käyttäjille, jotta he saavat lisätietoja Microsoftin tuotteista, palveluista ja tekniikoista. Koska artikkeli on koneellisesti käännetty, se saattaa sisältää sanasto-, lauseoppi- ja kielioppivirheitä.

Kehitä taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×