Ulkoisen viittauksen (linkin) luominen toisen työkirjan solualueeseen

Ulkoisia viittauksia luomalla voit viitata toisen työkirjan solujen sisältöön. Ulkoinen viittaus (eli linkki) on viittaus toisen Excel-työkirjan laskentataulukon soluun tai alueeseen tai toisen työkirjan määritettyyn nimeen. Voit viitata tiettyyn solualueeseen, solualueen määritettyyn nimeen tai ulkoisen viittauksen määritettyyn nimeen.

Toimintaohjeet

Lisätietoja ulkoisista viitteistä

Ulkoisen viittauksen luominen eri työkirjoissa olevien solujen välille

Ulkoisen viittauksen luominen toisen työkirjan määritettyyn nimeen

Sellaisen nimen määrittäminen, joka sisältää ulkoisen viittauksen toisen työkirjan soluihin

Lisätietoja ulkoisista viitteistä

Ulkoiset viittaukset ja soluviittaukset ovat samankaltaisia, mutta niillä on myös merkittäviä eroja. Käytä ulkoisia viitteitä, kun työstät suurta tietomäärää tai käytät eri työkirjoissa olevia monimutkaisia kaavoja. Ulkoiset viittaukset ja soluviittaukset luodaan eri tavoin, ja ne näkyvät eri tavalla solussa tai kaavarivillä.

Missä ulkoisia viittauksia voidaan käyttää tehokkaasti

Ulkoiset viittaukset ovat erityisen hyödyllisiä, kun suuria laskentataulukkomalleja ei kannata pitää samassa työkirjassa.

  • Useiden työkirjojen tietojen yhdistäminen    Voit linkittää useiden käyttäjien tai osastojen työkirjoja ja yhdistää sitten olennaiset tiedot yhteenvetotyökirjaan. Tällä tavoin sinun ei tarvitse muuttaa yhteenvetotyökirjaa manuaalisesti, kun lähdetyökirjat muuttuvat.

  • Erilaisten näkymien luominen tiedoista    Voit kirjoittaa kaikki tiedot haluamiisi lähdetyökirjoihin ja luoda sitten raporttityökirjan, joka sisältää ulkoiset viittaukset vain olennaisiin tietoihin.

  • Laajojen ja monimutkaisten mallien osittaminen       Voit käyttää mallia avaamatta kaikkia siihen liittyviä taulukoita, kun purat monimutkaisen mallin yksittäisten työkirjojen sarjaksi. Pieniä työkirjoja on helpompi muuttaa, ne eivät vaadi paljon muistia ja ne on nopeampi avata, tallentaa ja laskea.

Eri tapoja ulkoisten linkkien luomiseen

Jos käytät ulkoisen viittauksen luomisessa soluviittausta, voit käyttää tietojen käsittelyssä myös kaavoja. Vaihtamalla soluviittausten lajia voit myös tarkistaa, mihin soluihin linkki kohdistuu, jos siirrät ulkoista viittausta. Jos käytät esimerkiksi suhteellista viittausta ja siirrät ulkoista viittausta, linkitettävät solut vaihtuvat sen mukaan, mikä linkin uusi sijainti on laskentataulukossa.

Kun luot ulkoisen viittaukset työkirjasta toiseen työkirjaan, sinun on viitattava linkitettäviin soluihin nimellä. Voit luoda ulkoisen viittauksen käyttämällä jo määritettyä nimeä tai voit määrittää nimen luodessasi ulkoista viittausta. Nimen käyttäminen helpottaa linkitettävien solujen sisällön muistamista. Kun käytetään määritettyjä nimiä, ulkoiset viittaukset eivät muutu siirrettäessä, koska nimi viittaa tiettyyn soluun tai solualueeseen. Jos haluat määritettyä nimeä käyttävän ulkoisen viittauksen muuttuvan siirrettäessä, voit muuttaa ulkoisessa viittauksessa käytettävää nimeä tai vaihtaa solut, joihin nimi viittaa.

Miltä ulkoinen viittaus toiseen työkirjaan näyttää

Excel näyttää toisiin työkirjoihin ulkoisia viittauksia sisältävät kaavat kahdella tavalla sen mukaan, onko lähdetyökirja (kaavaan tietoja antava työkirja) avoinna vai suljettu.

Kun lähde on avoinna, ulkoisessa viittauksissa näkyy ensimmäisenä työkirjan nimi hakasulkeissa ([ ]), seuraavana taulukon nimi, huutomerkki (!) ja solut, joista kaava muodostuu. Esimerkiksi seuraava laskee yhteen Budjetti.xlsx-työkirjan solut C10:C25.

Ulkoinen viittaus

=SUMMA([Budjetti.xlsx]Vuosi!C10:C25)

Kun lähde ei ole avoinna, ulkoinen viittaus sisältää koko polun.

Ulkoinen viittaus

=SUMMA('C:\Raportit\[Budjetti.xlsx]Vuosi'!C10:C25)

Huomautus: Jos toisen työkirjan tai laskentataulukon nimi sisältää muita merkkejä kuin kirjaimia, nimi (tai polku) on kirjoitettava puolilainausmerkkeihin.

Jonkin toisen työkirjan nimi linkitetyissä kaavoissa käytetään työkirjan nimeä, huutomerkkiä (!) ja määritettyä nimeä. Esimerkiksi seuraava kaava laskee yhteen Budjetti.xlsx-työkirjassa sijaitsevan Myynti-alueen solut.

Ulkoinen viittaus

=SUMMA(Budjetti.xlsx!Myynti)

Sivun alkuun

Ulkoisen viittauksen luominen eri työkirjoissa olevien solujen välille

  1. Avaa työkirja, johon haluat lisätä ulkoisen viittauksen (kohdetyökirja), ja avaa sitten työkirja, joka sisältää linkitettävät tiedot (lähdetyökirja).

  2. Valitse lähdetyökirjan Pikatyökalurivi-kohdassa Tallenna Painikkeen kuva .

  3. Valitse solut, joihin haluat luoda ulkoisen viittauksen.

  4. Kirjoita = (yhtäläisyysmerkki). Jos haluat suorittaa laskutoimituksia tai funktioita ulkoisen viittauksen arvolla, kirjoita operaattori tai funktio, jonka haluat edeltävän ulkoista viittausta.

  5. Vaihda lähdetyökirjaan ja valitse laskentataulukko, joka sisältää linkitettävät solut.

  6. Valitse linkitettävä solu tai solut.

  7. Palaa kohdetyökirjaan. Huomaa, että Excel lisää viittauksen lähdetyökirjaan ja edellisessä vaiheessa valitsemiisi soluihin.

  8. Voit tarvittaessa muokata kaavaa tai vaihtaa sen kohdetyökirjassa.

  9. Paina CTRL+VAIHTO+ENTER.

Sivun alkuun

Ulkoisen viittauksen luominen toisen työkirjan määritettyyn nimeen

  1. Avaa työkirja, johon haluat lisätä ulkoisen viittauksen (kohdetyökirja), ja avaa sitten työkirja, joka sisältää linkitettävät tiedot (lähdetyökirja).

  2. Valitse lähdetyökirjan Pikatyökalurivi-kohdassa Tallenna Painikkeen kuva .

  3. Valitse solut, joihin haluat luoda ulkoisen viittauksen.

  4. Kirjoita = (yhtäläisyysmerkki). Jos haluat suorittaa laskutoimituksia tai funktioita ulkoisen viittauksen arvolla, kirjoita operaattori tai funktio, jonka haluat edeltävän ulkoista viittausta.

  5. Valitse Näytä-välilehden Ikkuna-ryhmästä Vaihda ikkunaa, valitse lähdetyökirja ja valitse sitten laskentataulukko, joka sisältää linkitettävät solut.

    Näytä-välilehden Ikkuna-ryhmä

  6. Paina F3 ja valitse nimi, johon haluat linkittää.

Sivun alkuun

Sellaisen nimen määrittäminen, joka sisältää ulkoisen viittauksen toisen työkirjan soluihin

  1. Avaa kohdetyökirja ja lähdetyökirja.

  2. Valitse kohdetyökirjan Kaavat-välilehden Määritetyt nimet -ryhmästä Määritetty nimi.

    Excelin valintanauhan kuva

  3. Kirjoita alueen nimi Uusi nimi -valintaikkunan Nimi-ruutuun.

  4. Poista Viittaa-ruudun sisältö ja jätä sitten kohdistin ruutuun.

    Jos nimi sisältää kaavan, kirjoita kaava ja sijoita kohdistin kohtaan, johon haluat lisätä ulkoisen viittauksen. Kirjoita esimerkiksi =SUMMA() ja sijoita kohdistin sulkujen väliin.

  5. Valitse Näytä-välilehden Ikkuna-ryhmästä Vaihda ikkunaa, valitse lähdetyökirja ja valitse sitten laskentataulukko, joka sisältää linkitettävät solut.

    Näytä-välilehden Ikkuna-ryhmä

  6. Valitse solu tai solualue, johon haluat linkittää.

  7. Valitse Uusi nimi -valintaikkunassa OK.

Sivun alkuun

Kehitä taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×