Työnkulun tilaa vastaavan lomakkeen suunnitteleminen

Voit suunnitella Microsoft Office InfoPath -lomakkeet niin, että niissä näkyy tietoja, jotka vastaavat työnkulun nykyistä tilaa. Lomakemalliin lisätään suunnittelun yhteydessä sääntöjä, jotka käynnistävät työnkulun tilan mukaisen toiminnon lomakkeissa. Työnkulun tilan näyttö voi yksinkertaistaa lomakkeiden täyttöprosessia.

Tässä artikkelissa kuvataan, miten luodaan kuluraportin lomakemalli, jossa näkyvät hyväksymistyönkulun kulloisenkin vaiheen mukaan automaattisesti vaihtelevat näkymät. Esimerkiksi ennen työnkulun aloittamista lomakkeessa näkyy Kulut-näkymä, jonka toistuvaan taulukkoon käyttäjät voivat syöttää kuluja. Kun työnkulun tila on Käynnissä, lomakkeessa näkyy Kuluyhteenveto-näkymä, jossa näkyvät kunkin luokan kokonaiskulut. Kun työnkulun tila on Valmis, lomakkeessa näkyy Valmis-näkymä, joka sisältää tietoja arvioiduista takaisinmaksuajoista.

Jotta voit ottaa työnkulun tiloja vastaavat lomakkeet käyttöön, sinun on suoritettava tehtäviä Microsoft Office SharePoint Server 2007 -sivustossa tai Windows SharePoint Services 3.0 -sivustoissa, joissa lomakkeet sijaitsevat. Lisäksi sinun on suoritettava tehtäviä InfoPathissa. SharePoint-sivustossa sinun on luotava työnkulku ja sivuston sisältötyyppi. InfoPathissa sinun on lisättävä tietoyhteys lomakemalliin, luotava sääntö ja julkaistava lomakemalli.

Huomautus: Tässä artikkelissa käytetään esimerkkiskenaariota, jossa lomakemalli on julkaistu sivuston sisältölajina. Lomakemalli voidaan julkaista myös jaetussa verkkosijainnissa. Voit myös luoda uuden asiakirjakirjaston, kun julkaiset lomakemallin SharePoint-sivustossa. Lisätietoja lomakemallien julkaisemista on Katso myös -osassa.

Tässä artikkelissa käsiteltävät aiheet

Tietoja työnkulkujen käyttämisestä InfoPath-lomakkeilla

Yhteensopivuuteen liittyvät näkökohdat

Toimet ennen aloittamista

Vaihe 1: Hyväksyntä-työnkulun lisääminen kirjastoon

Vaihe 2: Tietoyhteyden lisääminen lomakemalliin

Vaihe 3: Tietyn näkymän näyttävän säännön lisääminen lomakemalliin

Vaihe 4: Lomakemallin julkaiseminen sivuston sisältölajina

Vaihe 5: Sisältölajin lisääminen asiakirjakirjastoon

Tietoja työnkulkujen käyttämisestä InfoPath-lomakkeilla

Työnkulut helpottavat asiakirjoihin liittyvän yhteistyön tekemistä ja projektin tehtävien hallintaa, sillä niiden avulla voidaan ottaa käyttöön tiettyjä liiketoimintaprosesseja asiakirjoissa ja Microsoft Office SharePoint Server 2007 -sivuston tai Windows SharePoint Services 3.0 -sivuston kohteissa. Työnkulkujen avulla voidaan hallita tiettyihin liiketoimintaprosesseihin liittyviä tehtäviä ja vaiheita, minkä ansiosta organisaatiot voivat pitää kiinni yhdenmukaisista liiketoimintaprosesseista ja parantaa tehokkuutta ja tuottavuutta. Kun työnkulut on otettu käyttöön, tehtäviä suorittavat henkilöt voivat keskittyä itse työn suorittamiseen työnkulun hallinnan sijaan.

Voit ottaa käyttöön InfoPath-lomakkeita, joissa näkyy tiettyjä tietoja työnkulun nykyisen tilan mukaisesti, suunnittelemalla lomakemallin, jossa käytetään sääntöjä. Säännöt käynnistävät lomakkeessa toimen työnkulun tilan mukaisesti. Voit esimerkiksi ottaa käyttöön lomakkeen, jonka näkymä on vain luku -tyyppinen, kun työnkulun tila on Valmis eikä lomakkeen tietoihin enää ole tarkoitus tehdä muutoksia.

Jotta työnkulut olisivat käytettävissä InfoPath-lomakemalleissa, työnkulut on lisättävä SharePoint-luetteloon, -kirjastoon tai sisältölajiin. Sivuston käytettävissä olevat työnkulut vaihtelevat sivuston tyypin ja Microsoft Office SharePoint Designer 2007 -ohjelman avulla mahdollisesti luotujen mukautettujen työnkulkujen mukaan.

Tässä artikkelissa käytetään esimerkkinä Hyväksyntä-työnkulkua ja sen avulla havainnollistetaan, miten työnkulkuja voidaan käyttää InfoPath-lomakemalleissa. Hyväksyntä-työnkulku reitittää InfoPath-lomakkeen, joka on tallennettu hyväksyjien ryhmän kirjastoon. Oletusarvoisesti Hyväksyntä-työnkulku liittyy Asiakirja-sisältölajiin ja se on automaattisesti käytettävissä asiakirja- ja lomakekirjastoissa.

Kunkin työnkulku määritetään erilaisilla tiloilla, joilla on kuvaavat nimet, kuten Käynnissä. Tilojen nimet vaihtelevat työnkulun tyypin mukaan. Esimerkiksi hyväksynnän työnkulku, joka on saatavilla palvelimissa, joissa on Microsoft Office SharePoint Server 2007, sisältää tilat Käynnissä, Peruutettu ja Valmis. Tilat Kolmen tilan työnkulussa, joka on käytettävissä Windows SharePoint Services 3.0 -ohjelmassa, voi määrittää henkilö, joka lisää työnkulun kirjastoon tai luetteloon. Muissa työnkuluissa käytetään vakiotiloja, kuten aiemmin mainittua Käynnissä-tilaa. Vaikka kuvaava nimi näkyy käyttäjälle, työnkulun tilat ilmaistaan ohjelmallisesti numeerisina arvoina. Jos haluat suunnitella lomakemallin, jolla vastataan tiettyyn työnkulun tilaan, sinun on tiedettävä käytettävän työnkulun tilan numeerinen arvo. Tämä johtuu siitä, että InfoPath käyttää työnkulun numeerista arvoa käynnistääkseen toiminnon, kuten näkymien vaihdon.

Kuten aiemmin todettiin, voit ottaa käyttöön InfoPath-lomakemallin, jossa näkyy työnkulun kulloistakin tilaa vastaavia tietoja. Tässä artikkelissa kuvataan, miten otetaan käyttöön kuluraportin lomakemalli, jossa näkyy työnkulun tilan mukaan vaihtuvia näkymiä, mutta voit myös mukauttaa työnkulkua lisäämällä siihen toimintoja. Tiettyjen näkymien käyttämisen sijaan voit ottaa lomakkeissa käyttöön esimerkiksi ohjeita sisältävän valintaikkunasanoman. Hyväksyntä-työnkulun sijaan voit käyttää myös kolmen tilan työnkulkua.

Huomautus: Jos otat käyttöön muita kuin tässä artikkelissa kuvattu toimintoja, saatat joutua suorittamaan ylimääräisiä vaiheita, jotta lomakemallit toimisivat oikein käyttämäsi työnkulun kanssa.

Sivun alkuun

Yhteensopivuuteen liittyvät näkökohdat

Jos aiot luoda selainyhteensopiva lomakemalli, muista, että Microsoft Office -asiakirjojen lomakkeiden (mukaan lukien InfoPath-lomakkeiden) täytön yhteydessä näkyvä toimintorivi ei ole käytettävissä selainyhteensopivissa lomakemalleissa, jotka täytetään selaimessa. Selainyhteensopivissa lomakkeissa voi kuitenkin käyttää työnkulkuja. Tällaisissa lomakkeissa työnkulun osallistujat voivat muuttaa työnkulun tilaa käyttämällä asiakirjakirjaston asetuksia. Lisätietoja työnkulun asetusten muuttamisesta SharePoint-sivustojen avulla on Katso myös -osassa.

Sivun alkuun

Toimet ennen aloittamista

Varmista seuraavat asiat ennen tämän artikkelin tehtävien suorittamista:

  • Ota yhteyttä farmin järjestelmänvalvojaan ja varmista, että Hyväksyntätyönkulku on asennettu ja otettu käyttöön haluamassasi SharePoint-sivustossa.

  • Varmista, että sinulla on vähintään Suunnittelu- käyttöoikeustaso SharePoint-sivustossa. Käyttöoikeustasoa tarvitaan lomakemallin julkaisemiseen ja työnkulun luomiseen.

  • Luo lomakemalli, jossa on vähintään kaksi näkymää. Mukauta kutakin näkymää siten, että näkymässä näkyy kutakin työnkulun tilaa koskeva tietotyyppi. Esimerkiksi työnkulun valmistumiseen liittyvään näkymään voit määrittää vain luku -muotoisia ohjausobjekteja.

  • Luo asiakirja- ja lomakekirjasto ja varmista, että kirjastossa voidaan käyttää useita sisältölajeja.

Sivun alkuun

Vaihe 1: Hyväksyntä-työnkulun lisääminen kirjastoon

Tässä skenaariossa keskitytään Hyväksyntä-työnkulkuun, mutta voit halutessasi käyttää myös muuntyyppistä työnkulkua. Jos käytät muuta työnkulkutyyppiä, työnkulun asetukset saattavat poiketa tässä artikkelissa kuvatuista asetuksista.

  1. Avaa kirjasto, johon haluat lisätä työnkulun.

  2. Valitse Asetukset-valikosta sen kirjaston asetukset, jota parhaillaan avaat.

    Valitse esimerkiksi asiakirjakirjaston osalta Asiakirjakirjaston asetukset.

  3. Valitse Käyttöoikeudet ja käytännöt -kohdasta Työnkulun asetukset.

  4. Valitse Lisää työnkulku.

  5. Valitse Lisää työnkulku -sivun Työnkulku-osasta Hyväksyntä.

  6. Kirjoita Nimi-osaan työnkulun yksilöllinen nimi.

    1. Määritä Tehtäväluettelo-osassa tässä työnkulussa käytettävä tehtäväluettelo.

      Huomautukset: 

      • Voit käyttää Tehtävät-oletusluetteloa tai luoda uuden luettelon. Jos käytät Tehtävät-oletusluetteloa, työnkulun osallistujat löytävät omat työnkulun tehtävät helposti Tehtävät-luettelon Omat tehtävät -luettelosta.

      • Jos tämän työnkulun tehtävissä esitetään luottamuksellisia tietoja, jotka haluat pitää erillään yleisestä Tehtävät-luettelosta, luo uusi tehtäväluettelo.

      • Jos organisaatiossa käytetään useita työnkulkuja tai työnkuluissa on lukuisia tehtäviä, luo uusi tehtäväluettelo. Tässä tilanteessa voit luoda esimerkiksi kullekin työnkululle oman tehtäväluettelon.

  7. Valitse Historialuettelo-osasta työnkulun kanssa käytettävä historialuettelo. Historialuettelossa näkyvät työnkulun kunkin esiintymän yhteydessä tapahtuvat tapahtumat.

    Voit käyttää oletusarvoista historialuetteloa tai luoda uuden historialuettelon. Jos organisaatiossa on käytössä useita työnkulkuja, voit luoda erillisen historialuettelon kullekin työnkululle.

  8. Jos haluat sallia työnkulun manuaalisen aloittamisen, valitse Salli tämän työnkulun manuaalinen aloittaminen todennetuille käyttäjille, joilla on kohteiden muokkausoikeudet -valintaruutu Aloitusasetukset-osasta.

  9. Jos työnkulun aloittamisessa halutaan edellyttää muita käyttöoikeuksia, valitse Edellytä luetteloiden hallintaoikeudet työnkulun aloittamista varten -valintaruutu.

  10. Määritä muut haluamasi asetukset, kuten se, milloin haluat aloittaa työnkulun, ja valitse sitten Seuraava.

  11. Valitse Työnkulun mukauttaminen -sivulla haluamasi asetukset, esimerkiksi tehtävien reititystapa, oletusarvot työnkulun alkaessa sekä työnkulun päättämistapa. Valitse sitten OK.

    Valitse seuraavien osien asetukset. Kaikkien osien asetusten määrittäminen ei ole pakollista.

    Työnkulun tehtävät

    Toiminto:

    Toimet:

    Tehtävien määrittäminen kaikille osallistujille samanaikaisesti (rinnakkainen työnkulku)

    Valitse Kaikki osallistujat yhtä aikaa (rinnakkainen).

    Tehtävien määrittäminen yhdelle osallistujalle kerrallaan edellyttäen, että edeltävä osallistuja suorittaa tehtävän, ennen kuin seuraava osallistuja saa tehtävän (peräkkäinen työnkulku)

    Valitse Yksi osallistuja kerrallaan (peräkkäinen).

    Tehtävien uudelleenmäärittämisen salliminen työnkulun osallistujille

    Valitse Määritä tehtävä toiselle henkilölle -valintaruutu.

    Tiedostoon tai kohteeseen tehtävän muutoksen pyytämisen salliminen työnkulun osallistujille. Muutos pitää hyväksyä ennen tehtävän päättymistä.

    Valitse Tee muutospyyntö ennen tehtävän päättymistä -valintaruutu.

    Oletusarvot työnkulun alkaessa

    Toiminto:

    Toimet:

    Oletusosallistujaluettelon määrittäminen kaikille työnkulun esiintymille

    Kirjoita niiden osallistujien nimet, jotka haluat sisällyttää työnkulkuun sen alkaessa. Voit myös valita Hyväksyjät ja valita sitten henkilöt ja ryhmät hakemistopalvelusta.

    Huomautukset: 

    • Erota nimet toisistaan puolipisteillä.

    • Jos määrität työnkulun peräkkäiseksi työnkuluksi, lisää osallistujien nimet siinä järjestyksessä, jossa haluat määrittää tehtävät.

    Yksittäisen tehtävän määrittäminen ryhmille sen sijaan, että kullekin ryhmän jäsenelle määritettäisiin yksilölliset tehtävät

    Valitse Määritä yksi tehtävä kullekin määritetylle ryhmälle. (Älä laajenna ryhmiä.) -valintaruutu.

    Osallistujien muuttamisen tai lisäämisen salliminen henkilölle, joka aloittaa työnkulun

    Valitse Salli osallistujaluettelon muuttaminen, kun työnkulku on aloitettu -valintaruutu.

    Kunkin tehtävän yhteydessä näkyvän oletussanoman määrittäminen

    Kirjoita sanoma tai ohje tekstikehykseen.

    Rinnakkaisten työnkulkujen määräpäivän määrittäminen

    Kirjoita päivämäärä kohtaan Tehtävien määräpäivä (rinnakkainen).

    Peräkkäisen työnkulun osallistujille tehtävän suorittamista varten annetun ajan määrittäminen

    Kirjoita numero Jokaiselle henkilölle tehtävän suorittamista varten annettava aika (peräkkäinen) -kohtaan ja valitse sitten ajan lisäykseksi päivä(ä) tai viikkoa(a).

    Niiden henkilöiden luettelon määrittäminen, jotka vastaanottavat ilmoituksia (ei tehtävävarauksia) työnkulun alkaessa

    Kirjoita kohtaan Ilmoittaminen muille niiden henkilöiden nimi, joiden haluat saavan ilmoituksen, tai valitse Kopio ja valitse henkilö tai ryhmät hakemistopalvelusta.

    Huomautus: Erota nimet toisistaan puolipisteillä.

    Työnkulun päättyminen

    Toiminto:

    Toimet:

    Rinnakkaisen työnkulun määrittäminen päättyneeksi, kun valittu määrä osallistujia on suorittanut tehtävänsä

    Valitse Päätökseen on saatu seuraava määrä tehtäviä -valintaruutu ja kirjoita sitten lukumäärä.

    Työnkulun määrittäminen päättyneeksi, kun asiakirja tai kohde on hylätty

    Valitse Asiakirja on hylätty -valintaruutu.

    Työnkulun määrittäminen päättyneeksi, kun asiakirjaa tai kohdetta muutetaan

    Valitse Asiakirjaa on muutettu -valintaruutu.

    Toimet työnkulun jälkeen

    Toiminto:

    Toimet:

    Asiakirjan tai kohteen hyväksynnän tilan päivittäminen työnkulun päätyttyä

    Valitse Hyväksyntätilan päivittäminen (tämän työnkulun avulla voit hallita sisällön hyväksyntää) -valintaruutu.

    Huomautukset: 

    • Jos käytät Hyväksyntä-työnkulkua kirjaston sisällön hyväksynnän hallintaan ja valitset Aloita tämä työnkulku kohteen pääversion julkaisemisen hyväksymiseksi -valintaruudun Lisää työnkulku -sivulla, valintaruutu valitaan oletusarvon mukaan.

    • Jos et ole valinnut Aloita tämä työnkulku kohteen pääversion julkaisemisen hyväksymiseksi -valintaruutua Lisää työnkulku -sivulla, koska et halua työnkulun olevan kirjaston sisällön oletushyväksyntätyönkulku, voit valita tämän valintaruudun. Tällöin työnkulku on toissijainen sisällön hyväksyntätyönkulku, jonka tietyt käyttäjät voivat aloittaa manuaalisesti.

Sivun alkuun

Vaihe 2: Tietoyhteyden lisääminen lomakemalliin

Seuraavissa ohjeissa kerrotaan, miten voit lisätä toissijaisen tietoyhteyden, joka suorittaa kyselyn vaiheessa 1 lisäämäsi työnkulun tilasta. Tämä toissijainen tietoyhteys sisältää tietoja, joiden avulla lomakkeessa otetaan käyttöön säännöt, jotka muuttavat näkymää työnkulun tilan mukaan.

  1. Valitse InfoPathin Työkalut-valikosta Tietoyhteydet.

  2. Valitse Tietoyhteydet-valintaikkunassa Lisää.

  3. Valitse ohjatussa tietoyhteyden muodostamisessa Luo uusi yhteys kohteeseen, valitse Vastaanota tiedot ja valitse sitten Seuraava.

  4. Valitse ohjatun toiminnon seuraavalla sivulla SharePoint-kirjastosta tai -luettelosta ja valitse sitten Seuraava.

  5. Kirjoita ohjatun toiminnon seuraavalle sivulle SharePoint-sivuston URL-osoite.

  6. Valitse Valitse luettelo tai kirjasto -luettelosta sen asiakirjakirjaston nimi, johon lisäsit Hyväksyntä-työnkulun vaiheessa 1. Valitse sitten Seuraava.

  7. Valitse ohjatun toiminnon seuraavan sivun Valitse kentät -luettelossa sen kentän nimen vieressä oleva valintaruutu, joka vastaa työnkulun nimeä.

    Kentän nimi ei välttämättä vastaa tarkalleen työnkulun nimeä. Jos kentän nimi alkaa erikoismerkillä, joka ei ole alaviiva tai kirjain, työnkulun nimeä mukautetaan luettelossa.

  8. Valitse Sisällytä vain aktiivisen lomakkeen tiedot -valintaruutu ja valitse sitten Seuraava.

  9. Poista Tallenna kopio tiedoista lomakemalliin -valintaruudun valinta ja valitse sitten Seuraava.

  10. Kirjoita kuvaileva nimi toissijaiselle tietoyhteydelle ohjatun toiminnon seuraavan sivun Kirjoita tämän tietoyhteyden nimi -ruutuun. Nimi näkyy Tietolähde-luettelossa Tietolähde-tehtäväruudussa.

  11. Jos haluat suorittaa kyselyn automaattisesti aina, kun käyttäjä avaa lomakkeen, valitse Hae tiedot automaattisesti, kun lomake avataan -valintaruutu.

  12. Valitse ohjatun toiminnon viimeisellä sivulla Valmis.

  13. Valitse Tietoyhteydet -valintaikkunassa Sulje.

Sivun alkuun

Vaihe 3: Tietyn näkymän näyttävän säännön lisääminen lomakemalliin

Kun suunnittelet lomakemallia, voit sääntöjen avulla näyttää automaattisesti valintaikkunan, määrittää kentän arvon, luoda kyselyn tai lähettää lomaketiedot tietoyhteyden kautta, vaihtaa näkymää tai avata tai sulkea lomakkeen tiettyjen tapahtumien ja ehtojen perusteella. Tapahtumia ovat tietyn kentän tai ryhmän muutos tietolähde -ohjelmassa, painikkeen napsauttaminen, toistuva osa-kohteen tai rivin lisääminen toistuva taulukko -ohjelmassa tai lomakkeen avaaminen tai lähettäminen. Ehdot voivat sisältää esimerkiksi laskutoimituksia, XPath-lausekkeita ja käyttäjärooleja. Ehdoilla voi myös määrittää, onko kentän arvo tyhjä, määrätyllä alueella, yhtä suuri kuin toisen kentän arvo tai onko sen alussa tai sisältääkö se tiettyjä merkkejä.

Tässä esimerkissä luot säännön, joka vaihtaa näkymiä työnkulun tilan mukaan.

  1. Valitse Työkalut-valikosta Lomakkeen asetukset.

  2. Valitse Luokka-luettelosta Avaaminen ja tallentaminen.

  3. Valitse Avaamistoimi-kohdassa Säännöt.

  4. Valitse Lomakkeiden avaamisen säännöt -valintaikkunassa Lisää.

  5. Kirjoita säännön nimi Nimi-ruutuun.

    Kirjoita esimerkiksi Näkymän vaihtaminen.

  6. Määritä säännön suorittamisen ehto valitsemalla Määritä ehtoa.

  7. Valitse kohdan Käytä sääntöä, kun tämä ehto toteutuu ensimmäisessä ruudussa Valitse kenttä tai ryhmä.

  8. Valitse Tietolähde-luettelosta vaiheessa 2 lisäämäsi toissijaisen tietolähteen nimi ja valitse sitten OK.

  9. Valitse sen kentän nimi, joka vastaa työnkulun tilaa.

    Joudut ehkä laajentamaan ikkunassa näkyviä kansioita, jotta haluamasi kenttä tulee näkyviin.

  10. Valitse Ehto-valintaikkunan toisessa luettelossa on yhtä suuri kuin.

  11. Valitse kolmannessa luettelossa Kirjoita numero ja kirjoita sitten arvo, joka vastaa työnkulun tilaa.

    Kirjoita esimerkiksi työnkulun valmistumisen jälkeen näkyvälle näkymälle luku 5.

    Työnkulun tilojen numeeriset arvot Hyväksyntä-työnkulussa

    Tila

    Numeerinen arvo

    Käynnissä

    2

    Valmis

    5

    Peruutettu

    15

    Hyväksytty

    16

    Hylätty

    17

    Huomautukset: 

    • Muiden työnkulkujen numeeriset arvot saattavat olla erilaisia.

    • InfoPathissa työnkulun tilan arvo on vain luku -tilassa. Tämä tarkoittaa sitä, että et voi suunnitella lomakemallia siten, että käyttäjä voi muuttaa työnkulun tilaa manuaalisesti määrittämällä itse ohjausobjektin arvon.

  12. Valitse OK.

  13. Valitse Sääntö-valintaikkunassa Lisää toiminto.

  14. Valitse Toiminto-kohdassa Näkymän vaihtaminen.

  15. Valitse Näkymä-kohdassa sen näkymän nimi, jonka haluat tulevan näkyviin silloin, kun työnkulun tila vastaa ehdon tilaa. Valitse sitten OK.

    Jos esimerkiksi kirjoitit vaiheessa 11 2, valitse näkymän nimi, jonka haluat näkyvän silloin, kun työnkulun tila on Käynnissä.

  16. Valitse Sääntö-valintaikkunassa OK.

  17. Toista vaiheita 4–16, jos haluat luoda lisää sääntöjä, jotka vaihtavat näkymää työnkulun tilan mukaan.

Sivun alkuun

Vaihe 4: Lomakemallin julkaiseminen sivuston sisältölajina

Voit julkaista lomakemallin asiakirjakirjastoon tai julkaista lomakemallin sivuston sisältölajina, jolloin lomakemallia voidaan käyttää useissa sivustokokoelman asiakirjakirjakirjastossa. Koska olet jo luonut asiakirjakirjaston ja määrittänyt työnkulun sitä varten, sinun on julkaistava lomakemalli sisältölajina. Myöhemmin voit yhdistää lomakemallin sisältölajin luomaasi kirjastoon.

Lisäksi voit julkaista lomakemallin jaettuun verkkosijaintiin tai luoda uuden asiakirjakirjaston, kun julkaiset lomakemallin SharePoint-sivustossa. Lisätietoja lomakemallien julkaisemisesta on Katso myös -osassa.

  1. Valitse Tiedosto-valikosta Tallenna.

  2. Etsi Tallenna nimellä -valintaikkunassa sijainti, johon haluat tallentaa lomakemallin, ja valitse sitten Tallenna.

  3. Voit avata Rakenteen tarkistaminen -tehtäväruudun valitsemalla Työkalut-valikosta Rakenteen tarkistaminen.

  4. Jos Rakenteen tarkistaminen -tehtäväruudun luettelossa on virheitä, korjaa virheet. Valitse Päivitä, jolloin järjestelmä määrittää, esiintyykö virheitä vielä.

  5. Napsauta Tiedosto-valikosta Julkaise.

  6. Napsauta ohjatussa julkaisutoiminnossa SharePoint-palvelimeen (InfoPath Forms Services ei ole pakollinen) ja napsauta sitten Seuraava.

  7. Kirjoita ohjatun toiminnon seuraavalla sivulla Kirjoita SharePoint- tai InfoPath Forms Services -sivuston sijainti -ruutuun SharePoint-sivuston sijainti, jossa haluat julkaista lomakemallin, ja valitse sitten Seuraava.

  8. Jos haluat sallia lomakkeen täyttämisen selaimessa, valitse ohjatun toiminnon seuraavalla sivulla Ota käyttöön lomakkeen täyttäminen selaimessa -valintaruutu.

  9. Valitse Sivuston sisältölaji (lisäasetukset) ja valitse sitten Seuraava.

  10. Valitse ohjatun toiminnon seuraavalla sivulla Luo uusi sisältölaji.

  11. Valitse Sisältölaji perustuu seuraavaan: -luettelosta Lomake ja valitse sitten Seuraava.

  12. Kirjoita ohjatun toiminnon seuraavalla sivulla uuden sisältölajin nimi ja kuvaus ja valitse sitten Seuraava.

  13. Määritä ohjatun toiminnon seuraavan sivun Määritä lomakemallin sijainti ja tiedostonimi -ruudussa SharePoint-sivuston sijainti ja valitse sitten Selaa.

  14. Etsi Selaa-valintaikkunassa sen palvelimen sijainti, johon haluat julkaista lomakemallin sivuston sisältölajina. Kirjoita lomakemallin nimi Tiedoston nimi -ruutuun ja valitse sitten Tallenna.

  15. Valitse Seuraava.

  16. Valitse lomakemallin kentät, joiden haluat näkyvän asiakirjakirjaston oletusnäkymän sarakkeina.

    Toimintaohjeet

    1. Valitse Lisää.

    2. Valitse kenttä, jonka haluat lisätä tiedostokirjaston sarakkeeksi, ja tee sitten jompikumpi seuraavista:

      • Kirjoita sarakkeelle nimi Sarakkeen nimi -ruutuun.

      • Valitse sivustosarake Sivustosarakeryhmä-luettelosta ja valitse sitten nimi Sarakkeen nimi -luettelosta. Valitse lopuksi OK.

        Jos valitset toistuvan kentän tiedostokirjaston tietojen näyttämiseksi, voit määrittää, miten haluat näyttää kentän tiedostokirjastossa napsauttamalla arvoa Funktio-luettelossa. Voit valita, näytetäänkö kentän ensimmäinen arvo vai viimeinen arvo, lasketaanko kentän kaikkien esiintymien määrä yhteen vai yhdistetäänkö kaikki arvot.

    3. Valitse OK.

  17. Valitse Seuraava.

  18. Vahvista ohjatun toiminnon seuraavalla sivulla, että tiedot ovat oikein, ja valitse sitten Julkaise.

  19. Valitse Sulje ja varmista sitten, että lomakemalli on sisältötyyppi SharePoint-sivustossa.

    Toimintaohjeet

    1. Avaa SharePoint-sivusto Web-selaimessa.

    2. Valitse sivuston oikeassa yläkulmassa olevan Sivuston toiminnot -valikon Sivuston asetukset.

    3. Valitse Sivuston asetukset -sivun Valikoimat-kohdasta Sivuston sisältölajit.

      Lomakemallisi pitäisi näkyä InfoPath-sisältötyypit-luettelossa Sivuston sisältölajien valikoima -sivulla.

Sivun alkuun

Vaihe 5: Sisältölajin lisääminen asiakirjakirjastoon

Sisältötyyppien avulla organisaatiot voivat järjestää, hallita ja käsitellä koko sivustokokoelman sisältöä tehokkaasti. Määrittämällä tietyntyyppisille tiedostoille sisältötyyppejä organisaatio voi varmistaa kunkin sisältöryhmän tehokkaan hallinnan. Jos haluat, että luettelo tai kirjasto sisältää useita kohde- tai tiedostotyyppejä, lisää sisältötyyppejä luetteloon tai kirjastoon.

Huomautus: Jotta voit lisätä sisältölajeja luetteloon tai kirjastoon, sinulla on oltava vähintään kirjaston suunnitteluoikeudet.

Ennen kuin aloitat, varmista, että kirjastossa voi käyttää useita sisältölajeja.

Useiden sisältölajien salliminen

  1. Valitse Asetukset-valikosta Asiakirjakirjaston asetukset.

  2. Valitse Yleiset asetukset -kohdasta Lisäasetukset.

  3. Salli useiden sisältölajien käyttäminen valitsemalla Sisältölajit-osassa Kyllä. Valitse sitten OK.

  1. Jos luettelo tai kirjasto ei ole valmiiksi avoimena, napsauta sen nimeä pikakäynnistyspalkissa.

    Huomautus: Jos luettelon tai kirjaston nimi ei tule näyttöön, valitse Näytä sivuston kaikki sisältö ja valitse sitten luettelon tai kirjaston nimi.

  2. Valitse Asetukset-valikosta Asiakirjakirjaston asetukset.

  3. Valitse Sisältölajit-kohdassa Lisää aiemmin luoduista sivuston sisältölajeista.

  4. Valitse Valitse sivuston sisältölajit kohteesta: -luettelon Valitse sisältölajit -osasta sisältölajien ryhmä, josta haluat valita sisältölajin.

  5. Valitse Käytettävissä olevat sivuston sisältölajit -luettelosta haluamasi sisältölaji ja siirrä valittu sisältölaji Lisättävät sisältölajit -luetteloon valitsemalla Lisää.

  6. Jos haluat lisätä muita sisältölajeja, toista vaiheita 4 ja 5 ja valitse sitten OK.

Kun käyttäjä nyt luo uuden lomakkeen tässä kirjastossa, lomakkeen näkymä on työnkulun tilan mukainen.

Sivun alkuun

Kehitä taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×