Tietoyhteyden lisääminen käyttämällä yhteyskirjaston asetuksia

Tässä artikkelissa käsiteltävät aiheet

Yleiskatsaus

Toimet ennen aloittamista

Kyselyn tietoyhteyden lisääminen

Lähetystietoyhteyden lisääminen

Yleiskatsaus

Jos suunnittelet useita lomakemalleja, jotka käyttävät samankaltaisia tietoyhteyksiä, harkitse tietoyhteystiedoston käyttämistä sen sijaan, että loisit tietoyhteyden ulkoiseen tietolähteeseen kullekin lomakemallille. Tällä tavalla sinun täytyy päivittää vain yksi tietoyhteystiedosto, kun liittyneiden lomakemallien sarjan tietoyhteystiedot muuttuvat. Esimerkiksi kun siirrät lomakemallit testiverkosta tuotantoverkkoon, sinun täytyy päivittää tietoyhteysasetukset vain kerran yhteyskirjastossa kunkin lomakemallin tietoyhteyden päivittämisen sijaan. Kun tietoyhteystiedostoa käyttävään lomakemalliin perustuva lomake käyttää tietoyhteyttä, tietoyhteys päivitetään automaattisesti uusilla asetuksilla.

Tietoyhteystiedosto on XML-tiedosto, jossa on .xml- tai .udcx-tiedostotunniste. Se sisältää yksittäisen ulkoisen tietolähteen yhteystiedot. Tämä tiedosto on tallennettu tietoyhteyskirjastoon palvelimessa, jossa on käytössä Microsoft Office SharePoint Server 2007. Tietoyhteystiedoston luo ohjelmistokehittäjä tai se luodaan muuntamalla tietoyhteys aiemmin luodussa lomakemallissa tietoyhteystiedostoksi napsauttamalla Muunna-painiketta Tietoyhteydet-valintaikkunassa (Työkalut-valikko).

Tietoyhteystiedoston käytön etuja ovat esimerkiksi seuraavat:

  • Useat lomakkeet voivat käyttää samaa tietoyhteystiedostoa, jolloin samaa tietoyhteyttä ei tarvitse luoda uudelleen tyhjästä jokaiselle lomakemallille.

  • Jos ulkoisen tietolähteen sijainti tai yhteysasetukset muuttuvat, sinun on päivitettävä vain tietoyhteystiedosto eikä jokaista lomakemallia.

  • Tietoyhteystiedosto voi sisältää vaihtoehtoisia todennustietoja, joita palvelin voi käyttää, kun käyttäjä täyttää lomakkeen verkkoselaimen avulla.

  • Selainyhteensopivaan lomakemalliin perustuvat lomakkeet, jotka täytetään selaimessa, voivat yhdistää toisen toimialueen palvelimiin vain tietoyhteyksillä, jotka käyttävät tietoyhteystiedostoja.

Huomautus: Microsoft Office InfoPath käyttää tietoyhteystiedostoja, jotka noudattavat Universal Data Connection version 2.0 -tiedostomuotoa. Tämä versio on Microsoft Office FrontPagen ja Microsoft Office Excelin käyttämän version 1.0 -tiedostomuodon osa. InfoPath ei voi käyttää tietoyhteystiedostoja versio 1.0 -tiedostomuodossa.

Kun lisäät lomakemalliin tietoyhteyden käyttämällä tietoyhteyskirjaston asetuksia, luot lomakemalliin toissijaisen tietoyhteyden. Tämä toissijainen tietoyhteys eroaa päätietoyhteydestä, joka luodaan suunniteltaessa tietokantaan, verkkopalveluun tai tietoyhteyskirjaston asetuksiin perustuvaa lomakemallia. Toissijainen tietoyhteys lisätään vain, jos tietoja ei voi vastaanottaa tai lähettää päätietolähteen kautta.

Sivun alkuun

Toimet ennen aloittamista

Jotta voit lisätä tietoyhteyden lomakemalliin käyttämällä tietoyhteyskirjastoon tallennettuja asetuksia, tarvitset sivuston järjestelmänvalvojalta

  • sen palvelimen sijaintitiedot, jossa on käytössä Microsoft Office SharePoint Server 2007, joka sisältää tietoyhteyskirjaston sisältävän sivuston

  • sen tietoyhteyskirjaston tietoyhteystiedoston nimen, jota haluat käyttää

  • tiedon siitä, sisältääkö tietoyhteystiedosto kyselyn tietoyhteyden vai lähetystietoyhteyden asetukset

  • tiedon siitä, voitko määrittää lomakemallin niin, että se tallentaa kyselyn tulokset lomakkeeseen turvallisesti offline-käyttöä varten, jos asetukset ovat kyselyn tietoyhteyden asetuksia.

Sivun alkuun

Kyselyn tietoyhteyden lisääminen

Jotta voit lisätä tietoyhteyden lomakemalliin käyttämällä yhteyskirjaston asetuksia, tee seuraavasti:

  1. Lisää toissijainen tietolähde lomakemalliin.

  2. Sido ohjausobjektit toissijaisen tietolähteen kysely- ja tietokenttiin.

  3. Määritä lomakemalli käyttämään tietoyhteyttä säännön tai painikkeen avulla.

Vaihe 1: toissijaisen tietoyhteyden lisääminen

  1. Napsauta Työkalut-valikosta Tietoyhteydet.

  2. Napsauta Tietoyhteydet-valintaikkunassa Lisää.

  3. Napsauta ohjatun tietoyhteyden muodostamisessa Etsi yhteyksiä Microsoft Office SharePoint Server -palvelimesta ja napsauta sitten Seuraava.

  4. Napsauta ohjatun toiminnon seuraavan sivun Sivusto-luettelosta siinä palvelimessa sijaitsevan sivuston nimeä, jossa on käytössä yhteyskirjaston sisältävä Office SharePoint Server 2007.

    Oma sivusto ei ole luettelossa

    Voit lisätä oman sivustosi luetteloon seuraavasti:

    1. Napsauta Sivustojen hallinta.

    2. Napsauta Sivustojen hallinta -valintaikkunassa Lisää.

    3. Kirjoita tietoyhteyskirjaston sijainti URL-osoite-ruutuun.

    4. Kirjoita tietoyhteyskirjaston nimi Näyttönimi-ruutuun. Tämä nimi näkyy Sivusto-luettelossa ohjatun tietoyhteyden muodostamisessa.

    5. Napsauta OK.

    6. Napsauta Sulje.

  5. Napsauta tietoyhteyskirjaston nimeä, jotta näkyviin tulee luettelo tietoyhteystiedostoista. Napsauta tietoyhteystiedoston nimeä, jota haluat käyttää tätä tietoyhteyttä varten, ja napsauta sitten Seuraava.

  6. Tietoyhteystiedoston yhteysasetusten mukaan ohjatun toiminnon seuraavalla sivulla sinua ehkä pyydetään määrittämään malliarvot jokaiselle parametrille.

    Malliarvojen määrittäminen

    1. Valitse parametri Parametrit-taulukossa ja napsauta sitten Määritä malliarvo.

    2. Kirjoita Malliarvo-ruutuun arvo, jota käyttäjä saattaa käyttää tälle kentälle, ja napsauta sitten OK.

    3. Toista nämä vaiheet kullekin parametrille Parametrit-taulukossa ja napsauta sitten Seuraava.

    Tekninen huomautus

    Kun määrität tietoyhteyden verkkopalveluun ohjatussa tietoyhteyden muodostamisessa, Microsoft Office InfoPath muodostaa yhteyden verkkopalveluun ja pyytää Web Service Description Language (WSDL) -tiedostoa. WSDL-tiedosto sisältää verkkopalvelun käyttämän rakenteen. Verkkopalvelu vastaa pyyntöön lähettämällä tämän tiedoston InfoPathiin. InfoPath käyttää tämän tiedoston tietoja tarvittavien kenttien ja ryhmien lisäämiseen lomakemallin toissijaiseen tietolähteeseen. Jos InfoPath löytää tuntemattoman elementtityypin WSDL-tiedostossa, InfoPath määrittää mallitietojen avulla tuntemattoman elementtityypin määritelmän ja lisää sitten tarvittavat kentät ja ryhmät toissijaiseen tietolähteeseen.

  7. Jos haluat, että kyselyn tulokset ovat käytettävissä, kun lomake ei ole yhteydessä verkkoon, valitse Tallenna kopio tiedoista lomakemalliin -valintaruutu.

    Tietoturvahuomautus : Tämän valintaruudun valitseminen tallentaa kyselyn tulokset lomakemalliin. Koska tiedot tallennetaan lomakemalliin, ne ovat käytettävissä lomakkeessa, kun käyttäjä täyttää lomaketta, vaikka tietokone ei olisikaan yhteydessä verkkoon. Jos vastaanotat tämän tietoyhteyden välityksellä arkaluonteisia tietoja, tämä ominaisuus kannattaa poistaa käytöstä tietojen suojaamiseksi siinä tilanteessa, että tietokone katoaa tai se varastetaan.

  8. Napsauta Seuraava.

    Ohjatun toiminnon seuraavalla sivulla näytetään yhteenveto kyseisen tietoyhteyden asetuksista.

  9. Kirjoita tietoyhteydelle sitä kuvaava nimi. Tämä nimi näkyy Tietolähde-tehtäväruudun Tietolähde-luettelossa.

  10. Jos haluat, että tähän lomakemalliin perustuvat lomakkeet käyttävät tätä tietoyhteyttä, kun ne avataan, valitse Hae tiedot automaattisesti, kun lomake avataan -valintaruutu.

Sivun alkuun

Vaihe 2: käyttäjille tiedot näyttävän ohjausobjektin lisääminen

  1. Jos Ohjausobjektit-tehtäväruutu ei ole näkyvissä, napsauta Lisää-valikosta Lisää ohjausobjekteja tai paina ALT+I, C -näppäinyhdistelmää.

  2. Vedä ohjausobjekti lomakemalliin.

  3. Valitse Ohjausobjektin sidonta -valintaikkunassa kenttä, johon haluat sitoa ohjausobjektin, ja napsauta sitten OK.

Vaihe 3: lomakemallin määrittäminen niin, että se käyttää tietoyhteyttä

Jos haluat, että käyttäjät hakevat tämän tietoyhteyden tietoja lomakkeen avautumisen jälkeen, voit lisätä lomakemalliin säännön, joka käyttää tietoyhteyttä tietyn ehdon täyttyessä. Voit vaihtoehtoisesti lisätä lomakemalliin painikkeen, jota painamalla käyttäjät voivat käyttää tietoyhteyttä.

Säännön lisääminen

Voit lisätä lomakemalliin säännön, joka suorittaa kyselyn tietoyhteyden aina, kun säännön ehto täyttyy. Seuraavassa oletetaan, että olet luonut kyselyn tietoyhteyden lomakemallille ja että olet määrittänyt lomakemallin ohjausobjektin näyttämään tietoyhteyden tiedot.

  1. Jos lomakemalli sisältää useita näkymiä, napsauta Näkymä-valikosta Näkymän nimi ja siirry näkymään, jonka sisältämässä ohjausobjektissa haluat näyttää toissijaisesta tietolähteestä noutamasi tiedot.

  2. Kaksoisnapsauta ohjausobjektia, johon haluat lisätä säännön.

  3. Napsauta Tiedot-välilehteä.

  4. Napsauta Kelpoisuustarkistus ja säännöt -kohdasta Säännöt.

  5. Napsauta Säännöt-valintaikkunassa Lisää.

  6. Kirjoita säännölle nimi Nimi-ruutuun.

  7. Voit määrittää ehdon, joka määrittää säännön suoritusajankohdan, napsauttamalla Määritä ehto ja kirjoittamalla ehdon. Sääntö suoritetaan, kun ehto täyttyy. Jos et määritä ehtoa, sääntö suoritetaan aina, kun käyttäjä muuttaa ohjausobjektin arvoa tai siirtää kohdistuksen pois ohjausobjektista.

  8. Napsauta Lisää toiminto.

  9. Napsauta Toiminto-luettelosta Kysely tietoyhteyden avulla.

  10. Napsauta Tietoyhteys-luettelosta haluamasi kyselyn tietoyhteys ja sulje sitten jokainen valintaikkuna napsauttamalla OK.

  11. Testaa muutokset napsauttamalla vakiotyökaluriviltä Esikatselu tai painamalla CTRL+VAIHTO+B-näppäinyhdistelmää.

Painikkeen lisääminen kyselyn tietoyhteyden käyttöä varten

Voit lisätä lomakemalliin painikkeen ohjausobjektin, jota käyttäjät voivat napsauttaa täyttäessään lomakemalliin perustuvaa lomaketta. Painikkeen napsautus hakee kyselyn tietoyhteyden tietoja.

  1. Jos lomakemalli sisältää useita näkymiä, napsauta Näkymä-valikosta Näkymän nimi ja siirry näkymään, jonka sisältämässä ohjausobjektissa haluat näyttää toissijaisesta tietolähteestä noutamasi tiedot.

  2. Jos Ohjausobjektit-tehtäväruutu ei ole näkyvissä, napsauta Lisää-valikosta Lisää ohjausobjekteja tai paina ALT+I, C -näppäinyhdistelmää.

  3. Vedä painikkeen ohjausobjekti lomakemalliin.

  4. Kaksoisnapsauta juuri lomakemalliin lisäämääsi painikkeen ohjausobjektia.

  5. Napsauta Yleiset-välilehteä.

  6. Napsauta Toiminto-luettelosta Päivitä.

  7. Kirjoita Selite-ruutuun nimi, jonka haluat näkyvän lomakemallin painikkeessa.

  8. Napsauta Asetukset.

  9. Napsauta Päivitä-valintaikkunasta Yksi toissijainen tietolähde.

  10. Napsauta Valitse toissijainen tietolähde -luettelosta kyselyn tietoyhteyteen liittyvä toissijainen tietolähde.

  11. Sulje jokainen avoinna oleva valintaikkuna napsauttamalla OK.

  12. Testaa muutokset napsauttamalla vakiotyökaluriviltä Esikatselu tai painamalla CTRL+VAIHTO+B-näppäinyhdistelmää.

Sivun alkuun

Lähetystietoyhteyden lisääminen

Jos tietoyhteystiedosto sisältää lähetystietoyhteyden asetukset, voit määrittää lomakemallin niin, että se sallii käyttäjien lähettää lomaketiedot tämän tietoyhteyden kautta. Kun määrität lomakemallin sallimaan käyttäjien lähettää lomaketietoja, InfoPath lisää Lähetä-painikkeen vakiotyökaluriville ja Lähetä-komennon Tiedosto-valikkoon. Voit määrittää lomakemallin lähetyksen asetukset Lähetyksen asetukset -valintaikkunassa (Työkalut-valikko). Lähetyksen asetukset määritetään samalla tavalla kuin lisäisit toissijaisen tietolähteen, joka on lähetystietoyhteys. Lisätietoja lähetystietoyhteyden lisäämisestä lomakemalliin on Katso myös -osan linkeissä.

  1. Napsauta Työkalut-valikosta Tietoyhteydet.

  2. Napsauta Tietoyhteydet-valintaikkunassa Lisää.

  3. Napsauta ohjatun tietoyhteyden muodostamisessa Etsi yhteyksiä Microsoft Office SharePoint Server -palvelimesta ja napsauta sitten Seuraava.

  4. Napsauta ohjatun toiminnon seuraavan sivun Sivusto-luettelosta yhteyskirjaston sisältävän sivuston nimeä.

    Oma sivusto ei ole luettelossa

    Voit lisätä oman sivustosi luetteloon seuraavasti:

    1. Napsauta Sivustojen hallinta.

    2. Napsauta Sivustojen hallinta -valintaikkunassa Lisää.

    3. Kirjoita tietoyhteyskirjaston sijainti URL-osoite-ruutuun.

    4. Kirjoita tietoyhteyskirjaston nimi Näyttönimi-ruutuun. Tämä nimi näkyy Sivusto-luettelossa ohjatun tietoyhteyden muodostamisessa.

    5. Napsauta OK.

    6. Napsauta Sulje.

  5. Napsauta tietoyhteyskirjaston nimeä, jotta näkyviin tulee luettelo tietoyhteystiedostoista. Napsauta tietoyhteystiedoston nimeä, jota haluat käyttää tätä lähetystietoyhteyttä varten, ja napsauta sitten Seuraava.

  6. Jos asetukset ovat lähetystietoyhteydelle verkkopalveluun, InfoPath voit havaita, mitkä verkkopalvelun parametrit voivat vastaanottaa tietoja. Voit määrittää lähetystietoyhteyden lähettämään kaikki lomakemallin tiedot tai vain osan sen tiedoista.

    Toimintaohjeet

    1. Napsauta Parametrit-luettelosta parametria, joka vastaanottaa tiedot lomakkeesta.

    2. Jos haluat lähettää kaikki lomakkeen tiedot kyseiselle parametrille, mukaan lukien pääelementin ja käsittelyohjeet, tee seuraavasti:

      1. Napsauta Koko lomake (XML-asiakirja ja käsittelyohjeet).

      2. Jos haluat lähettää tiedot merkkijonona, valitse Lähetä tiedot merkkijonona -valintaruutu. Yleensä tämä valintaruutu valitaan, kun halutaan lähettää digitaalisesti allekirjoitettuja tietoja. Useimmissa tapauksissa tämän valintaruudun valinnan voi poistaa.

    3. Jos haluat määrittää kentän tai ryhmän tälle parametrille, tee seuraavasti:

      1. Napsauta Parametrin asetukset -kohdasta Kenttä tai ryhmä.

      2. Napsauta Muokkaa Tietolähde-painike .

      3. Napsauta Kentän tai ryhmän valitseminen -valintaikkunasta kenttää tai ryhmää, jonka tiedot haluat lähettää, ja napsauta sitten OK.

      4. Napsauta Sisällytä-luettelosta Vain teksti ja alielementit, jos haluat lähettää vain kentän tai ryhmän sisällön, tai napsauta XML-alipuu, mukaan lukien valittu elementti, jos haluat lähettää sekä sisällön että valitun kentän tai ryhmän.

    4. Toista nämä vaiheet jokaisen parametrin yhteydessä.

  7. Napsauta Seuraava.

  8. Kirjota ohjatun toiminnon seuraavalla sivulla Kirjoita tämän tietoyhteyden nimi -ruutuun lähetystietoyhteyden kuvaava nimi.

Sivun alkuun

Kehitä taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×