Tietoyhteyden lisääminen Web-palveluun

Tärkeää: Tämä on artikkeli on käännetty koneellisesti. Lue vastuuvapauslauseke. Tämän artikkelin englanninkielinen versio on täällä .

Voit lisätä lomakemalliin yhden tai usean toissijaisen tietoyhteyden, joka joko suorittaa kyselyjä Web-palvelusta tai lähettää tietoja siihen.

Tässä artikkelissa käsiteltävät aiheet

Yleiskatsaus

Yhteensopivuuden huomioon otettavia seikkoja

Ennen aloittamista

Kyselyn tietoyhteyden lisääminen

Lähetystietoyhteyden lisääminen

Yleiskatsaus

Toissijainen tietoyhteys on mikä tahansa ulkoiseen tietolähteeseen muodostettava tietoyhteys, joka lisätään lomakemalliin. Tämä tietoyhteys on erilainen kuin päätietoyhteys, joka luodaan tietokantaan, verkkopalveluun tai yhteyskirjaston asetuksiin perustuvaa lomakemallia luotaessa. Toissijainen tietoyhteys lisätään vain, jos kyselyjen tekeminen tai tietojen lähettäminen päätietoyhteyden välityksellä ei ole mahdollista.

Kun lisäät toissijaisen tietoyhteyden lomakemalliin, kyselyt, Microsoft Office InfoPath luo toissijaisen tietolähde tietojen kentät ja ryhmät, joka vastaa WWW-palvelun XML-rakenne . Toissijainen tietolähde tietorakenteen on vastattava XML-rakenteen, koska et voi muokata aiemmin luotuja kenttiä tai ryhmiä toissijainen tietolähde. Kun lisäät lähetystietoyhteyden lomakemalliin, voit määrittää lomakemallin, jotta käyttäjät voivat lähettää tiedot ja määrität lomakemallissa perustuvia lomakkeita lähetyksen asetukset.

Sivun alkuun

Yhteensopivuuteen liittyvät näkökohdat

selainyhteensopiva lomakemalli lähetystietoyhteyttä ei voi määrittää sallimaan käyttäjien lähettää muutostietoja lomaketietojen kanssa Web-palvelimeen, joka hyväksyy Microsoft ADO.NET DataSetin. Muutostiedot koostuvat muokkauksista, jotka käyttäjä tekee tietokantaan tallennettuihin tietoihin. Tietokanta yhdistää käyttäjät tietokantaan käyttämällä Web-palvelua. ADO.NET voi käyttää muutostietoja tietokannan tietojen päivitystavan määrittämisessä. Kysy Web-palvelun järjestelmänvalvojalta, tarvitseeko Web-palvelu muutostietoja tietokannan päivittämisessä. Jos muutostietoja tarvitaan, sinun tulee suunnitella lomakemalli, jonka lomakkeet voi täyttää vain käyttämällä InfoPathia.

Sivun alkuun

Toimet ennen aloittamista

Ennen toissijaisen tietoyhteyden lisäämistä lomakemalliin tarvitset Web-palvelun järjestelmänvalvojalta

  • Web-palvelun sijaintitiedot

  • vahvistuksen, että Web-palvelu käyttää Document Literal -tyylistä koodausta, sillä InfoPath voi käyttää vain Document Literal -tyylin Web-palveluja

  • sen Web-palvelun toiminnon nimen, joka lähettää tai vastaanottaa tietoja tähän lomakemalliin perustuvista lomakkeista.

Sivun alkuun

Kyselyn tietoyhteyden lisääminen

Jotta käyttäjät voivat suorittaa tietokyselyjä Web-palvelusta käyttämällä lomakemallia, sinun tulee

  1. lisätä lomakemalliin toissijainen tietoyhteys

  2. määrittää lomakemalli niin, että se käyttää toissijaista tietoyhteyttä.

Vaihe 1: toissijaisen tietoyhteyden lisääminen

  1. Valitse Työkalut-valikosta Tietoyhteydet.

  2. Valitse Tietoyhteydet-valintaikkunassa Lisää.

  3. Valitse ohjatussa tietoyhteyden muodostamisessa Luo uusi yhteys kohteeseen, valitse Vastaanota tiedot ja valitse sitten Seuraava.

  4. Valitse Mistä haluat hakea tiedot? -kohdasta Web-palvelu ja valitse sitten Seuraava.

  5. Kirjoita ohjatun toiminnon seuraavalle sivulle Web-palvelun sijainti ja valitse Seuraava.

    Huomautus: Jos haluat etsiä verkkopalvelun yleinen kuvaus etsiminen ja integrointi (UDDI) palvelimen avulla, valitse UDDI, kirjoita URL-OSOITE, jonka haluat etsiä, määrittää, haluatko Etsi toimittaja tai palvelu, joka on annettu, Kirjoita avainsana ja valitse sitten EtsiUDDI-palvelimesta. Web-palvelut, jotka vastaavat hakusana näkyvät hakutulokset -luettelosta. Valitse Web-palvelu, jota haluat käyttää, ja valitse sitten OK.

  6. Valitse ohjatun toiminnon seuraavalla sivulla Valitse toiminto -luettelosta Web-palvelun toiminto, joka palauttaa tiedot lomakkeeseen, ja valitse sitten Seuraava.

  7. Jos ohjattu tietoyhteyden muodostaminen havaitsee tuntemattoman elementin Web-palvelun rakenteessa, sinua pyydetään ehkä antamaan malliarvot jokaiselle parametrille ohjatun toiminnon seuraavalla sivulla, jotta ohjattu toiminto voi määrittää, mitkä kentät tai ryhmät lisätään päätietolähteeseen.

    Toimintaohjeet

    1. Valitse parametri Parametrit-taulukossa ja napsauta sitten Määritä malliarvo.

    2. Kirjoita Malliarvo-ruutuun arvo, jota käyttäjä saattaa käyttää tälle kentälle, ja napsauta sitten OK.

    3. Toista nämä vaiheet kullekin parametrille Parametrit-taulukossa ja napsauta sitten Seuraava.

    Teknisiä tietoja

    Kun määrität tietoyhteyden verkkopalveluun ohjatussa tietoyhteyden muodostamisessa, Microsoft Office InfoPath muodostaa yhteyden verkkopalveluun ja pyytää Web Service Description Language (WSDL) -tiedostoa. WSDL-tiedosto sisältää verkkopalvelun käyttämän rakenteen. Verkkopalvelu vastaa pyyntöön lähettämällä tämän tiedoston InfoPathiin. InfoPath käyttää tämän tiedoston tietoja tarvittavien kenttien ja ryhmien lisäämiseen lomakemallin toissijaiseen tietolähteeseen. Jos InfoPath löytää tuntemattoman elementtityypin WSDL-tiedostossa, InfoPath määrittää mallitietojen avulla tuntemattoman elementtityypin määritelmän ja lisää sitten tarvittavat kentät ja ryhmät toissijaiseen tietolähteeseen.

  8. Jos haluat, että kyselyn tulokset ovat käytettävissä, kun lomake ei ole yhteydessä verkkoon, valitse Tallenna kopio tiedoista lomakemalliin -valintaruutu.

    Tietoturvahuomautus : Tämän valintaruudun valitseminen tallentaa kyselyn tulokset lomakemalliin. Koska tiedot tallennetaan lomakemalliin, ne ovat käytettävissä lomakkeessa, kun käyttäjä täyttää lomaketta, vaikka tietokone ei olisikaan yhteydessä verkkoon. Jos vastaanotat tämän tietoyhteyden välityksellä arkaluonteisia tietoja, tämä ominaisuus kannattaa poistaa käytöstä tietojen suojaamiseksi siinä tilanteessa, että tietokone katoaa tai se varastetaan.

  9. Valitse Seuraava.

  10. Kirjoita ohjatun toiminnon seuraavalla sivulla kyselyn tietoyhteyttä kuvaava nimi.

  11. Jos haluat, että tähän lomakemalliin perustuvat lomakkeet vastaanottavat tietoja automaattisesti, kun ne avataan, valitse Hae tiedot automaattisesti, kun lomake avataan -valintaruutu.

  12. Tarkista, että Yhteenveto -osassa tiedot ovat oikein ja valitse sitten Valmis.

  13. Valitse Sulje.

Vaihe 2: Lomakemallin määrittäminen niin, että se käyttää toissijaista tietoyhteyttä.

Kun lomakemalliin lisätään kyselyn tietoyhteys, tähän lomakemalliin oletusarvoisesti perustuvat lomakkeet käyttävät tietoyhteyttä, kun käyttäjä avaa ne. Voit myös määrittää lomakemallin käyttämään kyselyn tietoyhteyttä jollakin seuraavista tavoista:

  • Lisää sääntö    Voit määrittää säännön, joka ottaa käyttöön kyselytietoyhteyden, kun säännön ehdot täyttyvät.

  • Lisää painike    Voit lisätä lomakemalliin painikkeen, jota napsauttamalla käyttäjät voivat noutaa tietoja kyselytietoyhteyden välityksellä.

  • Käytä mukautettua koodia    Jos et voi lisätä sääntöä tai painiketta, voit määrittää tietojen noutamisen kyselytietoyhteyden välityksellä käyttämällä mukautettua koodia. Mukautetun koodin käyttäminen edellyttää, että kehittäjä luo mukautetun koodin.

Säännön lisääminen

Voit lisätä lomakemalliin säännön, jotta saat kyselyn tietoyhteyden tietoja aina, kun säännön ehto täyttyy. Seuraavassa oletetaan, että olet luonut kyselyn tietoyhteyden lomakemallille ja että olet määrittänyt lomakemallin ohjausobjektin näyttämään kyseiset tietoyhteyden tiedot.

  1. Jos lomakemalli sisältää useita näkymiä, valitse Näytä-valikosta Näkymän nimi ja siirry näkymään, jonka sisältämässä ohjausobjektissa haluat näyttää toissijaisesta tietolähteestä noutamasi tiedot.

  2. Kaksoisnapsauta ohjausobjektia, johon haluat lisätä säännön.

  3. Valitse Tiedot-välilehti.

  4. Napsauta Kelpoisuustarkistus ja säännöt -kohdasta Säännöt.

  5. Napsauta Säännöt-valintaikkunassa Lisää.

  6. Kirjoita säännölle nimi Nimi-ruutuun.

  7. Voit määrittää ehdon, joka määrittää säännön suoritusajankohdan, napsauttamalla Määritä ehto ja kirjoittamalla ehdon. Sääntö suoritetaan, kun ehto täyttyy. Jos et määritä ehtoa, sääntö suoritetaan aina, kun käyttäjä muuttaa ohjausobjektin arvoa tai siirtää kohdistuksen pois ohjausobjektista.

  8. Napsauta Lisää toiminto.

  9. Valitse Toiminto-luettelosta Kysely tietoyhteyden avulla.

  10. Valitse Tietoyhteys-luettelosta haluamasi kyselyn tietoyhteys ja sulje sitten jokainen avoinna oleva valintaikkuna valitsemalla OK.

  11. Testaa muutokset valitsemalla vakiotyökaluriviltä Esikatselu tai painamalla CTRL+VAIHTO+B-näppäinyhdistelmää.

Painikkeen lisääminen

Voit lisätä lomakemalliin painikkeen ohjausobjektin, jota napsauttamalla käyttäjät voivat hakea kyselyn tietoyhteyden tietoja. Seuraavassa oletetaan, että olet luonut lomakemalliin kyselyn tietoyhteyden.

  1. Jos lomakemalli sisältää useita näkymiä, valitse Näytä-valikosta Näkymän nimi ja siirry näkymään, jonka sisältämässä ohjausobjektissa haluat näyttää toissijaisesta tietolähteestä noutamasi tiedot.

  2. Jos Ohjausobjektit-tehtäväruutu ei ole näkyvissä, napsauta Lisää-valikosta Lisää ohjausobjekteja tai paina ALT+I, C -näppäinyhdistelmää.

  3. Vedä painikkeen ohjausobjekti lomakemalliin.

  4. Kaksoisnapsauta juuri lomakemalliin lisäämääsi painiketta.

  5. Valitse Yleiset-välilehti.

  6. Valitse Toiminto-luettelosta Päivitä.

  7. Kirjoita Selite-ruutuun nimi, jonka haluat näkyvän lomakemallin painikkeessa.

  8. Valitse Asetukset.

  9. Valitse Päivitä-valintaikkunasta Yksi toissijainen tietolähde.

  10. Valitse Valitse toissijainen tietolähde -luettelosta toissijainen tietolähde, joka liittyy kyselyn tietolähteeseen, ja sulje sitten jokainen avoinna oleva valintaikkuna valitsemalla OK.

  11. Testaa muutokset valitsemalla vakiotyökaluriviltä Esikatselu tai painamalla CTRL+VAIHTO+B-näppäinyhdistelmää.

Sivun alkuun

Lähetystietoyhteyden lisääminen

Jotta käyttäjät voivat lähettää lomakemalliin perustuvia lomakkeita Web-palveluun, sinun on ensin lisättävä lomakemalliin toissijainen tietoyhteys, joka lähettää tietoja. Tämän jälkeen määrität lomakemallin sallimaan käyttäjien lähettää lomaketietoja.

Vaihe 1: toissijaisen tietoyhteyden lisääminen

  1. Valitse Työkalut-valikosta Tietoyhteydet.

  2. Valitse Tietoyhteydet-valintaikkunassa Lisää.

  3. Valitse ohjatussa tietoyhteyden muodostamistoiminnossa Luo uusi yhteys kohteeseen, valitse Lähetä tiedot ja valitse sitten Seuraava.

  4. Valitse Mihin haluat lähettää tiedot? -kohdasta Web-palveluun ja valitse sitten Seuraava.

  5. Kirjoita ohjatun toiminnon seuraavalla sivulla sen Web-palvelun sijainti, johon käyttäjät lähettävät tiedot, ja valitse sitten Seuraava.

    Huomautus: Jos haluat etsiä verkkopalvelun yleinen kuvaus etsiminen ja integrointi (UDDI) palvelimen avulla, valitse UDDI, kirjoita URL-OSOITE, jonka haluat etsiä, määrittää, haluatko Etsi toimittaja tai palvelu, joka on annettu, Kirjoita avainsana ja valitse sitten EtsiUDDI-palvelimesta. Web-palvelut, jotka vastaavat hakusana näkyvät hakutulokset -luettelosta. Valitse Web-palvelu, jota haluat käyttää, ja valitse sitten OK.

  6. Valitse Valitse toiminto -luettelosta Web-palvelun toiminto, joka vastaanottaa lomaketietoja, ja valitse sitten Seuraava.

  7. Jotta voit valita, mitä lomakkeen tietoja voit lähettää kullekin Web-palvelun parametrille, tee ohjatun toiminnon seuraavalla sivulla jokin seuraavista:

    Kentän tai ryhmän tietojen lähettäminen

    1. Valitse Parametrit-luettelosta Web-palvelun parametri, joka vastaanottaa lomaketiedot lomakkeesta.

    2. Napsauta Parametrin asetukset -kohdasta Kenttä tai ryhmä.

    3. Napsauta Muokkaa Tietolähde-painike .

    4. Napsauta Kentän tai ryhmän valitseminen -valintaikkunasta kenttää tai ryhmää, jonka tiedot haluat lähettää, ja napsauta sitten OK.

    5. Jos haluat lähettää vain tämän kentän tiedot ja kentän tai ryhmän alielementit, valitse Sisällytä-ruudussa Vain teksti ja alielementit. Jos haluat lähettää kentän nimen, kentän tiedot ja valitun ryhmän tai kentän alielementit, valitse XML-alipuu, mukaan lukien valittu elementti.

    Lähetä kaikki tiedot-lomake

    1. Valitse Parametrit-luettelosta Web-palvelun parametri, joka vastaanottaa lomaketiedot lomakkeesta.

    2. Valitse parametrin asetukset-kohdassa koko lomake (XML-asiakirja ja käsittelyohjeet).

    Lähetä tiedot merkkijonona

    1. Valitse Parametrit-luettelosta Web-palvelun parametri, joka vastaanottaa lomaketiedot lomakkeesta.

    2. Valitse parametrin asetukset-kohdassa koko lomake (XML-asiakirja ja käsittelyohjeet).

    3. Valitse Lähetä tiedot merkkijonona -valintaruutu.

      Huomautus: Yleensä tämä valintaruutu valitaan, kun halutaan lähettää digitaalisesti allekirjoitettuja tietoja. Useimmissa tapauksissa tämän valintaruudun valinnan voi poistaa.

    Tekninen Huomautus ADO.NET DataSet objekteista

    Jos Web-palvelu edellyttää ADO.NET DataSet -objektia, valitse DataSet-solmu, kun määrität kyseistä tietoyhteyttä. Jos käytät jotakin muuta solmua ADO.NET DataSet -objektia edellyttävään Web-palveluun liittyvässä tietoyhteydessä, lähetystoiminto epäonnistuu.

  8. Valitse Seuraava.

  9. Kirjoita ohjatun toiminnon seuraavalla sivulla lähetystietoyhteyden nimi.

  10. Tarkista, että Yhteenveto -osassa tiedot ovat oikein ja valitse sitten Valmis.

  11. Valitse Sulje.

Toissijaisen lähetystietoyhteyden lisäämisen jälkeen sinun on määritettävä lomakemalli niin, että se sallii käyttäjien lähettää lomaketiedot käyttämällä kyseistä lähetystietoyhteyttä.

Vaihe 2: lähetyksen salliminen lomakemallissa.

Kun määrität lomakemallin sallimaan käyttäjien lähettää lomaketiedot, InfoPath lisää Lähetä-painikkeen vakiotyökaluriville ja Lähetä-komennon lomakkeen Tiedosto-valikkoon. Voit myös mukauttaa lomakemallin lähetysasetuksia seuraavasti:

  • Voit muuttaa Lähetä-painikkeen ja Lähetä-komennon tekstiä.

  • Voit muuttaa Lähetä-painikkeen tai Lähetä-komennon pikanäppäintä.

  • Voit luoda mukautettuja viestejä, jotka näytetään käyttäjille heidän lähettäessään lomakkeita.

  • Voit määrittää, haluatko säilyttää lomakkeen avoinna, sulkea lomakkeen tai avata toisen tyhjän lomakkeen lomakkeen lähettämisen jälkeen.

  • Valitse Työkalut-valikosta Lähetyksen asetukset.

  • Valitse Lähetysasetukset-valintaikkunassa Salli tämän lomakkeen lähettäminen -valintaruutu, valitse Lähetä lomakkeen tiedot yhteen kohteeseen ja valitse sitten luettelosta Web-palvelu.

  • Napsauta Valitse lähetyksen tietoyhteys -luettelossa edellisissä vaiheissa luodun Web-palvelun lähetystietoyhteyden nimeä.

    1. Voit muuttaa käyttäjän lomaketta täyttäessä Vakio-työkaluriville tulevan Lähetä-painikkeen sekä Tiedosto-valikkoon näkyviin tulevan Lähetä-komennon nimeä kirjoittamalla uuden nimen Lähetyksen asetukset -valintaikkunan Komennon nimi -ruutuun.

      Vihje: Jos haluat määrittää painikkeelle ja komennolle pikanäppäimen, kirjoita pikanäppäimenä käytettävän merkin eteen et-merkki (&). Jos esimerkiksi haluat määrittää Lähetä-painikkeen ja -komennon pikanäppäimeksi ALT+H, kirjoita Lä&hetä.

  • Jos et halua, että käyttäjät voivat käyttää Lähetä-komentoa tai vakiotyökalurivinLähetä-painiketta täyttäessään lomakettasi, poista Näytä Lähetä-valikkokomento ja työkalurivin Lähetä-painike -valintaruudun valinta.

    1. Oletusarvon mukaan InfoPath jättää lomakeikkunan avoimeksi käyttäjän lähetettyä lomakkeen ja näyttää sanoman, joka ilmaisee, onnistuiko lomakkeen lähettäminen. Voit muuttaa tätä oletusarvon mukaista toimintaa valitsemalla Lisäasetukset ja toimimalla jollakin seuraavista tavoista:

      • Jos haluat, että täytetyn lomakkeen lähettämisen jälkeen lomake suljetaan tai luodaan uusi, tyhjä lomake, valitse haluamasi vaihtoehto Lähettämisen jälkeen -luettelosta.

      • Jos haluat luoda mukautetun sanoman, joka ilmoittaa lähetyksen onnistuneen tai epäonnistuneen, valitse Käytä mukautettuja sanomia -valintaruutu ja kirjoita haluamasi teksti Toiminnon onnistuessa- ja Toiminnon epäonnistuessa -ruutuihin.

        Vihje: Sisällytä Toiminnon epäonnistuessa -ruudun tekstiin ohje, mitä tehdä, jos lomakkeen lähettäminen ei onnistu. Voit esimerkiksi kehottaa käyttäjää tallentamaan lomakkeen ja ottamaan yhteyttä tukipalveluun.

      • Jos et halua, että näyttöön tulee sanoma sen jälkeen, kun käyttäjä on lähettänyt lomakkeen, poista Näytä onnistumis- ja epäonnistumissanomat -valintaruudun valinta.

Sivun alkuun

Huomautus: Konekäännöksestä ilmoittava vastuusvapauslauseke: Tämä artikkeli on käännetty tietokonejärjestelmällä, eikä kieliasiantuntija ole muokannut sitä. Microsoft tarjoaa nämä konekäännökset avuksi muille kuin englantia puhuville käyttäjille, jotta he saavat lisätietoja Microsoftin tuotteista, palveluista ja tekniikoista. Koska artikkeli on koneellisesti käännetty, se saattaa sisältää sanasto-, lauseoppi- ja kielioppivirheitä.

Kehitä taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×