Tietoyhteyden lisääminen SharePoint-asiakirjakirjastoon tai -luetteloon

Voit lisätä lomakemalliin toissijaisia tietoyhteyksiä, jotka joko suorittavat tietokyselyjä asiakirjakirjastosta tai -luettelosta tai lähettävät tietoja asiakirjakirjastoon palvelimessa, jossa on käytössä Microsoft Windows SharePoint Services.

Artikkelin sisältö

Yleiskatsaus

Toimet ennen aloittamista

Kyselyn tietoyhteyden lisääminen

Lähetystietoyhteyden lisääminen

Yleiskatsaus

Toissijainen tietoyhteys on mikä tahansa ulkoiseen tietolähteeseen muodostettava tietoyhteys, joka lisätään lomakemalliin. Tämä tietoyhteys on erilainen kuin päätietoyhteys, joka luodaan tietokantaan, verkkopalveluun tai yhteyskirjaston asetuksiin perustuvaa lomakemallia luotaessa. Toissijainen tietoyhteys lisätään vain, jos kyselyjen tekeminen tai tietojen lähettäminen päätietoyhteyden välityksellä ei ole mahdollista.

Kun lisäät lomakemalliin tietokyselyjä suorittavan toissijaisen tietoyhteyden, Microsoft Office InfoPath luo toissijaisen tietolähteen, jonka tietokentät ja ryhmät vastaavat sitä, miten tiedot on tallennettu asiakirjakirjastoon tai -luetteloon. Ulkoisen tietolähteen ja lomakemallin tietolähteen välinen yhteys.

Koska toissijaisen tietolähteen tietorakenteen on vastattava tapaa, jolla tiedot on tallennettu asiakirjakirjastoon tai -luetteloon, toissijaisen tietolähteen aiemmin luotuja kenttiä tai ryhmiä ei voi muokata.

Jos tietoyhteys suorittaa kyselyitä SharePoint-tiedostokirjastosta tai -luettelosta, se palauttaa automaattisesti kaikki kyseisen tiedostokirjaston tai -luettelon kohteet. Jos käytät kyselyn tietoyhteyttä luetteloruutu-, avattava luetteloruutu- tai yhdistelmäruutu-ohjausobjektin täyttämiseen ja ohjausobjektissa on liian monta kohdetta tai haluat näyttää vain kohteet, jotka täyttävät määritetyt ehdot, voit rajoittaa kohteiden määrää käyttämällä ohjausobjektissa suodatinta. Lisätietoja ohjausobjektissa näkyvien tietojen suodattamiseen on Katso myös -osan linkeissä.

Voit myös määrittää jokaisen kyselyn tietoyhteyden tallentamaan sen tulokset, jotta käyttäjät voivat käyttää tietoja, kun lomake ei ole yhteydessä verkkoon. Tietojen tyypin mukaan haluat ehkä näyttää tulokset vain silloin, kun käyttäjät ovat yhteydessä verkkoon.

Tietoturvahuomautus : Jos noudat arkaluontoisia tietoja ulkoisesta tietolähteestä käyttämällä toissijaista tietoyhteyttä, tämä ominaisuus kannattaa poistaa suojaussyistä käytöstä siltä varalta, että tietokone katoaisi tai se varastettaisiin. Jos poistat tämän ominaisuuden käytöstä, tiedot ovat käytettävissä vain, kun verkkoyhteys on muodostettuna.

Kun lomakemalliin lisätään kyselyn tietoyhteys, tähän lomakemalliin oletusarvoisesti perustuvat lomakkeet käyttävät tietoyhteyttä, kun käyttäjä avaa ne. Voit myös määrittää lomakemallin käyttämään kyselyn tietoyhteyttä jollakin seuraavista tavoista:

  • Lisää sääntö    Voit määrittää säännön, joka ottaa käyttöön kyselytietoyhteyden, kun säännön ehdot täyttyvät.

  • Lisää painike    Voit lisätä lomakemalliin painikkeen, jota napsauttamalla käyttäjät voivat noutaa tietoja kyselytietoyhteyden välityksellä.

  • Käytä mukautettua koodia    Jos et voi lisätä sääntöä tai painiketta, voit määrittää tietojen noutamisen kyselytietoyhteyden välityksellä käyttämällä mukautettua koodia. Mukautetun koodin käyttäminen edellyttää, että kehittäjä luo mukautetun koodin.

Kun lisäät lomakemalliin lähetystietoyhteyden, voit määrittää lomakemallin sallimaan käyttäjien lähettää lomaketietonsa. Voit myös määrittää lähetysasetukset lomakemalliin perustuville lomakkeille.

Sivun alkuun

Toimet ennen aloittamista

Ennen toissijaisen tietoyhteyden lisäämistä lomakemalliin tarvitset sivuston järjestelmänvalvojalta

  • SharePoint-sivuston sijaintitiedot ja tarvittavat oikeudet sen käyttöön

  • vahvistuksen, että sivusto on määritetty, jotta käyttäjät voivat hakea tietoja asiakirjakirjastosta tai -luettelosta

  • vahvistuksen, että voit tallentaa asiakirjakirjaston tai -luettelon tietoja käyttäjien tietokoneisiin offline-käyttöä varten.

Sivun alkuun

Kyselyn tietoyhteyden lisääminen

Jotta käyttäjät voivat suorittaa tietokyselyn asiakirjakirjastosta tai -luettelosta sivustossa, joka sijaitsee palvelimessa, jossa on käytössä Microsoft Windows SharePoint Services, tee seuraavat toimet lomakemallissa:

  1. Toissijaisen tietoyhteyden lisääminen.

  2. määrittää lomakemalli niin, että se käyttää toissijaista tietoyhteyttä.

Vaihe 1: toissijaisen tietoyhteyden lisääminen

  1. Valitse Työkalut-valikosta Tietoyhteydet.

  2. Valitse Tietoyhteydet-valintaikkunassa Lisää.

  3. Valitse ohjatussa tietoyhteyden muodostamisessa Luo uusi yhteys kohteeseen, valitse Vastaanota tiedot ja valitse sitten Seuraava.

  4. Valitse ohjatun toiminnon seuraavalla sivulla SharePoint-kirjastosta tai -luettelosta ja valitse sitten Seuraava.

    Ohjatun tietoyhteyden muodostamisen sivu, jossa SharePoint-sivusto määritetään tietolähteeksi.

  5. Kirjoita ohjatun toiminnon seuraavalle sivulle asiakirjakirjaston tai -luettelon sisältävän SharePoint-sivuston URL-osoite ja valitse sitten Seuraava. Jos esimerkiksi haluat käyttää sellaisessa SharePoint-sivustossa olevaa asiakirjaluetteloa, jonka URL-osoite on http://www.adventureworks.com/EmployeeList, kirjoita http://www.adventureworks.com/EmployeeList.

  6. Valitse ohjatun toiminnon seuraavalla sivulla Valitse luettelo tai kirjasto -luettelosta luettelo tai kirjasto, jota haluat käyttää, ja valitse sitten Seuraava.

  7. Valitse ohjatun toiminnon seuraavalla sivulla niiden arvojen vieressä olevat valintaruudut, jotka haluat vastaanottaa. Jos lomakemalli julkaistaan asiakirjakirjastoon, ja haluat, että tähän lomakemalliin perustuvat lomakkeet hakevat lomakkeeseen liittyviä metatietoja, valitse Lisää vain aktiivisen lomakkeen tiedot -valintaruutu.

  8. Valitse Seuraava.

  9. Jos haluat tallentaa kyselyn tulokset lomakemallin kanssa, valitse Tallenna kopio tiedoista lomakemalliin -valintaruutu. Kun valitset tämän valintaruudun, kyselyn tulokset tallennetaan lomakemalliin. Koska tiedot tallennetaan lomakemalliin, tiedot ovat käytettävissä lomakkeissa, joita käyttäjät täyttävät, vaikka käyttäjien tietokoneet eivät ole yhteydessä verkkoon.

    Tietoturvahuomautus : Tämän valintaruudun valitseminen tallentaa kyselyn tulokset lomakemalliin. Koska tiedot tallennetaan lomakemalliin, ne ovat käytettävissä lomakkeessa, kun käyttäjä täyttää lomaketta, vaikka tietokone ei olisikaan yhteydessä verkkoon. Jos vastaanotat tämän tietoyhteyden välityksellä arkaluonteisia tietoja, tämä ominaisuus kannattaa poistaa käytöstä tietojen suojaamiseksi siinä tilanteessa, että tietokone katoaa tai se varastetaan.

  10. Valitse Seuraava.

  11. Kirjoita ohjatun toiminnon seuraavan sivun Kirjoita tämän tietoyhteyden nimi -ruutuun tätä toissijaista tietoyhtyettä kuvaava nimi. Tämä nimi näkyy Tietolähde-tehtäväruudun Tietolähde-luettelossa. Jos haluat, että tämä kysely suoritetaan automaattisesti aina, kun käyttäjä avaa lomakemallin, valitse Hae tiedot automaattisesti, kun lomake avataan -valintaruutu.

Vaihe 2: Lomakemallin määrittäminen niin, että se käyttää toissijaista tietoyhteyttä.

Jos haluat, että lomakemalliisi perustuvat lomakkeet käyttävät tätä tietoyhteyttä lomakkeen avaamisen jälkeen, voit lisätä lomakemalliin säännön, jonka mukaan lomakemalli käyttää tätä tietoyhteyttä tietyn ehdon täyttyessä. Voit vaihtoehtoisesti lisätä lomakemalliin painikkeen, jota painamalla käyttäjät ottavat käyttöön tämän tietoyhteyden.

Säännön lisääminen

Voit lisätä lomakemalliin säännön, jotta saat kyselyn tietoyhteyden tietoja aina, kun säännön ehto täyttyy. Seuraavassa oletetaan, että olet luonut kyselyn tietoyhteyden lomakemallille ja että olet määrittänyt lomakemallin ohjausobjektin näyttämään kyseiset tietoyhteyden tiedot.

  1. Jos lomakemalli sisältää useita näkymiä, valitse Näytä-valikosta Näkymän nimi ja siirry näkymään, jonka sisältämässä ohjausobjektissa haluat näyttää toissijaisesta tietolähteestä noutamasi tiedot.

  2. Kaksoisnapsauta ohjausobjektia, jonka haluat näyttävän kyselyn tulokset.

  3. Valitse Tiedot-välilehti.

  4. Valitse Kelpoisuustarkistus ja säännöt -kohdasta Säännöt.

  5. Valitse Säännöt-valintaikkunassa Lisää.

  6. Kirjoita säännölle nimi Nimi-ruutuun.

  7. Voit määrittää ehdon, joka määrittää säännön suoritusajankohdan, valitsemalla Määritä ehto ja kirjoittamalla ehdon. Sääntö suoritetaan, kun ehto täyttyy. Jos et määritä ehtoa, sääntö suoritetaan aina, kun käyttäjä muuttaa ohjausobjektin arvoa tai siirtää kohdistuksen pois ohjausobjektista.

  8. Valitse Lisää toiminto.

  9. Valitse Toiminto-luettelosta Kysely tietoyhteyden avulla.

  10. Valitse Tietoyhteys-luettelosta haluamasi kyselyn tietoyhteys ja sulje sitten jokainen avoinna oleva valintaikkuna valitsemalla OK.

  11. Testaa muutokset valitsemalla vakiotyökaluriviltä Esikatselu tai painamalla CTRL+VAIHTO+B-näppäinyhdistelmää.

Painikkeen lisääminen

Voit lisätä lomakemalliin painikkeen ohjausobjektin, jota napsauttamalla käyttäjät voivat käyttää tätä kyselyn tietoyhteyttä. Seuraavassa oletetaan, että olet luonut lomakemalliin kyselyn tietoyhteyden.

  1. Jos lomakemalli sisältää useita näkymiä, valitse Näytä-valikosta Näkymän nimi ja siirry näkymään, jonka sisältämässä ohjausobjektissa haluat näyttää toissijaisesta tietolähteestä noutamasi tiedot.

  2. Jos Ohjausobjektit-tehtäväruutu ei ole näkyvissä valitse Lisää-valikosta Lisää ohjausobjekteja tai paina ALT+I, C -näppäinyhdistelmää.

  3. Vedä painikkeen ohjausobjekti lomakemalliin.

  4. Kaksoisnapsauta juuri lomakemalliin lisäämääsi painikkeen ohjausobjektia.

  5. Valitse Yleiset-välilehti.

  6. Valitse Toiminto-luettelosta Päivitä.

  7. Kirjoita Selite-ruutuun nimi, jonka haluat näkyvän lomakemallin painikkeessa.

  8. Valitse Asetukset.

  9. Valitse Päivitä-valintaikkunasta Yksi toissijainen tietolähde.

  10. Valitse Valitse toissijainen tietolähde -luettelosta toissijainen tietolähde, joka liittyy kyselyn tietolähteeseen, ja sulje sitten jokainen avoinna oleva valintaikkuna valitsemalla OK.

  11. Testaa muutokset valitsemalla vakiotyökaluriviltä Esikatselu tai painamalla CTRL+VAIHTO+B-näppäinyhdistelmää.

Sivun alkuun

Lähetystietoyhteyden lisääminen

Jotta käyttäjät voivat lähettää lomakemalliin perustuvia lomakkeita asiakirjakirjastoon, tee seuraavat toimet:

  1. Lisää toissijainen tietoyhteys, joka lähettää tietoja lomakemalliin.

  2. Määritä lomakemalli niin, että se sallii käyttäjien lähettää lomaketiedot asiakirjakirjastoon.

Vaihe 1: toissijaisen tietoyhteyden lisääminen

  1. Valitse Työkalut-valikosta Tietoyhteydet.

  2. Valitse Tietoyhteydet-valintaikkunassa Lisää.

  3. Valitse ohjatussa tietoyhteyden muodostamistoiminnossa Luo uusi yhteys kohteeseen, valitse Lähetä tiedot ja valitse sitten Seuraava.

  4. Valitse Miten haluat lähettää tiedot -kohdasta SharePoint-sivuston asiakirjakirjastoon ja valitse sitten Seuraava.

  5. Kirjoita ohjatun toiminnon seuraavalla sivulla Asiakirjakirjasto-ruutuun SharePoint-asiakirjakirjaston URL.

  6. Kirjoita Tiedostonimi-ruutuun nimi, jota käytetään lomakkeen tunnistamiseen asiakirjakirjastossa.

    Vihje: Voit myös varmistaa kaavan avulla, että jokainen lomakenimi on yksilöllinen.

    Toimintaohjeet:

    1. Valitse Lisää kaava Painikkeen kuva .

    2. Tee Kaavan lisääminen -valintaikkunassa jompikumpi seuraavista:

      • Jos haluat käyttää kaavassa kenttää, valitse Lisää kenttä tai ryhmä, valitse haluamasi kenttä Kentän tai ryhmän valitseminen -valintaikkunassa ja valitse sitten OK.

      • Jos haluat käyttää kaavassa funktiota, valitse Lisää funktio, valitse haluamasi funktio Funktion lisääminen -valintaikkunassa ja valitse OK.

        Vihje: Jos funktio edellyttää parametreja, valitse funktio Funktion lisääminen -valintaikkunassa ja valitse OK. Kaksoisnapsauta sitten Kaavan lisääminen -valintaikkunan Kaava-ruudussa lisäämääsi funktiota ja napsauta kenttää tai ryhmää. Lisätietoja funktioista on Katso myös -osan linkeissä.

      • Jos haluat lisätä kaavaan arvon tai laskutoimituksen, kirjoita arvo tai laskutoimituksen merkki Kaava-ruutuun.

    Laskutoimitus

    Merkki

    Yhteenlasku

    +

    Vähennyslasku

    -

    Kertolasku

    *

    Jakolasku

    /

    • Huomautus: Jos kaava käyttää jakolaskuoperaattoria (/), varmista, että jakolaskuoperaattoria ennen ja sen jälkeen on välilyönti. Jos jakolaskuoperaattoria ennen tai sen jälkeen ei ole välilyöntiä, InfoPath saattaa tulkita merkinnän "/" XPathin sijaintivaiheiden erottimeksi jakolaskuoperaattorin asemesta.

    • Voit tarkistaa kaavan syntaksin oikeellisuuden valitsemalla Lisää kaava -valintaikkunassa Tarkista kaava.

      Lisätietoja kaavoista on Katso myös -osan linkeissä.

  7. Jos haluat korvata asiakirjakirjaston samannimisiä aiemmin luotuja lomakkeita, valitse Salli korvaaminen, jos tiedosto on jo olemassa -valintaruutu.

  8. Valitse Seuraava.

  9. Kirjota ohjatun toiminnon seuraavalla sivulla Kirjoita tämän tietoyhteyden nimi -ruutuun lähetystietoyhteyden kuvaava nimi.

Toissijaisen lähetystietoyhteyden lisäämisen jälkeen sinun on määritettävä lomakemalli niin, että se sallii käyttäjien lähettää lomaketiedot käyttämällä kyseistä lähetystietoyhteyttä.

Vaihe 2: lähetyksen salliminen lomakemallissa.

Kun määrität lomakemallin sallimaan käyttäjien lähettää lomaketiedot, InfoPath lisää Lähetä-painikkeen vakiotyökaluriville ja Lähetä-komennon lomakkeen Tiedosto-valikkoon. Voit myös mukauttaa lomakemallin lähetysasetuksia seuraavasti:

  • Voit muuttaa Lähetä-painikkeen tekstiä.

  • Voit muuttaa Lähetä-painikkeen pikanäppäintä.

  • Voit luoda mukautettuja viestejä, jotka näytetään käyttäjille heidän lähettäessään lomakkeita.

  • Voit määrittää, haluatko säilyttää lomakkeen avoinna, sulkea lomakkeen tai avata toisen tyhjän lomakkeen lomakkeen lähettämisen jälkeen.

  • Valitse Työkalut-valikosta Lähetyksen asetukset.

  • Valitse Lähetysasetukset-valintaikkunassa Salli tämän lomakkeen lähettäminen -valintaruutu, valitse Lähetä lomakkeen tiedot yhteen kohteeseen ja valitse sitten luettelosta SharePoint-asiakirjakirjasto.

  • Napsauta Valitse lähetyksen tietoyhteys -luettelossa SharePoint-kirjaston lähetystietoyhteyden nimeä.

    1. Voit muuttaa käyttäjän lomaketta täyttäessä Vakio-työkaluriville tulevan Lähetä-painikkeen sekä Tiedosto-valikkoon näkyviin tulevan Lähetä-komennon nimeä kirjoittamalla uuden nimen Lähetyksen asetukset -valintaikkunan Komennon nimi -ruutuun.

      Vihje: Jos haluat määrittää painikkeelle ja komennolle pikanäppäimen, kirjoita pikanäppäimenä käytettävän merkin eteen et-merkki (&). Jos esimerkiksi haluat määrittää Lähetä-painikkeen ja -komennon pikanäppäimeksi ALT+H, kirjoita Lä&hetä.

  • Jos et halua, että käyttäjät voivat käyttää Lähetä-komentoa tai vakiotyökalurivinLähetä-painiketta täyttäessään lomakettasi, poista Näytä Lähetä-valikkokomento ja työkalurivin Lähetä-painike -valintaruudun valinta.

    1. Oletusarvon mukaan InfoPath jättää lomakeikkunan avoimeksi käyttäjän lähetettyä lomakkeen ja näyttää sanoman, joka ilmaisee, onnistuiko lomakkeen lähettäminen. Voit muuttaa tätä oletusarvon mukaista toimintaa valitsemalla Lisäasetukset ja toimimalla jollakin seuraavista tavoista:

      • Jos haluat, että täytetyn lomakkeen lähettämisen jälkeen lomake suljetaan tai luodaan uusi, tyhjä lomake, valitse haluamasi vaihtoehto Lähettämisen jälkeen -luettelosta.

      • Jos haluat luoda mukautetun sanoman, joka ilmoittaa lähetyksen onnistuneen tai epäonnistuneen, valitse Käytä mukautettuja sanomia -valintaruutu ja kirjoita haluamasi teksti Toiminnon onnistuessa- ja Toiminnon epäonnistuessa -ruutuihin.

        Vihje: Sisällytä Toiminnon epäonnistuessa -ruudun tekstiin ohje, mitä tehdä, jos lomakkeen lähettäminen ei onnistu. Voit esimerkiksi kehottaa käyttäjää tallentamaan lomakkeen ja ottamaan yhteyttä tukipalveluun.

      • Jos et halua, että näyttöön tulee sanoma sen jälkeen, kun käyttäjä on lähettänyt lomakkeen, poista Näytä onnistumis- ja epäonnistumissanomat -valintaruudun valinta.

Sivun alkuun

Kehitä taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×