Tietokantamallin luominen (tunnetaan myös nimellä Käsiterelaatio-kaavio)

Tietokantamallin luominen (tunnetaan myös nimellä Käsiterelaatio-kaavio)

Tärkeää: Tämä on artikkeli on käännetty koneellisesti. Lue vastuuvapauslauseke. Tämän artikkelin englanninkielinen versio on täällä .

Tietokantamallikaavion avulla voit luoda uuden mallin tai luoda mallin aiemmin luodun tietokannan rakenteen selvittämällä. Voit käyttää apuna relaatio- ja objektirelaatiomallinnuksen käsitteitä. Voit mallintaa SQL92-standardiin ja sitä aiempiin standardeihin perustuvia tietokantoja Käsiterelaatio-kaavaimen avulla. SQL99-standardiin ja sitä uudempiin standardeihin perustuvia tietokantoja voit mallintaa käyttämällä Objektirelaatio-kaavainta.

Esimerkki tietokantamallista

Tietokantamallikaavion avulla voit luoda uuden mallin tai luoda mallin aiemmin luodun tietokannan rakenteen selvittämällä. Voit käyttää apuna relaatio- ja objektirelaatiomallinnuksen käsitteitä. Voit mallintaa SQL92-standardiin ja sitä aiempiin standardeihin perustuvia tietokantoja Käsiterelaatio-kaavaimen avulla. SQL99-standardiin ja sitä uudempiin standardeihin perustuvia tietokantoja voit mallintaa käyttämällä Objektirelaatio-kaavainta.

Tässä artikkelissa kuvataan, miten voit luoda tietokantamallin ja mihin voit sitä käyttää.

Etkö löydä tietokannan mallin ominaisuuksia?

Kaikissa Microsoft Visio -versioissa ei ole tietokantamalliominaisuutta. Jos et löydä tämän artikkelin toimintosarjoissa kuvattuja ominaisuuksia, Visio-versiossasi ei todennäköisesti ole niitä.

  • Microsoft Visio Standard ei sisällä Tietokantamallikaavio-mallia.

  • Microsoft Office Visio Professional- ja Premium-versiot tukevat Tietokantamallikaavio-mallin lähdekoodin selvittämisominaisuuksia (eli mallin luomista Visiossa aiemmin luodun tietokannan pohjalta), mutta eivät tue koodin uustuotantoa (eli SQL-koodin luomista Visio-tietokantamallin pohjalta).

  1. Aloita tietokantamallin laatiminen jollakin seuraavista tavoista:

    Uuden mallikaavion luominen alusta alkaen

    Jos käytettävissäsi ei ole aiemmin luotua tietokantaa, jota haluat käyttää pohjana, voit aloittaa tyhjästä tietokantamallista ja lisätä siihen taulukoita ja yhteyksiä itse.

    1. Valitse Tiedosto-välilehti.

    2. Valitse Uusi, valitse Ohjelmistot ja tietokannat ja kaksoisnapsauta sitten Tietokantamallikaavio.

    3. Napsauta Tietokanta-välilehden Hallinta-ryhmästä Näyttöasetukset.

    4. Valitse Tietokannan asiakirjan asetukset -valintaikkunasta haluamasi merkistö sekä muut taulukko- ja yhteysasetukset ja valitse sitten OK.

    Aiemmin luodun tietokannan käyttäminen pohjana

    Jos käytettävissäsi on tietokanta, jonka haluat mallintaa ymmärtääksesi sitä paremmin tai käyttääksesi sitä uuden mallin pohjana, voit selvittää tietokannan rakenteen ohjatun lähdemääritysten selvittämisen avulla ja luoda sitten uuden mallin.

    Ennen ohjatun toiminnon käynnistämistä:

    1. Jos haluat selvittää Microsoft Excel -työkirjan määritykset, avaa työkirja ja nimeä sarakeotsikot sisältävä solualue, ennen kuin käynnistät ohjatun toiminnon. Jos haluat käyttää useampaa kuin yhtä laskentataulukkoa, nimeä kunkin laskentataulukon sarakesolualue. Ohjattu toiminto käsittelee näitä alueita taulukkoina. Lisätietoja solualueen nimeämisestä on Excelin ohjeaiheessa, jossa käsitellään nimettyjen soluviittausten tai -alueiden määrittämistä.

    2. Paras lopputulos saavutetaan määrittämällä rakenteen selvittämisen kohteena olevan tietokannan oletusohjain ennen ohjatun rakenteen selvittämisen käynnistämistä. Näin varmistetaan se, että ohjattu toiminto yhdistää alkuperäiset tietotyypit oikein ja että kaikki poimittu koodi näkyy Koodi-ikkunassa virheettömästi.

    3. Valitse Tiedosto-välilehti.

    4. Valitse Uusi, valitse Ohjelmistot ja tietokannat ja kaksoisnapsauta sitten Tietokantamallikaavio.

    5. Napsauta Tietokanta-välilehden Malli-ryhmästä Muuta lähdekoodiksi.

    6. Toimi ohjatun lähdemääritysten selvittämisen aloitusnäytössä seuraavasti:

      1. Valitse käytettävää tietokannan hallintajärjestelmää (DBMS:ää) vastaava tietokantaohjain. Jos et ole vielä määrittänyt Vision tietokantaohjainta mihinkään tiettyyn ODBC-tietolähteeseen, valitse Asetukset.

        Huomautus: Jos selvität Excel-laskentataulukon lähdemäärityksiä, valitse Yleinen ODBC-ohjain.

      2. Valitse päivitettävän tietokannan tietolähde. Jos et ole vielä luonut olemassa olevan tietokannan tietolähdettä, valitse Uusi.

        Kun luot uuden lähteen, tämän lähteen nimi lisätään Tietolähteet-luetteloon.

      3. Kun olet tehnyt haluamasi muutokset asetuksiin, valitse Seuraava.

    7. Noudata ohjaimen valintaikkunoissa näkyviä ohjeita.

      Kirjoita esimerkiksi Yhdistä tietolähteeseen -valintaikkunaan käyttäjän nimi ja salasana ja valitse sitten OK.

      Huomautus: Jos käytät yleistä ODBC-ohjainta, näyttöön saattaa tulla virhesanoma, jossa ilmoitetaan, että selvitetyt tiedot ovat ehkä epätäydellisiä. Useimmissa tapauksissa tämä ei ole ongelma, vaan voit jatkaa ohjatun toiminnon suorittamista valittuasi OK.

    8. Valitse valintaruudut sen mukaan, mitä tietoja haluat poimia ja valitse sitten Seuraava.

      Huomautus: Jotkin tiedot eivät ehkä ole käytettävissä (näkyvät harmaina), koska kaikki tietokantojen hallintajärjestelmät eivät tue kaikkia osia, jotka ohjattu toiminto voi poimia.

    9. Valitse niitä taulukoita (ja mahdollisia näkymiä) vastaavat valintaruudut, joiden lähdemääritykset haluat poimia, tai napsauta Valitse kaikki -painiketta, jolloin kaikki lähdemääritykset selvitetään. Valitse sitten Seuraava.

      Huomautus: Jos selvität Excel-laskentataulukon lähdemäärityksiä eikä tässä luettelossa näy mitään, sinun on todennäköisesti nimettävä laskentataulukkosi solualue, joka sisältää sarakeotsikot.

    10. Jos valitsit Tallennetut toimintosarjat -valintaruudun, valitse ne nyt poimittavat toimintosarjat, tai valitse Valitse kaikki, jolloin kaikkien toimintosarjojen lähdemääritykset selvitetään. Valitse sitten Seuraava.

    11. Valitse, haluatko lisätä lähdemäärityksiltään selvitetyt kohteet automaattisesti nykyiselle sivulle.

      Huomautus: Voit valita, että ohjattu toiminto luo piirustuksen automaattisesti sen lisäksi, että selvitetyt määritykset luetellaan Taulukot ja näkymät -ikkunassa. Jos valitset, että piirustusta ei luoda automaattisesti, voit koota tietokantamallin manuaalisesti vetämällä kohteet Taulukot ja näkymät -ikkunasta piirustussivulle.

    12. Tarkista tekemäsi valinnat ja varmista, että poimittavat tiedot ovat oikein, ja valitse sitten Valmis.

      Ohjattu toiminto poimii valitut tiedot ja näyttää poimintaan liittyvät huomautukset Kohde-ikkunassa.

    Tuominen ja aiemmin luodun mallin muokkaaminen

    Jos käytettävissäsi on valmis VisioModeler- tai PLATINUM ERwin -malli, voit ehkä sen tuomalla luoda Visio-tietokantamallikaavion. Tämä ominaisuus rajoittuu vain VisioModeler 2.0 -tiedostoihin ja sitä uudempiin sanastomallitiedostoihin (.imd) sekä PLATINUM ERwin 2.6:n, 3.0:n ja 3.52:n .erx-tiedostoihin.

    1. Valitse Tiedosto-välilehti.

    2. Valitse Uusi, valitse Ohjelmistot ja tietokannat ja kaksoisnapsauta sitten Tietokantamallikaavio.

    3. Napsauta Tietokanta-välilehden Malli-ryhmästä Tuo ja valitse sitten mallin tyyppi.

    4. Kirjoita tuotavan mallin polku ja tiedostonimi tai avaa mallitiedosto napsauttamalla Selaa-painiketta ja valitsemalla sitten Avaa.

    5. Valitse Tuo-valintaikkunassa OK.

      Visio tuo tiedoston ja näyttää vaiheiden edistymisen Kohde-ikkunassa. Tuodut taulukot näkyvät Taulukot ja näkymät -ikkunassa.

    6. Valitse Taulukot ja näkymät -ikkunasta malliin haluamasi taulukot ja vedä ne sitten piirustussivulle.

  2. Kun olet luonut tietokantamallikaavion, voit aloittaa kaavion yksityiskohtaisten tietojen määrittämisen. Voit lisätä ja mukauttaa taulukoita ja näkymiä, luoda yhteyksiä sekä mukauttaa sarakkeita ja tietotyyppejä.

    Taulukot

    Objektikokonaisuus-muodon avulla voit luoda kaavioon taulukon.

    1. Vedä Objektikokonaisuus-muoto Käsiterelaatio- tai Objektirelaatio-kaavaimesta piirustussivulle.

    2. Avaa Tietokannan ominaisuudet -ikkuna kaksoisnapsauttamalla muotoa.

    3. Valitse Luokat-kohdasta Määritelmä ja kirjoita taulukon nimi.

    4. Valitse Luokat-kohdasta Sarakkeet, kirjoita nimi ja valitse tietotyyppi.

    5. Valitse niiden sarakkeiden Pakollinen-valintaruutu, jotka eivät voi sisältää Null-arvoja.

    6. Valitse niiden sarakkeiden Perusavain-valintaruutu, jotka yksilöivät tietokantataulukon rivit.

    7. Voit valita valinnaisia osia valitsemalla Luokat-kohdasta Indeksit, Käynnistimet, Tarkistusmääreet tai Laajennettu.

    Sarakkeet

    Tietokannan ominaisuudet -ikkunassa voit lisätä ja muuttaa sarakkeiden ominaisuuksia, kuten tietotyypin tai perusavaimet.

    1. Kaksoisnapsauta kaavion sisältämää taulukkoa.

    2. Napsauta Tietokannan ominaisuudet -ikkunan Luokat-kohdasta Sarakkeet.

    3. Napsauta ensimmäistä tyhjää Fyysinen nimi -solua ja kirjoita nimi.

    4. Voit muuttaa sarakkeen tietotyypin napsauttamalla sarakkeen Tietotyyppi-kenttää ja valitsemalla sitten tietotyypin luettelosta tai kirjoittamalla sen luetteloon. Voit kirjoittaa esimerkiksi decimal(8,2) tai char(30).

    5. Estä Null-arvojen määrittäminen valitsemalla Pakollinen-valintaruutu.

    6. Määritä sarake perusavaimeksi valitsemalla Perusavain-valintaruutu.

    7. Voit tuoda näkyviin lisää sarakeominaisuuksia napsauttamalla Sarakkeet-luokkaa, valitsemalla sarakkeen ja valitsemalla Muokkaa.

    Yhteydet

    Tietokantojen oikeudet määrittää vastaavuuksia toisiinsa liittyvien taulukoiden rivien välille määritetään perus- ja viiteavaimien avulla. Voit tuoda näkyviin nämä yhteydet kaaviossasi. Lisäksi voit määrittää yhteyden kardinaliteetin (esimerkiksi yksi moneen -yhteys) sekä esittää yhteydet käyttämällä Kukonaskeleet-, Relaatio- ja IDEF1X-merkintöjä. Moni moneen -yhteyttä ei voi esittää tietokantamallikaaviossa näiden merkintöjen avulla.

    1. Yhteyksien luominen taulukoiden välille:

      1. Tarkista, että molemmat taulukot ovat näkyvissä kaaviossa. Jos olet luonut mallin aiemmin luodun tietokannan rakenteen selvittämällä, toinen tai kumpikin taulukko on ehkä vedettävä Taulukot ja näkymät -ikkunasta piirustussivulle.

      2. Kaksoisnapsauta sitä taulukkoa, jonka haluat määrittää yhteyden perusavainpuolelle.

      3. Napsauta Tietokannan ominaisuudet -ikkunan Luokat-kohdasta Sarakkeet.

      4. Napsauta ruudukossa saraketta, jonka haluat yksilöivän taulukon rivit, ja määritä se perusavaimeksi valitsemalla Perusavain-valintaruutu.

      5. Vedä Yhteys-muoto Objektirelaatio- tai Käsiterelaatio-kaavaimesta ja pudota se tyhjään kohtaan sivulle.

      6. Yhdistä yläreuna taulukkoon, jolla on päätaulukko.

      7. Yhdistä toinen reuna alitaulukkoon.

        Jos toinen taulukko ei vielä sisällä samannimistä saraketta kuin perusavain, mallinnustoiminto lisää sellaisen toiseen taulukkoon viiteavaimeksi.

        Huomautus: Jos yhteysviivat katoavat näkyvistä, valitse Tietokanta-välilehden Hallitse-ryhmästä Näyttöasetukset. Valitse Yhteydet-välilehden Näytä-kohdan Yhteydet-valintaruutu.

    2. Yhteyksien kardinaliteetin määrittäminen:

      1. Kaksoisnapsauta yhteyttä.

      2. Valitse Tietokannan ominaisuudet -ikkunan Luokat-luettelosta Muut.

      3. Valitse Kardinaliteetti-kohdasta yhteyttä parhaiten kuvaava kardinaliteetti. Yksi moneen -yhteyksille paras vaihtoehto on Nolla tai enemmän tai Yksi tai enemmän. Yksi yhteen -yhteyksille paras vaihtoehto on Nolla tai yksi tai Täsmälleen yksi.

  3. Voit tehdä kaavioon muita muutoksia (esimerkiksi luoda indeksejä, tarkistusmääreitä ja käynnistimiä) toimimalla seuraavasti:

    Indeksien luominen

    Indeksit parantavat tietokannan suorituskykyä, eli nopeutta, kyselyitä suoritettaessa.

    1. Avaa tietokantamallikaavio.

    2. Aloita kaksoisnapsauttamalla taulukkoa, johon haluat lisätä indeksin. Valitse sitten Tietokannan ominaisuudet -ikkunan Luokat-luettelosta Indeksit.

    3. Valitse Uusi.

    4. Kirjoita Indeksin luominen -valintaikkunaan indeksin nimi ja valitse sitten OK.

    5. Valitse Indeksityyppi-luettelosta yksilöivä tai ei-yksilöivä indeksi sen mukaan, kumman haluat luoda.

    6. Valitse Käytettävissä olevat sarakkeet -luettelosta niiden sarakkeiden nimet, jotka haluat sisällyttää tähän indeksiin, ja valitse sitten Lisää >.

    7. Luo nousevaa lajittelujärjestystä käyttävä indeksi valitsemalla Indeksoidut sarakkeet -luettelosta Nouseva-valintaruutu. Valintaruudun valinnan poistaminen muuttaa indeksin lajittelujärjestyksen laskevaksi.

      Tietokantamallikaavio päivittyy.

    Näkymien luominen

    Voit ajatella näkymää tallennettuna kyselynä. Näkymät ovat erityisen käteviä silloin, kun samoja tietoja on käytettävä useasta taulukosta toistuvasti tai kun haluat näyttää tiedot käyttäjille, mutta et halua sallia taulukoiden muokkaamista.

    Vedä Näkymä-muoto Käsiterelaatio- tai Objektirelaatio-kaavaimesta piirustussivulle.

    Laajennettujen ominaisuuksien määrittäminen taulukot ja näkymät

    Sen mukaan, mitä tietokantojen hallintajärjestelmää käytät, voit ehkä määrittää taulukoiden ja näkymien tallennuspaikan määrittämällä niiden laajennettuja ominaisuuksia.

    Aloita kaksoisnapsauttamalla taulukkoa tai näkymää, jonka laajennettujen ominaisuuksien asetukset haluat määrittää, ja valitse sitten Tietokannan ominaisuudet -ikkunan Luokat-luettelosta Laajennettu.

    Tarkistusmääreiden luominen

    Tarkistusmääreiden avulla voit tarkistaa, että sarakkeeseen lisätyt tiedot sijoittuvat tietylle arvoalueelle. Voit esimerkiksi luoda sellaisen tarkistusmääreen, joka edellyttää, että Ikä-nimisen sarakkeeseen ei kirjoiteta lukua 65 pienempiä arvoja.

    1. Avaa Tietokannan ominaisuudet -ikkuna kaksoisnapsauttamalla taulukkoa.

    2. Valitse Luokat-kohdasta Sarakkeet ja napsauta saraketta, johon haluat lisätä tarkistusmääreen.

    3. Valitse Muokkaa.

    4. Kirjoita haluamasi rajoitukset Sarakkeen ominaisuudet -valintaikkunan Tarkistus-välilehteen.

      Tarkistusmääre lisätään Koodi-ikkunaan Paikallinen koodi -kohtaan.

    Luo tallennettujen toimintosarjojen ja käyttäjän määrittämät funktiot

    Tallennettujen toimintosarjojen ja käyttäjän määrittämien funktioiden avulla voit luoda koodipaketteja, joiden avulla voit suorittaa samoja toimintoja toistuvasti. Nämä kaksi eroavat toisistaan siinä, että käyttäjän määrittämät funktiot palauttavat arvon, kun taas tallennetut toimintosarjat suorittavat koodin, mutta eivät palauta arvoa.

    1. Avaa Koodi-ikkuna valitsemalla Tietokanta-välilehden Näyttäminen tai piilottaminen -ryhmästä Koodi-valintaruutu.

    2. Valitse Yleinen koodi ja valitse Uusi.

    3. Valitse Koodieditori-ikkunan Ominaisuudet-välilehdestä luotavan koodin tyyppi ja kirjoita koodin nimi.

    4. Kirjoita Runko-välilehteen koodi ja valitse OK.

    Käynnistimien luominen

    Käynnistimen avulla voit määrittää, että käynnistimeen määrittämäsi SQL-koodi suoritetaan, kun tietty tapahtuma suoritetaan tietokannassa.

    1. Avaa Tietokannan ominaisuudet -ikkuna kaksoisnapsauttamalla taulukkoa.

    2. Valitse Luokat-kohdasta Käynnistimet ja valitse Lisää.

    3. Kirjoita Ominaisuudet-välilehteen käynnistimen nimi.

    4. Kirjoita Runko-välilehteen koodi ja valitse OK.

      Käynnistin lisätään Koodi-ikkunaan Paikallinen koodi -kohtaan.

Tässä artikkelissa kuvataan, kuinka voit luoda tietokantamallin ja mihin voit sitä käyttää. Pääset nopeimmin alkuun, kun valitset Tiedosto -valikosta Uusi, valitset Ohjelmistot ja tietokannat ja valitset sitten Tietokantamallikaavio.

Etkö löydä tietokannan mallin ominaisuuksia?

Todennäköisin syy on se, että käyttämäsi Microsoft Office Vision versio ei sisällä etsimiäsi ominaisuuksia. Voit selvittää oman Visio-ohjelmasi versiotiedot valitsemalla Ohje-valikosta Tietoja Microsoft Office Visiosta. Version nimi näkyy valintaikkunan ensimmäisellä rivillä.

  • Microsoft Office Visio Standard ei sisällä Tietokantamallikaavio-mallia.

  • Microsoft Office Visio Professional tukee Tietokantamallikaavio-mallin lähdekoodin selvittämisominaisuuksia (eli mallin luomista Visiossa aiemmin luodun tietokannan pohjalta), mutta ei tue koodin uustuotantoa (eli SQL-koodin luomista Visio-tietokantamallin pohjalta).

  • Täydet tietokantamallinnusominaisuudet, sekä lähdekoodin selvittämisominaisuudet että koodin uustuotanto-ominaisuudet, sisältyvät Visio for Enterprise Architects -versioon. Visio for Enterprise Architects sisältyy MSDN Premium Subscription -tilaukseen, joka puolestaan sisältyy Visual Studio Professionalin ja Visual Studio Team Systemin roolipohjaisiin versioihin.

  1. Aloita tietokantamallin laatiminen jollakin seuraavista tavoista:

    Uuden mallikaavion luominen alusta alkaen

    Jos käytettävissäsi ei ole aiemmin luotua tietokantaa, jota haluat käyttää pohjana, voit aloittaa tyhjästä tietokantamallista ja lisätä siihen taulukoita ja yhteyksiä itse.

    1. Valitse Tiedosto-valikosta Uusi Ohjelmistot ja tietokannat ja valitse sitten Tietokantamallikaavio.

    2. Valitse Tietokanta-valikosta Asetukset ja sitten Asiakirja.

    3. Valitse Tietokannan asiakirjan asetukset -valintaikkunasta haluamasi merkistö sekä muut taulukko- ja yhteysasetukset ja valitse sitten OK.

    Aiemmin luodun tietokannan käyttäminen pohjana

    Jos käytettävissäsi on tietokanta, jonka haluat mallintaa ymmärtääksesi sitä paremmin tai käyttääksesi sitä uuden mallin pohjana, voit selvittää tietokannan rakenteen ohjatun lähdemääritysten selvittämisen avulla ja luoda sitten uuden mallin.

    Huomautus: Ennen ohjatun toiminnon käynnistämistä:

    1. Jos haluat selvittää Microsoft Office Excel -työkirjan lähdemääritykset, avaa työkirja ja nimeä sarakeotsikot sisältävä solualue, ennen kuin käynnistät ohjatun toiminnon. Jos haluat käyttää useampaa kuin yhtä laskentataulukkoa, nimeä kunkin laskentataulukon sarakesolualue. Ohjattu toiminto käsittelee näitä alueita taulukkoina. Lisätietoja solualueen nimeämisestä on Microsoft Office Excelin ohjeaiheessa, jossa käsitellään nimettyjen soluviittausten tai -alueiden määrittämistä.

    2. Paras lopputulos saavutetaan määrittämällä rakenteen selvittämisen kohteena olevan tietokannan oletusohjain ennen ohjatun rakenteen selvittämisen käynnistämistä. Näin varmistetaan se, että ohjattu toiminto yhdistää alkuperäiset tietotyypit oikein ja että kaikki poimittu koodi näkyy Koodi-ikkunassa virheettömästi.

    3. Valitse Tiedosto-valikosta Uusi Ohjelmistot ja tietokannat ja valitse sitten Tietokantamallikaavio.

    4. Valitse Tietokanta-valikosta Muuta lähdekoodiksi.

    5. Toimi ohjatun lähdemääritysten selvittämisen aloitusnäytössä seuraavasti:

      1. Valitse käytettävää tietokannan hallintajärjestelmää (DBMS:ää) vastaava Microsoft Office Vision tietokantaohjain. Jos et ole vielä määrittänyt Vision tietokantaohjainta mihinkään tiettyyn ODBC-tietolähteeseen, valitse Asetukset.

        Huomautus: Jos selvität Excel-laskentataulukon lähdemäärityksiä, valitse Yleinen ODBC-ohjain.

      2. Valitse päivitettävän tietokannan tietolähde. Jos et ole vielä luonut olemassa olevan tietokannan tietolähdettä, valitse Uusi.

        Kun luot uuden lähteen, tämän lähteen nimi lisätään Tietolähteet-luetteloon.

      3. Kun olet tehnyt haluamasi muutokset asetuksiin, valitse Seuraava.

    6. Noudata ohjaimen valintaikkunoissa näkyviä ohjeita.

      Kirjoita esimerkiksi Yhdistä tietolähde -valintaikkunaan käyttäjän nimi ja salasana ja valitse sitten OK. Jos tietolähdettä ei ole suojattu salasanalla, valitse OK.

      Huomautus: Jos käytät yleistä ODBC-ohjainta, näyttöön saattaa tulla virhesanoma, jossa ilmoitetaan, että selvitetyt tiedot ovat ehkä epätäydellisiä. Useimmissa tapauksissa tämä ei ole ongelma, vaan voit jatkaa ohjatun toiminnon suorittamista valittuasi OK.

    7. Valitse valintaruudut sen mukaan, mitä tietoja haluat poimia ja valitse sitten Seuraava.

      Huomautus: Jotkin tiedot eivät ehkä ole käytettävissä (näkyvät harmaina), koska kaikki tietokantojen hallintajärjestelmät eivät tue kaikkia osia, jotka ohjattu toiminto voi poimia.

    8. Valitse niitä taulukoita (ja mahdollisia näkymiä) vastaavat valintaruudut, joiden lähdemääritykset haluat poimia, tai napsauta Valitse kaikki -painiketta, jolloin kaikki lähdemääritykset selvitetään. Valitse sitten Seuraava.

      Huomautus: Jos selvität Excel-laskentataulukon lähdemäärityksiä eikä tässä luettelossa näy mitään, sinun on todennäköisesti nimettävä laskentataulukkosi solualue, joka sisältää sarakeotsikot.

    9. Jos valitsit kohdassa 5 Tallennetut toimintosarjat -valintaruudun, valitse ne nyt poimittavat toimintosarjat, tai valitse Valitse kaikki, jolloin kaikkien toimintosarjojen lähdemääritykset selvitetään. Valitse sitten Seuraava.

    10. Valitse, haluatko lisätä lähdemäärityksiltään selvitetyt kohteet automaattisesti nykyiselle sivulle.

      Huomautus: Voit valita, että ohjattu toiminto luo piirustuksen automaattisesti sen lisäksi, että selvitetyt määritykset luetellaan Taulukot ja näkymät -ikkunassa. Jos valitset, että piirustusta ei luoda automaattisesti, voit koota tietokantamallin manuaalisesti vetämällä kohteet Taulukot ja näkymät -ikkunasta piirustussivulle.

    11. Tarkista tekemäsi valinnat ja varmista, että poimittavat tiedot ovat oikein, ja valitse sitten Valmis.

      Ohjattu toiminto poimii valitut tiedot ja näyttää poimintaan liittyvät huomautukset Kohde-ikkunassa.

    Tuominen ja aiemmin luodun mallin muokkaaminen

    Jos käytettävissäsi on valmis VisioModeler- tai PLATINUM ERwin -malli, voit ehkä sen tuomalla luoda Visio-tietokantamallikaavion. Tämä ominaisuus rajoittuu vain VisioModeler 2.0 -tiedostoihin ja sitä uudempiin sanastomallitiedostoihin (.imd) sekä PLATINUM ERwin 2.6:n, 3.0:n ja 3.52:n .erx-tiedostoihin.

    1. Valitse Tiedosto-valikosta Uusi Ohjelmistot ja tietokannat ja valitse sitten Tietokantamallikaavio.

    2. Valitse Tietokanta-valikosta Tuo ja sitten Tuo <mallityyppi> -tiedosto.

    3. Kirjoita tuotavan mallin polku ja tiedostonimi tai avaa mallitiedosto napsauttamalla Selaa-painiketta ja valitsemalla sitten Avaa.

    4. Valitse Tuo-valintaikkunassa OK.

      Visio tuo tiedoston ja näyttää vaiheiden edistymisen Kohde-ikkunassa. Tuodut taulukot näkyvät Taulukot ja näkymät -ikkunassa.

    5. Valitse Taulukot ja näkymät -ikkunasta malliin haluamasi taulukot ja vedä ne sitten piirustussivulle.

  2. Kun olet luonut tietokantamallikaavion, voit aloittaa kaavion yksityiskohtaisten tietojen määrittämisen. Voit lisätä ja mukauttaa taulukoita ja näkymiä, luoda yhteyksiä sekä mukauttaa sarakkeita ja tietotyyppejä.

    Taulukot

    Objektikokonaisuus-muodon avulla voit luoda kaavioon taulukon.

    1. Vedä Objektikokonaisuus-muoto Käsiterelaatio- tai Objektirelaatio-kaavaimesta piirustussivulle.

    2. Avaa Tietokannan ominaisuudet -ikkuna kaksoisnapsauttamalla muotoa.

    3. Valitse Luokat-kohdasta Määritelmä ja kirjoita taulukon nimi.

    4. Valitse Luokat-kohdasta Sarakkeet, kirjoita nimi ja valitse tietotyyppi.

    5. Valitse niiden sarakkeiden Pakollinen-valintaruutu, jotka eivät voi sisältää Null-arvoja.

    6. Valitse niiden sarakkeiden Perusavain-valintaruutu, jotka yksilöivät tietokantataulukon rivit.

    7. Voit valita valinnaisia osia valitsemalla Luokat-kohdasta Indeksit, Käynnistimet, Tarkistusmääreet tai Laajennettu.

    Sarakkeet

    Tietokannan ominaisuudet -ikkunassa voit lisätä ja muuttaa sarakkeiden ominaisuuksia, kuten tietotyypin tai perusavaimet.

    1. Kaksoisnapsauta kaavion sisältämää taulukkoa.

    2. Valitse Tietokannan ominaisuudet -ikkunan Luokat-kohdasta Sarakkeet.

    3. Napsauta ensimmäistä tyhjää Fyysinen nimi -solua ja kirjoita nimi.

    4. Voit muuttaa sarakkeen tietotyypin napsauttamalla sarakkeen Tietotyyppi-kenttää ja valitsemalla sitten tietotyypin luettelosta tai kirjoittamalla sen luetteloon. Voit kirjoittaa esimerkiksi decimal(8,2) tai char(30).

    5. Estä Null-arvojen määrittäminen valitsemalla Pakollinen-valintaruutu.

    6. Määritä sarake perusavaimeksi valitsemalla Perusavain-valintaruutu.

    7. Voit tuoda näkyviin lisää sarakeominaisuuksia napsauttamalla Sarakkeet-luokkaa, valitsemalla sarakkeen ja valitsemalla Muokkaa.

    Yhteydet

    Tietokantojen oikeudet määrittää vastaavuuksia toisiinsa liittyvien taulukoiden rivien välille määritetään perus- ja viiteavaimien avulla. Voit tuoda näkyviin nämä yhteydet kaaviossasi. Lisäksi voit määrittää yhteyden kardinaliteetin (esimerkiksi yksi moneen -yhteys) sekä esittää yhteydet käyttämällä Kukonaskeleet-, Relaatio- ja IDEF1X-merkintöjä. Moni moneen -yhteyttä ei voi esittää tietokantamallikaaviossa näiden merkintöjen avulla.

    1. Yhteyksien luominen taulukoiden välille:

      1. Tarkista, että molemmat taulukot ovat näkyvissä kaaviossa. Jos olet luonut mallin aiemmin luodun tietokannan rakenteen selvittämällä, toinen tai kumpikin taulukko on ehkä vedettävä Taulukot ja näkymät -ikkunasta piirustussivulle.

      2. Kaksoisnapsauta sitä taulukkoa, jonka haluat määrittää yhteyden perusavainpuolelle.

      3. Valitse Tietokannan ominaisuudet -ikkunan Luokat-kohdasta Sarakkeet.

      4. Napsauta ruudukossa saraketta, jonka haluat yksilöivän taulukon rivit, ja määritä se perusavaimeksi valitsemalla Perusavain-valintaruutu.

      5. Vedä Yhteys-muoto Objektirelaatio- tai Käsiterelaatio-kaavaimesta ja pudota se tyhjään kohtaan sivulle.

      6. Yhdistä yläreuna taulukkoon, jolla on päätaulukko.

      7. Yhdistä toinen reuna alitaulukkoon.

        Jos toinen taulukko ei vielä sisällä samannimistä saraketta kuin perusavain, mallinnustoiminto lisää sellaisen toiseen taulukkoon viiteavaimeksi.

        Huomautus: Jos yhteysviivat katoavat näkyvistä, valitse Tietokanta-valikosta Asetukset ja valitse sitten Asiakirja. Valitse Yhteydet-välilehden Näytä-kohdasta Yhteydet-valintaruutu.

    2. Yhteyksien kardinaliteetin määrittäminen:

      1. Kaksoisnapsauta yhteyttä.

      2. Valitse Tietokannan ominaisuudet -ikkunan Luokat-kohdasta Muut.

      3. Valitse Kardinaliteetti-kohdasta yhteyttä parhaiten kuvaava kardinaliteetti. Yksi moneen -yhteyksille paras vaihtoehto on Nolla tai enemmän tai Yksi tai enemmän. Yksi yhteen -yhteyksille paras vaihtoehto on Nolla tai yksi tai Täsmälleen yksi.

  3. Voit tehdä kaavioon muita muutoksia (esimerkiksi luoda indeksejä, tarkistusmääreitä ja käynnistimiä) toimimalla seuraavasti:

    Indeksien luominen

    Indeksit parantavat tietokannan suorituskykyä, eli nopeutta, kyselyitä suoritettaessa.

    1. Avaa tietokantamallikaavio.

    2. Aloita kaksoisnapsauttamalla taulukkoa, johon haluat lisätä indeksin. Valitse sitten Tietokannan ominaisuudet -ikkunan Luokat-luettelosta Indeksit.

    3. Valitse Uusi.

    4. Kirjoita Indeksin luominen -valintaikkunaan indeksin nimi ja valitse sitten OK.

    5. Valitse Indeksityyppi-luettelosta yksilöivä tai ei-yksilöivä indeksi sen mukaan, kumman haluat luoda.

    6. Valitse Käytettävissä olevat sarakkeet -luettelosta niiden sarakkeiden nimet, jotka haluat sisällyttää tähän indeksiin, ja valitse sitten Lisää >.

    7. Luo nousevaa lajittelujärjestystä käyttävä indeksi valitsemalla Indeksoidut sarakkeet -luettelosta Nouseva-valintaruutu. Valintaruudun valinnan poistaminen muuttaa indeksin lajittelujärjestyksen laskevaksi.

      Tietokantamallikaavio päivittyy.

    Näkymien luominen

    Voit ajatella näkymää tallennettuna kyselynä. Näkymät ovat erityisen käteviä silloin, kun samoja tietoja on käytettävä useasta taulukosta toistuvasti tai kun haluat näyttää tiedot käyttäjille, mutta et halua sallia taulukoiden muokkaamista.

    Vedä Näkymä-muoto Käsiterelaatio- tai Objektirelaatio-kaavaimesta piirustussivulle.

    Laajennettujen ominaisuuksien määrittäminen taulukot ja näkymät

    Sen mukaan, mitä tietokantojen hallintajärjestelmää käytät, voit ehkä määrittää taulukoiden ja näkymien tallennuspaikan määrittämällä niiden laajennettuja ominaisuuksia.

    Aloita kaksoisnapsauttamalla taulukkoa, jonka laajennettujen ominaisuuksien asetukset haluat määrittää ja valitse sitten Tietokannan ominaisuudet -ikkunan Luokat-luettelosta Laajennettu.

    Tarkistusmääreiden luominen

    Tarkistusmääreiden avulla voit tarkistaa, että sarakkeeseen lisätyt tiedot sijoittuvat tietylle arvoalueelle. Voit esimerkiksi luoda sellaisen tarkistusmääreen, joka edellyttää, että Ikä-nimisen sarakkeeseen ei kirjoiteta lukua 65 pienempiä arvoja.

    1. Avaa Tietokannan ominaisuudet -ikkuna kaksoisnapsauttamalla taulukkoa.

    2. Valitse Luokat-kohdasta Sarakkeet ja napsauta saraketta, johon haluat lisätä tarkistusmääreen.

    3. Valitse Muokkaa.

    4. Kirjoita Sarakkeen ominaisuudet -valintaikkunassa Tarkista -välilehdessä haluamasi rajoitukset. Saat lisätietoja valintasi sarakkeen ja kenttäominaisuudet-valintaikkuna (Tarkista-välilehti).

      Tarkistusmääre lisätään Koodi-ikkunaan Paikallinen koodi -kohtaan.

    Luo tallennettujen toimintosarjojen ja käyttäjän määrittämät funktiot

    Tallennettujen toimintosarjojen ja käyttäjän määrittämien funktioiden avulla voit luoda koodipaketteja, joiden avulla voit suorittaa samoja toimintoja toistuvasti. Nämä kaksi eroavat toisistaan siinä, että käyttäjän määrittämät funktiot palauttavat arvon, kun taas tallennetut toimintosarjat suorittavat koodin, mutta eivät palauta arvoa.

    1. Avaa Koodi-ikkuna valitsemalla Tietokanta-valikosta Näytä ja valitse sitten Koodi.

    2. Valitse Yleinen koodi ja valitse Uusi.

    3. Valitse Koodieditori-ikkunan Ominaisuudet-välilehdestä luotavan koodin tyyppi ja kirjoita koodin nimi.

    4. Kirjoita Runko-välilehteen koodi ja valitse OK.

    Käynnistimien luominen

    Käynnistimen avulla voit määrittää, että käynnistimeen määrittämäsi SQL-koodi suoritetaan, kun tietty tapahtuma suoritetaan tietokannassa.

    1. Avaa Tietokannan ominaisuudet -ikkuna kaksoisnapsauttamalla taulukkoa.

    2. Valitse Luokat-kohdasta Käynnistimet ja valitse Lisää.

    3. Kirjoita Ominaisuudet-välilehteen käynnistimen nimi.

    4. Kirjoita Runko-välilehteen koodi ja valitse OK.

      Käynnistin lisätään Koodi-ikkunaan Paikallinen koodi -kohtaan.

Huomautus: Konekäännöksestä ilmoittava vastuusvapauslauseke: Tämä artikkeli on käännetty tietokonejärjestelmällä, eikä kieliasiantuntija ole muokannut sitä. Microsoft tarjoaa nämä konekäännökset avuksi muille kuin englantia puhuville käyttäjille, jotta he saavat lisätietoja Microsoftin tuotteista, palveluista ja tekniikoista. Koska artikkeli on koneellisesti käännetty, se saattaa sisältää sanasto-, lauseoppi- ja kielioppivirheitä.

Kehitä taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×