Tietojen linkittäminen tai upottaminen Office for Mac

Tärkeää: Tämä on artikkeli on käännetty koneellisesti. Lue vastuuvapauslauseke. Tämän artikkelin englanninkielinen versio on täällä .

Voit jakaa tietoja Office-sovellusten välillä monella tavalla. Yksi keino on kopioiminen ja sijoittaminen, mutta voit myös linkittää tietoja, jolloin ne päivitetään automaattisesti, tai upottaa tietoja, jolloin ne pitää päivittää manuaalisesti, kun avaat tiedoston. Lisäksi voit linkittää osan tiedostosta, esimerkiksi muutaman solun Excel-taulukosta, luomalla linkitetyn objektin.

Linkittämisen ja upottamisen hyödyt ja haitat

Linkittäminen

Upottaminen

Tiedot päivitetään automaattisesti.

Sovellus, jossa upotetut tiedot luotiin, on helppo avata.

Tiedoston koko pysyy pienenä.

Tiedoston koko on suurempi kuin linkitettyjä tietoja sisältävän tiedoston.

Molempien tiedostojen on oltava käytettävissä, jotta tietoja voi tarkastella.

Molempien tiedostojen on oltava käytettävissä tietojen päivittämistä varten, mutta tietoja voi silti tarkastella.

Ei sovellu tiedoston jakamiseen verkossa.

Sopii tiedoston jakamiseen verkossa, koska kaikki tiedot ovat yhdessä tiedostossa.

Word

Jos sinulla on toisiinsa liittyviä tietoja Excel- ja Word-tiedostossa, voit linkittää tiedot, jolloin niiden päivittäminen on helppoa. Voit esimerkiksi linkittää viimeisimmät myyntiluvut kuukauden tilanneraporttiin. Tilanneraportti on Word-asiakirja ja myyntiluvut on kirjattu Excel-taulukkoon. Kun linkität asiakirjan laskentataulukkoon, tilanneraportti päivittyy automaattisesti, kun myyntilukuja päivitetään. Voit myös linkittää Word-asiakirjassa olevat ohjeet useaan Excel-tiedostoon. Kun päivität linkitettyjä ohjeita, päivitykset näkyvät kaikissa Excel-tiedostoissa.

  1. Valitse kohta, johon haluat lisätä linkin.

  2. Valitse Lisää-valikossa Objekti ja valitse sitten Tiedostosta.

  3. Etsi ja valitse tiedosto, jonka haluat linkittää ja valitse sitten asetukset.

  4. Valitse Linkitä tiedostoon -valintaruutu

    Vihje: Jos haluat näyttää valitussa kohdassa vain kuvakkeen, jota osoittamalla tiedot tulevat näkyviin, valitse Näytä kuvakkeena -valintaruutu.

  5. Valitse Lisää , jos käytössäsi on Word tai valitse OK , jos käytössäsi on Excelin.

  1. Valitse Muokkaa-valikossa Linkit.

    Jos Linkit-komento ei ole käytettävissä, tiedostossa ei ole linkitettyjä tietoja.

  2. Valitse linkitetty tiedosto Lähdetiedosto-kohdassa ja valitse sitten Avaa lähde.

  3. Tee haluamasi muutokset.

  4. Tallenna muutokset valitsemalla Tiedosto-valikossa Tallenna, ja sulje sitten sovellus.

    Huomaat, että muutokset näkyvät linkin sisältävässä tiedostossa.

Jos haluat säilyttää kahden tiedoston välisen yhteyden, mutta et halua, että päätiedosto päivittyy kun toista tiedostoa muutetaan, voit upottaa tiedot. Tietojen upottaminen on käytännöllistä esimerkiksi silloin, kun et halua, että tilanneraportti päivittyy, kun Excel-taulukkoa muutetaan, tai kun et halua, että Excel-taulukkoa muutetaan, kun ohjeet muuttuvat. Koska kaikki tiedot sisältyvät yhteen tiedostoon, upottamisesta on hyötyä, kun haluat jakaa tiedoston verkossa henkilöille, joilla ei ole upotetun tiedoston käyttöoikeutta.

  1. Valitse kohta, johon haluat upottaa tiedoston.

  2. Valitse Lisää-valikossa Objekti ja valitse sitten Tiedostosta.

  3. Valitse poistettava tiedosto ja valitse sitten asetukset.

    Jos upotat Excel-taulukon, sen on oltava työkirjan ensimmäinen laskentataulukko.

  4. Poista Linkitä tiedostoon -valintaruudun valinta.

    Vihje: Jos haluat näyttää valitussa kohdassa vain kuvakkeen, jota osoittamalla tiedot tulevat näkyviin, valitse Näytä kuvakkeena -valintaruutu.

  5. Valitse Lisää , jos käytössäsi on Word tai valitse OK , jos käytössäsi on Excelin.

  1. Kaksoisnapsauta upotettua objektia.

  2. Tee haluamasi muutokset ja tallenna ne.

  3. Valitse Tiedosto-valikossa Sulje ja palaa: [tiedoston nimi].

    Huomaat, että muutokset näkyvät upotetussa tiedostossa.

Voit linkittää tiedoston osa. Esimerkiksi kuukausiraportti, ehkä haluat luoda linkin tiettyyn solualueeseen sen sijaan, että koko taulukko Excel-laskentataulukossa. Haluat esimerkiksi linkittäminen tarkemmat ohjeet sen sijaan, että koko asiakirjan Word-asiakirjasta.

  1. Valitse tiedot, jotka haluat sijoittaa (esimerkiksi solualue Excel-taulukosta).

  2. Valitse Muokkaa-valikossa Kopioi.

  3. Siirry toiseen tiedostoon ja valitse kohta, johon haluat sijoittaa linkitetyt tiedot.

  4. Valitse Muokkaa-valikossa Sijoita määräten ja valitse sitten Sijoita linkki.

  5. Valitse Liitetään-ruudussa objektin tyyppi, esimerkiksi Microsoft Excel -taulukko-objekti, ja valitse sitten OK.

PowerPoint

Jos haluat säilyttää kahden tiedoston välisen yhteyden, mutta et halua, että päätiedosto päivittyy kun toista tiedostoa muutetaan, voit upottaa tiedot. Voit esimerkiksi upottaa viimeisimmät myyntiluvut kuukauden tilanneraporttiin. Tilanneraportti on PowerPoint-esitys ja myyntiluvut on kirjattu Excel-taulukkoon. Laskentataulukon upottaminen esitykseen muodostaa yhteyden tiedostojen välille.

  1. Valitse kohta, johon haluat upottaa tiedoston.

  2. Lisää -valikosta objektija valitse sitten tiedostosta.

  3. Etsi ja valitse tiedosto, jonka haluat upottaa.

    Jos upotat Excel-taulukon, sen on oltava työkirjan ensimmäinen laskentataulukko.

  4. Valitse Lisää ja valitse sitten OK.

    Jos et näe upotetun tiedoston tietoja, vedä koonmuuttokahvaa, kunnes tiedoston sisältö on näkyvissä.

  1. Kaksoisnapsauta upotettu tiedosto.

  2. Tee haluamasi muutokset.

  3. Valitse Tiedostoja valitse sitten Päivitä.

  4. Valitse Tiedosto-valikossa Sulje ja palaa: [tiedoston nimi].

    Huomaat, että muutokset näkyvät upotetussa tiedostossa.

Voit upottaa myös osan tiedostosta. Saatat esimerkiksi haluta upottaa tietyn solualueen Excel-taulukosta koko laskentataulukon upottamisen sijaan.

  1. Valitse tiedot, jotka haluat sijoittaa (esimerkiksi solualue Excel-taulukosta).

  2. Valitse Muokkaa-valikossa Kopioi.

  3. Siirry toiseen tiedostoon ja valitse kohta, johon haluat sijoittaa linkitetyt tiedot.

  4. Valitse Muokkaa-valikosta Sijoita määräten.

  5. Valitse Sijoita muodossa -ruudussa objektin tyyppi, esimerkiksi Microsoft Excel -taulukko-objekti, ja valitse sitten OK.

Excel

Jos sinulla on toisiinsa liittyviä tietoja Excel- ja Word-tiedostossa, voit linkittää tiedot, jolloin niiden päivittäminen on helppoa. Voit esimerkiksi linkittää viimeisimmät myyntiluvut kuukauden tilanneraporttiin. Tilanneraportti on Word-asiakirja ja myyntiluvut on kirjattu Excel-taulukkoon. Kun linkität asiakirjan laskentataulukkoon, tilanneraportti päivittyy automaattisesti, kun myyntilukuja päivitetään. Voit myös linkittää Word-asiakirjassa olevat ohjeet useaan Excel-tiedostoon. Kun päivität linkitettyjä ohjeita, päivitykset näkyvät kaikissa Excel-tiedostoissa.

  1. Valitse kohta, johon haluat lisätä linkin.

  2. Valitse Lisää-valikossa Objekti ja valitse sitten Tiedostosta.

  3. Valitse tiedosto, jonka haluat linkittää ja valitse sitten asetukset.

  4. Valitse Linkitä tiedostoon -valintaruutu

    Vihje: Jos haluat näyttää valitussa kohdassa vain kuvakkeen, jota osoittamalla tiedot tulevat näkyviin, valitse Näytä kuvakkeena -valintaruutu.

  5. Valitse Lisää , jos käytössäsi on Word tai valitse OK , jos käytössäsi on Excelin.

  1. Valitse tiedot -valikko Valitse Muokkaa linkkejä.

    Jos Muokkaa linkkejä -komento ei ole käytettävissä, tiedostossa ei ole linkitettyjä tietoja.

  2. Valitse linkitetty tiedosto Lähdetiedosto-kohdassa ja valitse sitten Avaa lähde.

  3. Tee haluamasi muutokset.

  4. Tallenna muutokset valitsemalla Tiedosto-valikossa Tallenna, ja sulje sitten sovellus.

  5. Valitse linkitetty tiedosto. Huomaa, että tiedosto sisältää muutokset.

Jos haluat säilyttää kahden tiedoston välisen yhteyden, mutta et halua, että päätiedosto päivittyy kun toista tiedostoa muutetaan, voit upottaa tiedot. Tietojen upottaminen on käytännöllistä esimerkiksi silloin, kun et halua, että tilanneraportti päivittyy, kun Excel-taulukkoa muutetaan, tai kun et halua, että Excel-taulukkoa muutetaan, kun ohjeet muuttuvat. Koska kaikki tiedot sisältyvät yhteen tiedostoon, upottamisesta on hyötyä, kun haluat jakaa tiedoston verkossa henkilöille, joilla ei ole upotetun tiedoston käyttöoikeutta.

  1. Valitse kohta, johon haluat upottaa tiedoston.

  2. Valitse Lisää-valikossa Objekti ja valitse sitten Tiedostosta.

  3. Valitse tiedosto, jonka haluat upottaa, ja valitse sitten asetukset.

    Jos upotat Excel-taulukon, sen on oltava työkirjan ensimmäinen laskentataulukko.

    Vihje: Jos haluat näyttää valitussa kohdassa vain kuvakkeen, jota osoittamalla tiedot tulevat näkyviin, valitse Näytä kuvakkeena -valintaruutu.

  4. Poista Linkitä tiedostoon -valintaruudun valinta ja valitse sitten Wordissa Lisää tai Excelissä OK.

  1. Kaksoisnapsauta upotettu tiedosto.

  2. Tee haluamasi muutokset.

  3. Valitse Tiedosto -valikosta valitsemalla Päivitä.

    Huomaat, että muutokset näkyvät upotetussa tiedostossa.

Voit muodostaa linkin tiettyyn tiedoston osaan. Saatat esimerkiksi haluta linkittää tietyn solualueen Excel-taulukosta koko laskentataulukon sijaan.

  1. Valitse tiedot, jotka haluat sijoittaa (esimerkiksi muutama virke Word-asiakirjasta).

  2. Valitse Muokkaa-valikossa Kopioi.

  3. Siirry toiseen tiedostoon ja valitse kohta, johon haluat sijoittaa linkitetyt tiedot.

  4. Valitse Muokkaa-valikossa Sijoita määräten ja valitse sitten Sijoita linkki.

  5. Valitse Liitetään-ruudussa objektin tyyppi, esimerkiksi Microsoft Word -asiakirjaobjekti, ja valitse sitten OK.

Word

Jos sinulla on toisiinsa liittyviä tietoja Excel- ja Word-tiedostossa, voit linkittää tiedot, jolloin niiden päivittäminen on helppoa. Voit esimerkiksi linkittää viimeisimmät myyntiluvut kuukauden tilanneraporttiin. Tilanneraportti on Word-asiakirja ja myyntiluvut on kirjattu Excel-taulukkoon. Kun linkität asiakirjan laskentataulukkoon, tilanneraportti päivittyy automaattisesti, kun myyntilukuja päivitetään. Voit myös linkittää Word-asiakirjassa olevat ohjeet useaan Excel-tiedostoon. Kun päivität linkitettyjä ohjeita, päivitykset näkyvät kaikissa Excel-tiedostoissa.

  1. Valitse kohta, johon haluat lisätä linkin.

  2. Valitse Lisää-valikossa Objekti ja valitse sitten Tiedostosta.

  3. Etsi ja valitse tiedosto, johon haluat muodostaa linkin.

    Vihje: Jos haluat näyttää valitussa kohdassa vain kuvakkeen, jota osoittamalla tiedot tulevat näkyviin, valitse Näytä kuvakkeena -valintaruutu.

  4. Valitse Linkitä tiedostoon -valintaruutu ja valitse sitten Wordissa Lisää tai Excelissä OK.

  1. Valitse Muokkaa-valikossa Linkit.

    Jos Linkit-komento ei ole käytettävissä, tiedostossa ei ole linkitettyjä tietoja.

  2. Valitse linkitetty tiedosto Lähdetiedosto-kohdassa ja valitse sitten Avaa lähde.

  3. Tee haluamasi muutokset.

  4. Tallenna muutokset valitsemalla Tiedosto-valikossa Tallenna, ja sulje sitten sovellus.

    Huomaat, että muutokset näkyvät linkin sisältävässä tiedostossa.

Jos haluat säilyttää kahden tiedoston välisen yhteyden, mutta et halua, että päätiedosto päivittyy kun toista tiedostoa muutetaan, voit upottaa tiedot. Tietojen upottaminen on käytännöllistä esimerkiksi silloin, kun et halua, että tilanneraportti päivittyy, kun Excel-taulukkoa muutetaan, tai kun et halua, että Excel-taulukkoa muutetaan, kun ohjeet muuttuvat. Koska kaikki tiedot sisältyvät yhteen tiedostoon, upottamisesta on hyötyä, kun haluat jakaa tiedoston verkossa henkilöille, joilla ei ole upotetun tiedoston käyttöoikeutta.

  1. Valitse kohta, johon haluat upottaa tiedoston.

  2. Valitse Lisää-valikossa Objekti ja valitse sitten Tiedostosta.

  3. Etsi ja valitse tiedosto, jonka haluat upottaa.

    Jos upotat Excel-taulukon, sen on oltava työkirjan ensimmäinen laskentataulukko.

    Vihje: Jos haluat näyttää valitussa kohdassa vain kuvakkeen, jota osoittamalla tiedot tulevat näkyviin, valitse Näytä kuvakkeena -valintaruutu.

  4. Poista Linkitä tiedostoon -valintaruudun valinta ja valitse sitten Wordissa Lisää tai Excelissä OK.

  1. Valitse upotettu tiedosto.

  2. Valitse Muokkaa-valikossa kohta [objektin tyyppi] -objekti (esimerkiksi Taulukko-objekti) ja valitse sitten Muokkaa.

  3. Tee haluamasi muutokset.

  4. Valitse Tiedosto-valikossa Sulje ja palaa: [tiedoston nimi].

    Huomaat, että muutokset näkyvät upotetussa tiedostossa.

Voit linkittää tiedoston osa. Esimerkiksi kuukausiraportti, ehkä haluat luoda linkin tiettyyn solualueeseen sen sijaan, että koko taulukko Excel-laskentataulukossa. Haluat esimerkiksi linkittäminen tarkemmat ohjeet sen sijaan, että koko asiakirjan Word-asiakirjasta.

  1. Valitse tiedot, jotka haluat sijoittaa (esimerkiksi solualue Excel-taulukosta).

  2. Valitse Muokkaa-valikossa Kopioi.

  3. Siirry toiseen tiedostoon ja valitse kohta, johon haluat sijoittaa linkitetyt tiedot.

  4. Valitse Muokkaa-valikossa Sijoita määräten ja valitse sitten Sijoita linkki.

  5. Valitse Liitetään-ruudussa objektin tyyppi, esimerkiksi Microsoft Excel -taulukko-objekti, ja valitse sitten OK.

PowerPoint

Jos haluat säilyttää kahden tiedoston välisen yhteyden, mutta et halua, että päätiedosto päivittyy kun toista tiedostoa muutetaan, voit upottaa tiedot. Voit esimerkiksi upottaa viimeisimmät myyntiluvut kuukauden tilanneraporttiin. Tilanneraportti on PowerPoint-esitys ja myyntiluvut on kirjattu Excel-taulukkoon. Laskentataulukon upottaminen esitykseen muodostaa yhteyden tiedostojen välille.

  1. Valitse kohta, johon haluat upottaa tiedoston.

  2. Valitse Lisää-valikossa Objekti ja valitse sitten Luo tiedostosta.

  3. Etsi ja valitse tiedosto, jonka haluat upottaa.

    Jos upotat Excel-taulukon, sen on oltava työkirjan ensimmäinen laskentataulukko.

  4. Valitse Lisää ja valitse sitten OK.

    Jos et näe upotetun tiedoston tietoja, vedä koonmuuttokahvaa, kunnes tiedoston sisältö on näkyvissä.

  1. Valitse upotettu tiedosto.

  2. Valitse Muokkaa-valikossa kohta [objektin tyyppi] -objekti (esimerkiksi Taulukko-objekti) ja valitse sitten Muokkaa.

  3. Tee haluamasi muutokset.

  4. Valitse Tiedosto-valikossa Sulje ja palaa: [tiedoston nimi].

    Huomaat, että muutokset näkyvät upotetussa tiedostossa.

Voit upottaa myös osan tiedostosta. Saatat esimerkiksi haluta upottaa tietyn solualueen Excel-taulukosta koko laskentataulukon upottamisen sijaan.

  1. Valitse tiedot, jotka haluat sijoittaa (esimerkiksi solualue Excel-taulukosta).

  2. Valitse Muokkaa-valikossa Kopioi.

  3. Siirry toiseen tiedostoon ja valitse kohta, johon haluat sijoittaa linkitetyt tiedot.

  4. Valitse Muokkaa-valikosta Sijoita määräten.

  5. Valitse Sijoita muodossa -ruudussa objektin tyyppi, esimerkiksi Microsoft Excel -taulukko-objekti, ja valitse sitten OK.

Excel

Jos sinulla on toisiinsa liittyviä tietoja Excel- ja Word-tiedostossa, voit linkittää tiedot, jolloin niiden päivittäminen on helppoa. Voit esimerkiksi linkittää viimeisimmät myyntiluvut kuukauden tilanneraporttiin. Tilanneraportti on Word-asiakirja ja myyntiluvut on kirjattu Excel-taulukkoon. Kun linkität asiakirjan laskentataulukkoon, tilanneraportti päivittyy automaattisesti, kun myyntilukuja päivitetään. Voit myös linkittää Word-asiakirjassa olevat ohjeet useaan Excel-tiedostoon. Kun päivität linkitettyjä ohjeita, päivitykset näkyvät kaikissa Excel-tiedostoissa.

  1. Valitse kohta, johon haluat lisätä linkin.

  2. Valitse Lisää-valikossa Objekti ja valitse sitten Tiedostosta.

  3. Etsi ja valitse tiedosto, johon haluat muodostaa linkin.

    Vihje: Jos haluat näyttää valitussa kohdassa vain kuvakkeen, jota osoittamalla tiedot tulevat näkyviin, valitse Näytä kuvakkeena -valintaruutu.

  4. Valitse Linkitä tiedostoon -valintaruutu ja valitse sitten Wordissa Lisää tai Excelissä OK.

  1. Valitse Muokkaa-valikossa Linkit.

    Jos Linkit-komento ei ole käytettävissä, tiedostossa ei ole linkitettyjä tietoja.

  2. Valitse linkitetty tiedosto Lähdetiedosto-kohdassa ja valitse sitten Avaa lähde.

  3. Tee haluamasi muutokset.

  4. Tallenna muutokset valitsemalla Tiedosto-valikossa Tallenna, ja sulje sitten sovellus.

    Huomaat, että muutokset näkyvät linkin sisältävässä tiedostossa.

Jos haluat säilyttää kahden tiedoston välisen yhteyden, mutta et halua, että päätiedosto päivittyy kun toista tiedostoa muutetaan, voit upottaa tiedot. Tietojen upottaminen on käytännöllistä esimerkiksi silloin, kun et halua, että tilanneraportti päivittyy, kun Excel-taulukkoa muutetaan, tai kun et halua, että Excel-taulukkoa muutetaan, kun ohjeet muuttuvat. Koska kaikki tiedot sisältyvät yhteen tiedostoon, upottamisesta on hyötyä, kun haluat jakaa tiedoston verkossa henkilöille, joilla ei ole upotetun tiedoston käyttöoikeutta.

  1. Valitse kohta, johon haluat upottaa tiedoston.

  2. Valitse Lisää-valikossa Objekti ja valitse sitten Tiedostosta.

  3. Etsi ja valitse tiedosto, jonka haluat upottaa.

    Jos upotat Excel-taulukon, sen on oltava työkirjan ensimmäinen laskentataulukko.

    Vihje: Jos haluat näyttää valitussa kohdassa vain kuvakkeen, jota osoittamalla tiedot tulevat näkyviin, valitse Näytä kuvakkeena -valintaruutu.

  4. Poista Linkitä tiedostoon -valintaruudun valinta ja valitse sitten Wordissa Lisää tai Excelissä OK.

  1. Valitse upotettu tiedosto.

  2. Valitse Muokkaa-valikossa kohta [objektin tyyppi] -objekti (esimerkiksi Taulukko-objekti) ja valitse sitten Muokkaa.

  3. Tee haluamasi muutokset.

  4. Valitse Tiedosto-valikossa Sulje ja palaa: [tiedoston nimi].

    Huomaat, että muutokset näkyvät upotetussa tiedostossa.

Voit muodostaa linkin tiettyyn tiedoston osaan. Saatat esimerkiksi haluta linkittää tietyn solualueen Excel-taulukosta koko laskentataulukon sijaan.

  1. Valitse tiedot, jotka haluat sijoittaa (esimerkiksi muutama virke Word-asiakirjasta).

  2. Valitse Muokkaa-valikossa Kopioi.

  3. Siirry toiseen tiedostoon ja valitse kohta, johon haluat sijoittaa linkitetyt tiedot.

  4. Valitse Muokkaa-valikossa Sijoita määräten ja valitse sitten Sijoita linkki.

  5. Valitse Liitetään-ruudussa objektin tyyppi, esimerkiksi Microsoft Word -asiakirjaobjekti, ja valitse sitten OK.

Tutustu myös seuraaviin ohjeaiheisiin

Hyperlinkin luominen, muokkaaminen tai poistaminen

Huomautus: Konekäännöksestä ilmoittava vastuusvapauslauseke: Tämä artikkeli on käännetty tietokonejärjestelmällä, eikä kieliasiantuntija ole muokannut sitä. Microsoft tarjoaa nämä konekäännökset avuksi muille kuin englantia puhuville käyttäjille, jotta he saavat lisätietoja Microsoftin tuotteista, palveluista ja tekniikoista. Koska artikkeli on koneellisesti käännetty, se saattaa sisältää sanasto-, lauseoppi- ja kielioppivirheitä.

Kehitä taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×