Tiedoston kuittaaminen sisään SharePoint-kirjastoon ja ulos SharePoint-kirjastosta

Tärkeää: Tämä on artikkeli on käännetty koneellisesti. Lue vastuuvapauslauseke. Tämän artikkelin englanninkielinen versio on täällä .

Kuittaamalla tiedoston ulos Microsoft Windows SharePoint Services -sivuston kirjastosta voit varmistaa, että muut eivät tee tiedostoon muutoksia samanaikaisesti. Kun tiedosto on kuitattu ulos, voit muokata tiedostoa, sulkea sen, avata sen uudelleen ja jopa käsitellä sitä omalla kiintolevyllä. Muut käyttäjät eivät voi muuttaa tiedostoa tai tarkastella muutoksia, ennen kuin olet kuitannut tiedoston sisään.

Tässä artikkelissa käsiteltävät aiheet

Yleiskatsaus

SharePoint-kirjaston tiedoston kuittaaminen ulos

SharePoint-kirjaston tiedoston kuittaaminen sisään

Jos käsittelet uloskuitatut tiedostot sijainnin muuttaminen

Yleisiä tietoja

Kun useat henkilöt käsittelevät samoja tiedostoja, sekaannusten ja ristiin menevien muokkausten välttämiseksi tiedostot voidaan kuitata ulos ennen muokkaustoimien tekemistä. Kun tiedosto on kuitattu ulos, vain tiedoston uloskuitannut henkilö voi tehdä tiedostoon muutoksia. Minkä tahansa sellaisen SharePoint-sivuston tiedoston voi kuitata ulos, johon käyttäjällä on käyttöoikeudet. Tiedostoja voi kuitata ulos suoraan 2007 Microsoft Office System -ohjelmiston Word-, Excel-, PowerPoint- ja Visio-ohjelmilla.

Kun kuittaat tiedoston sisään, voit kirjoittaa tekemiäsi muutoksia koskevia kommentteja. Tällöin kaikki näkevät, mikä tiedostossa on muuttunut vanhempiin versioihin verrattuna. Tästä on hyötyä etenkin, jos usea henkilö käsittelee samaa tiedostoa tai jos tiedostoa todennäköisesti korjataan tai kirjoitetaan uusiksi useita kertoja. Jos tiedostoversioiden seurantaa käytetään kirjastossa, kommentit liitetään osaksi tiedoston versiohistoriaa. Tästä on hyötyä, jos tiedoston vanhempia versioita joskus tarkastellaan tai palautetaan.

Organisaatiossa voidaan edellyttää, että tiedosto kuitataan ulos ennen muokkaustoimia. Jos uloskuittaaminen on pakollista ja kirjastoon luodaan tai ladataan uusi tiedosto, se täytyy kuitata sisään kirjastoon.

Kun tiedosto on kuitattu ulos, muut näkevät muutokset vasta, kun käyttäjä on kuitannut tiedoston takaisin sisään. Joissakin tilanteissa on mahdollista, että käyttäjä haluaa kuitata tiedoston ja tekemänsä muutokset sisään muiden nähtäviksi, vaikka haluaakin jatkaa tiedoston käsittelyä ja pitää sen kuitattuna ulos. Kun kuittaat tiedoston sisään, voit halutessasi jatkaa tiedoston käsittelemistä – paitsi jos kuittaat tiedoston pääversion sisään kirjastoon, jossa tiedostojen pää- ja aliversiot on määritetty seurattaviksi. Pääversioon on tavallisesti tullut merkittävästi muutoksia edelliseen pääversioon verrattuna, kun taas aliversio on voinut muuttua hyvinkin vähän edellisestä versiosta. Uusi pääversio voi olla esimerkiksi sellainen, johon on lisätty huomattavasti uutta sisältöä. Aliversio taas voi sisältää esimerkiksi pelkkiä kieliasun korjauksia.

Kun kuittaat tiedoston ulos Windows SharePoint Services 3.0 -sivustosta Office-ohjelmalla, tiedosto tallennetaan oletusarvon mukaan kiintolevyn Omat tiedostot -kansion luonnoskansioon. Voit halutessasi vaihtaa tämän sijainnin joksikin muuksi kiintolevyn tai verkon sijainniksi tai määrittää, että uloskuitattuja tiedostoja säilytetään tekemiesi muokkaustoimien ajan Web-palvelimessa. Järjestelmänvalvoja voi määrittää mukautetun sijainnin tai estää käyttäjiä muuttamasta sijaintia, jos organisaation tarpeet sitä edellyttävät.

Kun kuittaat tiedoston ulos Microsoft Windows SharePoint Services 2.0 -sivustosta, tiedostoa säilytetään tekemiesi käsittelytoimien ajan palvelimessa. Tiedosto täytyy kuitenkin kuitata takaisin sisään, ennen kuin muut voivat tarkastella tekemiäsi muutoksia. Kun tiedosto kuitataan ulos Windows SharePoint Services 3.0 -sivustosta, näkyviin tulee useimmiten sanoma, jossa ilmoitetaan, missä uloskuitattua tiedostoa säilytetään muokkaustoimien ajan. Tällaista sanomaa ei tule näkyviin, kun tiedostoja kuitataan ulos Windows SharePoint Services 2.0 -sivustosta.

Kun asiakirja on kuitattu ulos, Office-ohjelman Asiakirjanhallinta-tehtäväruudussa on komento, jolla tiedoston voi kuitata takaisin sisään.

Jos tiedoston pää- ja aliversioita seurataan kirjastossa, sinua voidaan pyytää valitsemaan, kuittaatko sisään pää- vai aliversion.

Sivun alkuun

Tiedoston kuittaaminen ulos SharePoint-kirjastosta

Noudattamalla näitä toimintaohjeita voit kuitata ulos tiedoston, joka on avattuna Office-ohjelmassa. Voit kuitata ulos myös SharePoint-sivuston kirjaston tiedoston.

Tee seuraavat toimet näissä 2007 Office -versio -ohjelmissa:

Word, Excel tai PowerPoint:

  1. Valitse Microsoft Office-painiketta Office-painikkeen kuva , valitse palvelinja valitse Kuittaa ulos.

    Word-asiakirjat avataan usein oletusarvoisesti koko näytön lukutilassa. Näiden toimien tekeminen voi edellyttää, että siirryt tulostusasettelunäkymään valitsemalla Tulostusasettelu.

  2. Jos näkyviin tulee sanoma, jossa ilmoitetaan, missä uloskuitattua tiedostoa säilytetään muokkaustoimien ajan, valitse OK.

    Tämä sanoma tulee useimmiten näkyviin, kun tiedosto kuitataan ulos Windows SharePoint Services 3.0 -sivustosta.

    Vihje: Voit muuttaa uloskuitattavien tiedostojen säilytyssijainnin asetuksia sanomassa, jossa ilmoitetaan, missä uloskuitattua tiedostoa säilytetään muokkaustoimien ajan.

Visio:

  1. Valitse Tiedosto-valikosta Kuittaa ulos.

  2. Jos näkyviin tulee sanoma, jossa ilmoitetaan, missä uloskuitattua tiedostoa säilytetään muokkaustoimien ajan, valitse OK.

    Tämä sanoma tulee useimmiten näkyviin, kun tiedosto kuitataan ulos Windows SharePoint Services 3.0 -sivustosta.

    Vihje: Voit muuttaa uloskuitattavien tiedostojen säilytyssijainnin asetuksia sanomassa, jossa ilmoitetaan, missä uloskuitattua tiedostoa säilytetään muokkaustoimien ajan.

Sivun alkuun

Tiedoston kuittaaminen sisään SharePoint-kirjastoon

Noudattamalla näitä toimintaohjeita voit kuitata sisään tiedoston, joka on avattuna Office-ohjelmassa. Voit kuitata sisään myös SharePoint-sivuston kirjaston tiedoston.

Tee seuraavat toimet näissä 2007 Office -versio -ohjelmissa:

Word, Excel tai PowerPoint:

  1. Valitse Microsoft Office-painiketta Office-painikkeen kuva , valitse palvelinja valitse Kuittaa sisään.

    Word-asiakirjat avataan usein oletusarvoisesti koko näytön lukutilassa. Näiden toimien tekeminen voi edellyttää, että siirryt tulostusasettelunäkymään valitsemalla Tulostusasettelu.

  2. Jos ohjelma kysyy, kirjataanko tiedosto sisään pää- vai aliversiona, valitse Aliversio, jos muutokset ovat olleet vähäisiä, tai Pääversio, jos muutokset ovat olleet suuria.

  3. Jos haluat lisätä tekemiäsi muutoksia koskevia kommentteja, kirjoita ne Kommentit versiosta -ruutuun.

    Nämä kommentit liitetään SharePoint-kirjastoon osaksi tiedoston versiohistoriaa. Tästä voi olla hyötyä, jos joku muu tarvitsee tietoja tiedoston aiemmista versioista.

  4. Jos haluat jatkaa tiedoston käsittelemistä, valitse Säilytä asiakirja kuitattuna ulos tämän version sisään kuittaamisen jälkeen -valintaruutu, jos se on käytettävissä.

    Tämä asetus on käytettävissä, jos versioiden seuranta ei ole käytössä kirjastossa, jos kaikkia versioita seurataan samalla tavalla tai jos sisään kuitattava versio on aliversio. Asetus ei ole käytettävissä, jos kuittaat sisään pääversion tai julkaiset tiedoston.

Visio:

  1. Valitse Tiedosto-valikosta Kuittaa sisään.

  2. Jos ohjelma kysyy, kirjataanko tiedosto sisään pää- vai aliversiona, valitse Aliversio, jos muutokset ovat olleet vähäisiä, tai Pääversio, jos muutokset ovat olleet suuria.

  3. Jos haluat lisätä tekemiäsi muutoksia koskevia kommentteja, kirjoita ne Kommentit versiosta -ruutuun.

    Nämä kommentit liitetään SharePoint-kirjastoon osaksi tiedoston versiohistoriaa. Tästä voi olla hyötyä, jos joku muu tarvitsee tietoja tiedoston aiemmista versioista.

  4. Jos haluat jatkaa tiedoston käsittelemistä, valitse Säilytä asiakirja kuitattuna ulos tämän version sisään kuittaamisen jälkeen -valintaruutu, jos se on käytettävissä.

    Tämä asetus on käytettävissä, jos versioiden seuranta ei ole käytössä kirjastossa, jos kaikkia versioita seurataan samalla tavalla tai jos sisään kuitattava versio on aliversio. Asetus ei ole käytettävissä, jos kuittaat sisään pääversion tai julkaiset tiedoston.

Sivun alkuun

Uloskuitattavien tiedostojen käsittelysijainnin muuttaminen

Tämä asetus muuttaa sijaintia, jossa uloskuitattavia tiedostoja käsitellään. Jos uloskuitattu tiedosto on parhaillaan käsittelyssä, sen käsittelysijainti ei kuitenkaan muutu näitä toimintaohjeita noudattamalla.

Tee seuraavat toimet näissä 2007 Office -versio -ohjelmissa:

Word, Excel tai PowerPoint:

  1. Valitse Microsoft Office-painiketta Office-painikkeen kuva ja valitse sitten ohjelma asetukset: Wordin asetuksetExcelin asetuksetja PowerPointin asetukset.

  2. Valitse näkyviin tulevassa valintaikkunassa Tallenna.

  3. Tee jompikumpi seuraavista toimista Asiakirjojen hallintapalvelimen tiedostojen offline-muokkausasetukset -kohdassa:

    • Käsittele uloskuitattavia tiedostoja kiintolevyllä tai verkkosijainnissa noudattamalla seuraavia ohjeita:

      1. Valitse Tallenna ulos kuitatut tiedostot sijaintiin -kohdasta Palvelinversioiden sijainti tässä tietokoneessa.

      2. Kirjoita Palvelinversioiden sijainti -ruutuun kiintolevyn sijainti, jossa haluat käsitellä uloskuitattuja tiedostoja, tai paikanna sijainti valitsemalla Selaa.

    • Käsittele uloskuitattavia tiedostoja Web-palvelimessa valitsemalla Tallenna ulos kuitatut tiedostot sijaintiin -kohdasta Web-palvelin.

      Kun valitset tämän asetuksen, uloskuitattavia tiedostoja käsitellään Web-palvelimessa tai sivustossa, johon tiedostot on tallennettu. Tarkempaa sijaintia ei voi erikseen määrittää.

  4. Valitse OK.

Visio

  1. Valitse Työkalut-valikosta Asetukset.

  2. Valitse Asetukset-valintaikkunan Yleiset-välilehti ja valitse Palveluasetukset.

  3. Valitse näkyviin tulevassa valintaikkunassa Offline-muokkauksen asetukset.

  4. Tee jompikumpi seuraavista toimista Asiakirjojen hallintapalvelimen tiedostojen offline-muokkausasetukset -kohdassa:

    • Käsittele uloskuitattavia tiedostoja kiintolevyllä tai verkkosijainnissa noudattamalla seuraavia ohjeita:

      1. Käsittele uloskuitattavia tiedostoja kiintolevyllä valitsemalla Tallenna ulos kuitatut tiedostot sijaintiin -kohdasta Palvelinversioiden sijainti tässä tietokoneessa.

      2. Kirjoita Palvelinversioiden sijainti -kohtaan kiintolevyn sijainti, jossa haluat käsitellä uloskuitattavia tiedostoja, tai paikanna sijainti valitsemalla Selaa.

    • Käsittele uloskuitattavia tiedostoja palvelinsijainnissa valitsemalla Tallenna ulos kuitatut tiedostot sijaintiin -kohdasta Web-palvelin.

      Kun valitset tämän asetuksen, uloskuitattavia tiedostoja käsitellään Web-palvelimessa tai sivustossa, johon tiedostot on tallennettu. Tarkempaa sijaintia ei voi erikseen määrittää.

  5. Valitse OK.

Sivun alkuun

Huomautus: Konekäännöksestä ilmoittava vastuusvapauslauseke: Tämä artikkeli on käännetty tietokonejärjestelmällä, eikä kieliasiantuntija ole muokannut sitä. Microsoft tarjoaa nämä konekäännökset avuksi muille kuin englantia puhuville käyttäjille, jotta he saavat lisätietoja Microsoftin tuotteista, palveluista ja tekniikoista. Koska artikkeli on koneellisesti käännetty, se saattaa sisältää sanasto-, lauseoppi- ja kielioppivirheitä.

Kehitä taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×