Testaa ehtojen yhdistelmä JA- ja TAI-funktioilla

Kun tarvitset useamman kuin yhden ehdon täyttäviä tietoja, kuten huhti- ja toukokuun myydyt yksiköt ja Nancyn myymät yksiköt, voit käyttää JA- ja TAI-funktioita yhdessä. Esimerkki:

JA- ja TAI-funktion käyttäminen samassa kaavassa

Tähän kaavaan sisältyy JA-funktioTAI-funktion sisällä, ja se hakee 1. huhtikuuta 2011–1. tammikuuta 2012 myydyt yksiköt tai Nancyn myymät yksiköt. Näet, että se palauttaa arvon Tosi Nancyn myymille yksiköille sekä Timin ja Edin myymille yksiköille kaavassa annetulla aikavälillä.

Voit kopioida ja liittää kaavan tässä muodossa. Jos haluat harjoitella sen käyttöä mallityökirjassa, katso tämän artikkelin loppua.

=TAI(JA(C2>PÄIVÄMÄÄRÄ(2011,4,30),C2<PÄIVÄMÄÄRÄ(2012,1,1)),B2="Nancy")

Tutustutaan kaavaan tarkemmin. TAI-funktio vaatii joukon argumentteja (tietoja), joista se voi testata, ovatko ne tosia vai epätosia. Tässä kaavassa ensimmäinen argumentti on JA-funktio sekä PÄIVÄMÄÄRÄ-funktio, jotka ovat sisäkkäin. Toinen argumentti on "Nancy". Voit lukea kaavan näin: Testaa, tehtiinkö kauppa 30 huhtikuuta 2011 ja 1. tammikuuta 2012 välisenä aikana, tai tekikö Nancy kaupan.

JA-funktio palauttaa myös arvon Tosi tai Epätosi. Useimmiten JA-funktiota laajennetaan toisen funktion, kuten TAI- tai JOS-funktion, ominaisuuksia. Tässä esimerkissä TAI-funktio ei löytäisi oikeita päivämääriä ilman JA-funktiota.

JA- ja TAI-funktioiden käyttö JOS-funktion kanssa

Voit myös käyttää JA- ja TAI-funktiota JOS-funktion kanssa.

JA- ja TAI-funktio JOS-funktion sisällä

Tässä esimerkissä bonuksia saa vasta, kun on myynyt 125 000 dollarin arvosta tuotteita, paitsi jos he työskentelevät eteläisellä alueella, missä markkinat ovat pienemmät. Siellä bonuksen ansaitsee jo 100 000 dollarin myynnillä.

=JOS(TAI(C4>=125000,JA(B4="Etelä",C4>=100000))=TOSI,C4*0,12,"Ei bonusta")

Katsotaan tarkemmin. IF-funktion suorittamiseen tarvitaan kolme tietoa (argumenttia). Ensimmäinen on looginen testi, toinen on arvo, jonka haluat nähdä, jos testin tulos on Tosi, ja kolmas on arvo, jonka haluat nähdä, jos testin tulos on Epätosi. Tässä esimerkissä TAI-funktio ja kaikki sen sisällä tekevät loogisen testin. Voit lukea sen seuraavasti: Hae arvoja, jotka ovat suurempia tai yhtä suuria kuin 125 000, paitsi jos sarakkeen C arvo on South. Silloin hae arvoja, jotka ovat suurempia kuin 100 000. Jos molemmat ehdot täyttyvät, kerro arvo luvulla 0,12 eli provision suuruudella. Muussa tapauksessa näytä sanat Ei bonusta.

Sivun alkuun

Kokeile

Ennen kuin ryhdyt käyttämään tämän artikkelin esimerkkejä omien tietojesi kanssa, voit halutessasi harjoitella oheisella Excel Online ‑esimerkkitiedostolla.

EWA

Voit avata tämän työkirjan myös Excelissä. Napsauta tiedoston oikeassa alakulmassa olevaa Excel-kuvaketta Excel Online -sovelluksen Excel-kuvake , tallenna tiedosto omaan tietokoneeseesi haluamaasi sijaintiin ja avaa tiedosto.

Sivun alkuun

Kehitä taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×