Taulukko_matriisi-argumentin käyttäminen hakufunktiossa

Tärkeää: Tämä on artikkeli on käännetty koneellisesti. Lue vastuuvapauslauseke. Tämän artikkelin englanninkielinen versio on täällä .

Kun luodaan kaava PHAKU- tai VHAKU-funktioilla, syötetään taulukko_matriisi-argumentti, joka on solualue, kuten D2:F39. Funktio etsii alueelta haettavia tietoja.

Taulukko_matriisi-argumentti on aina PHAKU- tai VHAKU-funktion toinen argumentti (ensimmäinen on etsitty arvo), jota ilman funktiot eivät toimi.

Ensimmäinen argumentti voi olla tietty arvo, kuten "41" tai "smith" tai se voi olla soluviite, kuten F2. Ensimmäinen argumentti näyttäisi tältä:

=PHAKU(F2; ...

Taulukko_matriisi-argumentti on aina haettavan arvon jälkeen:

=PHAKU(F2;B4:D39; ...

Taulukko_matriisi-argumentissa luetellussa solualueessa voidaan käyttää suhteellisia tai absoluuttisia soluviittauksia. Jos kaava kopioidaan toisiin soluihin, on käytettävä absoluuttisia soluviittauksia (huomaa $-merkit) tällä tavalla:

=PHAKU(F2;$B$2:BD$39; ...

Jos taulukko_matriisi-argumentin solut ovat työkirjassa toisessa laskentataulukossa, argumenttiin pitää sisällyttää taulukon nimi ja sen perässä huutomerkki. Kaava näyttäisi seuraavalta:

=PHAKU(F2;Taul2!$C$14:E$42; ...

Sarake, jossa ovat etsityt arvot, on kolmas syötettävä argumentti. Tätä kutsutaan hakusarakkeeksi. Jos tarkasteltavat arvot ovat sarakkeessa D (taulukko_matriisin kolmas sarake), viimeinen argumentti on 3.

=PHAKU(F2;B4:D39;3)

On suositeltavaa, joskin valinnaista, käyttää neljättäkin argumenttia, joko Tosi tai Epätosi. Jos etsit tarkkaa vastinetta, käytä Epätosi.

=PHAKU(F2;B4:D39;3;Epätosi)

Jos käytössä on Tosi tai neljäs argumentti jätetään tyhjäksi, funktio palauttaa ensimmäisen argumentin arvon likimääräisen vastineen. Jos siis ensimmäinen argumentti on "smith" ja käytössä on Tosi, PHAKU palauttaa arvot "Smith," "Smithberg" jne. Mutta jos käytössä on Epätosi, funktio palauttaa ainoastaan arvon "Smith", joka on tarkka vastine, joka useimmiten halutaan tulokseksi.

Tosi-arvon käyttöä hankaloittaa se, että jos hakusaraketta – kolmannessa argumentissa määritettyä saraketta – ei ole lajiteltu nousevassa järjestyksessä (A-Ö tai pienimmästä luvusta suurimpaan), funktio saattaa palauttaa väärän tuloksen.

Lisätietoja PHAKU- ja VHAKU-funktioista on artikkelissa Haku- ja viitefunktiot (viite).

Huomautus: Konekäännöksestä ilmoittava vastuusvapauslauseke: Tämä artikkeli on käännetty tietokonejärjestelmällä, eikä kieliasiantuntija ole muokannut sitä. Microsoft tarjoaa nämä konekäännökset avuksi muille kuin englantia puhuville käyttäjille, jotta he saavat lisätietoja Microsoftin tuotteista, palveluista ja tekniikoista. Koska artikkeli on koneellisesti käännetty, se saattaa sisältää sanasto-, lauseoppi- ja kielioppivirheitä.

Kehitä taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×