Taulukko_matriisi-argumentin käyttäminen hakufunktiossa

Tärkeää: Tämä on artikkeli on käännetty koneellisesti. Lue vastuuvapauslauseke. Tämän artikkelin englanninkielinen versio on täällä .

Kun luot PHAKU-tai VHAKU-funktion, määrität samalla solualueen, kuten D2:F39. Tätä aluetta kutsutaan taulukko_matriisi-argumentiksi ja argumentti on tieto, jonka funktio tarvitsee toimiakseen. Tässä tapauksessa funktio hakee soluista etsimiäsi tietoja.

Taulukko_matriisi-argumentti on aina PHAKU-tai VHAKU-funktion toinen argumentti (ensimmäinen on etsitty arvo), jota ilman funktiot eivät toimi.

Ensimmäinen argumentti, eli etsittävä arvo, voi olla jokin tietty arvo, kuten "41" tai "smith", tai se voi olla soluviittaus, kuten F2. Ensimmäinen argumentti voi siis näyttää tältä:

= PHAKU (F2, ...

Taulukko_matriisi-argumentti on aina haettavan arvon jälkeen:

= PHAKU (F2, B4:D39, ...

Taulukko_matriisi-argumentissa luetellussa solualueessa voidaan käyttää suhteellisia tai suoria soluviittauksia. Jos kopioit funktion, sinun on käytettävä suoria viittauksia:

= PHAKU (F2, $B$ 2: $39 BD ...

Lisäksi taulukko_matriisi-argumentin solut voivat olla työkirjan toisessa laskentataulukossa. Tällöin argumentti sisältää laskentataulukon nimen ja syntaksi näyttää tältä:

= PHAKU (F2, Taul2! $C$ 14: $42, E ...

Muista lisätä huutomerkki laskentataulukon nimen perään.

Lopuksi lisätään kolmas argumentti eli sarake, joka sisältää etsittävät arvot. Tätä kutsutaan hakusarakkeeksi. Ensimmäisessä esimerkissä oli kolmen sarakkeen kautta kulkeva solualue B4 - D39. Oletetaan, että etsittävät arvot ovat solualueen kolmannessa sarakkeessa D, jolloin viimeisen argumentin arvona on 3.

=PHAKU(F2;B4:D39;3)

Voit myös käyttää vaihtoehtoista neljättä argumenttia, joka on joko Tosi tai Epätosi. Useimmiten käytössä on Epätosi.

Jos käytössä on Tosi tai neljäs argumentti jätetään tyhjäksi, funktio palauttaa ensimmäisen argumentin arvon lähes tarkan vastineen. Jos siis ensimmäinen argumentti on "smith" ja käytössä on Tosi, funktio palauttaa arvot "Smith," "Smithberg" jne. Jos käytössä on Epätosi, funktio palauttaa ainoastaan arvon "Smith", joka on tarkka vastine, joka useimmiten halutaan tulokseksi.

Tosi-arvon käyttöä hankaloittaa se, että jos kolmannessa argumentissa määritettyä hakusaraketta ei ole lajiteltu nousevassa järjestyksessä (A-Ö tai pienimmästä luvusta suurimpaan), funktio saattaa palauttaa väärän tuloksen. Lisätietoa on artikkelissa Arvojen hakeminen PHAKU- ja muilla funktioilla.

Lisätietoa PHAKU- ja VHAKU-funktioista on kohdassa:

Huomautus: Konekäännöksestä ilmoittava vastuusvapauslauseke: Tämä artikkeli on käännetty tietokonejärjestelmällä, eikä kieliasiantuntija ole muokannut sitä. Microsoft tarjoaa nämä konekäännökset avuksi muille kuin englantia puhuville käyttäjille, jotta he saavat lisätietoja Microsoftin tuotteista, palveluista ja tekniikoista. Koska artikkeli on koneellisesti käännetty, se saattaa sisältää sanasto-, lauseoppi- ja kielioppivirheitä.

Kehitä taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×