TULOJEN.SUMMA-funktion #ARVO!-virheen korjaaminen

Tässä artikkelissa käsitellään tavalliset tilanteet, joissa #ARVO!-virhe ilmenee TULOJEN.SUMMA-funktiota käytettäessä.

Ongelma: Matriisiargumenttien ulottuvuus ei ole sama

Kaikilla matriisiargumenteilla on oltava sama ulottuvuus. Jos näin ei ole, saat #VALUE!-virheen. Esimerkiksi jos matriisi 1 viittaa alueeseen, jossa on 3 riviä ja 2 saraketta, myös matriisin 2 vastattava samanlaista aluetta.

TULOJEN.SUMMA-kaava, joka aiheuttaa virheen, on =TULOJEN.SUMMA(D2:D13,E2:E10). E10 on muutettava arvoksi E13, jotta se vastaa ensimmäistä aluetta.
  • =TULOJEN.SUMMA(D2:D13,E2:E10)

Epäonnistuu, koska viitatuilla alueilla ei ole yhtä monta riviä (13 ensimmäisellä alueella, mutta vain 10 toisella alueella).

Ratkaisu: Muuta kaava seuraavaan muotoon:

  • =TULOJEN.SUMMA(D2:D13,E2:E13)

Näin molemmilla alueilla on sama alun ja lopun rivinumero. Kokeile suorittaa kaava uudelleen.

Ratkaise tietojen #ARVO!-virhe, jotta ratkaiset TULOJEN.SUMMA-virheen

Ongelma: Vähintään yhdessä alueen solussa on tekstiä

Jos vähintään yksi viitatun alueen solu sisältää tekstiä tai on muotoiltu Teksti-tietotyypiksi, saat #ARVO!-virheen. Teksti saattaa johtua toisen kaavan laskutoimituksesta tai solu on voitu muotoilla virheellisesti.

Solussa E15 oleva kaava näyttää #ARVO!-virheen, koska sarakkeessa E on #ARVO!-virhe.

Ratkaisu: Tarkista, onko jossakin solussa tekstiä tai onko jokin solu muotoiltu tekstiksi, ja määritä oikea tietotyyppi.

Onko sinulla jokin funktioihin liittyvä kysymys?

Lähetä kysymys Excel-yhteisön keskustelupalstalle

Auta meitä parantamaan Exceliä

Onko sinulla ehdotuksia, miten voimme parantaa seuraavaa Excel-versiota? Jos on, lue aiheet Excel User Voice -palvelussa.

Katso myös

#ARVO!-virheen korjaaminen

TULOJEN.SUMMA-funktio

Yleiskuva kaavoista Excelissä

Viallisten kaavojen ratkaiseminen

Kaavoissa esiintyvien virheiden etsiminen

Kaikki Excel-funktiot (aakkosjärjestyksessä)

Kaikki Excel-funktiot (luokittain)

Kehitä taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×