TAI-funktio

TAI-funktio, yksi loogisista funktioista, auttaa selvittämään testin ehtojen täyttymistä.

Esimerkki

Esimerkkejä TAI-funktion käyttämisestä.

TAI-funktio palauttaa arvon TOSI, jos jokin argumenttien arvo on TOSI, ja arvon EPÄTOSI, jos kaikkien argumenttien arvo on EPÄTOSI.

Yleinen tapa käyttää TAI-funktiota on laajentaa muita funktioita, jotka suorittavat loogisia testejä. Esimerkiksi JOS-funktio suorittaa loogisen testin ja palauttaa yhden arvon jos testin tulos on TOSI ja toisen arvon jos testin tulos on EPÄTOSI. Käyttämällä TAI-funktiota JOS-funktion totuus_testi-argumenttina voit testata useita eri ehtoja vain yhden sijaan.

Syntaksi

TAI(totuus1; [totuus2], ...)

TAI-funktion syntaksissa on seuraavat argumentit:

Argumentti

Kuvaus

Totuus1

Pakollinen. Ensimmäinen ehto, jota haluat testata ja jonka arvo voi olla joko TOSI tai EPÄTOSI.

Totuus2, ...

Valinnainen. Lisäehdot, joita haluat testata ja joiden arvo voi olla joko TOSI tai EPÄTOSI. Voit testata enintään 255 ehtoa.

Huomautuksia

  • Argumenttien on oltava totuusarvoja, kuten TOSI tai EPÄTOSI, tai matriiseja tai viittauksia, jotka sisältävät totuusarvoja.

  • Jos matriisi tai viittaus sisältää tekstiä, lukuja tai tyhjiä soluja, näitä arvoja ei oteta huomioon.

  • Jos määritetyllä alueella ei ole totuusarvoja, TAI palauttaa #VALUE!‑virhearvon.

  • Voit käyttää TAI-matriisikaavaa tarkistaaksesi löytyykö jokin arvo matriisista. Jos haluat kirjoittaa matriisikaavan, paina CTRL + VAIHTO + ENTER.

Esimerkkejä

Seuraavassa on yleisiä esimerkkejä TAI-funktion käytöstä itsenäisesti ja JOS-funktion kanssa.

Esimerkkejä TAI-funktion käyttämisestä JOS-funktion kanssa.

Kaava

Kuvaus

=TAI(A2>1,A2<100)

Antaa tulokseksi TOSI, jos solun A2 arvo on suurempi kuin 1 TAI pienempi kuin 100. Muussa tapauksessa antaa tulokseksi EPÄTOSI.

=JOS(TAI(A2>1,A2<100),A3,"Arvo on alueen ulkopuolella")

Näyttää solun A3 arvon, jos se on suurempi kuin 1 TAI pienempi kuin 100. Muussa tapauksessa näyttää viestin "Arvo on alueen ulkopuolella".

=JOS(TAI(A2<0,A2>50),A2,"Arvo on alueen ulkopuolella")

Näyttää solun A2 arvon, jos se on pienempi kuin 0 TAI suurempi kuin 50. Muussa tapauksessa näyttää viestin.

Myyntiprovision laskenta

Tässä on melko tavallinen esimerkki, jossa JOS- ja TAI-funktioiden avulla lasketaan, ovatko myyjät oikeutettuja saamaan myyntiprovision.

Esimerkki JOS- ja TAI-funktioiden käyttämisestä myyntiprovision laskemiseen.
  • =JOS(TAI(B14>=$B$4,C14>=$B$5),B14*$B$6,0)JOS kokonaismyynti on suurempi tai yhtä suuri kuin (>=) myyntitavoite TAI tili on suurempi tai yhtä suuri (>=) kuin tavoitetili, kokonaismyynti kerrotaan provisioprosentilla. Muussa tapauksessa palauttaa 0.

Tarvitsetko lisätietoja?

Voit aina kysyä neuvoa Excel Tech Community -yhteisön asiantuntijalta, saada tukea yhteisön vastauksista tai ehdottaa uutta ominaisuutta tai parannusta Excel User Voice -sivustolla.

Aiheeseen liittyvät artikkelit

Video: Edistyneet JOS-funktiot
Lue, miten voit käyttää sisäkkäisiä funktioita kaavassa
JOS-funktio
JA-funktio
EI-funktio
Yleiskuva kaavoista Excelissä
Viallisten kaavojen ratkaiseminen
Käytä virheentarkistusta kaavoissa esiintyvien virheiden etsimiseen
Excel 2016 for Windowsin pikanäppäimet
Excel 2016 for Macin pikanäppäimet
Loogiset funktiot (hakemisto)
Excelin funktiot (aakkosjärjestyksessä)
Excelin funktiot (luokittain)

Kehitä taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×