Soluviittausten käyttäminen kaavassa

Huomautus:  Microsoft haluaa tarjota sinulle ajantasaisinta ohjesisältöä mahdollisimman nopeasti omalla kielelläsi. Tämä sivu on käännetty automaation avulla, ja siinä saattaa olla kielioppivirheitä tai epätarkkuuksia. Tarkoitus on, että sisällöstä on sinulle hyötyä. Kertoisitko sivun alareunassa olevan toiminnon avulla, oliko tiedoista hyötyä? Tästä pääset helposti artikkelin englanninkieliseen versioon .

Kun luot Yksinkertaisen kaavan tai kaava, joka käyttää funktiota, voit viitata laskentataulukon soluissa oleviin tietoihin lisäämällä soluviittauksia argumenteissa. Esimerkiksi Anna tai valitse soluviittaus A2, kun kaava käyttää solun arvon tuloksen laskemiseen. Voit luoda viittauksen solualue.

Saat lisätietoja soluviittauksia luominen tai muuttaminen soluun viittaavat. Lisätietoja kaavoista, katso Yleistä kaavoista.

  1. Valitse solu, johon haluat kirjoittaa kaavan.

  2. Kirjoita kaavarivi Painikkeen kuva :ssa = (yhtäläisyysmerkki).

  3. Tee jompikumpi seuraavista: valitse solu, joka sisältää haluamasi arvon, tai kirjoita sen soluviittaus.

    Voit luoda viittauksen valitsemalla solun, solualueen, sijainnin toisesta laskentataulukosta tai sijainnin toisesta työkirjasta.

    Voit siirtää valittua solualuetta vetämällä valintaa reunasta tai voit laajentaa valintaa vetämällä sitä kulmasta.

    Alueen etsimistoiminto värikoodaa edeltäjät

    1. Ensimmäinen soluviittaus on B3, ja sen väri on sininen. Solualueen reunaviivat ovat siniset, ja sen kulmissa on neliöt.

    2. Toinen soluviittaus on C3, ja sen väri on vihreä. Solualueen reunaviivat ovat vihreät, ja sen kulmissa on neliöt.

    Huomautus: Jos värikoodattujen reunaviivojen kulmissa ei ole neliöitä, viittaus viittaa nimettyyn alueeseen.

  4. Paina Enter-näppäintä.

    Vihje: Voit myös kirjoittaa nimetyn solun tai alueen viittaus. Lisätietoja on artikkelissa nimien määrittäminen ja käyttäminen kaavoissa.

Esimerkki

Kopioi esimerkkitiedot seuraavaan taulukkoon ja lisää se uuden Excel-laskentataulukon soluun A1. Kaavat näyttävät tuloksia, kun valitset ne, painat F2-näppäintä ja sitten Enter-näppäintä. Voit säätää sarakkeiden leveyttä, jotta näet kaikki tiedot. Voit määrittää "Varat" (B2:B4) ja "Vastattavat" (C2:C4) käyttämällä Määritä nimi -komentoa (Kaavat-välilehti, Määritetyt nimet -ryhmä).

Osasto

Varat

Vastattavat

IT

274000

71000

Hallinto

67000

18000

Henkilöstö

44000

3000

Kaava

Kuvaus

Tulos

'=SUMMA(Varat)

Palauttaa kolmen osaston varojen summan määritetyssä nimessä "Varat", joka on määritetty solualueeksi B2:B4. (385 000)

=SUMMA(Varat)

'=SUMMA(Varat)-SUMMA(Vastattavat)

Vähentää määritetyn nimen "Vastattavat" summan määritetyn nimen "Varat" summasta. (293 000)

=SUMMA(Varat)-SUMMA(Vastattavat)

Sivun alkuun

Kehitä Office-taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×