Solun merkkien laskeminen Excel 2016 for Macissa

Kun haluat laskea solujen merkkimäärän, käytä PITUUS-funktiota. Funktio laskee kirjaimet, numerot, merkit ja kaikki välilyönnit. Esimerkiksi lauseen "Tänään on 35 astetta lämmintä, joten menen uimaan" pituus on (ilman lainausmerkkejä) 49 merkkiä - 40 kirjainta, 2 numeroa, 7 välilyöntiä ja pilkku.

  • Kun haluat käyttää funktiota, kirjoita kaavariville =PITUUS(solu) ja paina Enter-näppäintä. Näissä esimerkeissä solu tarkoittaa laskettavaa solua, esimerkiksi B1.

  • Jos haluat laskea useamman kuin yhden solun merkit, kirjoita kaava. Kopioi ja sijoita sitten kaava muihin soluihin.

  • Voit laskea useiden solujen yhteenlasketun merkkimäärän käyttämällä SUMMA-funktion ja PITUUS-funktion yhdistelmää. Esimerkki: =SUMMA((PITUUS(solu1);PITUUS(solu2);(PITUUS(solu3)). Tässä esimerkissä PITUUS-funktio laskee kunkin solun merkit, ja SUMMA-funktio laskee ne yhteen.

  • Jos haluat laskea solujen tietyt merkit, käytä PITUUS-funktiota VAIHDA-funktion kanssa. Jos haluat esimerkiksi tietää, montako pientä z-kirjainta solussa on, käytä kaavaa: =PITUUS(solu1)-PITUUS(VAIHDA(solu1,"z",""))

Kokeile

Kirjoita seuraavat tiedot uuteen Excel-laskentataulukkoon. Aloita solusta A1.

Tekstimerkkijono

Kaavat

Nopea ruskea kettu

Nopea ruskea kettu hyppäsi

Nopea ruskea kettu hyppäsi laiskan koiran yli.

Yhden solun merkkimäärän laskeminen

  1. Napsauta solua B2.

  2. Kirjoita soluun =PITUUS(A2) ja paina Enter-näppäintä.

Kaava laskee solun A2 merkkimäärän (19), joka sisältää myös välilyönnit. Jos välilyöntejä on loppupisteen jälkeen, kaava laskee myös ne mukaan.

Useiden solujen merkkimäärän laskeminen

  1. Kopioi solu B2 painamalla näppäinyhdistelmää CONTROL + C.

  2. Sijoita sen kaava soluihin B3:B4 painamalla näppäinyhdistelmää CONTROL + V.

Kaava kopioituu soluihin B3 ja B4, ja funktio laskee kunkin solun merkkimäärän (26 ja 44).

Merkkien kokonaismäärän laskeminen

  1. Valitse solu B6.

  2. Kirjoita soluun =SUMMA(PITUUS(A2),PITUUS(A3),PITUUS(A4)) ja paina Enter-näppäintä.

Kaikkien kolmen solun merkkimäärä lasketaan yhteen (89).

Solujen tiettyjen merkkien laskeminen

  1. Valitse solu C4

  2. Kirjoita soluun =PITUUS(A4)-PITUUS(VAIHDA(A4,"z","")) ja paina Enter-näppäintä.

Tämä laskee kaikki solun A4 pienet z-kirjaimet. Tulos on 1.

Kehitä taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×