Office
Kirjaudu sisään

Solujen merkkimäärän laskeminen

Kun haluat laskea solujen merkkimäärän, käytä PITUUS-funktiota. Se laskee kirjaimet, numerot, merkit ja kaikki välilyönnit. Esimerkiksi lauseen "Tänään on 35 astetta lämmintä, joten menen uimaan" pituus on (ilman lainausmerkkejä) 49 merkkiä – 40 kirjainta, 2 numeroa, 7 välilyöntiä ja pilkku.

Jos haluat käyttää funktiota, kirjoita =PITUUS(solu) kaavariville ja paina Enter-näppäintä.

Useita soluja: Jos haluat käyttää samaa kaavaa useissa soluissa, kirjoita kaava ensimmäiseen soluun ja vedä täyttökahva alas (tai sivuttain) solualueen yli.

Usean PITUUS-funktion lisääminen laskentataulukkoon

Jos haluat laskea useiden solujen kokonaismerkkimäärän, käytä SUMMA-funktioita PITUUS-funktioiden kanssa. Tässä esimerkissä PITUUS-funktio laskee kunkin solun merkit ja SUMMA-funktio laskee määrät yhteen:

=SUMMA((PITUUS( solu1 ),PITUUS( solu2 ),(PITUUS( solu3 )) )).

Kokeile

Seuraavassa on esimerkkejä, joissa havainnollistetaan PITUUS-funktion käyttöä.

Kopioi alla oleva taulukko ja liitä se Excel-laskentataulukon soluun A1. Vedä kaava solusta B2 soluun B4 nähdäksesi tekstin pituuden sarakkeen A soluissa.

Tekstimerkkijono

Kaavat

Nopea ruskea kettu.

=PITUUS(A2)

Nopea ruskea kettu hyppäsi.

Nopea ruskea kettu hyppäsi laiskan koiran yli.

Yhden solun merkkimäärän laskeminen

  1. Napsauta solua B2.

  2. Kirjoita =PITUUS(A2).

Kaava laskee solussa A2 olevien merkkien määrän, joka on yhteensä 27. Luku sisältää kaikki välilyönnit ja pisteen virkkeen lopussa.

HUOMAUTUS: PITUUS laskee myös kaikki välilyönnit viimeisen merkin jälkeen.

Useiden solujen merkkimäärän laskeminen

  1. Napsauta solua B2.

  2. Kopioi solu B2 painamalla näppäinyhdistelmää Ctrl+C, valitse sitten solut B3 ja B4 ja liitä kaava soluihin B3:B4 painamalla näppäinyhdistelmää Ctrl+V.

Kaava kopioituu soluihin B3 ja B4, ja funktio laskee kunkin solun merkkimäärän (20, 27 ja 45).

Merkkien kokonaismäärän laskeminen

  1. Napsauta esimerkkitiedoston solua B6.

  2. Kirjoita soluun =SUMMA(PITUUS(A2),PITUUS(A3),PITUUS(A4)) ja paina Enter-näppäintä.

Kaikkien kolmen solun merkkimäärä lasketaan yhteen (92).

Kehitä Office-taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×