Solujen merkkimäärän laskeminen

Kun haluat laskea solujen merkkimäärän, käytä PITUUS-funktiota. Funktio laskee kirjaimet, numerot, merkit ja kaikki välilyönnit. Esimerkiksi lauseen "Tänään on 35 astetta lämmintä, joten menen uimaan" pituus on (ilman lainausmerkkejä) 49 merkkiä - 40 kirjainta, 2 numeroa, 7 välilyöntiä ja pilkku.

  • Kun haluat käyttää funktiota, kirjoita kaavariville =PITUUS(solu) ja paina ENTER-näppäintä. Näissä esimerkeissä solu tarkoittaa sitä solua, jonka haluat laskea, esimerkiksi B1.

  • Jos haluat laskea usean solun merkit, kirjoita kaava ja vedä täyttökahva laskettavien solujen yli.

Usean PITUUS-funktion lisääminen laskentataulukkoon

  • Voit laskea useiden solujen kokonaismerkkimäärän SUMMA-funktioiden ja PITUUS-funktioiden avulla. Esimerkiksi =SUMMA((PITUUS(solu1);PITUUS(2);(PITUUS(solu3)))). Tässä esimerkissä PITUUS-funktio laskee kunkin solun merkit ja SUMMA-funktio laskee määrät yhteen.

Kokeile

Työkirjan seuraavien esimerkkien avulla näet, miten PITUUS-funktiota käytetään.

Kopioi alla oleva taulukko ja liitä se Excel-laskentataulukon soluun A1. Vedä kaava solusta B2 soluihin B3:B4 nähdäksesi tekstin pituuden sarakkeen A soluissa.

Tekstimerkkijono

Kaavat

Nopea ruskea kettu

=PITUUS(A2)

Nopea ruskea kettu hyppäsi

Nopea ruskea kettu hyppäsi laiskan koiran yli.

Yhden solun merkkimäärän laskeminen

  1. Napsauta esimerkkitiedostossa olevan Taul1-laskentataulukon solua B2.

  2. Kirjoita soluun =PITUUS(A2) ja paina Enter-näppäintä.

Kaava laskee A1-solun merkkimäärän (45), joka sisältää myös välilyönnit. Jos tekstissä on välilyöntejä loppupisteen jälkeen, kaava laskee ne mukaan.

Useiden suljen merkkimäärän laskeminen

  1. Napsauta esimerkkitiedoston solua B2.

  2. Kirjoita soluun, =PITUUS(A2).

  3. Kopioi solu B2 painamalla näppäinyhdistelmää Ctrl+C ja liitä sen kaava soluihin B3:B4 painamalla näppäinyhdistelmää Ctrl+V.

Kaava kopioituu soluihin B3 ja B4, ja funktio laskee kunkin solun merkkimäärän (19, 26 ja 45).

Merkkien kokonaismäärän laskeminen

  1. Napsauta esimerkkitiedoston solua B6.

  2. Kirjoita soluun =SUMMA(PITUUS(A2),PITUUS(A3),PITUUS(A4)) ja paina Enter-näppäintä.

Kaikkien kolmen solun merkkimäärä lasketaan yhteen (90).

Kehitä taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×