Sivuston suorituskyvyn ja käyttömäärän mittaaminen raporttien avulla

Tärkeää: Tämä on artikkeli on käännetty koneellisesti. Lue vastuuvapauslauseke. Tämän artikkelin englanninkielinen versio on täällä .

Jos vastaat sivuston hallinnasta, sinulta luultavasti kysytään usein seuraavia sivustoa koskevia asioita:

  • Kuinka monta vierailijaa sivustossani käy?

  • Miten sivuston liikennemäärä on muuttunut ajan kuluessa?

  • Ketkä käyttävät sivustoani eniten?

  • Mistä käyttäjät tulevat sivustooni?

  • Mitä sivustoni sivuja ja resursseja käytetään eniten?

  • Mikä on työnkulkuprosessiin kuuluvien tiedostojen ja muiden resurssien tilanne?

Web-sivuston ylläpitäjänä sinulla itselläsikin on kysymyksiä, joihin haluat vastauksia, kuten:

  • Onko sivustossa resursseja, jotka voin poistaa, koska niitä ei käytetä tai ne ovat vanhoja?

  • Kuinka löydän sivustossa olevat ongelmat (kuten linkittämättömät tiedostot, hitaat sivut ja katkenneet hyperlinkit), ennen kuin käyttäjät havaitsevat ne ja ilmoittavat niistä?

Nämä kysymykset saattavat vaikuttaa vaikeilta, mutta kun käytössäsi on Microsoft Office SharePoint Designer 2007 -ohjelma ja Windows SharePoint Services 3.0- tai Microsoft Office SharePoint Server 2007 -sivusto, voit helposti vastata niihin Office SharePoint Designer 2007 -raportteja käyttämällä. Tässä artikkelissa kerrotaan, kuinka voit raportteja käyttämällä mitata sivuston suorituskykyä ja käyttöä.

Tärkeää: Office SharePoint Designer 2007 -ohjelman muodostamien raporttien tiedot tallentuvat siihen palvelimeen, jossa sivusto sijaitsee. Palvelimen järjestelmänvalvoja voi sallia tai estää näiden raporttien käyttämisen. Jos pyytämäsi raportti on tyhjä, ota yhteys palvelimen järjestelmänvalvojaan. Käyttötietoraporttien suorittamista varten sinulla on oltava käyttötietojen tarkasteluoikeudet ja palvelimen järjestelmänvalvojan on otettava käyttötietojen kerääminen käyttöön palvelimessa. Oletusarvon mukaan palvelimen käyttötietojen kerääminen ei ole käytössä.

Valitse haluamasi toimet

Tarkastele sivuston yhteenvetoraportti

Tiedostojen koskevien raporttien tarkastelu

Jaetun sisällön koskevien raporttien tarkastelu

Saat lisätietoja raporttien tarkasteleminen

Käyttötietojen yhteenveto-raportin tarkasteleminen

Näytä yksityiskohtaiset käyttöraportit

Kaavion käyttö tietojen tulokset

Raportin lajitteleminen

Raportin suodattaminen

Kopioi raportti

Raportin tallentaminen

Sivuston yhteenvetoraportin tarkasteleminen

Sivuston yhteenvetoraportti näyttää yleiskuvan sivustosta. Se sisältää myös linkit tarkemmat tiedot sisältäviin raportteihin. Voit esimerkiksi muodostaa samanlaisen sivuston yhteenvetoraportin kuin seuraavassa kuvassa.

Sivuston yhteenvetoraportti

Voit muodostaa sivuston yhteenvetoraportin seuraavasti:

  1. Avaa Office SharePoint Designer 2007 -ohjelmassa sivusto, josta haluat suorittaa raportin.

  2. Valitse Sivusto-valikosta Raportit ja valitse Sivuston yhteenveto.

    Ohjelma muodostaa raportin.

Huomautus: Nimi-sarakkeen hyperlinkkejä napsauttamalla voit siirtyä yksityiskohtaisempiin raportteihin. Esimerkiksi valitsemalla Katkenneet hyperlinkit voit siirtyä suoraan Katkenneet hyperlinkit -raporttiin.

Sivun alkuun

Tiedostoraportin tarkasteleminen

Voit luoda raportin, jossa näkyvät kaikki tiedostot, viimeksi lisätyt tiedostot, viimeksi muutetut tiedostot tai vanhat tiedostot. Jos esimerkiksi haluat mainostaa uutta sisältöä sivuston aloitussivulla tai sivustoasi esittelevässä uutiskirjeessä, voit etsiä uuden sisällön Viimeksi lisätyt tiedostot -raportin avulla. Vastaavasti voit Vanhat tiedostot -raportin avulla etsiä vanhan sisällön, joka kannattaa tarkistaa ja joko poistaa tai päivittää.

Määritä ennen tiedostoraportin muodostamista viimeksi lisättyjä ja vanhoja tiedostoja koskevat määritykset ja määritä myös, montako kuukautta haluat näkyvän raportissa:

  1. Avaa Office SharePoint Designer 2007 -ohjelmassa Web-sivusto, josta haluat suorittaa raportin.

  2. Valitse Työkalut-valikosta Sovelluksen asetukset.

  3. Valitse Raporttinäkymä-välilehti.

    Raporttinäkymä-välilehti Sovelluksen asetukset -valintaikkunassa

  4. Kirjoita Uusien tiedostojen ikä on enintään -ruutuun, montako päivää vanhat sivut tulkitaan viimeksi lisätyiksi sivuiksi.

  5. Kirjoita Vanhojen tiedostojen ikä on vähintään -ruutuun, montako päivää vanhat sivut tulkitaan vanhoiksi sivuiksi.

  6. Kirjoita Näytettyjä kuukausia -ruutuun, monenko kuukauden kuukausikohtaiset tiedot haluat raporttiin.

  7. Valitse OK.

    Nyt kaikki on valmista raporttien suorittamista varten.

  8. Valitse Sivusto-valikosta Raportit, sitten Tiedostot ja valitse lopuksi haluamasi raportti.

    • Kaikki tiedostot     Kaikki sivuston tiedostot.

    • Viimeksi lisätyt tiedostot     Tiedostot, jotka on lisätty sivustoon vaiheessa 4 määrittämiesi päivien aikana.

    • Viimeksi muutetut tiedostot     Tiedostot, joita on muutettu vaiheessa 4 määrittämiesi päivien aikana.

    • Vanhemmat tiedostot     Tiedostot, jotka ovat vanhempia kuin vaiheessa 5 määritetty aikaraja.

    • Kuittaustila     Sivuston tiedostoluettelo, jossa näkyy myös kunkin tiedoston Kuittaustila. (Tässä raportissa on myös sarakkeet Kuitannut-, Versio- ja Lukitsemisen päivämäärä -tiedoille.)

      Voit raporttinäkymän tiedostoluettelon valintoja napsauttamalla muuttaa nopeasti vanhempia sekä viimeksi lisättyjä ja muutettuja tiedostoja koskevia asetuksia.

      Raporttinäkymä, jossa näkyy tiedoston ikäsuodatinvalikko

Sivun alkuun

Jaettu sisältö -raportin tarkasteleminen

Jaettu sisältö voi sisältää perustyylisivuja, mukautettuja ja muita sivumääritykseen kuuluvia sivuja sekä tyylisivulinkkejä. Jaettu sisältö on helppo löytää Office SharePoint Designer 2007 -ohjelman avulla. Jos esimerkiksi Web-sivusto on muotoiltu perustyylisivuja käyttämällä ja haluat vaihtaa kaikilla sivuilla olevan logon, voit Perustyylisivut-raporttia käyttämällä etsiä kaikki ne perustyylisivut, joiden logon haluat vaihtaa. Tyylisivulinkit-raportin avulla voit lisäksi etsiä kaikki ne tyylisivut, jotka on päivitettävä, kun haluat ottaa käyttöön uuden fontin tai muotoilun sivustossa.

  1. Avaa Office SharePoint Designer 2007 -ohjelmassa Web-sivusto, josta haluat suorittaa raportin.

  2. Valitse Sivusto-valikosta Raportit, sitten Jaettu sisältö ja valitse lopuksi jokin seuraavista raporteista:

    • Dynaamiset Web-mallit     Kaikki sivuston sivut sisältävä luettelo, jonka Dynaaminen Web-malli -sarakkeessa näkyy kunkin sivun kohdalla, onko sivu liitetty dynaamiseen Web-sivuun (ja jos on, niin mihin sivuun).

    • Perustyylisivut     Kaikki sivuston sivut sisältävä luettelo , jonka Perustyylisivu-sarakkeessa näkyy kunkin sivun kohdalla, onko sivu liitetty perustyylivisuun (ja jos on, niin mihin sivuun).

    • Mukautetut sivut     Kaikki sivuston sivut sisältävä luettelo, jonka Mukautettu-sarakkeessa näkyy, onko sivumääritykseen perustuvaa sivua mukautettu.

    • Tyylisivulinkit     Kaikki sivuston sivut sisältävä luettelo, jonka Tyylisivulinkit-sarakkeessa näkyy kunkin sivun kohdalla, onko sivu liitetty tyylisivuun.

      Huomautus: Luettelossa näkyvät tyylisivulinkit ovat staattisia tyylisivulinkkejä (<linkki>-tunnisteita). Microsoft ASP.NET -ohjausobjekteilla luodut dynaamiset tyylisivulinkit (kuten <SharePoint:CssLink>) eivät näy tässä raportissa.

Sivun alkuun

Ongelmaraporttien tarkasteleminen

Office SharePoint Designer 2007 -ohjelman ongelmaraporttien avulla voit ennakoida mahdolliset ongelmat ja korjata ne, ennen kuin ne haittaavat käyttäjiä. Näiden raporttien avulla voit esimerkiksi havaita hitaat sivut ja etsiä katkenneet hyperlinkit sekä tiedostot, jotka voidaan poistaa, koska niitä ei ole linkitetty muihin tiedostoihin. Määritä ennen raporttien suorittamista asetukset siten, että ohjelma voi tunnistaa hitaat sivut.

  1. Avaa Office SharePoint Designer 2007 -ohjelmassa Web-sivusto, josta haluat suorittaa raportin.

  2. Valitse Työkalut-valikosta Sovelluksen asetukset.

  3. Valitse Raporttinäkymä-välilehti.

    Raporttinäkymä-välilehti Sovelluksen asetukset -valintaikkunassa

  4. Kirjoita Hitaiden sivujen latautuminen kestää vähintään -ruutuun kuinka monta sekuntia hitaan sivun latautuminen kestää vähintään.

  5. Kirjoita Yhteyden oletettu nopeus on -ruutuun, mikä on käyttäjien liittymän nopeus keskimäärin (kbit/s).

  6. Valitse OK.

    Nyt kaikki on valmista raporttien suorittamista varten.

  7. Valitse Sivusto-valikosta Raportit, sitten Ongelmat ja valitse jokin seuraavista raporteista:

    • Linkittämättömät tiedostot     Ne sivuston tiedostot, joihin osoittavia linkkejä ei ole. Tämän luettelon avulla voit etsiä käyttämättömät tiedostot, jotka pitäisi poistaa sivustosta. Huomaa, että tämä raportti ei huomioi ASP.NET-ohjausobjektien, kuten Office SharePoint Server 2007 -sivustojen Sisällysluettelo-Web-osan, luomia linkkejä.

    • Hitaat sivut     Luettelo sivustossa olevista sivuista, jotka kohdassa 3 määritetyn latausajan ja kohdassa 4 määritetyn yhteysnopeuden mukaan tulkitaan hitaasti latautuviksi sivuiksi. Huomaa, että tämä raportti näyttää, kauanko sivun merkintäkielikoodin lataaminen kestää. Se ei huomioi ASP.NET-ohjausobjektien luomaa dynaamista sisältöä.

    • Hyperlinkit     Sivuston kaikki hyperlinkit sisältävä luettelo. Kun olet suorittanut tämän raportin, näyttöön tulee kehote, jossa kysytään, haluatko tarkistaa sivuston hyperlinkit. Valitse Kyllä, jos haluat Office SharePoint Designer 2007 -ohjelman tarkistavan kaikki hyperlinkit. Tuloksena on luettelo, jossa kunkin hyperlinkin kohdalla on merkintä OK tai Katkennut. Jos haluat muokata hyperlinkkiä, valitse linkki raportista ja napsauta sitten Muokkaa hyperlinkkiä -painiketta työkalurivillä, joka tulee näkyviin asiakirjaikkunan oikeaan yläkulmaan raporttinäkymässä.

      Huomautus:  Muokkaa hyperlinkkiä -valintaikkuna

    • Komponenttivirheet     Sellaisten komponenttien – kuten interaktiiviset painikkeet tai laskurit (joista käytetään yhteistä nimeä webbot- tai bot-komponentit) – luettelo, jotka aiheuttavat virheitä. Jos haluat tarkastella Web-komponenttien luetteloa, valitse Lisää-valikosta Web-komponentit.

Sivun alkuun

Käyttötietojen yhteenveto -raportin tarkasteleminen

Sivuston käyttötietoraportit auttavat vastaamaan sellaisiin sivuston omistajien esittämiin kysymyksiin, kuten montako henkilöä käyttää sivustoa, mitkä ovat suosituimmat resurssit, kuka käyttää sivustoa eniten ja mistä kävijät tulevat sivustoon. Käyttötietojen yhteenveto -raportissa näkyy esimerkiksi käyntien, osumien ja ladattujen tavujen määrä.

Käyttötietojen yhteenveto -raportti

Voit suorittaa Käyttötietojen yhteenveto -raportin seuraavasti:

  1. Avaa Office SharePoint Designer 2007 -ohjelmassa Web-sivusto, josta haluat suorittaa raportin.

  2. Valitse Sivusto-valikosta Raportit, valitse Käyttö ja sitten Käyttötietojen yhteenveto.

    Ohjelma muodostaa raportin. Voit tarkastella yksityiskohtaisia raportteja napsauttamalla Nimi-sarakkeen hyperlinkkejä.

Sivun alkuun

Yksityiskohtaisten käyttötietoraporttien tarkasteleminen

Voit suorittaa yksityiskohtaisia käyttötietoraportteja, kun haluat vastauksia sivuston käyttöä koskeviin kysymyksiin. Yllä suoritettu Käyttötietojen yhteenveto -raportti sisältää osumien kokonaismäärän, mutta Kuukausittaiset osumat -raportista näkyy sivuston kunkin sivun osumien määrä. Voit suorittaa yksityiskohtaiset käyttötietoraportit seuraavasti:

  1. Avaa Office SharePoint Designer 2007 -ohjelmassa Web-sivusto, josta haluat suorittaa raportin.

  2. Valitse Sivusto-valikosta Raportit, sitten Käyttö ja valitse jokin seuraavista raporteista:

    • Kuukausittainen yhteenveto     Yhteenveto, joka sisältää seuraavat kuukausittaiset tiedot sivustosta: vierailut, osumat, osumat yhteensä ja ladattujen tiedostojen koko.

    • Viikoittainen yhteenveto     Yhteenveto, joka sisältää seuraavat viikoittaiset tiedot sivustosta: vierailut, osumat, osumat yhteensä ja ladattujen tiedostojen koko.

    • Päivittäinen yhteenveto     Yhteenveto, joka sisältää seuraavat päivittäiset tiedot sivustosta: vierailut, osumat, osumat yhteensä ja ladattujen tiedostojen koko.

    • Kuukausittaiset osumat     Web-sivuston kunkin sivun osumien yhteismäärä ja osumat kuukausittain.

    • Viikoittaiset osumat     Web-sivuston kunkin sivun osumien yhteismäärä ja osumat viikoittain.

    • Päivittäiset osumat     Web-sivuston kunkin sivun osumien yhteismäärä ja osumat päivittäin.

    • Käyttäjät     Sivustossa vierailleiden käyttäjien määrä yhteensä ja valitun kuukauden prosenttiosuus kokonaismäärästä.

    • Käyttöjärjestelmät     Sivustossa vierailleiden käyttäjien määrä käyttöjärjestelmittäin ja valitun kuukauden prosenttiosuudet kokonaismääristä.

    • Selaimet     Sivustossa vierailleiden käyttäjien määrä selaimittain ja valitun kuukauden prosenttiosuudet kokonaismääristä.

    • Viittaavat toimialueet     Sivustossa vierailleiden käyttäjien määrä toimialueittain ja valitun kuukauden prosenttiosuudet kokonaismääristä.

    • Viittaavat URL-osoitteet     Vierailujen määrät tietystä URL-osoitteesta ja valitun kuukauden prosenttiosuudet kokonaismääristä.

    • Etsintämerkkijonot     Sivuston hakuruutuun kirjoitettujen eri etsintämerkkijonojen määrät ja valitun kuukauden prosenttiosuudet kokonaismääristä.

Sivun alkuun

Kaavion tekeminen käyttötiedoista

Voit luoda helposti kaavion, jossa käyttötiedot näkyvät graafisessa muodossa. Tämä helpottaa trendien ja käyttötapojen havaitsemista.

  1. Valitse Sivusto-valikosta Raportit, sitten Käyttö ja valitse haluamasi raportti.

  2. Valitse asiakirjaikkunan oikeassa yläkulmassa olevan työkalurivin Kaavio-luettelosta kaavio, jonka haluat luoda, esimerkiksi Pylväskaavio.

    Raporttinäkymän työkalurivi, jolla näkyy Kaavio-luettelo

    Raportti avautuu uudessa ikkunassa.

    Käyttötietoraportti

    Huomautus: Oletusarvon mukaan ohjelma luo kaavion samalla kuin se luo käyttötietoraportin. Jos et löydä kaavion tietoja, kun yrität suorittaa raportin, valitse Työkalut-valikosta Sovelluksen asetukset, sitten Raporttinäkymä-välilehti ja varmista, että Sisällytä kaavio, kun käyttöraportti tallennetaan -valintaruutu on valittuna.

Sivun alkuun

Raportin lajitteleminen

Voit lajitella raportin raporttinäkymässä sarakeotsikoita napsauttamalla.

Sivun alkuun

Raportin suodattaminen

Voit valita tuloksista vain ne tiedot, jotka haluat nähdä. Voit suodattaa joko yhden sarakkeen mukaan tai luoda progressiivisen suodattimen suodattamalla usean sarakkeen mukaan.

  1. Valitse Sivusto-valikosta Raportit ja valitse sitten haluamasi raportti.

  2. Napsauta suodatettavan sarakkeen otsikon vieressä olevaa nuolta ja valitse tiedot, joiden mukaan haluat suodattaa.

    Jos esimerkiksi haluat suodattaa tiedostotyypin mukaan, napsauta Tyyppi-sarakkeen otsikon vieressä olevaa nuolta. Valitse sitten bmp, jos haluat raporttiin näkyviin vain bittikarttatiedostot.

    Tyyppi-sarake, jossa näkyy suodatinvalikko

  3. Jos haluat suodattaa usean sarakkeen mukaan, toista vaihe 2 kunkin sarakkeen kohdalla.

  4. Jos haluat luoda sarakkeeseen mukautetun suodattimen, napsauta sarakeotsikon vieressä olevaa nuolta ja valitse (Mukautettu). Kirjoita hakuehdot ja valitse OK.

    Omaa pikasuodatinta käyttämällä voit esimerkiksi etsiä sivustossa olevat .bmp- ja .gif-kuvatiedostot

    Oma pikasuodatus -valintaikkuna

  5. Jos haluat poistaa kaikki suodattimet sarakkeesta, napsauta sarakeotsikon vieressä olevaa nuolta ja valitse (Kaikki).

Huomautus: Valittuna olevat suodatinasetukset tallentuvat, kun suljet sivuston. Jos et näe tiedostoja, kun suoritat raportin uudelleen, edellisen istunnon aikana käyttämäsi suodattimet ehkä piilottavat etsimäsi tiedostot.

Jos haluat poistaa kaikki suodattimet raportista, napsauta jotakin sarakeotsikkoa hiiren kakkospainikkeella ja valitse pikavalikosta Poista suodattimet.

Sivun alkuun

Raportin kopioiminen

Kun olet suorittanut raportin, haluat ehkä kopioida tulokset ja liittää ne sähköpostiviestiin tai muuhun tiedostoon (kuten Microsoft Office Excel -laskentataulukkoon). Voit kopioida minkä tahansa raportin Sivuston yhteenveto -raporttia lukuun ottamatta.

  1. Napsauta suorittamasi raportin mitä tahansa sarakeotsikkoa hiiren kakkospainikkeella ja valitse pikavalikosta Kopioi raportti.

    Nimi-sarake-valikko, jossa Kopioi raportti -komento on valittuna

  2. Tietojen liittäminen tiedostoon tai viestiin

Sivun alkuun

Raportin tallentaminen

Voit tallentaa raportit, jos haluat Microsoft Office Excel 2007 -ohjelmaa käyttämällä tarkastella ja analysoida tuloksia tai luoda niistä mukautettuja kaavioita ja kuvaajia.

  1. Valitse Sivusto-valikosta Raportit ja valitse haluamasi raportti.

  2. Valitse Tiedosto-valikosta Tallenna tai paina CTRL+S.

  3. Kirjoita raportin nimi Tiedoston nimi -ruutuun ja valitse sitten Tallenna. Ohjelma tallentaa raportin sivustoon .htm-tiedostona.

    Raportti avoinna Excelissä

  4. Voit avata raportin kaksoisnapsauttamalla sitä.

    Raportti avautuu Office Excel 2007 -ohjelmassa.

Sivun alkuun

Huomautus: Konekäännöksestä ilmoittava vastuusvapauslauseke: Tämä artikkeli on käännetty tietokonejärjestelmällä, eikä kieliasiantuntija ole muokannut sitä. Microsoft tarjoaa nämä konekäännökset avuksi muille kuin englantia puhuville käyttäjille, jotta he saavat lisätietoja Microsoftin tuotteista, palveluista ja tekniikoista. Koska artikkeli on koneellisesti käännetty, se saattaa sisältää sanasto-, lauseoppi- ja kielioppivirheitä.

Kehitä taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×