Sisäkkäisiä osia sisältävän kaavan laskeminen vaihe kerrallaan

Huomautus:  Microsoft haluaa tarjota sinulle ajantasaisinta ohjesisältöä mahdollisimman nopeasti omalla kielelläsi. Tämä sivu on käännetty automaation avulla, ja siinä saattaa olla kielioppivirheitä tai epätarkkuuksia. Tarkoitus on, että sisällöstä on sinulle hyötyä. Kertoisitko sivun alareunassa olevan toiminnon avulla, oliko tiedoista hyötyä? Tästä pääset helposti artikkelin englanninkieliseen versioon .

Joskus tietoja siitä, miten sisäkkäisiä kaava laskee lopputuloksen on vaikeaa koska tilikaudessa on useita laskutoimituksissa ja looginen testit. Kuitenkin Kaavan valintaikkunan avulla voit nähdä järjestyksessä kaava laskee sisäkkäisen kaavan eri osat. Esimerkiksi kaava =Jos(keskiarvo(F2:F5) > 50,summa(G2:G5),0) on helpompi hahmottaa, kun näet keskitason seuraavat tulokset:

Valintaikkunassa näkyvät vaiheet:

Kuvaus

=JOS(KESKIARVO(F2:F5)>50;SUMMA(G2:G5);0)

Sisäkkäisiä osia sisältävä kaava näkyy ensimmäiseksi. KESKIARVO-funktio ja SUMMA-funktio ovat JOS-funktion sisällä.

=JOS(40>50,SUMMA(G2:G5),0)

Solualue F2: F5 sisältää arvot 55, 35, 45 ja 25 ja joten funktion keskiarvo(F2:F5) tulos on 40.

=JOS(EPÄTOSI,SUMMA(G2:G5),0)

40 ei ole suurempi kuin 50, joten jos (totuus_testi-argumentti)-funktion ensimmäisen argumentin lauseke on EPÄTOSI.

0

Jos-funktio palauttaa arvon kolmas argumentti (arvo_jos_epätosi-argumentti). Summa-funktiota ei lasketa, koska se on toinen argumentti (arvo_jos_epätosi-argumenttia) Jos-funktion ja palauttaa vain silloin, kun lauseke on TOSI.

  1. Valitse laskettava solu. Vain yksi solu voidaan laskea kerrallaan.

  2. Valitse sitten Kaavat-välilehden Kaavan tarkistaminen -ryhmässä Kaavan laskeminen.

    Kaavat-välilehden Kaavan tarkistaminen -ryhmä

  3. Tarkista alleviivatun viittauksen arvo valitsemalla Laske. Laskennan tulos näkyy kursivoituna.

    Jos kaavan alleviivattu osa on viittaus toiseen kaavaan, valitsemalla Suorita rivi voit näyttää toisen kaavan Laskeminen-ruudussa. Voit palata takaisin edelliseen soluun ja kaavaan valitsemalla Suorita toimintosarja loppuun.

    Huomautus: Suorita rivi -painike ei ole käytettävissä viittausta varten, jos viittaus on kaavassa toiseen kertaan tai jos kaava viittaa jonkin muun työkirjan soluun.

  4. Jatka, kunnes olet laskenut kaavan jokaisen osan.

  5. Jos haluat nähdä laskennan uudelleen, valitse Aloita alusta.

    Lopeta laskenta valitsemalla Sulje.

    Huomautukset: 

    • Jos ja valitse indeksi-funktioita käyttävien kaavojen osia ei lasketa ja Laskenta -ruudussa näkyy #puuttuu!.

    • Jos viittaus on tyhjä, Laskenta-ruudussa näkyy nolla-arvo (0).

    • Kaavat, joissa on Kehäviittaukset eivät ehkä Laske odotetulla tavalla. Tarvittaessa kehäviittaukset voit Salli iteratiivinen laskenta.

    • Seuraavat funktiot lasketaan uudelleen aina, kun laskentataulukko muuttuu, joten voit antaa eri tuloksen kuin solussa näkyy Kaavan laskeminen -työkalun: SATUNNAISLUKU, siirtymä, solu, epäsuora, nyt, tänään, SATUNNAISLUKU.väliltä, tiedot ja summa.Jos (-osa skenaariot).

Kehitä Office-taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×