Sisäkkäisiä osia sisältävän kaavan laskeminen vaihe kerrallaan

Joskus voi olla vaikeaa ymmärtää, kuinka Excel laskee sisäkkäisiä osia sisältävän kaava, koska se joutuu laskemaan useita välituloksia ja tekemään loogisia testejä. Käyttämällä Kaavan laskeminen -valintaikkunaa voit kuitenkin nähdä, missä järjestyksessä Excel laskee kaavan eri osat. Esimerkiksi kaava = jos (Keski arvo (F2: F5) >50, SUM (G2: G5), 0) on helpompi ymmärtää, kun näet seuraavat väli tulokset:

Valintaikkunassa näkyvät vaiheet:

Kuvaus

=JOS(KESKIARVO(F2:F5)>50;SUMMA(G2:G5);0)

Sisäkkäisiä osia sisältävä kaava näkyy ensimmäiseksi. KESKIARVO-funktio ja SUMMA-funktio ovat JOS-funktion sisällä.

=JOS(40>50,SUMMA(G2:G5),0)

Solualue F2:F5 sisältää arvot 55, 35, 45 ja 25, joten funktion KESKIARVO(F2:F5) tulos on 40.

=JOS(EPÄTOSI,SUMMA(G2:G5),0)

40 ei ole suurempi kuin 50, joten jos-funktion ensimmäisen argumentin (logical_test-argumentin) ensimmäinen argumentti on EPÄTOSI.

0

JOS-funktio palauttaa kolmannen argumentin arvon (arvo_jos_epätosi-argumentti). Summa-funktiota ei lasketa, koska se on jos-funktion toinen argumentti (value_if_true-argumentti) ja se palautetaan vain silloin, kun lauseke on tosi.

  1. Valitse laskettava solu. Vain yksi solu voidaan laskea kerrallaan.

  2. Valitse sitten Kaavat-välilehden Kaavan tarkistaminen -ryhmässä Kaavan laskeminen.

    Kaavat-välilehden Kaavan tarkistaminen -ryhmä

  3. Tarkista alleviivatun viittauksen arvo napsauttamalla Laske. Laskennan tulos näkyy kursivoituna.

    Jos kaavan alleviivattu osa on viittaus toiseen kaavaan, valitsemalla Suorita rivi voit näyttää toisen kaavan Laskeminen-ruudussa. Voit palata takaisin edelliseen soluun ja kaavaan valitsemalla Suorita toimintosarja loppuun.

    Huomautus: Suorita rivi -painike ei ole käytettävissä viittausta varten, jos viittaus on kaavassa toiseen kertaan tai jos kaava viittaa jonkin muun työkirjan soluun.

  4. Jatka, kunnes olet laskenut kaavan jokaisen osan.

  5. Jos haluat nähdä laskennan uudelleen, valitse Aloita alusta.

    Lopeta laskenta valitsemalla Sulje.

    Huomautukset: 

    • Jos-ja valitse-funktioita käyttävien kaavojen osia ei lasketa, ja #N/A näkyy arviointi -ruudussa.

    • Jos viittaus on tyhjä, Laskenta-ruudussa näkyy nolla-arvo (0).

    • Kehä viittauksia sisältävät kaavat eivät ehkä Laske oikein. Jos haluat käyttää kehä viittauksia, voit ottaa iteratiivisen laskennan käyttöön.

    • Seuraavat funktiot lasketaan uudelleen aina, kun laskenta taulukko muuttuu, ja voi aiheuttaa kaavan laskeminen-työkalun näyttämään erilaiselta kuin solussa näkyvä tulos: SATUNNAISLUKU, siirtymä, solu, epäsuora, nyt, tänään, RANDBETWEEN, info ja summa. Jos (joissakin skenaariot).

Huomautus:  Tämä sivu on käännetty automaation avulla, ja siinä saattaa olla kielioppivirheitä tai epätarkkuuksia. Tarkoitus on, että sisällöstä on sinulle hyötyä. Kerrotko meille, oliko tiedoista hyötyä? Tästä pääset artikkelin englanninkieliseen versioon.

Katso myös

Viallisten kaavojen ratkaiseminen

Kehitä Office-taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×