Kaavat ja funktiot

SUMMA (SUMMA-funktio)

SUMMA (SUMMA-funktio)

SUMMA-funktio on yksi matemaattisista ja trigonometrisista funktiosta. Se laskee arvot yhteen. Voit lisätä yksittäisiä arvoja, soluviittauksia tai -alueita tai näiden kaikkien kolmen yhdistelmän.

Esimerkki:

  • =SUMMA(A2:A10)

  • =SUMMA(A2:A10, C2:C10)

Selaimesi ei tue videotoimintoa. Asenna Microsoft Silverlight, Adobe Flash Player tai Internet Explorer 9.

SUMMA(luku1,[luku2],...)

Argumentin nimi

Kuvaus

luku1    . (Pakollinen)

Ensimmäinen yhteenlaskettava luku. Luku voi olla esimerkiksi 4, soluviittaus, kuten B6, tai solu, alue, kuten B2:B8.

luku2–255    (Valinnainen)

Tämä on toinen yhteenlaskettava luku. Voit määrittää tällä tavalla enintään 255 lukua.

Tässä osassa käydään läpi SUMMA-funktion käyttöön liittyviä parhaita käytäntöjä. Näistä monia voi soveltaa myös muiden funktioiden käyttöön.

Menetelmä =1+2 tai =A+B: Vaikka syöttämällä =1+2+3 tai =A1+B1+C2 saa tarkkoja tuloksia, nämä menetelmät ovat virhealttiita useista syistä:

  1. Kirjoitusvirheet: kuvittele, millaista on syöttää useita ja/tai paljon suurempia arvoja, kuten

    • =14598,93+65437,90+78496,23

    Yritä sen jälkeen vahvistaa, että olet syöttänyt oikeat tiedot. On paljon helpompaa syöttää arvot omiin soluihinsa ja käyttää SUMMA-kaavaa. Voit lisäksi muotoilla arvot, kun ne ovat soluissa, jolloin ne ovat paljon luettavammassa muodossa kuin kaavassa.

    Käytä SUMMA-funktiota sen sijaan, että koodaat arvot kiinteästi kaavoihin.  Solussa D5 oleva kaava on =SUMMA(D2:D4)
  2. #ARVO! -virheet viitattaessa tekstiin numeroiden sijasta

    Jos käytät esimerkiksi seuraavanlaista kaavaa:

    • =A1+B1+C1 tai =A1+A2+A3

    Esimerkki kaavan huonosta rakenteesta.  Solussa D2 oleva kaava on =A2+B2+C2

    Kaava voi rikkoutua, jos viitatuissa soluissa on muita kuin numeroarvoja (tekstiä). Tällöin tuloksena on #ARVO!-virhe. SUMMA-funktio ohittaa tekstiarvot ja ilmoittaa vain numeeristen arvojen summan.

    Kaavan oikea rakenne  Kaavan =A2+B2+C2 sijasta solun D2 kaava on =SUMMA(A2:C2)
  3. #VIITTAUS! -virhe rivien tai sarakkeiden poistamisen takia

    Sarakkeen poistamisesta johtuva #VIITTAUS!-virhe.  Kaava on muuttunut muotoon =A2+#VIITTAUS!+B2

    Jos poistat rivin tai sarakkeen, kaava ei päivity ja sulje pois poistettua riviä. Tuloksena on #VIITTAUS! -virhe. SUMMA-funktio sen sijaan päivittyy automaattisesti.

    SUMMA-funktio säätyy automaattisesti lisättyjen tai poistettujen rivien ja sarakkeiden mukaan.
  4. Kaavat eivät päivitä viittauksia lisättäessä rivejä tai sarakkeita

    Muodossa =A+B+C olevat kaavat eivät päivity, kun rivejä lisätään.

    Jos lisäät rivin tai sarakkeen, kaava ei päivity ja sisällytä lisättyä riviä. SUMMA-funktio puolestaan päivittyy automaattisesti (kunhan olet kaavassa viitatulla alueella). Tämä on erityisen tärkeää, jos oletat, että kaava päivittyy mutta se ei päivitykään. Tällöin saat puutteelliset tulokset, mikä saattaa jäädä huomaamatta.

    Esimerkissä kuvataan SUMMA-kaava, joka laajenee automaattisesti muodosta =SUMMA(A2:C2) muotoon =SUMMA(A2:D2), kun sarake lisätään.
  5. SUMMA ja yksittäiset soluviittaukset vs. alueet

    Seuraavanlaisen kaavan käyttäminen:

    • =SUMMA(A1,A2,A3,B1,B2,B3)

    Tällainen kaava on yhtä virhealtis lisättäessä tai poistettaessa rivejä viitatulta alueelta samoista syistä. On paljon parempi käyttää yksittäisiä alueita, kuten:

    • =SUMMA(A1:A3,B1:B3)

    Ne päivittyvät, kun rivejä lisätään tai poistetaan.

Ongelma

Mikä meni vikaan

SUMMA-funktioni ei näytä tulosta, vaan merkkijonon #####.

Tarkista sarakeleveydet. ##### tarkoittaa yleensä, että sarake on niin kapea, ettei kaavan tulos mahdu siihen.

SUMMA-funktio näyttää kaavan itsensä tekstinä, ei tulosta.

Tarkista, ettei solua ole muotoiltu tekstiksi. Valitse kyseinen solu tai solualue ja paina Ctrl + 1, jolloin Muotoile solut -valintaikkuna avautuu, valitse Luku-välilehti ja valitse haluamasi muoto. Jos solu on muotoiltu tekstiksi eikä se muutu, kun muutat muotoilua, pakota muotoilun muutos painamalla F2 > Enter.

SUMMA-funktioni ei päivity.

Varmista, että Laskenta-asetukseksi on määritetty Automaattinen. Siirry Kaava-välilehdessä kohtaan Laskenta-asetukset. Voit myös pakottaa laskentataulukon laskennan painamalla F9.

Varmista, että laskennan asetukseksi on määritetty Automaattinen.  Siirry Kaava-välilehdessä kohtaan Laskenta-asetukset.

Joitakin arvoja ei lisätä.

Ainoastaan funktioviittauksen tai -alueen numeeriset arvot voidaan lisätä. Tyhjät solut, totuusarvot (kuten TOSI) ja teksti ohitetaan.

Virhe #NIMI? tulee näkyviin odotetun tuloksen sijaan.

Tämä tarkoittaa yleensä, että kaavassa on kirjoitusvirhe, kuten =sume(A1:A10) kaavan =SUMMA(A1:A10) sijaan.

SUMMA-funktioni näyttää kokonaisluvun, mutta sen pitäisi näyttää desimaaleja

Varmista, että desimaalien näyttö on käytössä solumuotoilussa. Valitse kyseinen solu tai solualue ja painamalla Ctrl+1, jolloin Muotoile solut -valintaikkuna avautuu, valitse Luku-välilehti ja valitse haluamasi muoto. Varmista, että määrität haluamasi desimaalien määrän.

  1. Haluan vain lisätä/vähentää/kertoa/jakaa lukuja Katso videosarja Excelin matemaattiset perustoiminnot tai Excelin käyttäminen laskimena.

  2. Miten voin näyttää enemmän tai vähemmän desimaaleja? Voit muuttaa lukumuotoilua. Valitse kyseinen solu tai solualue ja painamalla Ctrl+1, jolloin Muotoile solut -valintaikkuna avautuu, valitse Luku-välilehti ja valitse haluamasi muoto. Varmista, että määrität haluamasi desimaalien määrän.

  3. Miten aikoja lasketaan yhteen tai vähennetään? Voit laskea yhteen ja vähentää aikamääriä muutamilla eri tavoilla. Jos esimerkiksi haluaisit palkanlaskua varten laskea erotuksen välillä 8.00–12.00, käyttäisit kaavaa =("12.00"-"8.00")*24, eli vähentäisit päättymisajasta alkamisajan. Huomaa, että Excel laskee ajat vuorokauden murto-osina, joten tuntien määrän saamiseksi on käytettävä kertoimena arvoa 24. Ensimmäisessä esimerkissä lasketaan kaavan =((B2-A2)+(D2-C2))*24 avulla yhteen tunnit alusta loppuun ilman lounastaukoa (yhteensä 8.50 tuntia).

    Jos vain lasket yhteen tunteja ja haluat näyttää laskutoimituksen niin, voit käyttää yhteenlaskua ilman kerrointa 24. Siksi toisessa esimerkissä käytetään kaavaa =SUMMA(A6:C6), koska annetuista tehtävistä tarvitaan vain tuntien ja minuuttien kokonaismäärä (5.36 tai 5 tuntia 36 minuuttia).

    Aikojen laskeminen

    Lisätietoja on seuraavissa artikkeleissa: Ajan lisääminen tai vähentäminen.

  4. Miten voi laskea päivämäärien välisen eron? Voit laske yhteen ja vähentää päivämääriä kellonaikojen tapaan. Seuraavassa on hyvin yleinen esimerkki kahden päivämäärän välisten päivien määrän laskennasta. Kaava on yksinkertainen: =B2-A2. Avain sekä päivämäärien että kellonaikojen laskemiseen on, että aloitetaan päättymispäivästä tai -ajasta ja vähennetään siitä alkamispäivä tai -aika.

    Päivämääräerojen laskemisen

    Lisätietoja päivämäärien laskennasta on seuraavissa artikkeleissa: Kahden päivämäärän välisen eron laskeminen.

  5. Miten lasken yhteen vain näkyvät solut? Joskus, kun piilotat rivejä manuaalisesti tai näytät vain tietyt tiedot Pikasuodata-toiminnon avulla, voit halutessasi myös laskea yhteen vain näkyvät solut. Voit käyttää VÄLISUMMA-toimintoa. Jos käytät Excel-taulukossa summariviä, mikä tahansa avattavasta Summa-valikosta valitsemasi funktio syötetään automaattisesti välisummaksi. Lisätietoja on artikkelissa Excel-taulukon tietojen laskeminen yhteen.

Tarvitsetko lisätietoja?

Voit aina kysyä neuvoa Excel Tech Community -yhteisön asiantuntijalta, saada tukea yhteisön vastauksista tai ehdottaa uutta ominaisuutta tai parannusta Excel User Voice -sivustolla.

Katso myös

Lisätietoja SUMMA-funktiosta

SUMMA.JOS-funktio laskee yhteen ainoastaan yhden ehdon täyttävät arvot

SUMMA.JOS.JOUKKO-funktio laskee yhteen ainoastaan useita ehtoja täyttävät arvot

LASKE.JOS-funktio laskee ainoastaan yhden ehdon täyttävät arvot

LASKE.JOS.JOUKKO-funktio laskee ainoastaan useita ehtoja täyttävät arvot

Yleiskuva kaavoista Excelissä

Viallisten kaavojen ratkaiseminen

Kaavojen virheiden etsiminen ja korjaaminen

Excel for Windowsin pikanäppäimet

Excel for Macin pikanäppäimet

Matemaattiset ja trigonometriset funktiot

Excelin funktiot (aakkosjärjestyksessä)

Excelin funktiot (luokittain)

Kehitä Office-taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×