SUMMA.JOS (SUMMA.JOS-funktio)

SUMMA.JOS (SUMMA.JOS-funktio)

SUMMA.JOS-funktiolla lasketaan määrittämäsi ehdot täyttävän alue:n arvojen summa. Jos esimerkiksi haluat laskea lukuja sisältävässä sarakkeessa vain 5:tä suuremmat summat, käytä seuraavaa kaavaa: =SUMMA.JOS(B2:B25,">5")

Selaimesi ei tue videotoimintoa. Asenna Microsoft Silverlight, Adobe Flash Player tai Internet Explorer 9.

Tämä video on osa Lukujen laskeminen yhteen Excel 2013:ssa -harjoituskurssia.

Vihjeitä: 

  • Voit halutessasi käyttää ehtoja yhdelle alueelle ja laskea eri alueen vastaavien arvojen summan. Esimerkiksi kaava =SUMMA.JOS(B2:B5;"John";C2:C5) laskee vain niiden alueen C2:C5 solujen summan, joita vastaavien solujen arvo alueella B2:B5 on "John".

  • Jos haluat laskea solujen summan useiden ehtojen perusteella, lue ohjeaihe SUMMA.JOS.JOUKKO-funktio.

Syntaksi

SUMMA.JOS(alue; ehdot; [summa-alue])

SUMMA.JOS-funktion syntaksilla on seuraavat argumentit:

  • alue    Pakollinen. Solualue, jonka haluat arvioida ehtojen mukaan. Kunkin alueen solujen on sisällettävä lukuja tai lukuja sisältäviä nimiä, matriiseja tai viittauksia. Funktio ohittaa tyhjät arvot ja tekstiarvot. Valittu alue voi sisältää päivämääriä, jotka ovat Excelin vakiomuodossa (esimerkkejä alla).

  • ehdot    Pakollinen. Ehtojen muoto on luku, lauseke, soluviittaus, teksti tai funktio, joka määrittää yhteenlaskettavat solut. Ehdot-argumentti voidaan esittää seuraavissa muodoissa: 32, ">32", B5, "32", "omenat" tai TÄMÄ.PÄIVÄ().

    Tärkeää: Mikä tahansa tekstiehto tai loogisia tai matemaattisia symboleita sisältävä ehto on sijoitettava lainausmerkkien (") sisään. Jos ehto on numeerinen, lainausmerkkejä ei tarvita.

  • summa-alue    Valinnainen. Todelliset lisättävät solut, jos halutaan lisätä muut kuin alue-argumentissa määritetyt solut. Jos summa-alue-argumenttia ei anneta, Excel lisää alue-argumentissa määritetyt solut (samat solut, joille ehtoja käytetään).

  • Voit käyttää ehdot-argumentissa yleismerkkejä, eli kysymysmerkkiä (?) ja tähteä (*). Kysymysmerkki vastaa mitä tahansa yksittäistä merkkiä, ja tähti vastaa mitä tahansa merkkijonoa. Jos haluat löytää tekstissä olevan kysymysmerkin tai tähden, kirjoita tilde (~) ennen merkkiä.

Huomautuksia

  • SUMMA.JOS-funktio palauttaa vääriä tuloksia, kun sillä etsitään yli 255-merkkisiä merkkijonoja tai #ARVO!-merkkijonoja.

  • Summa-alue -argumentin ei tarvitse olla kooltaan tai muodoltaan samanlainen kuin alue-argumentti. Lisättävät solut määritetään käyttämällä summa-alue-argumentin vasemmassa yläkulmassa olevaa solua ensimmäisenä soluna ja valitsemalla sitten solut, joiden koko ja muoto vastaavat alue-argumenttia. Esimerkki:

Jos alue on

Ja summa-alue on

Lisättävät solut ovat

A1:A5

B1:B5

B1:B5

A1:A5

B1:B3

B1:B5

A1:B4

C1:D4

C1:D4

A1:B4

C1:C2

C1:D4

Jos SUMMA.JOS-funktion alue- ja summa-alue-argumenteissa on eri määrä soluja, työkirjan uudelleenlaskenta voi kestää odotettua kauemmin.

Esimerkkejä

Esimerkki 1

Kopioi esimerkkitiedot seuraavaan taulukkoon ja lisää se uuden Excel-laskentataulukon soluun A1. Kaavat näyttävät tuloksia, kun valitset ne, painat F2-näppäintä ja sitten Enter-näppäintä. Voit säätää sarakkeiden leveyttä, että näet kaikki tiedot.

Kiinteistön hinta

Välityspalkkio

Tiedot

100 000,00 €

7 000,00 €

250 000,00 €

200 000,00 €

14 000,00 €

300 000,00 €

21 000,00 €

400 000,00 €

28 000,00 €

Kaava

Kuvaus

Tulos

=SUMMA.JOS(A2:A5;">160000";B2:B5)

Yli 160 000 maksavien kiinteistöiden myyntipalkkioiden summa.

63 000,00 €

=SUMMA.JOS(A2:A5;">160000")

Yli 160 000 maksavien kiinteistöjen arvojen summa.

900 000,00 €

=SUMMA.JOS(A2:A5;300000;B2:B5)

Yli 300 000 maksavien kiinteistöiden myyntipalkkioiden summa.

21 000,00 €

=SUMMA.JOS(A2:A5;">" & C2;B2:B5)

Yli solussa C2 olevan arvon maksavien kiinteistöiden myyntipalkkioiden summa.

49 000,00 €

Esimerkki 2

Kopioi esimerkkitiedot seuraavaan taulukkoon ja lisää se uuden Excel‑laskentataulukon soluun A1. Kaavat näyttävät tuloksia, kun valitset ne, painat F2-näppäintä ja sitten Enter-näppäintä. Voit säätää sarakkeiden leveyttä, jotta näet kaikki tiedot.

Luokka

Ruoka

Myynti

Vihannekset

Tomaatit

2 300,00 €

Vihannekset

Sellerit

5 500,00 €

Hedelmät

Appelsiinit

800,00 €

Voi

400,00 €

Vihannekset

Porkkanat

4 200,00 €

Hedelmät

Omenat

1 200,00 €

Kaava

Kuvaus

Tulos

=SUMMA.JOS(A2:A7;"Hedelmät";C2:C7)

Kaikkien Hedelmät-luokassa olevien ruokien myynnin summa.

2 000,00 €

=SUMMA.JOS(A2:A7;"Vihannekset";C2:C7)

Kaikkien Vihannekset-luokassa olevien ruokien myynnin summa.

12 000,00 €

=SUMMA.JOS(B2:B7;"*at";C2:C7)

Kaikkien kirjaimiin "at" (Porkkanat ja Omenat) päättyvien elintarvikkeiden myynnin summa.

4 300,00 €

=SUMMA.JOS(A2:A7;"";C2:C7)

Kaikkien sellaisten elintarvikkeiden summa, joilla ei ole luokkaa määritettynä.

400,00 €

Sivun alkuun

Onko sinulla jokin funktioihin liittyvä kysymys?

Lähetä kysymys Excel-yhteisön keskustelupalstalle

Auta meitä parantamaan Exceliä

Onko sinulla ehdotuksia, miten voimme parantaa seuraavaa Excel-versiota? Jos on, lue aiheet Excel User Voice -palvelussa.

Tutustu myös seuraaviin ohjeaiheisiin

SUMMA.JOS.JOUKKO-funktio laskee yhteen kaikki useita ehtoja täyttävät argumentit

NELIÖSUMMA-funktio laskee yhteen useita arvoja suoritettuaan jokaiselle niistä matemaattisen neliölaskutoimituksen

LASKE.JOS-funktio laskee ainoastaan yhden ehdon täyttävät arvot

LASKE.JOS.JOUKKO-funktio laskee ainoastaan useita ehtoja täyttävät arvot

JOS.JOUKKO-funktio (Office 365, Excel 2016 ja uudempi versio)

Yleiskuva kaavoista Excelissä

Viallisten kaavojen ratkaiseminen

Kaavoissa esiintyvien virheiden etsiminen

Matemaattiset ja trigonometriset funktiot

Excelin funktiot (aakkosjärjestyksessä)

Excelin funktiot (luokittain)

Kehitä taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×