SUMMA.JOS/SUMMA.JOS.JOUKKO-funktion #ARVO!-virheen korjaaminen

Tässä artikkelissa luetellaan #ARVO!-virheen yleiset syyt SUMMA.JOS- ja SUMMA.JOS.JOUKKO-funktioissa sekä niiden ratkaiseminen.

Ongelma: Kaava viittaa suljetussa työkirjassa oleviin soluihin

SUMMA.JOS/SUMMA.JOS.JOUKKO-funktiot, jotka viittaavat suljetussa työkirjassa olevaan soluun tai solualueeseen, aiheuttavat #ARVO!-virheen.

Huomautus: Tämä on tunnettu ongelma useiden muiden Excel-funktioiden, kuten LASKE.JOS-, LASKE.JOS.JOUKKO- ja LASKE.TYHJÄT-funktioiden kohdalla. Katso lisätietoja artikkelista SUMMA.JOS-, LASKE.JOS- ja LASKE.TYHJÄT-funktiot palauttavat #ARVO! -virheen.

Ratkaisu: Avaa kaavaan merkitty työkirja ja päivitä kaava painamalla F9-näppäintä.

Voit ratkaista ongelman myös käyttämällä SUMMA- ja JOS-funktioita yhdessä matriisikaavassa. Katso lisätietoja artikkelista SUMMA.JOS-, LASKE.JOS- ja LASKE.TYHJÄT-funktiot palauttavat #ARVO!-virheen.

Ongelma: Ehtomerkkijono on yli 255 merkkiä.

LASKE.JOS/LASKE.JOS.JOUKKO-funktio palauttaa vääriä tuloksia, kun yrität käyttää sitä yli 255 merkin merkkijonojen yhteydessä.

Ratkaisu: Lyhennä merkkijonoa, jos mahdollista. Jos et voi lyhentää, jaa arvo useaan merkkijonoon käyttämällä KETJUTA-funktiota tai et-merkkioperaattoria (&). Esimerkki:

= SUMMA.JOS(B2:B12,”pitkä merkkijono”&”toinen pitkä merkkijono”)

Ongelma: SUMMA.JOS.JOUKKO-funktion ehtoalue-argumentti ei ole yhdenmukainen summa_alue-argumentin kanssa.

Alueargumenttien on oltava aina samat SUMMA.JOS.JOUKKO-funktiossa. Se tarkoittaa, että ehtoalue- ja summa_alue-argumenttien on viitattava samaan rivi- ja sarakemäärään.

Seuraavassa esimerkissä kaavan on tarkoitus palauttaa omenoiden päivittäisen myynnin summa Bellevuessa. summa_alue (C2:C10) -argumentti ei kuitenkaan vastaa samaa rivi- ja sarakemäärää ehtoalue (A2:A12 ja B2:B12) -argumenteissa. Syntaksin =SUMMA.JOS.JOUKKO(C2:C10,A2:A12,A14,B2:B12,B14) käyttäminen aiheuttaa #ARVO!-virheen.

Virheellinen kaava on =SUMMA.JOS.JOUKKO(C2:C10,A2:A12,A14,B2:B12,B14), jossa välin C2:C10 on oltava C2:C12
SUMMA.JOS. JOUKKO-funktiossa ehtoalue-argumentin on oltava yhdenmukainen summa_alue-argumentin kanssa.

Ratkaisu: Tämän esimerkin mukaisesti muuta summa_alue-argumentiksi C2:C12 ja kokeile kaavaa uudelleen.

Huomautus:  SUMMA.JOS voi käyttää eri kokoalueita.

Onko sinulla jokin funktioihin liittyvä kysymys?

Lähetä kysymys Excel-yhteisön keskustelupalstalle

Auta meitä parantamaan Exceliä

Onko sinulla ehdotuksia, miten voimme parantaa seuraavaa Excel-versiota? Jos on, lue aiheet Excel User Voice -palvelussa.

Katso myös

#ARVO!-virheen korjaaminen

SUMMA.JOS-funktio

SUMMA.JOS.JOUKKO-funktio

Edistyneitä JOS-funktioita koskevat videot

Yleiskuva kaavoista Excelissä

Viallisten kaavojen ratkaiseminen

Kaavoissa esiintyvien virheiden etsiminen

Kaikki Excel-funktiot (aakkosjärjestyksessä)

Kaikki Excel-funktiot (luokittain)

Kehitä taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×