Resurssienseurantaratkaisun luominen InfoPathin ja Excelin avulla

Tärkeää: Tämä on artikkeli on käännetty koneellisesti. Lue vastuuvapauslauseke. Tämän artikkelin englanninkielinen versio on täällä .

Microsoft Office InfoPathin avulla voit luoda lomakemalleja tietojen tallentamista ja keräämistä varten. Microsoft Office Excel 2007:n avulla voit laskea ja analysoida tietoja sekä luoda niistä kaavioita. Näiden ohjelmien ja XML:n avulla voit helposti luoda yksinkertaisen ja tehokkaan liiketoimintaratkaisun yrityksen omaisuuden seurantaan.

omaisuuden seurantaratkaisun yleiskatsaus

Tässä artikkelissa käsiteltävät aiheet

Omaisuuden seurantaratkaisun luominen

Vaihe 1: Omaisuuden seurannan lomakemallin mukauttaminen

Vaihe 2: Rakennetiedoston yhdistäminen ja taulukon asettelun mukauttaminen Excelissä

Vaihe 3: Pivot-taulukon ja Pivot-kaavion yhteenvetoraportin luominen

Vaihe 4: Omaisuustietojen kerääminen käyttäjiltä

Vaihe 5: Lomakkeiden tuonti Exceliin

Vaihtoehtoja: SharePoint-luettelon tai Access-tietokannan käyttäminen

Omaisuuden seurantaratkaisun luominen

Voit siirtää XML-tietoja InfoPathin ja Excelin välillä. Vaikka InfoPathin Vie-komento on helpoin tapa lähettää lomakkeen tiedot Exceliin, käytettävissä on myös toinen, joustavampi tapa tietojen lähettämiseen. Yhdistämällä InfoPathin XML-rakennetiedoston kentät (.xsd) Exceliin ja tuomalla sitten InfoPath-lomaketiedostot (.xml) Exceliin voit mukauttaa tietojen asettelua sekä hallita ja analysoida tietoja tehokkaasti Excelissä.

Tämä artikkeli havainnollistaa InfoPathin, XML:n ja Excelin toimintaa yhdessä käyttämällä esimerkkinä InfoPathin omaisuuden seurantalomaketta. Kuvittele, että organisaatio kerää joka vuosi omaisuusluettelon kunkin työntekijän toimistosta. Tämän jälkeen luodaan Excel-raportti, jota käytetään apuna tulevan vuoden laitteistobudjetin suunnittelussa. Seuraavassa kaaviossa on yleiskatsaus osaston omaisuustietojen keräämisestä, seurannasta ja raportoinnista.

a

1. Omaisuuden seurannan lomakemalli luodaan.

2. Rakennetiedosto yhdistetään Excel-taulukkoon ja taulukon asettelu mukautetaan.

3. Tyhjä Pivot-taulukon ja Pivot-kaavion yhteenvetoraportti luodaan.

4. Omaisuuden seurantalomaketta käytetään tietojen keräämiseen käyttäjiltä.

5. Kaikki lomaketiedot viedään Excel-taulukkoon, ja Pivot-taulukko- ja Pivot-kaavioraportit päivitetään.

Tähän ratkaisuun tarvitaan seuraavat käyttäjäroolit ja tuotteet:

Täysin tuettu -kuvake = Pakollinen Ei tuettu -kuvake = Ei pakollinen

Ohjelmistovaatimukset

Roolit

Office InfoPath 2007

Office Outlook 2007

Office Excel 2007

Ratkaisusuunnittelija

Täysin tuettu -kuvake

Täysin tuettu -kuvake

Täysin tuettu -kuvake

Päätöksentekijä

Täysin tuettu -kuvake

Täysin tuettu -kuvake

Täysin tuettu -kuvake

Työntekijät

Täysin tuettu -kuvake

Täysin tuettu -kuvake

Ei tuettu -kuvake

Sivun alkuun

Vaihe 1: Omaisuuden seurannan lomakemallin mukauttaminen

InfoPathiin sisältyvän omaisuuden seurannan lomakemallin avulla voit kerätä tiedot kunkin työntekijän toimistossa olevasta omaisuudesta, työntekijän osaston, omaisuuksien luokat sekä lisätiedot kustakin omaisuudesta. Tässä ratkaisussa lomakkeen suunnittelija lähettää lomakemallin päätöksentekijän sähköpostitiliin Office Outlook 2007:llä.

kohteiden seurantamalli

Tehtävä 1: Omaisuuden seurannan lomakemallin avaaminen ja mukauttaminen

Lomakemallia ei voi julkaista usealle vastaanottajalle sähköpostitse, jos siinä on linkitettyjä kuvia sisältävä RTF-ruudun ohjausobjekti, joten omaisuuden seurannan lomakemalliin on tehtävä pieni muutos.

  1. Valitse Tiedosto-valikosta Suunnittele lomakemalli.

  2. Valitse Lomakemallin suunnitteleminen -valintaikkunan Avaa lomakemalli -kohdassa Mukauta malli.

  3. Valitse Aloittaminen-valintaikkunassa Malli - Omaisuuden seuranta ja valitse sitten Lomaketehtävät-kohdassa Suunnittele tämä lomake.

  4. Napsauta hiiren kakkospainikkeella assetNotes-ohjausobjektia, osoita RTF-ruutu-ominaisuuksia, napsauta Näytä-välilehteä ja poista sitten Käytettävissä oleva muotoilu -kohdan Linkitetyt kuvat -valintaruudun valinta.

Tehtävä 2: Lähetysasetusten määrittäminen

Seuraavaksi lähetysasetukset on määritettävä niin, että työntekijät voivat lähettää yksilöllisesti nimetyn lomaketiedoston (.xml) päätöksentekijän sähköpostitiliin liitetiedostona.

  1. Valitse Työkalut-valikosta Lähetyksen asetukset.

  2. Valitse Lähetyksen asetukset -valintaikkunassa Salli tämän lomakkeen lähettäminen -valintaruudun valinta.

  3. Valitse Lähetä lomakkeen tiedot yhteen kohteeseen ja valitse sitten luettelosta Sähköposti.

  4. Valitse Lisää.

    Ohjattu tietoyhteyden muodostaminen tulee näkyviin.

  5. Kirjoita Vastaanottaja-ruutuun sen päätöksentekijän tunnus, joka vastaanottaa kaikki lähetetyt lomakkeet.

  6. Voit määrittää yksilöllisen aiherivin Aihe-ruutuun seuraavasti:

    • Valitse Lisää kaava Painikkeen kuva .

    • Kirjoita seuraava kaava:

concat(my:employee/my:employeeName, my:employee/my:employeeDepartment)

  • Valitse Tarkista kaava, ja valitse sitten OK kahdesti.

  • Kirjoita Johdanto-ruutuun asianmukainen viesti tai lisää ratkaisua koskevat tärkeät ohjeet.

  • Valitse Seuraava.

  • Valitse ohjatun toiminnon seuraavalla sivulla Lähetä lomakkeen tiedot liitteenä ja valitse sitten Liitä lomakemalli varmistaaksesi, että käyttäjät voivat avata lomakkeen -valintaruutu.

    Tämä varmistaa, että työntekijät voivat käyttää lomakkeen mallitiedostoa (.xsn), vaikka he eivät voisi käyttää sitä sen verkkosijainnista.

  • Voit määrittää kullekin lomaketiedostolle (.xml) yksilöllisen tiedostonimen Liitteen nimi -ruutuun seuraavasti:

    1. Valitse Lisää kaava Painikkeen kuva .

    2. Kirjoita sama kaava, jonka lisäsit Aihe-riville:

concat(my:employee/my:employeeName, my:employee/my:employeeDepartment)

  1. Valitse Tarkista kaava, ja valitse sitten OK kahdesti.

  • Valitse Seuraava.

  • Kirjota ohjatun toiminnon seuraavan sivun Kirjoita tämän tietoyhteyden nimi -ruutuun lähetystietoyhteyden kuvaava nimi.

  • Varmista, että tiedot ovat oikein Yhteenveto-osassa, ja valitse sitten Valmis.

  • Tallenna lomake julkiseen verkkokansioon, joka on päätöksentekijän ja kaikkien työntekijöiden käytettävissä.

Sivun alkuun

Vaihe 2: Rakennetiedoston yhdistäminen ja taulukon asettelun mukauttaminen Excelissä

InfoPathin ja Excelin välisen yhteyden määrittämisessä on kolme tehtävää: omaisuuden seurannan lomakemallin rakennetiedoston poiminta, rakennetiedoston yhdistäminen Excel-taulukkoon ja kaikki tuodut XML-lomakkeen datatiedostot sisältävän Excel-taulukon oletusasettelun mukauttaminen.

Tehtävä 1: Rakennetiedoston poiminta InfoPathista

  1. Avaa InfoPathin omaisuuden seurannan lomakemallitiedosto.

  2. Valitse Työkalut-valikosta Suunnittele tämä lomake.

  3. Valitse Tiedosto-valikosta Tallenna lähdetiedostoina.

  4. Valitse Selaa kansioita -valintaikkunassa kansio tai luo uusi kansio, johon haluat tallentaa rakennetiedoston.

Paina mieleen lähdetiedostot sisältävän kansion sijainti ja rakennetiedoston nimi, tässä esimerkissä myschema.xsd, joka sisältää lomakkeen XML-tietojen rakennemääritelmän.

Tehtävä 2: InfoPath-rakennetiedoston yhdistäminen Excel-taulukkoon

  1. Luo uusi Excel-tiedosto ja tallenna se sijaintiin, joka on päätöksentekijän käytettävissä.

  2. Jos Kehitystyökalut-välilehti ei ole näkyvissä Excelissä, tee seuraavat toimet:

    1. Napsauta Microsoft Office -painiketta Office-painikkeen kuva ja valitse Excelin asetukset.

    2. Valitse Käyttäjän asetukset -luokasta Excelin käyttämisen perusasetukset -kohdasta Näytä kehitystyökalut valintanauhassa -valintaruutu ja valitse OK.

      Huomautus: Valintanauha on Microsoft Officen sujuva käyttöliittymä -käyttöliittymän komponentti.

  3. Valitse Kehitystyökalut-välilehden XML-ryhmästä Lähde.

    Valintanauhan XML-ryhmä

    XML-lähde-tehtäväruutu tulee näkyviin.

  4. Valitse XML-määritykset ja valitse sitten XML-määritykset-valintaikkunassa Lisää.

  5. Windows Vista -käyttöjärjestelmää käyttävässä tietokoneessa   

    1. Napsauta osoiterivillä sitä asemaa tai kansiota, joka sisältää myschema.xsd-tiedoston, jonka loit vaiheessa 2 kohdassa Tehtävä 1: Rakennetiedoston poiminta InfoPathista.

      Microsoft Windows XP -käyttöjärjestelmää käyttävässä tietokoneessa   

    2. Napsauta Kohde-luettelossa sitä asemaa tai kansiota, joka sisältää myschema.xsd-tiedoston, jonka loit vaiheessa 2 kohdassa Tehtävä 1: Rakennetiedoston poiminta InfoPathista.

  6. Valitse tiedosto ja valitse sitten Avaa.

  7. Kun Useita pääsolmuja -valintaikkuna tulee näkyviin, valitse assetTracking-pääsolmu, joka on määritetty myschema.xsd-tiedostoon, ja valitse sitten OK.

    XML-määritys näkyy XML-lähde-tehtäväruudussa.

  8. Vedä ns1:asset-solmun elementti, joka on toistuva XML-elementti, siihen työkirjan sijaintiin, jossa haluat Excel-taulukon näkyvän.

    infopath-rakennetiedoston yhdistäminen exceliin

Tehtävä 3: Excel-taulukon asettelun mukauttaminen

Oletusarvoisesti Excel käyttää XML-elementtien nimiä taulukon sarakeotsikkoina. Voit kuitenkin muuttaa sarakeotsikoita muokkaamalla sarakeotsikkosoluja.

  1. Jos haluat muokata oletusarvoisia sarakeotsikoita, pidä Excel-taulukko valittuna, etsi merkkijonon etuliite, esimerkiksi ns1:asset, ja poista se. Tämä esimerkki muuttaa sarakeotsikon ns1:assetID muotoon ID.

    Excel-taulukko-otsikoiden mukauttaminen

  2. Jos haluat säätää sarakkeen leveyttä, napsauta Valitse kaikki -painiketta ja kaksoisnapsauta sitten mikä tahansa sarakeotsikon rajaa.

Sivun alkuun

Vaihe 3: Pivot-taulukon ja Pivot-kaavion yhteenvetoraportin luominen

Pivot-taulukko- ja Pivot-kaavioraporttien avulla päätöksentekijät voivat analysoida, tutkia ja visualisoida yhteenvetotietoja. Kun määrität tässä skenaariossa käytettävät Pivot-taulukko- ja Pivot-kaavioraportit etukäteen, päätöksentekijän on helppo ajaa raportti tietojen keräämisen jälkeen.

  1. Valitse solu Excel-taulukosta.

  2. Valitse Lisää-välilehden Taulukko-ryhmästä Pivot-taulukko ja valitse Pivot-taulukko.

    Excelin valintanauhan kuva

    Excel tuo näyttöön Luo Pivot-taulukko -valintaikkunan.

  3. Jos haluat sijoittaa Pivot-taulukkoraportin uuteen laskentataulukkoon alkaen solusta A1, valitse Uuteen laskentataulukkoon ja valitse sitten OK.

    Excel lisää tyhjän Pivot-taulukkoraportin määritettyyn sijaintiin ja näyttää Pivot-taulukon kenttäluettelon, jotta voit lisätä kenttiä, luoda asettelun ja mukauttaa Pivot-taulukkoraporttia.

  4. Jos haluat luoda taulukkomuotoisen raportin tiedoista, vedä ID-kenttä Arvot-alueelle, Department-kenttä Sarakeotsikot-alueelle, Category-kenttä Riviotsikot-alueelle ja AssignedTo-kenttä Raporttisuodatin-alueelle.

  5. Valitse Pivot-taulukkoraportti.

  6. Valitse Lisää-välilehden Kaaviot-ryhmässä Palkkikaavio.

    Excelin valintanauhan kuva

  7. Valitse 2-ulotteinen palkki -kohdasta Liitetty palkkikaavio.

  8. Muuta Pivot-kaavioraportin kokoa ja sijaintia tarpeen mukaan.

Tyhjät Pivot-taulukko- ja Pivot-kaavioraportit

Sivun alkuun

Vaihe 4: Omaisuustietojen kerääminen käyttäjiltä

Nyt lomakemalli on valmis kaikkien työntekijöiden täytettäväksi. Julkaise lomake ja lähetä se jokaiselle työntekijälle. Kun työntekijä lähettää täytetyn lomakkeen, se lähetetään XML-datatiedostona (.xml) sähköpostin liitetiedostona päätöksentekijän sähköpostiosoitteeseen. Päätöksentekijä voi siirtää kaikki kyseiset viestit erityiseen InfoPath-kansioon Outlookissa. Tässä tapauksessa on suositeltavaa määrittää tietty ajanjakso, jonka kuluessa kaikkien käyttäjien on täytettävä lomakkeet, jotta päätöksentekijä voi luoda raportin kerätyistä tiedoista, kun tietojen keräyksen määräaika on umpeutunut.

tietojen lisääminen kohteiden seurantalomakkeisiin

  1. Avaa InfoPathissa lomakemalli (.xsn), jonka tallensit vaiheessa 1: Omaisuuden seurannan lomakemallin suunnitteleminen.

  2. Valitse Työkalut-valikosta Suunnittele tämä lomake.

  3. Valitse Tiedosto-valikosta Julkaise.

  4. Valitse ohjatussa julkaisutoiminnossa Sähköpostivastaanottajien luetteloon ja valitse sitten Seuraava.

  5. Kirjoita ohjatun toiminnon seuraavalla sivulla Lomakemallin nimi -ruutuun lomakemallin nimi ja valitse sitten Seuraava. Lomakemallin nimi näkyy viestin, joka lähetetään sähköpostiviestin vastaanottajille, Aihe-otsikossa.

  6. Ohjatun toiminnon seuraavalla sivulla voit luoda sarakkeet, jotka näkyvät Outlook-kansioissa ja jotka helpottavat sähköpostiviestien järjestämistä.

  7. Valitse Seuraava.

  8. Valitse Julkaise.

  9. Kun ohjattu julkaisutoiminto on julkaissut lomakemallin, sähköpostiviesti, jossa on lomake, aukeaa.

  10. Lisää viesti, kirjoita työntekijöiden nimet tai käytä jakeluluetteloa ja lähettää viesti.

Päätöksentekijä voi järjestää kaikki lähetetyt XML-lomakkeet Outlookissa jommallakummalla seuraavista tavoista:

  • Jos InfoPath-lomakekansiot -viestiruutu tulee näkyviin, kun avaat viestin ensimmäisen kerran, valitse Luo lomakekansio.

  • Luo Outlookiin sääntö, joka siirtää kaikki InfoPath-lomakkeet InfoPath-kansioon.

    Lisätietoja on artikkelissa hallinta sääntöjen avulla viestejä.

Sivun alkuun

Vaihe 5: Lomakkeiden tuonti Exceliin

Koska olet jo luonut Excel-työkirjan vaiheissa 2 ja 3, päätöksentekijän on helppo viedä lomaketiedot ja tarkastella niitä. Päätöksentekijän tarvitsee vain viedä xml-tiedostot (.xml) Outlookista, tuoda lomaketiedostot (.xml) Excel-työkirjaan ja päivittää sitten tiedot.

Tehtävä 1: Lomakkeiden vieminen Outlookista Windowsin kansioon

  1. Valitse Outlookissa kansio, joka sisältää kaikki työntekijöiltä vastaanotetut lomakkeet. Valitse kaikki lomakesähköpostiviestit painamalla näppäinyhdistelmää Ctrl+A.

  2. Napsauta valintaa hiiren kakkospainikkeella, osoita kohtaa InfoPath-toiminnot ja valitse sitten Vie lomakkeet.

  3. Valitse Vie lomakkeet -valintaikkunassa kansio ja valitse sitten OK.

Tehtävä 2: Lomakkeiden tuonti Exceliin

  1. Avaa Excel-työkirja, jonka loit vaiheessa 2: Rakennetiedoston yhdistäminen ja taulukon asettelun mukauttaminen Excelissä, ja valitse jokin Excel-taulukkoon yhdistetyistä soluista.

  2. Valitse Kehitystyökalut-välilehden XML-ryhmästä Tuo.

    Valintanauhan XML-ryhmä

    Näkyviin tulee Tuo XML -valintaikkuna.

  3. Windows Vista -käyttöjärjestelmää käyttävässä tietokoneessa   

  4. Toimi seuraavasti:

    • Jos tiedostot ovat peräkkäisiä, pidä VAIHTONÄPPÄINTÄ alhaalla ja napsauta sitten luettelon ensimmäistä ja viimeistä tiedostoa.

    • Jos tiedostot eivät ole peräkkäisiä, pidä CTRL-näppäintä alhaalla ja valitse sitten kaikki tiedostot, jotka haluat tuoda luettelosta.

  5. Valitse Tuo.

    tuotujen tietojen excel-taulukko

Oletusarvoisesti Excel korvaa kaikki yhdistettyjen solujen aiemmat tiedot, mikä sopii hyvin tähän liiketoimintaratkaisuun. Päätöksentekijä voisi kuitenkin tuoda tiedot useita kertoja ennen sovittua määräaikaa ja seurata edistymistä.

Huomautus: Voit lisätä tietoja Excelissä käyttämällä Lisää uudet tiedot vanhoihin XML-taulukoihin -asetusta (Kehitystyökalut-välilehden XML-ryhmän Määritä ominaisuudet -toiminto). Tämä voi olla hyödyllinen toiminto muissa ratkaisuissa.

Lisätietoja on ohjeartikkeleissa Excel- tuominen XML-tiedot ja Liitä tai korvata yhdistetyn XML-tietojen.

Tehtävä 3: Pivot-taulukko- ja Pivot-kaavioraporttien päivittäminen

  • Valitse Pivot-taulukkoraportin solu.

  • Napsauta Asetukset-välilehden Tiedot-ryhmän Päivitä kaikki -kohdan viereistä nuolta ja valitse sitten Päivitä.

    Outlookin valintanauhan kuva

lopullinen pivot-taulukko ja pivot-kaavioraportti

Excel-työkirja sisältää nyt kaikki tarvittavat tiedot ja yhteenvetoraportit, jotka auttavat tulevan vuoden laitteistobudjetin suunnittelussa. Voit jatkaa Excel-työkirjan tietojen analysointia esimerkiksi lajittelemalla tai suodattamalla tietoja tai käyttämällä ehdollista muotoilua.

Sivun alkuun

Vaihtoehtoja: SharePoint-luettelon tai Access-tietokannan käyttäminen

XML:n sijaan voit käyttää tietojen siirtämiseen InfoPathin ja Excelin välillä myös SharePoint-luetteloa tai Access-tietokantaa.

SharePoint-luettelon käyttäminen

InfoPathissa voit helposti käyttää SharePoint-luetteloa vain luku -tietolähteenä. Voit tehdä jommankumman seuraavista:

  • Vie tiedot SharePoint-luettelosta Exceliin, jolloin tietoyhteys Exceliin muodostetaan automaattisesti.

  • Luo tietoyhteys SharePoint-luetteloon manuaalisesti Excelissä.

Kun tietoyhteys on luotu, voit noutaa ajantasaiset tiedot päivittää tiedot Excelissä.

Voit käyttää SharePoint-luetteloa tietojen lisäämiseen ja päivittämiseen, InfoPath-lomaketta luettelon kohteen näyttämiseen (esimerkiksi monimutkainen tai pitkä, pystysuuntaisesti näytettävä kohde) ja Exceliä tietojen analysoimiseen.

infopathin, sharepoint-luettelon ja excelin yhdistäminen

1. Tarkastele yksittäistä kohdetta helposti InfoPathissa.

2. Lisää ja päivitä tietoja SharePoint-luetteloon.

3. Päivitä tiedot Exceliin ja luo ajantasaisia raportteja.

Lisätietoja on artikkeleissa Tietoyhteyden lisääminen SharePoint-tiedostokirjastoon tai -luetteloon ja Tietojen tuominen SharePoint-luettelosta.

Access-tietokannan käyttäminen

Voit luoda InfoPathista luku- ja kirjoitusyhteyden Access-tietokantaan. Excelistä voit luoda Access-tietokantaan tietoyhteyden, jonka avulla voit noutaa ajantasaiset tiedot. Voit määrittää yhteyden päivittämään tiedot automaattisesti, kun työkirja avataan, tai säännöllisesti, esimerkiksi 5 minuutin välein.

Voit käyttää Access-tietokantaa välittäjänä InfoPathin ja Excelin välillä. Kun lähetät InfoPath-lomakkeen Accessiin, Access-tietokanta päivitetään. Kun päivität tietoyhteyden Excelissä, noudat päivitetyt tiedot Accessista. Käytännössä lähetät tiedot epäsuorasti InfoPathista Excel-työkirjaan.

infopathin, accessin ja excelin yhdistäminen

1. Avaa ja lähetä lomake Access-tietokantaan.

2. Tallenna tiedot Access-tietokantaan.

3. Päivitä tiedot Exceliin ja luo ajantasaisia raportteja.

Lisätietoja on artikkelissa Microsoft Access -tietokantaan perustuvan lomakemallin suunnitteleminen.

Vihje: Tiesitkö, että voit luoda InfoPath-lomakkeen suoraan Access 2007:ssä? Jos käyttäjillä on käytössä Outlook 2007 ja InfoPath 2007 on asennettuna tietokoneisiin, voit kerätä tietoja käyttäjiltä suoraan Access 2007:stä käyttämällä ohjattua Tietojen kerääminen sähköpostin avulla -toimintoa. Lisätietoja on Access 2007:n ohjeaiheessa Tietojen kerääminen sähköpostin avulla.

Sivun alkuun

Huomautus: Konekäännöksestä ilmoittava vastuusvapauslauseke: Tämä artikkeli on käännetty tietokonejärjestelmällä, eikä kieliasiantuntija ole muokannut sitä. Microsoft tarjoaa nämä konekäännökset avuksi muille kuin englantia puhuville käyttäjille, jotta he saavat lisätietoja Microsoftin tuotteista, palveluista ja tekniikoista. Koska artikkeli on koneellisesti käännetty, se saattaa sisältää sanasto-, lauseoppi- ja kielioppivirheitä.

Kehitä taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×