Publisher-Web-sivuston valmisteleminen, julkaiseminen ja ylläpito

Tärkeää: Tämä on artikkeli on käännetty koneellisesti. Lue vastuuvapauslauseke. Tämän artikkelin englanninkielinen versio on täällä .

Kun olet suunnitellut ja luonut verkkojulkaisun sovelluksessa Microsoft Office Publisher 2007, voit julkaista sen verkossa, verkkopalvelimessa tai oman tietokoneesi jaetussa kansiossa. Publisher luo julkaisukohteesta riippumatta suodatetut HTML-tiedostot verkkojulkaisusta. Voit avata ja lukea näitä HTML-tiedostoja millä tahansa selaimella, esimerkiksi Windows Internet Explorerilla.

Web-julkaisu ja sen siirtymispalkki, teksti ja grafiikka

Tässä artikkelissa

Tässä artikkelissa käsitellään verkkojulkaisun luomista ja julkaisemista HTML-tiedostoina sekä verkkosivuston päivittämistä verkkojulkaisun muokkaamisen ja uudelleenjulkaisun avulla.

Verkkosivuston valmisteleminen

Verkkosivuston julkaiseminen

Verkkosivuston ylläpitäminen

Verkkosivuston valmisteleminen

Verkkosivusto edustaa sinua, yritystäsi ja brändiäsi. Tästä syystä verkkosivusto kannattaa suunnitella hyvin ennen sen luomista. Saat apua tähän ohjeartikkelista Verkkosivuston suunnitteleminen.

Mikä on paras työkalu?

Kun suunnittelet sivustoasi ja sen tietoja, mieti, mikä työkalu vastaa tarpeitasi. Office Publisher 2007 on erinomainen työkalu, jolla voit nopeasti luoda, julkaista ja hallita yksinkertaisia muuttumattomia verkkosivustoja, jotka vastaavat yrityksesi brändiä ja joissa sinun täytyy päivittää vain tekstiä ja grafiikoita. Office Publisher 2007 ei ole sopiva työkalu seuraavissa tilanteissa.

  • Se ei ole oikea työkalu, jos verkkosivustosi vaatii vuorovaikutteisia toimintoja tai jos siinä on tietokantapohjaista sisältöä, joiden avulla kävijät voivat esimerkiksi kommentoida blogia tai ostaa tuotteita verkkokaupasta.

  • Se ei ole oikea työkalu, jos verkkosivustosi vaatii tietojen tarkistamista, esimerkiksi luottokorttinumeroiden tarkistamista.

  • Se ei ole oikea työkalu, jos aiot muokata sovelluksessa Office Publisher 2007 luomasi sivuston (joka sisältää HTML-, XML- ja VML-koodia) HTML-koodia HTML-editorilla sivuston luomisen jälkeen.

Microsoft Office Live voi tarjota tarvitsemasi verkkoisännöintitoiminnot ja sivustojen luomistoiminnot. Saat lisätietoja Microsoft Office Live -sivustosta.

Jos haluat luoda vuorovaikutteisen verkkosivuston, Microsoft Expression Web tarjoaa työkaluja paljon tietoja sisältävien standardeihin perustuvien verkkosivustojen luomiseen. Saat lisätietoja Microsoft Expression Web -sivustosta.

Verkkosivuston luominen

Office Publisher 2007 tarjoaa sinulle toiminnot verkkojulkaisun luomiseen. Jos haluat hyödyntää olemassa olevaa verkkosivustoa, josta sinulla ei ole verkkojulkaisua, voit kopioida ja liittää julkaistujen verkkosivujen sisällön uuteen verkkojulkaisuun. Tällä tavoin voit luoda verkkosivuston verkkojulkaisuna. Voit myös käyttää HTML-editoria.

  1. Valitse Tiedosto -valikosta Uusi.

  2. Valitse Julkaisulajit-luettelosta Verkkosivustot.

  3. Tee jompikumpi seuraavista:

    • Jos haluat luoda räätälöidyn sivuston tavoitteidesi mukaisesti, varmista, että Asetukset-tehtäväruudun Ohjattu helppokäyttöinen verkkosivun luominen -kohta on valittu. Valitse tämän jälkeen haluamasi rakenne.

    • Jos haluat luoda verkkosivuston alusta asti, valitse Verkkosivustot-kohdasta Tyhjien sivujen koot ja valitse sitten haluamasi koko.

  4. Valitse Luo.

  5. Jos käytät Ohjattu helppokäyttöinen verkkosivun luominen -toimintoa, valitse haluamasi asetukset Helppokäyttöinen verkkosivuston luonti -valintaikkunassa ja valitse sitten OK.

  6. Lisää sisältö julkaisuusi ja tee haluamasi muutokset.

    Vihje: Vältä objektien lisäämistä verkkojulkaisusi perustyylisivuille. Jos lisäät objekteja perustyylisivuille ohjelmassa Office Publisher 2007, niitä ei näytetä oikein joissain selaimissa.

Verkkojulkaisun tarkistaminen

Ennen kuin julkaiset verkkosivustosi, varmista, että sivusto toimii odotetusti ja että olet korjannut kaikki mahdolliset ongelmat.

Voit tarkistaa mahdollisia ongelmia Rakenteen tarkistaminen -toiminnolla ja esikatselemalla sivustosi.

Ongelmien etsiminen ja korjaaminen Rakenteen tarkistaminen -toiminnolla.

Rakenteen tarkistaminen -toiminto on tehokas työkalu mahdollisten ongelmien etsimiseen. Monet sen tarkistuksista liittyvät perusmuotoiluongelmiin. Jotkin sen tarkistuksista liittyvät kuitenkin erityisesti verkkojulkaisujen ongelmiin. Voit suorittaa Rakenteen tarkistaminen -toiminnon seuraavasti:

  1. Valitse Työkalut-valikosta Rakenteen tarkistaminen.

  2. Valitse Rakenteen tarkistaminen -tehtäväruudussa Suorita Yleiset rakenteen tarkistukset- ja Suorita sivuston tarkistukset -valintaruutujen valinnat.

    Huomautus: Varmista, että Suorita tulostuspalvelun tarkistukset -valintaruutu ei ole valittuna.

  3. Napsauta Rakenteen tarkistaminen -tehtäväruudun Valitse korjattava kohde -kohdassa korjattavan kohteen vieressä olevaa nuolta ja tee sitten jokin seuraavista toimista:

    • Voit korjata kohteen ongelmat automaattisesti valitsemalla automaattisen korjaustoiminnon.

      Automaattinen korjaus vaihtelee ongelman mukaan. Useimmissa tapauksissa automaattista korjausta ei ole saatavilla.

    • Jos haluat siirtyä sivulle, jossa valittu ongelma sijaitsee, valitse Siirry tähän kohteeseen.

      Voit sitten korjata ongelman tekemällä tarvittavat muutokset.

    • Voit avata ohjeaiheen, jossa selitetään ongelma tarkemmin ja annetaan ratkaisuehdotuksia. Voit tehdä tämän valitsemalla Selitys.

    • Jos haluat poistaa tarkistuksen käytöstä, valitse Älä suorita tätä tarkistusta uudelleen.

      Tämä koskee kaikkia kyseisen ongelman esiintymiä.

Verkkosivuston esikatseleminen

  • Valitse Tiedosto-valikosta Verkkosivun esikatselu.

Näet verkkosivuston esikatselun oletusselaimessasi. Tarkista esikatselusta seuraavat seikat:

  • Tarkista, että sivusto avautuu ja että kaikki sivut ovat käytettävissä.

  • Tarkista, että kaikki hyperlinkit toimivat odotetusti.

  • Tarkista, että siirtymistoiminnot toimivat odotetusti.

  • Tarkista, että mitään elementtejä ei puutu.

  • Tarkista, että kaikki taustaäänet toistetaan odotetusti.

Verkkoisännöintipalvelun etsiminen

Ennen kuin voit julkaista verkkosivustosi Internetissä, sinun täytyy hankkia verkkoisännöintipalvelun tilaus Internet-palveluntarjoajalta. Tämä palvelu tarjoaa sinulle Internet-yhteyden, tallennustilaa verkkopalvelimessa ja URL-osoitteen sivustollesi, jotta ihmiset voivat käydä sivustossasi. Ota ennen verkkosivuston julkaisemista yhteyttä Internet-palveluntarjoajaasi tai järjestelmänvalvojaasi. Heidän avullaan voit hankkia kaikki tarvittavat tiedot ja verkkosivuston URL-osoitteen tai sovelluksen FTP sivuston osoitteen, johon voit tallentaa tiedostosi.

Alueellasi toimii luultavasti useita Internet-palveluntarjoajia. Varmista, että valitsemasi Internet-palveluntarjoaja tarjoaa tarvitsemaasi tukea. Jos sinulla ei ole juurikaan kokemusta verkkojulkaisemista, sinun kannattaa ehkä valita Internet-palveluntarjoaja, joka voi tukea sinua mahdollisissa ongelmatilanteissa.

Sivun alkuun

Verkkosivuston julkaiseminen

Kun olet tarkistanut ja esikatsellut verkkojulkaisusi ja olet tilannut verkkoisännöintipalvelun, olet valmis julkaisemaan verkkosivustosi.

Voit julkaista verkkosivuston palvelussa Verkkopalvelin, verkkopalvelimessa, FTP-palvelimessa tai oman tietokoneesi kansiossa.

Sivuston julkaiseminen oman tietokoneen sijainnissa voi olla hyvä vaihtoehto monissa tilanteissa.

  • Julkaistujen tiedostojen avulla voit testata sivustoasi ennen sen julkaisemista yleisesti Internetissä.

  • Voit julkaista tiedostot Internetissä FTP-apuohjelmalla, joka lataa tiedostot Internetiin tietokoneesi sijainnista.

  • Voit säilyttää HTML-tiedostoista ja verkkojulkaisuista paikallisen kopion itselläsi.

Internet-palveluntarjoajaltasi saat tietoja, joiden avulla voit päättää itsellesi parhaiten soveltuvan julkaisemistavan.

Kun julkaiset Internetissä tai omassa tietokoneessasi, Office Publisher 2007 kerää kaikki luomansa liittyvät tiedostot yhteen kansioon. Office Publisher 2007 luo muun muassa muita sivustoosi kuuluvia HTML-sivuja, GIF- ja JPEG-grafiikkatiedostoja, joita sivuillasi käytetään, sekä upotettujen äänien tiedostoja.

Office Publisher 2007 on mahdollista määrittää siten, että se järjestää nämä tiedostot kansioon, jossa julkaiset verkkosivustosi. Voit tehdä tämän kahdella tavalla. Office Publisher 2007 luo oletusarvoisesti yhden aloitussivun ja alikansion, joka sisältää kaikki verkkosivustosi tarvitsemat tukitiedostot. Voit myös järjestää aloitussivun ja kaikki verkkosivustosi tukitiedostot yhteen ja samaan kansioon.

Miten voin hallita sitä, minne Office Publisher 2007 järjestää julkaisemansa verkkosivustotiedostot?

Valitse Työkalut-valikosta Asetukset, valitse Verkko-välilehti ja toimi sitten seuraavasti:

  • Jos haluat erottaa aloitussivun ja tukitiedostot toisistaan, valitse Järjestä tukitiedostot kansioon -valintaruutu.

  • Jos haluat järjestää aloitussivun ja tukitiedostot samaan kansioon, poista Järjestä tukitiedostot kansioon -valintaruudun valinta.

Kun julkaiset julkaisun Internetissä, Office Publisher 2007 luo suodatetut HTML-tiedostot, jotka ovat käytettävissä Internetissä nopeammin kuin suodattamattomat HTML-tiedostot. Koska suodatetut HTML-tiedostot, jotka Office Publisher 2007 luo, eivät sisällä Microsoft Officen omia tunnisteita, et voi avata HTML-tiedostoja ohjelmassa Office Publisher 2007 tai muokata niitä. Sinun täytyy tehdä muutokset verkkosivustoosi verkkojulkaisussa ja julkaista se sitten uudelleen Internetiin.

Verkkosivuston julkaiseminen Internetiin tai verkkoon

Ota ennen alla olevien toimenpiteiden suorittamista yhteyttä Internet-palveluntarjoajaasi tai järjestelmänvalvojaasi. Heidän avullaan voit hankkia kaikki tarvittavat tiedot ja verkkosivuston URL-osoitteen, johon voit tallentaa tiedostosi.

  1. Valitse Tiedosto-valikosta Muunna verkkosivuksi.

  2. Kirjoita Muunna verkkosivuksi -valintaikkunan Tiedostonimi-ruutuun se URL-osoite tai verkkopalvelinosoite, johon haluat tallentaa verkkosivustosi. Se voi olla esimerkiksi http://www.northwindtraders.com.

  3. Valitse Tallenna.

  4. Kirjoita pyydettäessä käyttäjänimesi sekä salasanasi ja valitse sitten OK.

    URL-osoitteesi mukainen hakemisto näytetään Muunna verkkosivuksi -valintaikkunassa.

  5. Kaksoisnapsauta kansiota, johon haluat tallentaa verkkosivustosi.

  6. Valitse Tiedostonimi-ruudussa aloitussivun oletusnimeksi index ja valitse sitten Tallenna.

    Index.htm on oletusvalinta. Kun valitset aloitussivusi nimeksi index, sen käyttö on helpompaa. Tämä myös estää käyttäjiä näkemästä luetteloa tiedostoista, joista sivustosi koostuu.

  7. Valitse pyydettäessä OK.

Verkkosivuston julkaiseminen FTP:n avulla

Ota ennen alla olevien toimenpiteiden suorittamista yhteyttä Internet-palveluntarjoajaasi tai järjestelmänvalvojaasi. Heidän avullaan voit hankkia kaikki tarvittavat tiedot palvelun FTP sivustoon julkaisemista varten. Sinun täytyy myös luoda FTP-sijainti Internet-osoitteet (FTP) -toiminnossa.

Toimintaohjeet

Tarvitset Internet- tai Intranet-yhteyden, jotta voit lisätä FTP-sivuston Internet-osoitteet (FTP) -toiminnossa.

Windows Vista

  1. Valitse Tiedosto-valikosta Muunna verkkosivuksi.

  2. Valitse Muunna verkkosivuksi -valintaikkunassa Työkalut ja valitse sitten Yhdistä verkkoasemaan.

  3. Toimi Yhdistä verkkoasemaan -valintaikkunassa seuraavasti:

    • Napsauta Asema-luettelossa jotain asemakirjainta. Voit valita minkä tahansa käytettävissä olevan kirjaimen.

    • Jotta yhteys tähän verkkoasemaan muodostetaan aina, kun kirjaudut tietokoneeseesi, valitse Muodosta yhteys uudelleen kirjauduttaessa -valintaruutu.

    • Valitse Muodosta yhteys WWW-sivustoon, jota voi käyttää asiakirjojen ja kuvien tallentamiseen.

  4. Valitse ohjatussa verkkosijainnin lisäystoiminnossa Seuraava > Valitse toinen verkkosijainti > Seuraava.

  5. Kirjoita Internet tai verkko -osoiteruutuun FTP-sivuston osoite (esimerkiksi ftp://ftp.microsoft.com) ja valitse sitten Seuraava.

    Huomautus: Jos et voi muodostaa yhteyttä verkkoasemaan tai -kansioon, tietokone saattaa olla sammutettu tai sinulla ei ehkä ole tarvittavia oikeuksia. Jos yhteyden muodostaminen ei onnistu, ota yhteyttä verkon järjestelmänvalvojaan tai Internet-palveluntarjoajaan.

  6. Jos et halua kirjautua sisään nimettömänä, poista Kirjaudu nimettömänä -valintaruudun valinta, anna käyttäjänimi Käyttäjänimi-ruutuun ja valitse sitten Seuraava.

  7. Kirjoita kyseisen verkkosijainnin nimi ja valitse sitten Seuraava.

  8. Valitse Valmis.

Microsoft Windows XP -käyttöjärjestelmässä

  1. Valitse Tiedosto-valikosta Muunna verkkosivuksi.

  2. Napsauta Kohde-luettelon nuolta ja valitse sitten Internet-osoitteet (FTP).

  3. Kaksoisnapsauta Lisää tai muuta FTP-polkuja -kohtaa.

  4. Kirjoita FTP-sivuston nimi FTP-palvelimen nimi -ruutuun. Se voi olla esimerkiksi ftp.microsoft.com.

  5. Toimi seuraavasti:

    • Jos haluat kirjautua nimettömät kirjautumiset sallivaan FTP-palvelimeen, valitse kirjautumisasetukseksiAnonyymi.

    • Jos haluat kirjautua FPT-palvelimeen, johon sinulla on käyttöoikeudet, valitse kirjautumisasetukseksiKäyttäjä ja anna sitten salasanasi Salasana-ruutuun.

  6. Valitse Lisää.

  7. Valitse OK.

  1. Valitse Tiedosto-valikosta Muunna verkkosivuksi.

  2. Valitse Kohde-luettelosta Internet-osoitteet (FTP).

  3. Kaksoisnapsauta FTP-palvelinluettelossa haluamaasi palvelinta ja kaksoisnapsauta kansiota, johon haluat julkaista verkkosivuston.

    Huomautus: Jos Internet-palveluntarjoajasi (ISP) vaatii erillistä ohjelmaa, jolla verkkosivusto lähetetään palvelimeen, tai jos julkaiset verkkosivuston yrityksen intranetiin, sinun täytyy ehkä tallentaa verkkosivustosta uusi versio tietyssä tiedostomuodossa (HTML) ja julkaista verkkosivusto eri ohjeiden mukaisesti. Kysy tässä tapauksessa Internet-palveluntarjoajaltasi tai järjestelmänvalvojaltasi lisäohjeita verkkosivuston tallentamiseen ja julkaisemiseen.

Verkkosivuston julkaiseminen oman tietokoneen kansiossa

Windows Vista

  1. Valitse Tiedosto-valikosta Muunna verkkosivuksi.

  2. Napsauta osoiterivillä sitä asemaa tai kansiota, johon haluat julkaista verkkosivustosi (esimerkiksi Tiedostot-kansio).

    Jos haluat lisätä verkkosivuston uuteen kansioon, valitse työkalupalkista Uusi kansio, anna sille nimi ja paina sitten Enteriä.

  3. Valitse Tiedostonimi-ruudussa aloitussivun oletusnimeksi index ja valitse sitten Tallenna.

    Index.htm on oletusvalinta. Kun valitset aloitussivusi nimeksi index, sen käyttö on helpompaa. Tämä myös estää käyttäjiä näkemästä luetteloa tiedostoista, joista sivustosi koostuu.

Windows XP

  1. Valitse Tiedosto-valikosta Muunna verkkosivuksi.

  2. Napsauta Kohde-luettelossa sitä asemaa tai kansiota, johon haluat julkaista verkkosivustosi (esimerkiksi Omat tiedostot-kansio).

    Jos haluat lisätä verkkosivuston uuteen kansioon, napsauta hiiren kakkospainiketta sijainnissa, johon haluat lisätä uuden kansion, ja luo sitten uusi kansio valitsemalla Uusi > Kansio. Anna uuden kansion nimi Nimi-ruutuun ja valitse sitten Avaa.

  3. Valitse Tiedostonimi-ruudussa aloitussivun oletusnimeksi index ja valitse sitten Tallenna.

    Index.htm on oletusvalinta. Kun valitset aloitussivusi nimeksi index, sen käyttö on helpompaa. Tämä myös estää käyttäjiä näkemästä luetteloa tiedostoista, joista sivustosi koostuu.

Sivun alkuun

Verkkosivuston ylläpitäminen

Kun olet julkaissut sivustosi, voit päivittää sitä tarvittaessa uusilla tiedoilla. Et kuitenkaan voi avata suodatettuja HTML-tiedostoja Publisherissa. Sinun täytyy avata alkuperäinen verkkojulkaisu, tehtävä haluamasi muutokset siihen ja julkaistava sitten sivusto uudelleen Internetiin.

Huomautus: Älä yritä päivittää suodatettuja HTML-tiedostoja tekstieditorilla, esimerkiksi Muistio- tai Microsoft WordPad -ohjelmilla. Vaikka tämä onkin mahdollista, on Publisherin luoma HTML-koodi hyvin monimutkaista, joten sen muokkaaminen manuaalisesti on hyvin vaikeaa. Saat parhaat tulokset, kun päivität Publisher-sivustosi aina verkkojulkaisua päivittämällä ja julkaisemalla sitten sen uudelleen Internetissä.

Julkaise vain tekemäsi muutokset

Office Publisher 2007 mahdollistaa aiemmin luodun verkkosivuston päivitysten julkaisemisen nopeasti, sillä voit julkaista vaiheittain uudelleen vain päivitetyt sivustot. Jos aiot päivittää sivustoa usein tai jos sivustosi on suuri ja monimutkainen, tämä vaiheittainen verkkojulkaiseminen voi nopeuttaa sivustosi päivittämistä.

Jos teet muutoksia verkkosivustoosi suoraan kohteessa Verkkopalvelin, joka on kohteen Office Publisher 2007 ulkopuolella, vaiheittaisen verkkojulkaisemisen käyttöönotto saattaa estää sinua julkaisemasta uusia päivityksiä sivustoosi Muunna verkkosivuksi -komennolla. Jos aiot hallita verkkosivustosi tiedostoja suoraan verkkopalvelimessa (esimerkiksi erillinen FTP), poista vaiheittainen verkkojulkaiseminen käytöstä.

Huomautus: Vaiheittainen verkkojulkaiseminen on oletusarvoisesti käytössä Publisherissa.

Vaiheittaisen verkkojulkaisemisen käyttöön ottaminen ja käytöstä poistaminen

  1. Valitse Työkalut-valikosta Asetukset ja valitse sitten Verkko-välilehti.

  2. Toimi tallentamisen kohdassa seuraavasti:

    • Jos haluat poistaa vaiheittaisen verkkojulkaisemisen käytöstä, poista Ota vaiheittainen WWW-julkaiseminen käyttöön -valintaruudun valinta.

    • Jos haluat ottaa vaiheittaisen verkkojulkaisemisen käyttöön, valitse Ota vaiheittainen WWW-julkaiseminen käyttöön -valintaruutu.

Muutosten julkaiseminen verkkosivustoon

Verkkosivuston muutosten julkaiseminen eroaa hieman verkkosivuston ensimmäisestä julkaisemisesta. Kun olet julkaissut sivuston Internetiin tai verkkoon, näet sivuston pikakuvakkeen Verkkoympäristö-kohdassa

Windows Vista

  1. Valitse Tiedosto-valikosta Muunna verkkosivuksi.

  2. Valitse Muunna verkkosivuksi -valintaikkunan siirtymisruudusta Tietokone.

  3. Kaksoisnapsauta tiedostoluettelossa sen verkkopalvelimen kansion pikakuvaketta, johon olet julkaissut verkkosivustosi.

  4. Kaksoisnapsauta kansiota, johon haluat tallentaa tiedoston.

  5. Kirjoita Tiedoston nimi -ruutuun sivun päivitettävän tiedoston nimi ja valitse sitten Tallenna.

Windows XP

  1. Valitse Tiedosto-valikosta Muunna verkkosivuksi.

  2. Valitse Muunna verkkosivuksi -valintaikkunassa Verkkoympäristö.

  3. Kaksoisnapsauta sen verkkopalvelimen kansion pikakuvaketta, johon olet julkaissut verkkosivustosi.

  4. Kaksoisnapsauta kansiota, johon haluat tallentaa tiedoston.

  5. Kirjoita Tiedoston nimi -ruutuun sivun päivitettävän tiedoston nimi ja valitse sitten Tallenna.

Sivun alkuun

Huomautus: Konekäännöksestä ilmoittava vastuusvapauslauseke: Tämä artikkeli on käännetty tietokonejärjestelmällä, eikä kieliasiantuntija ole muokannut sitä. Microsoft tarjoaa nämä konekäännökset avuksi muille kuin englantia puhuville käyttäjille, jotta he saavat lisätietoja Microsoftin tuotteista, palveluista ja tekniikoista. Koska artikkeli on koneellisesti käännetty, se saattaa sisältää sanasto-, lauseoppi- ja kielioppivirheitä.

Kehitä taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×