Mukautetun luettelolomakkeen luominen

Tärkeää: Tämä on artikkeli on käännetty koneellisesti. Lue vastuuvapauslauseke. Tämän artikkelin englanninkielinen versio on täällä .

Oletusarvon mukaan useat SharePoint-luettelot ja -kirjastot sisältävät lomakkeita, jotka näytetään, kun haluat lisätä kohteen kyseiseen luetteloon tai kirjastoon, muokata kohdetta kyseisessä luettelossa tai kirjastossa tai näyttää kohteen niissä. Microsoft Office SharePoint Designer 2007:llä voit helposti korvata minkä tahansa oletusluettelolomakkeen mukautetulla luettelolomakkeella, jonka voit luoda omia tarpeitasi vastaavaksi. Mukautetun luettelolomakkeen, mukaan lukien haluamiesi kenttien, luomisen jälkeen voit tehdä uudesta lomakkeesta kyseisen luettelon tai kirjaston oletuslomakkeen.

Kun olet luonut mukautetun luettelolomakkeen, voit käyttää Office SharePoint Designer 2007 WYSIWYG-työkaluilla voit lisätä tai poistaa sarakkeita, muuta fonttimuotoilut tai värejä. Kun teet näin, Extensible Stylesheet Language (XSL) on lisätty suoraan HTML-koodiin. Se on mahdollista muokata XSL koodin näkymässä, mutta voit käyttää myös muotoilutyökalut Office SharePoint Designer 2007 sovelletaan XSL nopeasti ja helposti ilman tietää, mitä tahansa XSL.

Tässä artikkelissa kerrotaan, kuinka voit paikantaa oletusluettelolomakkeet, luoda uuden mukautetun luettelolomakkeen sisältävän sivun ja liittää uuden sivun sen jälkeen luetteloon.

Tämän artikkelin sisältö

Etsi luettelosta Oletuslomakkeet

Uuden sivun, joka sisältää mukautetun luettelolomakkeen luominen

Uuden sivun liittäminen luetteloon

Oletusluettelolomakkeiden paikantaminen

Useissa SharePoint-luetteloissa ja -kirjastoissa on luettelolomakkeita, joita käytetään uuden kohteen lisäämiseen kyseiseen luetteloon ja kirjastoon sekä uuden kohteen muokkaamiseen ja näyttämiseen kyseisessä luettelossa tai kirjastossa. Luettelolomakkeet sijaitsevat kansiossa, joka sisältää liitetyn luettelon.

Vaikkei oletuslomakkeita tarvitse paikantaa ennen mukautetun luettelolomakkeen luomista, niiden sijainnin tietäminen ja mukautettujen luettelolomakkeiden tallentaminen samaan sijaintiin on kuitenkin hyödyllistä. Voit etsiä luettelon tai kirjaston oletusluettelolomakkeet seuraavasti:

  1. Jos kansioluettelo ei ole näkyvissä, valitse Näytä-valikosta Kansioluettelo.

    Pikanäppäin avaa Kansioluettelo, paina ALT + F1-näppäintä.

  2. Paikanna SharePoint-luettelon yhteydessä Luettelot-kansio kansioluettelosta. Paikanna SharePoint-kirjaston yhteydessä Jaetut asiakirjat -kansio. Jos Luettelot- tai Jaetut asiakirjat -kansio on kutistettuna, laajenna se napsauttamalla plusmerkkiä (+).

  3. Paikanna luettelo tai kirjasto, jolle haluat luoda mukautetun luettelolomakkeen. Jos luettelo tai kirjastoluettelo on kutistettuna, laajenna se napsauttamalla plusmerkkiä (+).

    Seuraavassa kuvassa on laajennettu Ilmoitukset-luettelo.

    SharePoint-luettelon luettelolomakkeet niin kuin ne näkyvät kansioluettelossa

Oletusarvon mukaan kansiossa näkyy kolme lomakesivutiedostoa: DispForm.aspx, EditForm.aspx ja NewForm.aspx. Neljäs tiedosto, AllItems.aspx, on oletustietonäkymä, joka näyttää luettelon kohteet, kuten seuraavassa kuvassa on esitetty:

AllItems-lomakesivu niin kuin se näkyy selaimessa

Huomautus: Luettelosta riippuen kansiossa saattaa olla useita tietonäkymäsivuja useiden lomakesivujen lisäksi.

Office SharePoint Designer 2007:llä voit luoda mukautettuja Uusi kohta-, Muokkaa kohtaa- tai Näytä kohta -oletuslomakkeen korvaavia lomakkeita korvaamalla aiemmin luodun luettelonäkymä-Web-osan mukautetulla lomake-Web-osalla.

Seuraavassa on kolme kuvaa Ilmoitukset-luettelon oletusluettelolomakkeista.

  • NewForm.aspx-sivu näyttää Uusi kohde -lomakkeen, joka tulee näkyviin, kun lisäät uuden kohteen luetteloon.

    NewForm.aspx-sivu niin kuin se näkyy selaimessa

  • EditForm.aspx-sivu näyttää Muokkaa kohtaa -lomakkeen, joka tulee näkyviin, kun muokkaat luettelon kohdetta.

    EditForm.aspx-sivu niin kuin se näkyy selaimessa

  • DispForm.aspx-sivu näyttää Näytä kohta -lomakkeen, joka tulee näkyviin, kun tarkastelet yhtä luettelon kohdetta.

    DispForm.aspx-lomakesivu niin kuin se näkyy selaimessa

Sivun alkuun

Uuden mukautetun luettelolomakkeen sisältävän sivun luominen

Aloitat luomalla uuden sivun ja lisäämällä sitten mukautetun luettelolomakkeen sivulle. Sivun tallentamisen jälkeen voit liittää sivun aiemmin luotuun luetteloon.

  1. Valitse Tiedosto-valikosta Uusi.

  2. Valitse Uusi-valintaikkunan Sivu-välilehdestä Yleiset ja kaksoisnapsauta sitten ASPX.

  3. Valitse Lisää-valikosta SharePoint-ohjausobjektit ja valitse sitten Mukautettu luettelolomake.

    Luettelon tai asiakirjakirjaston lomake -valintaikkuna avautuu.

    Luettelon tai asiakirjakirjaston lomake -valintaikkuna

  4. Valitse Lomakkeita varten käytettävä luettelo tai asiakirjakirjasto -luettelosta luettelo tai kirjasto, jolle haluat luoda lomakkeen. Valitse tässä esimerkissä Ilmoitukset.

  5. Valitse Lomakkeessa käytettävä sisältölaji -luettelosta sisältölaji, jolle haluat käyttää lomaketta. Valitse tässä esimerkissä Ilmoitukset.(Tämä voi olla ainut vaihtoehto, koska Ilmoitukset-luettelolla on vain yksi oletussisältölaji.)

    Jokainen luettelo tai kirjasto voidaan määrittää sallimaan useita sisältölajeja, jotka näkyvät sitten tämän valintaikkunan Lomakkeessa käytettävä sisältölaji -luettelossa. Voit käyttää erillisiä mukautettuja luettelolomakkeita jokaista sisältölajia varten, joka on käytettävissä luettelossa tai kirjastossa. Jos esimerkiksi luettelon sisältölajina on sekä Lehdistötiedote että Teollisuuden uutisia, voit luoda kaksi erilaista mukautettujen luettelolomakkeiden joukkoa, yhden kumpaakin sisältölajia varten.

    Kun kutakin sisältölajia varten on erillinen mukautettu luettelolomake, etuna on se, että jokainen mukautettu luettelolomake on suunniteltu silloin näyttämään vain kyseiselle sisältölajille sopivia kenttiä.

  6. Osoita Luotavan lomakkeen laji -kohdassa luotavan lomakkeen laji valitsemalla joko Uusi kohta -lomake, Muokkaa kohtaa -lomake tai Näytä kohta -lomake.

    Valitse tässä esimerkissä Uusi kohta -lomake.

  7. Voit sisällyttää työkalurivin lomakkeeseen valitsemalla Näytä vakiotyökalurivi -valintaruutu.

    Mukautettu luettelolomake voi sisältää työkalurivin, jonka avulla käyttäjät voivat suorittaa yleisiä toimintoja kohteelle. Työkalurivin komennot määräytyvät lomakkeen lajin mukaan. Esimerkiksi EditForm.aspx-lomakkeen työkalurivi näyttää mahdollisesti seuraavan kuvan kaltaiselta.

    EditForm.aspx-työkalurivi

    DispForm.aspx-lomakkeen työkalurivi taas voi näyttää seuraavan kuvan kaltaiselta.

    DispForm.aspx-työkalurivi

  8. Valitse OK. Uusi kohta -lomake tulee näkyviin sivulle.

    Uusi kohta -lomake näkyy sivulla

    Huomautus: Kuva on esimerkki ASPX-sivusta, jota ei ole liitetty perustyylisivuun. Voit ottaa SharePoint-sivuston ulkoasun käyttöön liittämällä sivun perustyylisivuun. Voit tehdä tämän valitsemalla Muotoile-valikosta Perustyylisivu ja valitsemalla sitten Liitä perustyylisivu. Valitse Perustyylisivun valitseminen -valintaikkunassa Oletusperustyylisivu ja valitse sitten OK. Täsmäytä sisältöalueet -valintaikkuna tulee näkyviin. Voit täsmäyttää sivun leipätekstin PlaceHolderMain-sisältöpaikkamerkkiin valitsemalla OK.

    Oletusarvon mukaan mukautettu luettelolomake näyttää valitun lomakelajin oletuskentät ja kunkin oletuskentän oletusohjausobjektit. Esimerkiksi Ilmoitukset-luettelon Voimassa-kentän ohjausobjektina on päivämäärävalitsin. Mahdolliset pakolliset kentät ilmoitetaan automaattisesti tähtimerkillä.

  9. Voit tallentaa uuden mukautetun luettelolomakkeen valitsemalla Tiedosto-valikosta Tallenna nimellä. Voit vaihtoehtoisesti painaa CTRL+S-näppäinyhdistelmää.

  10. Selaa Tallenna nimellä -valintaikkunan suuressa luetteloruudussa luettelo- tai kirjastokansioon, jolle olet luonut mukautetun luettelolomakkeen.

    Voit seurata esimerkiksi Tallenna nimellä -valintaikkuna kaksoisnapsauttamalla luettelotja kaksoisnapsauta sitten ilmoituksetilmoitukset -kansion avaaminen. Kirjoita Tiedostonimi -ruutuun NewAnnouncementsja valitse sitten Tallenna.

    Esimerkissä Tiedostonimi -ruutuun, kirjoita NewAnnouncementsja valitse sitten Tallenna.

    NewAnnouncements.aspx-sivu tulee näkyviin Ilmoitukset-kansion kansioluetteloon.

Sivun alkuun

Uuden sivun liittäminen luetteloon

Mukautetun luettelolomakkeen luomisen jälkeen voit liittää luettelolomakkeen luetteloon, jolle olet luonut sen. Mukautettu luettelolomake ei tule näkyviin selaimeen, kun käyttäjät luovat, tarkastelevat tai muokkaavat kyseisen luettelon kohteita, ennen kuin mukautettu luettelolomake on liitetty luetteloon.

Olet luonut aiemmassa esimerkissä NewAnnouncements.aspx-lomakkeen Ilmoitukset-luetteloon, joten seuraava vaihe on liittää NewAnnouncements.aspx Ilmoitukset-luetteloon.

  1. Napsauta hiiren kakkospainikkeella kansioluettelossa luetteloa tai kirjastoa, johon haluat liittää mukautetun luettelolomakkeen – tässä esimerkissä Ilmoitukset – ja valitse sitten pikavalikosta Ominaisuudet.

  2. Valitse Luettelon ominaisuudet -valintaikkunan Tukitiedostot-välilehti.

  3. Jos luettelo on määritetty sallimaan useita sisältölajeja, valitse Sisältölajikohtaiset lomakkeet -luettelosta sisältölaji, jolle haluat käyttää mukautettua luettelolomaketta.

    Aina kun muutat sisältölajia, tekstikehykset muuttuvat niin, että ne näyttävät nykyisessä sisältölajissa käytetyt lomakkeet. Jokainen sisältölaji voi käyttää erillisiä mukautettuja luettelolomakkeita.

  4. Valitse Uusi kohta -lomake -kohdassa Selaa, paikanna ja valitse mukautettu luettelolomake – tässä esimerkissä NewAnnouncements.aspx – ja valitse sitten OK.

    Polku mukautettuun luettelolomakkeeseen näkyy Uusi kohta -lomake -ruudussa.

  5. Valitse OK.

Jos olet noudattanut esimerkkiä, voit testata uutta mukautettua lomaketta. Valitse kansioluettelosta Default.aspx ja avaa sitten sivu selaimessa painamalla F12. Avaa mukautettu Uusi kohta -lomake valitsemalla selaimessa Ilmoitukset-kohdasta Lisää uusi ilmoitus.

Sivun alkuun

Huomautus: Konekäännöksestä ilmoittava vastuusvapauslauseke: Tämä artikkeli on käännetty tietokonejärjestelmällä, eikä kieliasiantuntija ole muokannut sitä. Microsoft tarjoaa nämä konekäännökset avuksi muille kuin englantia puhuville käyttäjille, jotta he saavat lisätietoja Microsoftin tuotteista, palveluista ja tekniikoista. Koska artikkeli on koneellisesti käännetty, se saattaa sisältää sanasto-, lauseoppi- ja kielioppivirheitä.

Kehitä taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×