Microsoft Visual C++ 6.0:n lähdekoodin rakenteen selvittäminen

Tärkeää: Tämä on artikkeli on käännetty koneellisesti. Lue vastuuvapauslauseke. Tämän artikkelin englanninkielinen versio on täällä .

  1. Mukauta Visual C++.

    miten

    1. Valitse Visual C++:ssa Tools-valikosta Customize.

    2. Valitse Customize-valintaikkunasta Add-Ins And Macro Files -välilehti.

    3. Valitse Add-Ins And Macro Files -luettelosta Visio UML Add-In.

      Visio UML Add-In -kohdan viereen tulee näkyviin valintamerkki.

    4. Valitse Close.

      Näyttöön tulee irrallinen viisipainikkeinen Visio UML -laajennuksen työkalurivi.

    5. Jos haluat, että työkalurivi on käytettävissä aina, kun avaat Visual C++:n, kiinnitä työkalurivi vetämällä se työkalurivien alueelle.

      Vihje: Jos haluat luoda pikanäppäimet kaikille Visio UML -laajennuksen työkalurivin painikkeille, valitse Tools-valikosta Customize, siirry Keyboard-välilehteen ja valitse Add-Ins-luokka.

      Voit määrittää edelleen järjestelmän lähdemääritysten (MFC, ATL tai Sisällytä)-tiedostot valitsemalla Vision UML-asetukset -painikkeen UML-asetukset-painikkeen kuva .

  2. Luo selaustietotiedosto.

    miten

    1. Valitse Visual C++:n Project-valikosta Settings.

    2. Valitse Project Settings -valintaikkunasta haluamasi rakennusmääritykset, valitse C/C++ -välilehti ja valitse sitten Generate Browse Info.

    3. Valitse Browse Info -välilehti selaustietotiedoston nimen ja sijainnin määrittämiseksi, valitse Build Browse Info File ja valitse sitten OK.

  3. Luo projekti Visual C++:ssa.

    Huomautus: Jos teet muutoksia Visual C++ -projektiin rakenteen selvityksen jälkeen, projekti on muodostettava ja sen rakenne selvitettävä uudelleen, jotta muutokset näkyisivät Visiossa.

  4. Valitse Visual C++ UML-malli lähdekoodiksi työkalurivin painikkeen Muuta UML-malli lähdekoodiksi -painikkeen kuva : Vision UML-apuohjelma -työkalurivillä.

    Jos Visual C++:n työtilassa on useampi kuin yksi projekti, valitse projekti, jonka rakenteen haluat selvittää, valitse projekti (Select Project -valintaikkunassa) ja valitse sitten OK.

    Jos projektihierarkiassa on useampi kuin yksi selaustiedosto, valitse selaustiedosto (Select Browse File -valintaikkunassa) ja valitse sitten OK.

    Luokkatietojen poiminta selaustietotiedostosta voi kestää useita sekunteja. Kun poiminta on tehty, Vision UML-mallikaavio avautuu siten, että näkyvissä on tyhjä staattisen rakennekaavion piirustussivu ja Mallien hallinnan puunäkymä, jossa on lähdekoodin luokkamäärityksiä edustavia kuvakkeita.

  5. Voit luoda mallin näkymää edustavan staattisen rakennekaavion vetämällä kuvakkeet UML-mallikaavion puunäkymästä piirustussivulle.

Huomautus: Konekäännöksestä ilmoittava vastuusvapauslauseke: Tämä artikkeli on käännetty tietokonejärjestelmällä, eikä kieliasiantuntija ole muokannut sitä. Microsoft tarjoaa nämä konekäännökset avuksi muille kuin englantia puhuville käyttäjille, jotta he saavat lisätietoja Microsoftin tuotteista, palveluista ja tekniikoista. Koska artikkeli on koneellisesti käännetty, se saattaa sisältää sanasto-, lauseoppi- ja kielioppivirheitä.

Kehitä taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×