Makron luominen tai suorittaminen

Voit automatisoida Wordissa usein käytettyjä tehtäviä luomalla ja suorittamalla makroja. Makro on komentojen ja ohjeiden sarja, jotka yhdistetään yhdeksi komennoksi tehtävän automaattista suorittamista varten.

Voit säästää aikaa usein toistuvissa tehtävissä, kun yhdistät vaiheet makroksi. Ensin sinun on tallennettava makro. Sen jälkeen voit suorittaa makron napsauttamalla pikatyökalurivin painiketta tai painamalla näppäinyhdistelmää. Tämä riippuu siitä, miten olet määrittänyt makron.

  1. Valitse Näytä > Makrot > Tallenna makro.

    Tallenna makro -komento

  2. Anna makrolle nimi.

    Makron nimi -ruutu

  3. Jos haluat käyttää makroa uudessa asiakirjassa, varmista, että Makron tallennuspaikka ‑valintaruudussa lukee Kaikki asiakirjat (Normal.dotm).

    Makron tallennuspaikan valintaruutu

  4. Jos haluat suorittaa makron painiketta painamalla, valitse Painike.

    Makron yhdistäminen painikkeeseen napsauttamalla

  5. Napsauta uutta makroa (sen nimi on esimerkiksi Normal.NewMacros.<oman makron nimi>) ja valitse Lisää.

    Makro ja Lisää-painike

  6. Valitse Muokkaa.

    Muokkaa-painike Mukauta pikatyökaluriviä -ruudussa

  7. Valitse painikkeen kuva, kirjoita haluamasi nimi ja valitse OK kahdesti.

    Painikevaihtoehdot Muokkaa-painikkeen ruudussa.

  8. Nyt voit tallentaa vaiheet. Napsauta kunkin tehtävän vaiheen komentoja tai paina niitä vastaavia painikkeita. Word tallentaa napsautukset ja painikkeiden painallukset.

    Huomautus: Voit valita tekstin näppäimistön avulla makroa tallennettaessa. Makrot eivät tallenna hiirellä tehtyjä valintoja.

  9. Kun haluat pysäyttää tallennuksen, valitse Näytä > Makrot > Lopeta tallentaminen.

    Lopeta tallentaminen -komento

Makron painike ilmestyy pikatyökaluriville.

Pikatyökalurivin makropainike

Kun haluat suorittaa makron, paina painiketta.

  1. Valitse Näytä > Makrot > Tallenna makro.

    Tallenna makro -komento

  2. Anna makrolle nimi.

    Makron nimi -ruutu

  3. Jos haluat käyttää makroa uudessa asiakirjassa, varmista, että Makron tallennuspaikka ‑valintaruudussa lukee Kaikki asiakirjat (Normal.dotm).

    Makron tallennuspaikan valintaruutu

  4. Jos haluat suorittaa makron pikanäppäintä painamalla, valitse Näppäimistö.

    Makron yhdistäminen pikanäppäimeen napsauttamalla

  5. Kirjoita painikeyhdistelmä Anna uusi näppäinyhdistelmä ‑valintaruutuun.

  6. Tarkista, ettei samaa yhdistelmää ole jo yhdistetty mihinkään muuhun. Jos se on jo käytössä, kokeile jotakin muuta yhdistelmää.

  7. Jos haluat käyttää tätä pikanäppäintä uudessa asiakirjassa, varmista, että Tallenna tiedostoon ‑valintaruudussa lukee Normal.dotm.

  8. Valitse Määritä.

  9. Nyt voit tallentaa vaiheet. Napsauta kunkin tehtävän vaiheen komentoja tai paina niitä vastaavia painikkeita. Word tallentaa napsautukset ja painikkeiden painallukset.

    Huomautus: Voit valita tekstin näppäimistön avulla makroa tallennettaessa. Makrot eivät tallenna hiirellä tehtyjä valintoja.

  10. Kun haluat pysäyttää tallennuksen, valitse Näytä > Makrot > Lopeta tallentaminen.

    Lopeta tallentaminen -komento

Kun haluat suorittaa makron, paina pikanäppäimiä.

Voit suorittaa makron napsauttamalla pikatyökalurivin painiketta, painamalla pikanäppäintä tai suorittamalla makron Makrot-luettelossa.

  1. Valitse Näytä > Makrot > Näytä makrot.

    Näytä makrot -komento

  2. Napsauta Makron nimi ‑kohdan luettelossa makroa, jonka haluat suorittaa.

  3. Valitse Suorita.

Jos haluat, että jonkin asiakirjan makro on saatavilla kaikkiin uusiin asiakirjoihin, lisää se Normal.dotm-malliin.

  1. Avaa makron sisältävä työkirja.

  2. Valitse Näytä > Makrot > Näytä makrot.

    Näytä makrot -komento

  3. Valitse Järjestäjä.

    Näytä makrot -valintaikkunan Järjestäjä-painike

  4. Napsauta Normal.dotm-malliin lisättävää makroa ja valitse Kopioi.

  1. Valitse Tiedosto > Asetukset > Muokkaa valintanauhaa.

  2. Valitse Makrot kohdassa Valitse komennoista.

  3. Valitse haluamasi makro.

  4. Napsauta Mukauta valintanauhaa ‑kohdan välilehteä ja mukautettua ryhmää, johon haluat lisätä makron.

Jos käytössäsi ei ole mukautettua ryhmää, valitse Uusi ryhmä. Valitse sitten Nimeä uudelleen ja anna mukautetulle ryhmälle nimi.

  1. Valitse Lisää.

  2. Valitse Nimeä uudelleen, kun haluat muuttaa makron kuvaa ja kirjoittaa haluamasi nimen.

  3. Valitse OK kahdesti.

  1. Valitse Kehitystyökalut-välilehden Koodi-ryhmästä Makrot.

  2. Kirjoita makron nimi Makron nimi -ruutuun.

    Huomautus: Jos annat uudelle makrolle saman nimen kuin makrolle, joka on jo valmiina Wordissa, uuden makron toiminnot korvaavat valmiin makron. Voit tarkastella valmiiden makrojen luetteloa valitsemalla Word-komennotMakrojen lähde -luettelosta.

  3. Valitse Makrojen lähde -luettelosta malli tai asiakirja, johon haluat tallentaa makron.

    Jotta makron voidaan asettaa käytettäväksi kaikissa asiakirjoissa, muista napsauttaa Normal.dotm.

  4. Avaa Visual Basic Editor valitsemalla Luo.

Kun olet avannut Visual Basic Editorin, lisätiedot Visual Basic for Applicationsin käyttämisestä voivat olla tarpeen. Saat lisätietoja napsauttamalla Microsoft Visual Basicin ohje -kohtaa Ohje-valikossa tai painamalla F1-näppäintä.

Voit nauhoittaa toiminnot tai kirjoittaa makron alusta alkaen kirjoittamalla Visual Basic for Applications -koodin kohdassa Visual Basic -editori.

Huomautus: Makrojen käsitteleminen Office Word 2007 -ohjelmassa edellyttää Kehitystyökalut-välilehden tuomista näkyviin.

  1. Napsauta Microsoft Office -painiketta Office-painikkeen kuva ja valitse sitten Wordin asetukset.

  2. Valitse Käyttäjän asetukset.

  3. Valitse Wordin käyttämisen perusasetukset -kohdasta Näytä Kehitystyökalut-välilehti valintanauhassa -valintaruutu.

    Huomautus: Valintanauha on osa Microsoft Officen sujuvaa käyttöliittymää.

  1. Valitse Kehitystyökalut-välilehden Koodi-ryhmästä Nauhoita makro.

    Kehitystyökalut-välilehden Koodi-ryhmä
  2. Kirjoita makron nimi Makron nimi -ruutuun.

    Huomautus: Jos annat uudelle makrolle saman nimen kuin makrolle, joka on jo valmiina Office Word 2007 -ohjelmassa, uuden makron toiminnot korvaavat valmiin makron. Valitse Kehitystyökalut-välilehden Koodi-ryhmästä Makrot, jos haluat nähdä luettelon valmiista makroista. Valitse Makrojen lähde -luettelosta Word-komennot.

  3. Valitse Makron tallennuspaikka -ruudusta malli tai asiakirja, johon haluat tallentaa makron.

    Tärkeää: Jotta makron voidaan asettaa käytettäväksi kaikissa asiakirjoissa, muista napsauttaa Normal.dotm.

  4. Kirjoita Kuvaus-ruutuun makron kuvaus.

  5. Tee jompikumpi seuraavista:

    • Nauhoittamisen aloittaminen    Kun haluat aloittaa makron nauhoittamisen yhdistämättä makroa pikatyökalurivin painikkeeseen tai pikanäppäimeen, valitse OK.

    • Luo painike     Toimi seuraavasti makron yhdistämiseksi painikkeeseen pikatyökaluriville:

      1. Valitse Painike.

      2. Valitse Mukauta pikatyökalurivi -kohdassa asiakirja (tai kaikki asiakirjat), joiden pikatyökaluriville haluat lisätä makron.

        Tärkeää: Jotta makron voidaan asettaa käytettäväksi kaikissa asiakirjoissa, muista napsauttaa Normal.dotm.

      3. Napsauta Valitse komennoista -valintaikkunassa nauhoitettavaa makroa ja valitse sitten Lisää.

      4. Voit mukauttaa painiketta valitsemalla Muokkaa.

      5. Valitse Symboli-kohdasta haluamasi merkki, jota haluat käyttää painikkeelle.

      6. Kirjoita Näyttönimi ‑ruutuun makron nimi, jonka haluat näkyvän.

      7. Napsauta OK kahdesti, kun haluat aloittaa makron nauhoittamisen.

        Valitsemasi merkki tulee näkyviin pikatyökalurivillä. Antamasi nimi näkyy, kun osoitat merkkiä.

    • Pikanäppäimen määrittäminen    Toimi seuraavasti makron määrittämiseksi pikanäppäimeen:

      1. Valitse Näppäimistö.

      2. Valitse Komennot-ruudusta nauhoitettava makro.

      3. Kirjoita Anna uusi näppäinyhdistelmä -ruutuun haluamasi näppäinyhdistelmä ja valitse Liitä.

      4. Aloita makron nauhoittaminen valitsemalla Sulje.

  6. Suorita toimet, jotka haluat nauhoittaa makroon.

    Huomautus: Kun nauhoitat makron, voit valita komentoja ja asetuksia napsauttamalla, mutta tekstiä ei voi valita. Teksti on valittava näppäimistöllä. Lisätietoja tekstin valitsemisesta näppäimistön avulla on kohdassa Tekstin valitseminen.

  7. Kun haluat lopettaa toimintojen nauhoittamisen, valitse Koodi-ryhmässä Lopeta nauhoitus.

Makron pikanäppäimen vaihtaminen

  1. Napsauta Microsoft Office ‑painiketta Office-painikkeen kuva ja valitse sitten Wordin asetukset.

  2. Valitse Mukauta.

  3. Valitse Pikanäppäimet-kohdan vierestä Mukauta.

  4. Valitse Luokat-luettelosta Makrot.

  5. Valitse Makrot -luettelossa makro, jonka haluat muuttaa.

  6. Kirjoita Anna uusi näppäinyhdistelmä -ruutuun näppäinyhdistelmä, jota haluat käyttää.

  7. Tarkista Nykyiset näppäimet -ruutu, jos haluat varmistaa, ettet määritä sellaista näppäinyhdistelmää, joka on jo käytössä jonkin muun tehtävän suorittamiseksi.

  8. Valitse Tallenna muutokset -luettelosta vaihtoehto, joka vastaa sitä, johon haluat suorittaa makron.

    Tärkeää: Jotta makron voidaan asettaa käytettäväksi kaikissa asiakirjoissa, muista napsauttaa Normal.dotm.

  9. Napsauta Sulje.

  1. Valitse Kehitystyökalut-välilehden Koodi-ryhmästä Makrot.

    Kehitystyökalut-välilehden Koodi-ryhmä

  2. Napsauta Makron nimi -luettelosta makroa, jonka haluat suorittaa.

  3. Valitse Suorita.

  1. Valitse Kehitystyökalut-välilehden Koodi-ryhmästä Makrot.

    Kehitystyökalut-välilehden Koodi-ryhmä

  2. Kirjoita makron nimi Makron nimi -ruutuun.

    Huomautus: Jos annat uudelle makrolle saman nimen kuin makrolle, joka on jo valmiina Office Word 2007 -ohjelmassa, uuden makron toiminnot korvaavat valmiin makron. Voit tarkastella valmiiden makrojen luetteloa valitsemalla Word-komennotMakrojen lähde -luettelosta.

  3. Valitse Makrojen lähde -luettelosta malli tai asiakirja, johon haluat tallentaa makron.

    Jotta makron voidaan asettaa käytettäväksi kaikissa asiakirjoissa, muista napsauttaa Normal.dotm.

  4. Avaa Visual Basic Editor valitsemalla Luo.

Kun olet avannut Visual Basic Editorin, lisätiedot Visual Basic for Applicationsin käyttämisestä voivat olla tarpeen. Saat lisätietoja napsauttamalla Microsoft Visual Basicin ohje -kohtaa Ohje-valikossa tai painamalla F1-näppäintä.

Kehitä taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×