Makron luominen, suorittaminen, muokkaaminen tai poistaminen

Tärkeää: Tämä on artikkeli on käännetty koneellisesti. Lue vastuuvapauslauseke. Tämän artikkelin englanninkielinen versio on täällä .

Voit säästää aikaa usein toistuvien tehtävien suorittamisesta luomalla näistä tehtävistä makroja. Tämän jälkeen voit suorittaa tällaisia tehtäviä suorittamalla makroja, joihin olet määrittänyt näiden tehtävien vaiheet.

Word

Word 2016 for Macin Luo makro, joka on pikanäppäin, makron suorittaminen ja poista makro, joka ei enää tarvita.

  1. Valitse Näytä > Makrot > Tallenna makro.

    Aloita makron luominen valitsemalla Näytä-välilehdestä Makro ja valitse sitten Tallenna makro.
  2. Anna makrolle nimi tai hyväksy oletusnimi, jonka Word antaa.

    Kirjoita makron nimi Makron nimi -kohtaan tai hyväksy Wordin tarjoama yleinen nimi.
  3. Jos haluat käyttää makroa uusissa luomissasi tiedostoissa, varmista, että Makron tallennuspaikka: ‑luettelossa lukee Kaikki asiakirjat (normaali).

  4. Valitse Näppäimistö ja määritä makrolle näppäinyhdistelmä.

    Word avaa Mukauta näppäimistö -valintaikkunan.

  5. Kirjoita pikanäppäinyhdistelmä Anna uusi pikanäppäin ‑ruutuun.

    Word näyttää komennon tai makron, joka on jo määritetty jollekin näppäinyhdistelmälle, kun painat tätä yhdistelmää.

    Kun painat pikanäppäinyhdistelmää, Word näyttää sille tälle hetkellä mahdollisesti määritetyn komennon tai toiminnon.

  6. Jos valitsemasi pikanäppäinyhdistelmä on jo käytössä, poista se Anna uusi pikanäppäinyhdistelmä -ruudusta ja kokeile toista pikanäppäinyhdistelmää.

    Kun löydät vapaan pikanäppäinyhdistelmän, siirry seuraavaan vaiheeseen.

    Word havaitsee, kun olet painanut näppäinyhdistelmää, jota ei ole vielä määritetty komennolle tai makrolle.
  7. Jos haluat käyttää tätä pikanäppäinyhdistelmää uusissa tiedostoissa, varmista, että yleinen malli Normal.dotm on valittuna Tallenna tiedostoon: -luettelossa.

    Valitse Normal.dotm, jos haluat tuoda makron käytettäväksi uusissa luomissasi asiakirjoissa.
  8. Valitse Määritä.

  9. Kun olet valmis määrittämään makron vaiheet, valitse OK.

  10. Napsauta tehtävän kunkin vaiheen komentoja tai paina niiden näppäimiä.

    Word tallentaa napsautuksesi ja näppäinpainalluksesi, mutta se ei tallenna hiirellä valitsemaasi tekstiä. Jos haluat valita tekstiä makron määrittämisen aikana, käytä näppäimistöä.

  11. Kun haluat pysäyttää tallennuksen, valitse Näytä > Makrot > Lopeta tallentaminen.

    Valitse Lopeta tallentaminen Makrot-valikosta, jos haluat lopettaa makron tallentamisen.

Voit suorittaa makron sille määritetyllä pikanäppäinyhdistelmällä tai Makrot-luettelosta.

  1. Valitse Näytä > Makrot > Näytä makrot.

    Valitse Näytä makrot, jos haluat tarkastella ja muokata makroja, jotka on liitetty nykyiseen asiakirjaan.
  2. Valitse Makron nimi -luettelosta makro, jonka haluat suorittaa.

  3. Valitse Suorita.

    Kun olet valinnut Makron nimi-kohdassa makron, suorita se valitsemalla Suorita.

  1. Valitse Näytä > Makrot > Näytä makrot.

    Valitse Näytä makrot, jos haluat tarkastella ja muokata makroja, jotka on liitetty nykyiseen asiakirjaan.
  2. Vahvista, että Makrojen lähde: -kohdan sijainti sisältää sen makron, jonka haluat poistaa.

    Valitse näytettävien makrojen sijainti Makrot-luettelosta.

    Luettelo sisältää tiedoston, joka on auki nykyisessä ikkunassa, sekä yleisen mallin ja Word-komennot.

  3. Valitse Makron nimi -kohdasta poistettava makro ja napsauta sitten miinusmerkkiä luettelon alapuolella.

    Valitse poistettava makro ja valitse sitten miinusmerkki luettelon alapuolella.
  4. Kun Word pyytää sinua vahvistamaan makron poistamisen, valitse Kyllä.

Excel

Excel 2016 for Macin Luo makro, joka on pikanäppäin, makron suorittaminen ja poista makro, joka ei enää tarvita.

Kun tallennat makroa, makron tallennuksen tietueet vaiheiden suorittamiseen tarvittava toiminnot, jotka haluat suorittaa makron. Näin voit sisällyttää kirjoittamaan tekstiä tai numeroita, valitsemalla solut tai jos haluat valita laskentataulukon solut komentoja valintanauhan tai valikoissa, muotoilu ja solujen, rivien tai sarakkeiden valitseminen hiirellä vetämällä.

Huomautus: Tallennuksen, luominen ja poistaminen makrot sekä muita lisätoimintoja komennot ovat käytettävissä myös valintanauhan Kehitystyökalut -välilehden. Lisätietoja Kehitystyökalut-välilehden artikkelissa luominen tai poistaminen Excel 2016 for Macin makron Kehitystyökalut-välilehti.

  1. Valitse Työkalut > makro > Uusi tietue.

    Valitse Työkalut, makro, valitse Tallenna uusi makro

  2. Kirjoita Makron nimi ‑ruutuun makron nimi.

    Kirjoita makron nimi, sijainti ja pikakuvake avain

  3. Jos haluat luoda makrolle näppäinoikotien, kirjoita kirjain optio + Cmd -ruutuun.

  4. Valitse makron sijainti avattavasta luettelosta.

    Tallenna makro

    Valitse

    Tiedosto, johon olet luomassa makroa

    Tämä työkirja

    Kaikki avoinna olevat tiedostot

    Uusi työkirja

    Käytettävissä aina, kun käytät Exceliä

    Omaan makrotyökirjaan

  5. (Valinnainen) Lisää makron kuvaus.

  6. Kun olet valmis, Tallenna, valitse OK.

  7. Napsauta tehtävän kunkin vaiheen komentoja tai paina niiden näppäimiä.

  8. Pysäytä tallennus valitsemalla Työkalut > makro > Pysäytä tallennus. (Tämä vaihe ei tallenneta makron).

    Valitse Lopeta tallentaminen

Jos haluat suorittaa makron, painamalla pikanäppäintä sille tai suorittamalla makron makrot -valintaikkunasta.

  1. Valitse Näytä-välilehdessä Näytä makrot.

  2. Makrot ponnahdusvalikosta ja valitse Tämä työkirja.

  3. Valitse makro luettelosta ja valitse Suorita.

    Makrojen valinta Excel for Macissa

  1. Valitse Työkalut > makro > makrot.

    Valitse makro ja valitse sitten makrot

  2. Valitse poistettava makro ja paina sitten miinusmerkkiä.

    Valitse Makron nimi ja valitse sitten miinusmerkki

  3. Näyttöön vahvistussanoma. Vahvista valitsemalla Kyllä poisto.

    Vahvista poistaminen

Voit myös poistaa makron Kehitystyökalut -välilehti.

  1. Valitse Kehitystyökalut-välilehdessä Makrot.

  2. Valitse poistettava makro luettelosta ja napsauta sitten Delete-näppäintä.

    Valitse makro ja poista se napsauttamalla miinusmerkkiä.

Word

Jos haluat automatisoida jonkin toistuvan tehtävän, voit luoda Wordissa nopeasti makron. Voit myös kirjoittaa oman makrokomentosarjan Microsoft Visual Basic for Applicationsissa käyttämällä Visual Basic -editoria tai kopioida jonkin makron kokonaan tai osittain uuteen makroon.

Kun tallennat makroa, kaikki vaiheet, jotka toiminnot, jotka haluat suorittaa makron suorittamiseen tarvittava tallennetaan. Kuitenkin Siirtyminen takaisin-välilehti ja lopettaa tallennuksen ei sisälly tallennetut vaiheet.

  1. Valitse Kehittäjä-välilehden Visual Basic -kohdassa Tallenna.

    Word Developer -välilehti, Visual Basic -ryhmä

    Jos Kehittäjä-välilehti ei ole käytettävissä

    1. Valitse nauhan oikeassa laidassa Toiminto-ponnahdusvalikko ja valitse sitten Valintanauhan asetukset.

    2. Valitse Mukauta-kohdassa Kehittäjä-valintaruutu.

  2. Kirjoita Makron nimi ‑ruutuun makron nimi.

  3. Tee makron tallennuspaikka -ponnahdusvalikossa jompikumpi seuraavista:

    Makron tallennuspaikka

    Valitse

    Tiedosto, johon olet luomassa makroa

    [tiedoston nimi] (asiakirja)

    Kaikki avoinna olevat tiedostot

    Kaikki asiakirjat (normaali)

  4. Valitse OK ja tee sitten toimet, jotka haluat tallentaa.

  5. Valitse Kehittäjä-välilehden Visual Basic -kohdassa Pysäytä.

Voit luoda makron käyttämällä ohjelmassa valmiina olevaa Visual Basic Editoria.

  1. Valitse Kehittäjä-välilehden Visual Basic -kohdassa Editori.

    Word Developer -välilehti, Visual Basic -ryhmä

    Jos Kehittäjä-välilehti ei ole käytettävissä

    1. Valitse nauhan oikeassa laidassa Toiminto-ponnahdusvalikko ja valitse sitten Valintanauhan asetukset.

    2. Valitse Mukauta-kohdassa Kehittäjä-valintaruutu.

  2. Jos tarvitset lisätä moduulin, valitse Visual Basic Editorin Lisää-valikossa Moduuli.

  3. Kirjoita tai sijoita moduulin koodi-ikkunaan makrokoodi, jota haluat käyttää.

  4. Kun olet valmis, valitse Word-valikossa Sulje ja palaa ohjelmaan Microsoft Word.

  1. Valitse Kehittäjä-välilehden Visual Basic -kohdassa Makrot.

    Word Developer -välilehti, Visual Basic -ryhmä

    Jos Kehittäjä-välilehti ei ole käytettävissä

    1. Valitse nauhan oikeassa laidassa Toiminto-ponnahdusvalikko ja valitse sitten Valintanauhan asetukset.

    2. Valitse Mukauta-kohdassa Kehittäjä-valintaruutu.

  2. Valitse suoritettava makro luettelosta ja valitse Suorita.

Makroa muokataan Visual Basic -editoriilla.

  1. Valitse Kehittäjä-välilehden Visual Basic -kohdassa Makrot.

    Word Developer -välilehti, Visual Basic -ryhmä

    Jos Kehittäjä-välilehti ei ole käytettävissä

    1. Valitse nauhan oikeassa laidassa Toiminto-ponnahdusvalikko ja valitse sitten Valintanauhan asetukset.

    2. Valitse Mukauta-kohdassa Kehittäjä-valintaruutu.

  2. Valitse muokattava makro luettelosta ja valitse Muokkaa.

    Visual Basic Editor avautuu.

  3. Tee haluamasi muutokset.

  4. Kun olet valmis, valitse Word-valikossa Sulje ja palaa ohjelmaan Microsoft Word.

  1. Valitse Kehittäjä-välilehden Visual Basic -kohdassa Makrot.

    Word Developer -välilehti, Visual Basic -ryhmä

    Jos Kehittäjä-välilehti ei ole käytettävissä

    1. Valitse nauhan oikeassa laidassa Toiminto-ponnahdusvalikko ja valitse sitten Valintanauhan asetukset.

    2. Valitse Mukauta-kohdassa Kehittäjä-valintaruutu.

  2. Valitse kopioitava makro luettelosta ja valitse Muokkaa.

    Visual Basic Editor avautuu.

  3. Valitse Visual Basic Editorin koodi-ikkunassa ne makron rivit, jotka haluat kopioida.

    Vihje: Jos haluat kopioida koko makron, varmista, että Sub- ja End Sub -rivit ovat mukana valinnassa.

  4. Valitse Muokkaa-valikossa Kopioi.

  5. Osoita koodi-ikkunan Projekti-ruudussa moduulia, johon haluat sijoittaa koodin.

  6. Valitse Muokkaa-valikossa Sijoita.

  1. Valitse Kehittäjä-välilehden Visual Basic -kohdassa Makrot.

    Word Developer -välilehti, Visual Basic -ryhmä

    Jos Kehittäjä-välilehti ei ole käytettävissä

    1. Valitse nauhan oikeassa laidassa Toiminto-ponnahdusvalikko ja valitse sitten Valintanauhan asetukset.

    2. Valitse Mukauta-kohdassa Kehittäjä-valintaruutu.

  2. Valitse poistettava makro luettelosta ja valitse Poista.

PowerPoint

Jos haluat automatisoida jonkin toistuvan tehtävän, makro luominen PowerPointissa Visual Basic for Applicationsin avulla.

Voit luoda makron käyttämällä ohjelmassa valmiina olevaa Visual Basic Editoria.

  1. Valitse Kehittäjä-välilehden Visual Basic -kohdassa Editori.

    PowerPoint Developer -välilehti, Visual Basic -ryhmä

    Jos Kehittäjä-välilehti ei ole käytettävissä

    1. Valitse nauhan oikeassa laidassa Toiminto-ponnahdusvalikko ja valitse sitten Valintanauhan asetukset.

    2. Valitse Mukauta-kohdassa Kehittäjä-valintaruutu.

  2. Jos tarvitset lisätä moduulin, valitse Visual Basic Editorin Lisää-valikossa Moduuli.

  3. Kirjoita tai sijoita moduulin koodi-ikkunaan makrokoodi, jota haluat käyttää.

  4. Kun olet valmis, valitse PowerPoint-valikossa Sulje ja palaa ohjelmaan Microsoft PowerPoint.

  1. Valitse Kehittäjä-välilehden Visual Basic -kohdassa Makrot.

    PowerPoint Developer -välilehti, Visual Basic -ryhmä

    Jos Kehittäjä-välilehti ei ole käytettävissä

    1. Valitse nauhan oikeassa laidassa Toiminto-ponnahdusvalikko ja valitse sitten Valintanauhan asetukset.

    2. Valitse Mukauta-kohdassa Kehittäjä-valintaruutu.

  2. Valitse suoritettava makro luettelosta ja valitse Suorita.

Makroa muokataan Visual Basic -editoriilla.

  1. Valitse Kehittäjä-välilehden Visual Basic -kohdassa Makrot.

    PowerPoint Developer -välilehti, Visual Basic -ryhmä

    Jos Kehittäjä-välilehti ei ole käytettävissä

    1. Valitse nauhan oikeassa laidassa Toiminto-ponnahdusvalikko ja valitse sitten Valintanauhan asetukset.

    2. Valitse Mukauta-kohdassa Kehittäjä-valintaruutu.

  2. Valitse muokattava makro luettelosta ja valitse Muokkaa.

    Visual Basic Editor avautuu.

  3. Tee haluamasi muutokset.

  4. Kun olet valmis, valitse PowerPoint-valikossa Sulje ja palaa ohjelmaan Microsoft PowerPoint.

  1. Valitse Kehittäjä-välilehden Visual Basic -kohdassa Makrot.

    PowerPoint Developer -välilehti, Visual Basic -ryhmä

    Jos Kehittäjä-välilehti ei ole käytettävissä

    1. Valitse nauhan oikeassa laidassa Toiminto-ponnahdusvalikko ja valitse sitten Valintanauhan asetukset.

    2. Valitse Mukauta-kohdassa Kehittäjä-valintaruutu.

  2. Valitse kopioitava makro luettelosta ja valitse Muokkaa.

    Visual Basic Editor avautuu.

  3. Valitse Visual Basic Editorin koodi-ikkunassa ne makron rivit, jotka haluat kopioida.

    Vihje: Jos haluat kopioida koko makron, varmista, että Sub- ja End Sub -rivit ovat mukana valinnassa.

  4. Valitse Muokkaa-valikossa Kopioi.

  5. Osoita koodi-ikkunan Projekti-ruudussa moduulia, johon haluat sijoittaa koodin.

  6. Valitse Muokkaa-valikossa Sijoita.

  1. Valitse Kehittäjä-välilehden Visual Basic -kohdassa Makrot.

    PowerPoint Developer -välilehti, Visual Basic -ryhmä

    Jos Kehittäjä-välilehti ei ole käytettävissä

    1. Valitse nauhan oikeassa laidassa Toiminto-ponnahdusvalikko ja valitse sitten Valintanauhan asetukset.

    2. Valitse Mukauta-kohdassa Kehittäjä-valintaruutu.

  2. Valitse poistettava makro luettelosta ja valitse Poista.

Excel

Jos haluat automatisoida jonkin toistuvan tehtävän, voit luoda Excelissä nopeasti makron. Voit myös kirjoittaa oman makrokomentosarjan Microsoft Visual Basic for Applicationsissa käyttämällä Visual Basic -editoria tai kopioida jonkin makron kokonaan tai osittain uuteen makroon.

Kaikki vaiheet, jotka vaaditaan makrolla toteutettavien toimintojen suorittamista varten, tallennetaan. Tallennettuihin vaiheisiin ei kuitenkaan sisälly siirtyminen takaisin välilehteen, jossa tallennus pysäytetään.

  1. Valitse Kehittäjä-välilehden Visual Basic -kohdassa Tallenna.

    Excel Developer -välilehti, Visual Basic -ryhmä

    Jos Kehittäjä-välilehti ei ole käytettävissä

    1. Valitse nauhan oikeassa laidassa Toiminto-ponnahdusvalikko ja valitse sitten Valintanauhan asetukset.

    2. Valitse Mukauta-kohdassa Kehittäjä-valintaruutu.

  2. Kirjoita Makron nimi ‑ruutuun makron nimi.

    Vihje: Jos haluat luoda makrolle näppäinoikotien, kirjoita kirjain Optio+Komento+-ruutuun.

  3. Tee Makron tallennuspaikka -ponnahdusvalikossa jokin seuraavista:

    Makron tallennuspaikka

    Valitse

    Tiedosto, johon olet luomassa makroa

    Tämä työkirja

    Kaikki avoinna olevat tiedostot

    Uusi työkirja

    Käytettävissä aina, kun käytät Exceliä

    Oma makrotyökirja

    Omaan makrotyökirjaan sijaitsee käyttäjät / käyttäjänimi/kirjasto/Application tuki / Microsoft/Office/Excel.

  4. Valitse OK ja tee sitten toimet, jotka haluat tallentaa.

  5. Valitse Kehittäjä-välilehden Visual Basic -kohdassa uudelleen Tallenna.

Voit luoda makron käyttämällä ohjelmassa valmiina olevaa Visual Basic Editoria.

  1. Valitse Kehittäjä-välilehden Visual Basic -kohdassa Editori.

    Excel Developer -välilehti, Visual Basic -ryhmä

    Jos Kehittäjä-välilehti ei ole käytettävissä

    1. Valitse nauhan oikeassa laidassa Toiminto-ponnahdusvalikko ja valitse sitten Valintanauhan asetukset.

    2. Valitse Mukauta-kohdassa Kehittäjä-valintaruutu.

  2. Jos tarvitset lisätä moduulin, valitse Visual Basic Editorin Lisää-valikossa Moduuli.

  3. Kirjoita tai sijoita moduulin koodi-ikkunaan makrokoodi, jota haluat käyttää.

  4. Kun olet valmis, valitse Excel-valikossa Sulje ja palaa ohjelmaan Microsoft Excel.

  1. Valitse Kehittäjä-välilehden Visual Basic -kohdassa Makrot.

    Excel Developer -välilehti, Visual Basic -ryhmä

    Jos Kehittäjä-välilehti ei ole käytettävissä

    1. Valitse nauhan oikeassa laidassa Toiminto-ponnahdusvalikko ja valitse sitten Valintanauhan asetukset.

    2. Valitse Mukauta-kohdassa Kehittäjä-valintaruutu.

  2. Valitse suoritettava makro luettelosta ja valitse Suorita.

    Vihje: Jos haluat suorittaa makron käyttämällä näppäinoikotietä, paina näppäinyhdistelmää OPTIO + KOMENTO + kirjain, jonka määritit näppäinoikotietä luodessasi.

Makroa muokataan Visual Basic -editoriilla.

  1. Valitse Kehittäjä-välilehden Visual Basic -kohdassa Makrot.

    Excel Developer -välilehti, Visual Basic -ryhmä

    Jos Kehittäjä-välilehti ei ole käytettävissä

    1. Valitse nauhan oikeassa laidassa Toiminto-ponnahdusvalikko ja valitse sitten Valintanauhan asetukset.

    2. Valitse Mukauta-kohdassa Kehittäjä-valintaruutu.

  2. Valitse muokattava makro luettelosta ja valitse Muokkaa.

    Visual Basic Editor avautuu.

  3. Tee haluamasi muutokset.

  4. Kun olet valmis, valitse Excel-valikossa Sulje ja palaa ohjelmaan Microsoft Excel.

Kun olet toiminut näiden ohjeiden mukaisesti, makro suoritetaan aina, kun avaat makron sisältävän työkirjan.

  1. Valitse Kehittäjä-välilehden Visual Basic -kohdassa Tallenna.

    Excel Developer -välilehti, Visual Basic -ryhmä

    Jos Kehittäjä-välilehti ei ole käytettävissä

    1. Valitse nauhan oikeassa laidassa Toiminto-ponnahdusvalikko ja valitse sitten Valintanauhan asetukset.

    2. Valitse Mukauta-kohdassa Kehittäjä-valintaruutu.

  2. Kirjoita Makron nimi -ruutuun Auto_avaa.

  3. Tee Makron tallennuspaikka -ponnahdusvalikossa jokin seuraavista:

    Makron tallennuspaikka

    Valitse

    Tiedosto, johon olet luomassa makroa

    Tämä työkirja

    Kaikki avoinna olevat tiedostot

    Uusi työkirja

    Käytettävissä aina, kun käytät Exceliä

    Oma makrotyökirja

  4. Valitse OK ja tee sitten toimet, jotka haluat tallentaa.

  5. Valitse Kehittäjä-välilehden Visual Basic -kohdassa uudelleen Tallenna.

  6. Valitse Tiedosto-valikossa Tallenna nimellä.

  7. Valitse Muoto-ponnahdusvalikossa Excel-työkirja (makrot käytössä) (.xlsm) ja valitse Tallenna.

  1. Valitse Kehittäjä-välilehden Visual Basic -kohdassa Makrot.

    Excel Developer -välilehti, Visual Basic -ryhmä

    Jos Kehittäjä-välilehti ei ole käytettävissä

    1. Valitse nauhan oikeassa laidassa Toiminto-ponnahdusvalikko ja valitse sitten Valintanauhan asetukset.

    2. Valitse Mukauta-kohdassa Kehittäjä-valintaruutu.

  2. Valitse kopioitava makro luettelosta ja valitse Muokkaa.

    Visual Basic Editor avautuu.

  3. Valitse Visual Basic Editorin koodi-ikkunassa ne makron rivit, jotka haluat kopioida.

    Vihje: Jos haluat kopioida koko makron, varmista, että Sub- ja End Sub -rivit ovat mukana valinnassa.

  4. Valitse Muokkaa-valikossa Kopioi.

  5. Osoita koodi-ikkunan Projekti-ruudussa moduulia, johon haluat sijoittaa koodin.

  6. Valitse Muokkaa-valikossa Sijoita.

  1. Valitse Kehittäjä-välilehden Visual Basic -kohdassa Makrot.

    Excel Developer -välilehti, Visual Basic -ryhmä

    Jos Kehittäjä-välilehti ei ole käytettävissä

    1. Valitse nauhan oikeassa laidassa Toiminto-ponnahdusvalikko ja valitse sitten Valintanauhan asetukset.

    2. Valitse Mukauta-kohdassa Kehittäjä-valintaruutu.

  2. Valitse poistettava makro luettelosta ja valitse Poista.

Huomautus: Konekäännöksestä ilmoittava vastuusvapauslauseke: Tämä artikkeli on käännetty tietokonejärjestelmällä, eikä kieliasiantuntija ole muokannut sitä. Microsoft tarjoaa nämä konekäännökset avuksi muille kuin englantia puhuville käyttäjille, jotta he saavat lisätietoja Microsoftin tuotteista, palveluista ja tekniikoista. Koska artikkeli on koneellisesti käännetty, se saattaa sisältää sanasto-, lauseoppi- ja kielioppivirheitä.

Kehitä taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×