Lukujoukon ainutkertaisten arvojen määrän laskeminen

Tärkeää: Tämä on artikkeli on käännetty koneellisesti. Lue vastuuvapauslauseke. Tämän artikkelin englanninkielinen versio on täällä .

Oletetaan, että haluat selvittää, kuinka monta yksilöllisten teksti- tai lukuarvojen on alueella. Jos sarakkeessa on esimerkiksi tekstin arvot Bradley, Doyle, Doyle, Doyle, on kaksi yksilöllisiä arvoja, Bradley ja Doyle. Jos alue on luvut 5, 6, 7 ja 6, yksilölliset arvot ovat 5, 6 ja 7.

Kun haluat laskea vain ainutkertaisia arvoja, käytä seuraavien funktioiden yhdistelmää, kuten alla olevassa laskentataulukon esimerkissä:

  • Jos-funktion avulla voit määrittää arvon 1 joka kerta, joka on TOSI.

  • Summa-funktion avulla voit laskea kaikki ainutkertaiset arvot.

  • Taajuus-funktion avulla voit laskea ainutkertaisten arvojen määrän. Tämä funktio ohittaa nolla-arvoja. Tietyn arvon ensimmäisen kerran se palauttaa luvun yhtä kyseisen arvon esiintymien määrän. Jokaiselle esiintymälle jälkeen ensimmäisen arvon, tämä funktio palauttaa arvon 0.

  • Käytä VASTINE-funktio palauttaa tekstiarvon sijainti alueella. TAAJUUS-funktio käyttää tuloksen laskeminen vastaavat tekstiarvot.

  • Pituus-funktion avulla voit etsiä tyhjät solut. Tyhjien solujen on 0 pituus (merkkimäärä).

Esimerkki

Kopioi taulukko Excelin tyhjän laskentataulukon soluun A1, jos haluat käyttää näiden esimerkkien funktioita käyttäviä kaavoja.

Tiedot

Tiedot

986

Sallinen

Suominen

563

67

789

235

Sallinen

Suominen

689

789

Suominen

143

56

237

67

235

Kaava

Kuvaus (tulos)

=SUMMA(JOS(TAAJUUS(A2:A10;A2:A10)>0;1))

Laskee solualueen A2:A10 sisältämien yksilöllisten numeroarvojen määrän, mutta ei laske tyhjiä soluja tai tekstiarvoja (4).

=SUMMA(JOS(TAAJUUS(VASTINE(B2:B10;B2:B10;0);VASTINE(B2:B10;B2:B10;0))>0;1))

Laskee solualueen B2:B10 yksilöllisten numero- ja tekstiarvojen määrän (solualue ei saa sisältää tyhjiä soluja) (7).

=SUMMA(JOS(TAAJUUS(JOS(PITUUS(A2:A10)>0;VASTINE(A2:A10;A2:A10;0);""); JOS(PITUUS(A2:A10)>0;VASTINE(A2:A10;A2:A10;0);""))>0;1))

Laskee solualueen A2:A10 sisältämien yksilöllisten teksti- ja numeroarvojen määrän, mutta ei laske tyhjiä soluja tai tekstiarvoja (6).

Huomautukset: 

  • Tässä esimerkissä kaavat on kirjoitettava matriisikaavoina. Valitse jokaisen kaavan sisältävä solu, paina F2-näppäintä ja paina Ctrl + Vaihto + Enter.

  • Jos haluat nähdä vaihe vaiheelta, kuinka funktio laskee arvot, valitse kaavan sisältävä solu ja valitse sitten Kaavat-välilehdessä Kaavan tarkistaminen ‑ryhmästä Laske kaava.

Huomautus: Konekäännöksestä ilmoittava vastuusvapauslauseke: Tämä artikkeli on käännetty tietokonejärjestelmällä, eikä kieliasiantuntija ole muokannut sitä. Microsoft tarjoaa nämä konekäännökset avuksi muille kuin englantia puhuville käyttäjille, jotta he saavat lisätietoja Microsoftin tuotteista, palveluista ja tekniikoista. Koska artikkeli on koneellisesti käännetty, se saattaa sisältää sanasto-, lauseoppi- ja kielioppivirheitä.

Kehitä taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×