Lukujen laskeminen yhteen

Tärkeää: Tämä on artikkeli on käännetty koneellisesti. Lue vastuuvapauslauseke. Tämän artikkelin englanninkielinen versio on täällä .

Oletetaan, että haluat laskea myymälän varastolle kokonaishinnan tai laskea yhteen vuosibudjettiin kuuluvien osastojen bruttokateprosentit. Voit laskea lukuja yhteen monella tavalla. Nopea tapa laskea lukuja yhteen soluissa on käyttää kaavassa +-merkkiä.

Jos kirjoitat esimerkiksi =5+10, solussa näkyy tulos 15.

Kaikkien rivillä tai sarakkeessa olevien lukujen laskeminen yhteen

Jos rivillä tai sarakkeessa on lukuja vierekkäisissä soluissa (tyhjiä soluja ei siis ole), voit käyttää toimintoa Automaattinen summa Painikkeen kuva .

  1. Valitse solu, joka on haluamasi luvut sisältävän sarakkeen alapuolella tai luvut sisältävän rivin oikealla puolella.

  2. Valitse Aloitus > Automaattinen summa ja paina sitten Enter-näppäintä.

Ei-vierekkäisten lukujen laskeminen yhteen

Jos lukujen välissä on tyhjiä soluja tai soluja, joissa on lukujen sijasta tekstiä, käytä kaavassa SUMMA-funktiota. Kaava ohittaa tällöin laskettavassa alueessa olevat tyhjät ja tekstiä sisältävät solut.

Esimerkki

Tässä työkirjassa on esimerkkejä tästä funktiosta. Tutustu niihin, muuta valmiita kaavoja tai kirjoita omia kaavoja, niin näet, miten funktio toimii.

Huomautus: SUMMA-funktioon voi sisältyä enintään 30 erilaista solu- tai alueviittausta minä tahansa yhdistelmänä. Esimerkiksi kaava =SUMMA(B2:B3;B5) sisältää yhden alueviittauksen (B2:B3) ja yhden soluviittauksen (B5).

Lukujen laskeminen yhteen ehdon perusteella

Voit laskea alueen kokonaisarvon toisen alueen arvon perusteella käyttämällä SUMMA.JOS-funktiota. Seuraavassa esimerkissä lasketaan vain niiden sarakkeessa B (Lasku) olevien arvojen kokonaisarvo, jotka vastaavat sarakkeen A (Myyjä) Lassila-nimisen myyjän arvoja.

Esimerkki

Alla olevassa työkirjassa on esimerkkejä SUMMA.JOS-funktiosta. Tutustu niihin, muuta valmiita kaavoja tai kirjoita omia kaavoja, niin näet, miten funktio toimii.

Lukujen laskeminen yhteen usean ehdon perusteella

Käytä SUMMA.JOS.JOUKKO-funktiota.

Esimerkki

Tässä työkirjassa on esimerkkejä tästä funktiosta. Tutustu niihin, muuta valmista kaavaa tai kirjoita omia kaavoja, niin näet, miten funktio toimii.

Funktioiden käyttäminen SUMMA.JOS.JOUKKO-esimerkissä

=SUMMA.JOS.JOUKKO(D2:D11;A2:A11;"Etelä";C2:C11;"Liha")

Ensimmäisen kaavan SUMMA.JOS.JOUKKO-funktio etsii rivit, joiden sarakkeessa A on arvo "Etelä" ja sarakkeessa C arvo "Liha". Tällaisia rivejä on kolme: 7, 8 ja 11. Funktio tutkii ensin, löytyykö alueiden nimet sisältävästä sarakkeesta A arvo "Etelä". Sitten se tutkii, löytyykö ruoka-ainetyypit sisältävästä sarakkeesta C arvo "Liha". Lopuksi funktio tarkistaa yhteenlaskettavat arvot sisältävän alueen (D2:D11) ja laskee yhteen vain ne sarakkeen arvot, jotka täyttävät nämä kaksi ehtoa.

=SUMMA(JOS((A2:A11="Etelä")+(A2:A11="Itä");D2:D11))

Toinen kaava, jossa käytetään SUMMA- ja JOS-funktioita, on kirjoitettu matriisikaavana (voit muuttaa matriiseja valitsemalla Avaa Excelissä) niiden rivien löytämiseksi, joissa joko "Etelä" tai "Itä" tai molemmat ovat sarakkeessa A. Tällaisia rivejä on seitsemän: 2, 4, 6, 7, 8, 9 ja 11. Koska tämä kaava on matriisikaava, +-operaattorilla ei lisätä arvoja, vaan sillä tarkistetaan vähintään kaksi ehtoa, joista ainakin yhden on täytyttävä. Tämän jälkeen nämä ehdot täyttävät arvot lisätään SUMMA-funktiolla.

Ainutkertaisten arvojen laskeminen yhteen

Käytä SUMMA-, JOS- ja TAAJUUS-funktioiden yhdistelmää.

Seuraavassa esimerkissä funktioita käytetään seuraavasti:

  • TAAJUUS-funktiolla lasketaan alueen ainutkertaiset arvot. Tietyn arvon ensimmäiselle esiintymälle palautetaan kyseisen arvon esiintymiskertoja vastaava luku. Funktio palauttaa jokaiselle tämän arvon seuraavalle esiintymälle arvon 0 (nolla).

  • JOS-funktion avulla jokaiselle todelle ehdolle määritetään arvo 1.

  • SUMMA-funktiolla lasketaan ainutkertaiset arvot yhteen.

Esimerkki

Tässä työkirjassa on esimerkkejä näistä funktioista. Tutustu esimerkkeihin ja harjoittele funktioiden käyttöä muuttamalla valmiita kaavoja tai kirjoittamalla omia kaavoja.

Huomautus: Konekäännöksestä ilmoittava vastuusvapauslauseke: Tämä artikkeli on käännetty tietokonejärjestelmällä, eikä kieliasiantuntija ole muokannut sitä. Microsoft tarjoaa nämä konekäännökset avuksi muille kuin englantia puhuville käyttäjille, jotta he saavat lisätietoja Microsoftin tuotteista, palveluista ja tekniikoista. Koska artikkeli on koneellisesti käännetty, se saattaa sisältää sanasto-, lauseoppi- ja kielioppivirheitä.

Kehitä taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×