Luettelon kohteiden järjestäminen

Tärkeää: Tämä on artikkeli on käännetty koneellisesti. Lue vastuuvapauslauseke. Tämän artikkelin englanninkielinen versio on täällä .

Luetteloiden järjestämistä määräytyy ryhmäsi ja miten haluat tallentaa ja etsiä tietoja tarpeiden mukaan.

Microsoft Office SharePoint Server 2007 sisältää lukuisia valmiita luetteloita ja luettelomalleja. Luettelokohteiden järjestäminen kannattaa aloittaa näiden luetteloiden ja mallien avulla.

Sisältö

Office SharePoint Server-luettelot ja Luettelomallit

Esimerkkejä luetteloiden järjestämisestä

Sarakkeen lisääminen luetteloon

Näkymän luominen

Näkymän vaihtaminen

Kansion lisääminen luetteloon

Office SharePoint Serverin luettelot ja luettelomallit

Kun asennat Office SharePoint Server 2007:n, asennusohjelma luo useita luetteloita puolestasi. Kaikilla näillä luetteloilla on joitakin yhteisiä ominaisuuksia, mutta jokainen on suunniteltu tiettyyn tehtävään organisaatiossa. Esimerkiksi Uudelleenkäytettävä sisältö -luetteloon voi tallentaa kohteita, jotka sisältävät HTML- tai tekstisisältöä, jota voi sitten lisätä Web-sivuihin. Uudelleenkäytettävä sisältö -luettelo tukee myös automaattista päivittämistä, joten luettelon kohteisiin tehdyt muutokset otetaan automaattisesti käyttöön kohteita käyttävissä Web-sivuissa.

Luettelomallit ovat erikseen, että Office SharePoint Server 2007 avulla voit pitää asiat järjestyksessä. Luettelomallien avulla voit helposti luoda luettelot, jotka tukevat tiettyjä kohteita sekä ottaa käyttöön tiettyyn luetteloon funktiot on suunniteltu. Lisätietoja Office SharePoint Server 2007 Luettelomallit on artikkelissa Office SharePoint Server 2007: ssä käytettävissä olevat luettelomallit.

Sivun alkuun

Esimerkkejä luetteloiden järjestämisestä

Luetteloita ja luettelokohteita voi järjestää esimerkiksi seuraavilla tavoilla:

  • Sarakkeiden lisääminen     Voit korostaa ryhmälle tärkeimmät kohteet lisäämällä luetteloon sarakkeita. Voit myös lisätä sarakkeita, jos haluat tallentaa lisätietoja luettelokohteista, esimerkiksi osaston nimen tai työntekijän nimen.

    Jos luettelossa on useita kohteita, kannattaa indeksoida jotkin sarakkeet, mikä parantaa suorituskykyä, kun tarkastellaan useita kohteita tai vaihdetaan näkymää. Tämä toiminto ei muuta kohteiden järjestystä, mutta sen avulla organisaatiot voivat helposti tallentaa luetteloon lukuisia kohteita. Indeksointi kuluttaa kuitenkin tietokannan tilaa. Lisätietoja saat järjestelmänvalvojalta.

  • Näkymien luominen     Voit käyttää näkymiä, jos ryhmän jäsenten tarvitsee usein nähdä tietoja tietyllä tavalla. Näkymissä tietoja lajitellaan, ryhmitellään, suodatetaan ja näytetään sarakkeiden avulla. Voit myös valita, kuinka monta kohdetta kussakin näkymässä on näkyvissä kerrallaan. Käyttäjät voivat selata luetteloa esimerkiksi siten, että yhdellä sivulla on 25 tai 100 luettelokohdetta käyttäjän valinnan ja yhteyden nopeuden mukaan.

    Näkymien avulla luetteloon voi tallentaa useita kohteita ja tarkastella vain tarvittavaa osaa kohteista kerrallaan, esimerkiksi kuluvana vuonna lähetettyjä kohteita tai vain kalenterin nykyisiä tapahtumia. Voit luoda omia näkymiä, jotka ovat vain sinun käytettävissä. Jos sinulla on luettelon muokkausoikeus, voit myös luoda julkisia näkymiä, jotka ovat kaikkien käytettävissä.

  • Kansioiden luominen     Useimpiin luettelolajeihin voi lisätä kansioita, jos luettelon omistaja on sallinut kansioiden luomisen. Tämä on erityisen hyödyllistä, jos luettelokohteet voi jakaa tietyllä tavalla, esimerkiksi projektin tai ryhmän perusteella. Kansioiden avulla käyttäjät voivat helposti etsiä ja hallita luettelokohteita. Office SharePoint Server 2007:ssä on puunäkymä, jonka avulla käyttäjät voivat liikkua sivustoissa ja kansioissa samaan tapaan kuin kiintolevyn kansioissa. Esimerkiksi kullakin osastolla voi olla oma kansio.

    • Käytä luetteloita yhtenäisyyden parantaminen eri sivustoissa    Jos ryhmä käyttää erityyppisiä luetteloita, voit lisätä yhdenmukaisuuden useiden luetteloiden sisältötyyppejä, sivustosarakkeita ja malleja. Seuraavien ominaisuuksien avulla voit käyttää tehokas tapa luettelorakenteen ja asetukset. Voit esimerkiksi luoda sisältötyypin asiakkaan palvelun ongelman, joka määrittää tietyt sarakkeet (kuten Asiakaskontaktit) ja liiketoimintaprosessien sisältötyypin. Toinen esimerkki luodaan, joka sisältää avattavan luettelon kaikista osastot osastojen nimiä sivustosarake. Voit käyttää useita luetteloita, varmista, että nimet näkyvät aina samalla tavalla kuin kunkin luettelon sarakkeen.

      Lisätietoja sisältötyyppejä, sivustosarakkeita ja Luettelomallit on Katso myös -osan linkeissä.

Vaikka luetteloiden ominaisuuksia voi käyttää useilla tavoilla, niiden käyttö määräytyy käytössä olevien luetteloiden koon ja määrän sekä organisaation tarpeiden mukaan.

Usean kohteen tallentaminen samaan luetteloon

Yksi suuri luettelo voi tarvittaessa palvella useita tarkoitusperiä. Suuren luettelon avulla organisaatio voi esimerkiksi seurata useita teknisiä ongelmakohtia, jotka vaikuttavat organisaation projektien ja ryhmien toimintaan.

Käytä yksittäistä luetteloa seuraavissa tilanteissa:

  • Ryhmä tarvitsee luettelokohteiden yhteenvetotiedot tai eri näkymiä samasta kohdejoukosta. Johtaja esimerkiksi haluaa näkyviin tiedot organisaation kaikissa teknisissä ongelmakohdissa tapahtuneesta kehityksestä tai kaikista tietyn ajanjakson aikana kirjatuista ongelmista.

  • Käyttäjät haluavat selata ongelmakohtien tietoja sekä tehdä niistä hakuja yksittäisessä sivuston sijainnissa.

  • Luettelokohteissa on tarkoitus käyttää samoja asetuksia. Tällaisia asetuksia ovat esimerkiksi versioiden seurannan ja hyväksynnän asetukset.

  • Luetteloa käsittelevillä ryhmillä on yhteisiä ominaisuuksia, esimerkiksi sama käyttöoikeustaso. Tietyissä luettelokohteissa voi käyttää yksilöllisiä käyttöoikeuksia, mutta jos käyttöoikeustasoissa on paljon vaihtelua, kannattaa harkita useiden luetteloiden käyttämistä.

  • Luetteloa koskevia tietoja on tarkoitus analysoida tai ohjelman on tarkoitus lähettää koottuja tietoja luettelon päivityksistä. Voit määrittää ohjelman lähettämään ilmoituksia muuttuneista luettelon kohteista tai tarkastella luetteloon tulleita muutoksia RSS-tekniikkaa hyödyntäen. Työryhmän jäsenet saavat koottuja tietoja muuttuneista kohteista RSS-syötteiden avulla.

Useiden luetteloiden luominen

Useista luetteloista on todennäköisesti hyötyä, kun hallittavissa kohteissa tai niitä käsittelevissä käyttäjäryhmissä on selviä eroja.

Käytä useita luetteloita seuraavissa tilanteissa:

  • Käyttäjät eivät todennäköisesti tarvitse yhteenvetoja, joissa kaikki kohteet ovat mukana.

  • Erilaiset käyttäjätyypit, joilla on erilaisia käyttöoikeustasoja, käsittelevät tietoja.

  • Eri kohdejoukoissa on tarkoitus käyttää eri asetuksia. Tällaisia asetuksia ovat esimerkiksi versioiden seurannan ja hyväksynnän asetukset.

  • Kokonaisanalyysejä kohteista ei tarvita kuten ei myöskään koottuja tietoja luetteloon tulleista muutoksista.

Sivun alkuun

Sarakkeen lisääminen luetteloon

Luetteloiden tiedot tallennetaan sarakkeisiin, joita voivat olla esimerkiksi Nimike, Sukunimi ja Yritys. Jos luettelokohteista on tarkoitus tallentaa lisätietoja, voit lisätä sarakkeita itse. Niistä on apua, kun luettelo lajitellaan tai ryhmitellään tai kun luodaan useita luettelonäkymiä. Voit esimerkiksi lajitella luettelon määräpäivän mukaan tai ryhmitellä kohteet osaston nimen mukaan.

Kun luot sarakkeen, käytettävissä on useita vaihtoehtoja. Vaihtoehtoja ovat esimerkiksi yksittäinen tekstirivi, avattava vaihtoehtoluettelo, muiden sarakkeiden perusteella laskettava luku tai jopa sivuston henkilön nimi ja kuva.

Huomautus: Seuraavat toimintaohjeet alkavat sen luettelon sivulta, johon sarake on tarkoitus lisätä. Jos luetteloa ei ole valmiiksi avattu, napsauta sen nimeä pikakäynnistyspalkissa. Jos luettelon nimeä ei näy, valitse Näytä sivuston kaikki sisältö ja napsauta luettelosi nimeä.

  1. Valitse asetukset valikon Asetukset-valikko , Luo sarake.

  2. Kirjoita Nimi ja laji -osan Sarakkeen nimi -ruutuun haluamasi nimi.

  3. Valitse Tämän sarakkeen tietotyyppi on -kohdassa tietotyyppi, jonka haluat määrittää sarakkeelle.

  4. Kirjoita Sarakkeiden lisäasetukset -osan Kuvaus-ruutuun kuvaus, jonka luettuaan käyttäjät ymmärtävät sarakkeen käyttötarkoituksen sekä sen, millaisia tietoja sarake voi sisältää. Tämä kuvaus on valinnainen.

  5. Sen mukaan, minkä saraketyypin valitsit, Sarakkeen lisäasetukset -osassa voi näkyä lisäasetuksia. Valitse haluamasi lisäasetukset.

  6. Jos lisäät sarakkeen oletusnäkymään, jonka sivuston käyttäjät näkevät avatessaan ensin luetteloon tai kirjastoon, valitse Lisää oletusnäkymään.

  7. Valitse OK.

Sivun alkuun

Näkymän luominen

Näkymien avulla voit tuoda näkyviin luettelon tärkeimmät kohteet tai sellaiset kohteet, jotka parhaiten sopivat tiettyyn tilanteeseen. Voit esimerkiksi luoda näkymiä hiljattain luoduista kohteista, tiettyä osastoa koskevista kohteista tai tietyn henkilön luomista kohteista.

Näytä-valikon näkymät

Useimpia luetteloita tarkastellessa voi lajitella tai suodattaa kohteet tilapäisesti osoittamalla hiirellä sarakkeen nimeä ja napsauttamalla sitten sarakkeen nimen vieressä olevaa nuolta. Tämä on kätevää, jos haluat silloin tällöin nähdä luettelon kohteet tietyllä tavalla, mutta tällä menetelmällä samat vaiheet on toistettava aina, kun haluat tarkastella näkymää uudelleen.

Luettelon tai kirjaston kohteiden lajitteleminen

Jos arvelet, voit tarkastella tietyllä tavalla, voit luoda näkymän. Voit käyttää tätä näkymää aina luettelon käsitteleminen. Kun luot näkymän, se lisätään- näkymän valikko Näytä-valikko luettelon.

Luetteloilla voi olla sekä omia että julkisia näkymiä. Kuka tahansa voi luoda oman näkymän, jossa luettelot näkyvät tietyllä tavalla, tai suodattaa luettelon siten, että vain tarpeelliset luettelokohteet jäävät näkyviin. Jos sinulla on sivuston suunnitteluoikeudet, voit luoda julkisen näkymän, jota kaikki luettelon käyttäjät voivat käyttää. Voit myös tehdä julkisesta näkymästä oletusnäkymän. Tällöin luettelon käyttäjät näkevät luettelon automaattisesti kyseisessä näkymässä.

Lisäksi sivuston suunnitellessasi voit linkittää eri näkymiin tai rakenne-sivut, joilla verkko-osat, jotka käyttävät eri näkymiä. Työryhmän voi esimerkiksi haluat linkittää, jossa näkyvät vain ne asiakirjat, jotka on luotu työryhmän jäsenten luettelon näkymän.

Jos ryhmäsi jäsenet tarkastelevat luetteloa mobiililaitteilla, voit ottaa laitteiden rajoitukset huomioon luomalla mobiilinäkymiä, jotka rajoittavat esimerkiksi näkyvissä olevien kohteiden määrää. Lisätietoja näkymien luomisesta on Katso myös -osassa.

  1. Jos luettelossa ei ole avoinna, napsauta sen nimeä pikakäynnistyksessä.

    Jos luettelon nimi ei ole näkyvissä, valitse Näytä sivuston kaikki sisältö ja napsauta haluamasi luettelon nimeä.

  2. Valitse asetukset valikon Asetukset-valikko , Luo näkymä.

  3. Valitse Valitse näkymän muoto -kohdasta luotavan näkymän laji. Useimmissa tilanteissa kannattaa luoda vakionäkymä, mutta voit tarvittaessa (jos olet luomassa esimerkiksi kalenteria tai Gantt-näkymää) valita muitakin näkymiä.

  4. Kirjoita Näkymän nimi -ruutuun nimi näkymän, kuten Sorted sukunimen mukaan.

  5. Jos haluat tehdä oletusnäkymässä, valitse Tee tästä oletusnäkymä -valintaruutu. Voit tehdä oletusnäkymän vain, jos se on yleinen näkymä ja sinulla on oikeus tehdä muutoksia luettelon rakenne.

  6. Valitse Käyttäjäryhmä-osasta Näkymän käyttäjäryhmä -kohdasta, haluatko luoda henkilökohtaisen näkymän, jota voit käyttää vain sinä, vai julkisen näkymän, jota voivat käyttää kaikki.

  7. Sarakkeet-kohdassa voit tuoda näkyviin tai piilottaa sarakkeet valitsemalla haluamasi valintaruudut. Kirjoita sarakkeen nimen viereen numero, joka kuvaa sarakkeen järjestystä näkymässä.

  8. Valitse Lajittele-kohdassa, onko luettelokohteet tarkoitus lajitella ja kuinka ne lajitellaan. Voit käyttää lajitteluperusteena kahta saraketta, esimerkiksi sukunimeä ensisijaisena lajitteluperusteena ja etunimeä toissijaisena.

  9. Valitse Suodatin-kohdassa, onko luettelokohteet tarkoitus suodattaa ja kuinka ne suodatetaan. Suodatetussa näkymässä näkyy vain osa luettelon sisällöstä, esimerkiksi tietyn osaston luomat kohteet tai hyväksytyt kohteet.

  10. Ryhmittelyperuste-kohdassa voit ryhmitellä sellaiset kohteet erilliseen osaan, joilla on sama arvo. Esimerkiksi tietyn tekijän asiakirjat voi ryhmitellä erilliseen, laajennettavaan osaan.

  11. Summat-osassa voit laskea sarakkeen kohteiden, esimerkiksi seurantakohteiden, määrän. Joissakin tilanteissa voit tehdä yhteenvetoja tai tuoda esiin lisätietoja, esimerkiksi keskiarvon.

  12. Valitse Tyyli-kohdassa näkymään haluamasi tyyli, kuten varjostettu luettelo, joka näyttää joka toisen rivin muita rivejä tummempana.

  13. Jos luettelossa on kansioita, voit luoda näkymän, josta kansiot jätetään pois. Tällaista näkymää kutsutaan myös sisentämättömäksi näkymäksi. Kun haluat tarkastella kaikkia luettelon kohteita samalla tasolla, valitse Näytä kaikki kohteet ilman kansioita

  14. Voit rajoittaa luettelon tarkasteltavissa olevien kohteiden määrää tai sitä, kuinka monta kohdetta voi näkyä samalla sivulla. Nämä asetukset ovat tärkeitä etenkin, jos luotava näkymä on tarkoitettu matkaviestinkäyttöön. Valitse haluamasi vaihtoehdot Kohderajoitus-kohdasta.

  15. Jos luetteloa on tarkoitus käyttää matkaviestimessä, valitse haluamasi vaihtoehdot Matkaviestin-kohdasta.

  16. Valitse OK.

Sivun alkuun

Näkymän vaihtaminen

Joissakin luetteloissa voi olla useita näkymiä, mutta voit myös itse luoda lisää näkymiä. Jos käytettävissä on useita näkymiä, voit siirtyä näkymästä toiseen Näytä-valikon avulla.

  1. Jos luettelossa ei ole avoinna, napsauta sen nimeä pikakäynnistyksessä.

    Jos luettelon nimi ei ole näkyvissä, valitse Näytä sivuston kaikki sisältö ja napsauta haluamasi luettelon nimeä.

  2. Valitse Näytä valikon Näytä-valikko , haluamasi näkymä.

    Vihje: Voit tehdä muutoksia aiemmin luotuun näkymään valitsemalla Näytä-valikosta Muokkaa tätä näkymää.

Sivun alkuun

Kansion lisääminen luetteloon

Jos luettelossa on useita erilaisia kohteita, voit helpottaa luettelon järjestämistä lisäämällä kansioita.

  1. Jos luettelossa ei ole avoinna, napsauta sen nimeä pikakäynnistyksessä.

    Jos luettelon nimi ei ole näkyvissä, valitse Näytä sivuston kaikki sisältö ja napsauta haluamasi luettelon nimeä.

  2. Valitse Uusi valikon Uusi valikko Valitse Uusi kansio.

    Uusi kansio -komento ei ole käytettävissä, jos luettelon luonut henkilö on määrittänyt, että luetteloon ei voi luoda kansioita.

  3. Kirjoita kansiolle nimi ja valitse OK.

Vihje: Jos useissa luetteloissa on käytössä kansioita tai jos ryhmän jäsenet haluavat selata luetteloa samalla tavalla kuin kiintolevyä, ryhmä voi halutessaan ottaa käyttöön puunäkymän. Puunäkymässä kansiosta toiseen on helppo siirtyä, ja kansioita voi laajentaa sekä kutistaa.

Sivun alkuun

Huomautus: Konekäännöksestä ilmoittava vastuusvapauslauseke: Tämä artikkeli on käännetty tietokonejärjestelmällä, eikä kieliasiantuntija ole muokannut sitä. Microsoft tarjoaa nämä konekäännökset avuksi muille kuin englantia puhuville käyttäjille, jotta he saavat lisätietoja Microsoftin tuotteista, palveluista ja tekniikoista. Koska artikkeli on koneellisesti käännetty, se saattaa sisältää sanasto-, lauseoppi- ja kielioppivirheitä.

Kehitä taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×