Lomakkeen tietojen lähettäminen Microsoft Access -tietokantaan

Tässä artikkelissa käsiteltävät aiheet

Yleiskatsaus

Vaihe 1: lähetystietoyhteyden käyttöönottaminen

Vaihe 2: lähetysasetusten määrittäminen

Yleiskatsaus

Kun luot Microsoft Office InfoPathin lomakemallin, joka perustuu Microsoft Office Accessin (.mdb) tai Microsoft Office Access 2007:n (.accdb) tietokantaan, ohjattu tietoyhteyden muodostaminen luo lähetystietoyhteyden tietokantaan, mikäli seuraavat ehdot täyttyvät.

  • Lomakemalli on suunniteltu siten, että käyttäjien on täytettävä se InfoPathissa. Jos lomake täytetään selaimessa, lomake ei voi lähettää tietoja suoraan tietokantaan. Määritä selainyhteensopiva lomakemalli lähettämään tiedot tietokantaan käyttämällä tietoyhteyttä, joka lähettää tiedot tietokannan kanssa toimivaan verkkopalveluun.

  • Päätietoyhteydessä käytetty ensisijainen tietokantataulukko sisältää perusavaimen, yksilöllisen rajoituksen tai yksilöllisen indeksin.

  • Muut tietokannan taulukot, joita käytetään päätietoyhteyden kanssa, sisältävät yksinkertaisen, hierarkkisen suhteen ensisijaiseen tietokantataulukkoon.

  • Tietokanta ei sisällä kenttiä, joissa voi olla suuria binaaritietoja, kuten kuvia, OLE-objekteja, liitetiedostoja, Office Accessin muistiotietotyyppejä tai SQL-tekstitietotyyppejä.

Jos tietokanta täyttää nämä vaatimukset, InfoPath luo lähetystietoyhteyden ja lisää Lähetä-painikkeen vakiotyökaluriviin ja Lähetä-komennon lomakkeen Tiedosto-valikkoon.

Huomautus: Toissijaiset tietoyhteydet eivät voi lähettää tietoja tietokantaan. Jos haluat käyttää tietokannan lähetystietoyhteyttä toissijaisena tietoyhteytenä, määritä tietokannan kanssa toimiva verkkopalvelu ja lisää sitten lähetystietoyhteys kyseiseen verkkopalveluun.

Kun olet ottanut lähetystietoyhteyden käyttöön, voit mukauttaa lomakemallin lähetysasetuksia seuraavilla tavoilla.

  • Voit muuttaa vakiotyökalurivinLähetä-painikkeen ja Tiedosto-valikon Lähetä-komennon tekstiä.

  • Voit muuttaa vakiotyökalurivinLähetä-painikkeen ja Tiedosto-valikon Lähetä-komennon pikanäppäimiä.

  • Voit luoda mukautettuja viestejä, jotka näytetään käyttäjille heidän lähettäessään lomakkeita.

  • Voit määrittää, haluatko säilyttää lomakkeen avoinna, sulkea lomakkeen tai avata toisen tyhjän lomakkeen lomakkeen lähettämisen jälkeen.

Sivun alkuun

Vaihe 1: lähetystietoyhteyden käyttöönottaminen

  1. Valitse Työkalut-valikosta Tietoyhteydet.

  2. Valitse Tietoyhteydet-valintaikkunassa päätietoyhteys ja sitten Muokkaa.

  3. Valitse ohjatussa tietoyhteyden muodostamistoiminnossa Seuraava.

  4. Valitse ohjatun toiminnon seuraavalla sivulla Ota käyttöön lähetys tässä yhteydessä -valintaikkuna ja valitse sitten Valmis.

Sivun alkuun

Vaihe 2: lähetysasetusten määrittäminen

Kun olet ottanut lähetystietoyhteyden käyttöön, InfoPath lisää Lähetä-painikkeen vakiotyökaluriviin ja Lähetä-komennon Tiedosto-valikkoon. InfoPath määrittää myös tähän lomakemalliin perustuvat lomakkeet näyttämään käyttäjille viestin täytetyn lomakkeen lähettämisen jälkeen. Viestissä todetaan, onnistuiko lomakkeen lähetys. Oletusarvoisesti InfoPath pitää lomakkeen avattuna sen jälkeen, kun käyttäjä on lähettänyt sen. Jos haluat muuttaa Lähetä-painikkeen tekstiä sekä toimintoa, joka tapahtuu käyttäjän lähetettyä lomakkeensa, toimi seuraavasti:

  1. Valitse Työkalut-valikosta Lähetyksen asetukset.

    1. Voit muuttaa käyttäjän lomaketta täyttäessä Vakio-työkaluriville tulevan Lähetä-painikkeen sekä Tiedosto-valikkoon näkyviin tulevan Lähetä-komennon nimeä kirjoittamalla uuden nimen Lähetyksen asetukset -valintaikkunan Komennon nimi -ruutuun.

      Vihje: Jos haluat määrittää painikkeelle ja komennolle pikanäppäimen, kirjoita pikanäppäimenä käytettävän merkin eteen et-merkki (&). Jos esimerkiksi haluat määrittää Lähetä-painikkeen ja -komennon pikanäppäimeksi ALT+H, kirjoita Lä&hetä.

  2. Jos et halua, että käyttäjät voivat käyttää Lähetä-komentoa tai vakiotyökalurivinLähetä-painiketta täyttäessään lomakettasi, poista Näytä Lähetä-valikkokomento ja työkalurivin Lähetä-painike -valintaruudun valinta.

    1. Oletusarvon mukaan InfoPath jättää lomakeikkunan avoimeksi käyttäjän lähetettyä lomakkeen ja näyttää sanoman, joka ilmaisee, onnistuiko lomakkeen lähettäminen. Voit muuttaa tätä oletusarvon mukaista toimintaa valitsemalla Lisäasetukset ja toimimalla jollakin seuraavista tavoista:

      • Jos haluat, että täytetyn lomakkeen lähettämisen jälkeen lomake suljetaan tai luodaan uusi, tyhjä lomake, valitse haluamasi vaihtoehto Lähettämisen jälkeen -luettelosta.

      • Jos haluat luoda mukautetun sanoman, joka ilmoittaa lähetyksen onnistuneen tai epäonnistuneen, valitse Käytä mukautettuja sanomia -valintaruutu ja kirjoita haluamasi teksti Toiminnon onnistuessa- ja Toiminnon epäonnistuessa -ruutuihin.

        Vihje: Sisällytä Toiminnon epäonnistuessa -ruudun tekstiin ohje, mitä tehdä, jos lomakkeen lähettäminen ei onnistu. Voit esimerkiksi kehottaa käyttäjää tallentamaan lomakkeen ja ottamaan yhteyttä tukipalveluun.

      • Jos et halua, että näyttöön tulee sanoma sen jälkeen, kun käyttäjä on lähettänyt lomakkeen, poista Näytä onnistumis- ja epäonnistumissanomat -valintaruudun valinta.

Sivun alkuun

Kehitä taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×