Lomaketietojen lähettäminen useisiin sijainteihin

Tärkeää: Tämä on artikkeli on käännetty koneellisesti. Lue vastuuvapauslauseke. Tämän artikkelin englanninkielinen versio on täällä .

Lomakemallin voi suunnitella niin, että käyttäjät voivat lähettää lomaketiedot useisiin sijainteihin napsauttamalla Lähetä-painiketta.

Tässä artikkelissa käsiteltävät aiheet

Yleiskatsaus

Vaihe 1: Lisää Lähetä tietoyhteydet

Vaihe 2: Määritä lomakemallin lähettämisen salliminen

Yleiskatsaus

Jotta lähettäjät voivat lähettää lomaketiedot useisiin sijainteihin, sinun on lisättävä lomakemalliin toissijainen tietoyhteys, joka lähettää tiedot jokaiseen sijaintiin, johon haluat käyttäjien lähettävän lomakkeensa. Kaikkien lähetystietoyhteyksien lisäämisen jälkeen voit määrittää lomakemallin sallimaan käyttäjien lähettää lomaketiedot useisiin sijainteihin käyttämällä sääntö. Tällöin Microsoft Office InfoPath lisää vakiotyökaluriviin Lähetä-painikkeen ja Tiedosto-valikkoon Lähetä-komennon käyttäjien täyttäessä lomaketta. InfoPath lähettää lomaketiedot toissijaisiin tietoyhteyksiin sääntöön merkityssä järjestyksessä. Sääntöä ei voi määrittää käyttämään kaikkia lähetystietoyhteyksiä samanaikaisesti.

Kun määrität lomakemallin sallimaan käyttäjien lähettää lomaketiedot, voit myös mukauttaa lähetysasetuksia seuraavilla tavoilla:

  • Voit muuttaa vakiotyökalurivin Lähetä-painikkeen ja Tiedosto-valikon Lähetä-komennon tekstiä.

  • Voit muuttaa vakiotyökalurivin Lähetä-painikkeen ja Tiedosto-valikon Lähetä-komennon pikanäppäintä.

  • Voit luoda mukautettuja viestejä, jotka näytetään käyttäjille heidän lähettäessään lomakkeita.

  • Voit määrittää, haluatko säilyttää lomakkeen avoinna, sulkea lomakkeen tai avata toisen tyhjän lomakkeen lomakkeen lähettämisen jälkeen.

Sivun alkuun

Vaihe 1: lähetystietoyhteyksien lisääminen

Voit määrittää lomakemallin sallimaan käyttäjien lähettää täytetyt lomakkeet useisiin sijainteihin lisäämällä tarpeelliset lähetystietoyhteydet lomakemalliin. Voit lisätä tietoyhteyksiä seuraaviin sijainteihin:

  • Web-palveluun

  • asiakirjakirjastoon palvelimessa, jossa on käytössä Microsoft Windows SharePoint Services

  • sähköpostiviestissä vastaanottajalle.

    Huomautus: Käyttäjien tietokoneessa on oltava asennettuna Microsoft Office Outlook, jotta he voivat lähettää lomaketiedot sähköpostiviestissä.

Seuraavissa vaiheissa selitetään, kuinka lähetystietoyhteydet voi lisätä kyseisiin sijainteihin.

Web-palveluun tietoja lähettävän tietoyhteyden lisääminen

  1. Valitse Työkalut-valikosta Tietoyhteydet.

  2. Valitse Tietoyhteydet-valintaikkunassa Lisää.

  3. Valitse ohjatussa tietoyhteyden muodostamistoiminnossa Luo uusi yhteys kohteeseen, valitse Lähetä tiedot ja valitse sitten Seuraava.

  4. Valitse ohjatun toiminnon seuraavalla sivulla Web-palveluun ja valitse sitten Seuraava.

  5. Kirjoita ohjatun toiminnon seuraavalla sivulla sen Web-palvelun sijainti, johon käyttäjät lähettävät lomakkeet, ja valitse sitten Seuraava.

    Jos haluat etsiä Web-palvelua UDDI (Universal Description, Discovery, and Integration) -palvelimesta, valitse UDDI-haku ja kirjoita sitten etsittävä UDDI-palvelin. Määritä sitten, haluatko etsiä palveluntarjoajan vai tarjottavien palvelujen mukaan, ja kirjoita haulle avainsana. Valitse sitten Etsi. Haun avainsanaa vastaavat Web-palvelut näkyvät Etsinnän tulokset -luettelossa.

  6. Valitse ohjatun toiminnon seuraavalla sivulla Valitse toiminto -luettelosta Web-palvelun toiminto, joka vastaanottaa lomaketiedot, ja valitse sitten Seuraava.

  7. Tee ohjatun toiminnon seuraavalla sivulla jokin seuraavista:

    Kentän tai ryhmän tietojen lähettäminen

    1. Valitse Parametrit-luettelosta Web-palvelun parametri, joka vastaanottaa lomaketiedot lomakkeesta.

    2. Valitse Parametrin asetukset -kohdassa Kenttä tai ryhmä.

    3. Valitse Muokkaa Tietolähde-painike .

    4. Valitse Kentän tai ryhmän valitseminen -valintaikkunasta kenttä tai ryhmä, jonka tiedot haluat lähettää, ja valitse OK.

    5. Valitse Sisällytä-ruudussa Vain teksti ja alielementit, jos haluat lähettää vain kentän tai ryhmän sisällön ja alielementit, tai valitse XML-alipuu, mukaan lukien valittu elementti, jos haluat lähettää sekä sisällön että valitun kentän tai ryhmän.

    Lähetä kaikki tiedot-lomake

    1. Napsauta Koko lomake (XML-asiakirja ja käsittelyohjeet).

    Lähetä tiedot merkkijonona

    1. Valitse Lähetä tiedot merkkijonona -valintaruutu.

      Yleensä tämä valintaruutu valitaan, kun halutaan lähettää digitaalisesti allekirjoitettuja tietoja. Useimmissa tapauksissa tämän valintaruudun valinnan voi poistaa.

  8. Valitse Seuraava.

  9. Kirjota ohjatun toiminnon seuraavan sivun Kirjoita tämän tietoyhteyden nimi -ruutuun lähetystietoyhteyden kuvaava nimi.

  10. Varmista, että tiedot ovat oikein Yhteenveto-osassa, ja valitse sitten Valmis.

Asiakirjakirjastoon tietoja lähettävän tietoyhteyden lisääminen

  1. Valitse Työkalut-valikosta Tietoyhteydet.

  2. Valitse Tietoyhteydet-valintaikkunassa Lisää.

  3. Valitse ohjatussa tietoyhteyden muodostamistoiminnossa Luo uusi yhteys kohteeseen, valitse Lähetä tiedot ja valitse sitten Seuraava.

  4. Valitse ohjatun toiminnon seuraavalla sivulla SharePoint-sivuston asiakirjakirjastoon ja valitse sitten Seuraava.

  5. Kirjoita ohjatun toiminnon seuraavan sivun Asiakirjakirjasto-ruutuun SharePoint-asiakirjakirjaston sijainti.

  6. Kirjoita Tiedostonimi-ruutuun nimi, jota käytetään lomakkeen tunnistamiseen asiakirjakirjastossa. Voit myös varmistaa kaavan avulla, että jokainen lomakenimi on yksilöllinen.

    Toimintaohjeet:

    1. Valitse Lisää kaava Painikkeen kuva .

    2. Tee Kaavan lisääminen -valintaikkunassa jompikumpi seuraavista:

      • Jos haluat käyttää kaavassa kenttää, valitse Lisää kenttä tai ryhmä, valitse haluamasi kenttä Kentän tai ryhmän valitseminen -valintaikkunassa ja valitse sitten OK.

      • Jos haluat käyttää kaavassa funktiota, valitse Lisää funktio, valitse haluamasi funktio Funktion lisääminen -valintaikkunassa ja valitse OK.

        Jos funktio edellyttää parametreja, valitse funktio Funktion lisääminen -valintaikkunassa ja valitse OK. Kaksoisnapsauta sitten Kaavan lisääminen -valintaikkunan Kaava-ruudussa lisäämääsi funktiota ja napsauta kenttää tai ryhmää. Lisätietoja funktioista on Katso myös -osan linkeissä.

      • Jos haluat lisätä kaavaan arvon tai laskutoimituksen, kirjoita arvo tai laskutoimituksen merkki Kaava-ruutuun.

    Laskutoimitus

    Merkki

    Yhteenlasku

    +

    Vähennyslasku

    -

    Kertolasku

    *

    Jakolasku

    /

    • Huomautus: Jos kaava käyttää jakolaskuoperaattoria (/), varmista, että jakolaskuoperaattoria ennen ja sen jälkeen on välilyönti. Jos jakolaskuoperaattoria ennen tai sen jälkeen ei ole välilyöntiä, InfoPath saattaa tulkita merkinnän "/" XPathin sijaintivaiheiden erottimeksi jakolaskuoperaattorin asemesta.

    • Voit tarkistaa kaavan syntaksin oikeellisuuden valitsemalla Lisää kaava -valintaikkunassa Tarkista kaava.

      Lisätietoja kaavoista on Katso myös -osan linkeissä.

  7. Jos haluat korvata asiakirjakirjaston samannimiset aiemmin luodut lomakkeet, valitse Salli korvaaminen, jos tiedosto on jo olemassa -valintaruutu.

  8. Valitse Seuraava.

  9. Kirjota ohjatun toiminnon seuraavan sivun Kirjoita tämän tietoyhteyden nimi -ruutuun lähetystietoyhteyden kuvaava nimi.

  10. Varmista, että tiedot ovat oikein Yhteenveto-osassa, ja valitse sitten Valmis.

Sähköpostiviestissä tietoja lähettävän tietoyhteyden lisääminen

  1. Valitse Työkalut-valikosta Tietoyhteydet.

  2. Valitse Tietoyhteydet-valintaikkunassa Lisää.

  3. Valitse ohjatussa tietoyhteyden muodostamistoiminnossa Luo uusi yhteys kohteeseen, valitse Lähetä tiedot ja valitse sitten Seuraava.

  4. Valitse ohjatun toiminnon seuraavalla sivulla Sähköpostiviestinä ja valitse sitten Seuraava.

  5. Kirjoita ohjatun toiminnon seuraavalla sivulla viestin vastaanottajien sähköpostiosoitteet, viestin aihe ja haluamasi lisätietokohdan teksti niitä vastaaviin ruutuihin ja valitse sitten Seuraava. Voit käyttää myös kaavaa kaikissa muissa ruuduissa paitsi Johdanto-ruudussa.

    Toimintaohjeet:

    1. Valitse Lisää kaava Painikkeen kuva .

    2. Tee Kaavan lisääminen -valintaikkunassa jompikumpi seuraavista:

      • Jos haluat käyttää kaavassa kenttää, valitse Lisää kenttä tai ryhmä, valitse haluamasi kenttä Kentän tai ryhmän valitseminen -valintaikkunassa ja valitse sitten OK.

      • Jos haluat käyttää kaavassa funktiota, valitse Lisää funktio, valitse haluamasi funktio Funktion lisääminen -valintaikkunassa ja valitse OK.

        Jos funktio edellyttää parametreja, valitse funktio Funktion lisääminen -valintaikkunassa ja valitse OK. Kaksoisnapsauta sitten Kaavan lisääminen -valintaikkunan Kaava-ruudussa lisäämääsi funktiota ja napsauta kenttää tai ryhmää. Lisätietoja funktioista on Katso myös -osan linkeissä.

      • Jos haluat lisätä kaavaan arvon tai laskutoimituksen, kirjoita arvo tai laskutoimituksen merkki Kaava-ruutuun.

    Laskutoimitus

    Merkki

    Yhteenlasku

    +

    Vähennyslasku

    -

    Kertolasku

    *

    Jakolasku

    /

    • Huomautus: Jos kaava käyttää jakolaskuoperaattoria (/), varmista, että jakolaskuoperaattoria ennen ja sen jälkeen on välilyönti. Jos jakolaskuoperaattoria ennen tai sen jälkeen ei ole välilyöntiä, InfoPath saattaa tulkita merkinnän "/" XPathin sijaintivaiheiden erottimeksi jakolaskuoperaattorin asemesta.

    • Voit tarkistaa kaavan syntaksin oikeellisuuden valitsemalla Lisää kaava -valintaikkunassa Tarkista kaava.

      Lisätietoja kaavoista on Katso myös -osan linkeissä.

  6. Tee ohjatun toiminnon seuraavalla sivulla jompikumpi seuraavista:

    1. Jos haluat näyttää lomakkeen sähköpostiviestin tekstiosassa, valitse Lähetä vain lomakkeen aktiivinen näkymä ilman liitettä.

    2. Lomaketietojen lähettäminen sähköpostiviestin liitteenä, valitse Lähetä liitteenä lomaketietojen, Liitä lomakemalli varmistaaksesi, että käyttäjät voivat avata lomakkeen -valintaruutu ja kirjoita Liitteen nimi -ruutuun lomakkeen nimi. Voit myös määrittää kentän tai kaavan avulla voit varmistaa, että lomake nimet ovat yksilöllisiä. Tämä asetus on käytettävissä vain, jos lomakemalli on määritetty, Määritä suojaustaso automaattisesti tai rajoitettu tai täyden luottamuksen suojaustaso on määritetty.

      Toimintaohjeet:

      1. Valitse Lisää kaava Painikkeen kuva .

      2. Tee Kaavan lisääminen -valintaikkunassa jompikumpi seuraavista:

        • Jos haluat käyttää kaavassa kenttää, valitse Lisää kenttä tai ryhmä, valitse haluamasi kenttä Kentän tai ryhmän valitseminen -valintaikkunassa ja valitse sitten OK.

        • Jos haluat käyttää kaavassa funktiota, valitse Lisää funktio, valitse haluamasi funktio Funktion lisääminen -valintaikkunassa ja valitse OK.

          Jos funktio edellyttää parametreja, valitse funktio Funktion lisääminen -valintaikkunassa ja valitse OK. Kaksoisnapsauta sitten Kaavan lisääminen -valintaikkunan Kaava-ruudussa lisäämääsi funktiota ja napsauta kenttää tai ryhmää. Lisätietoja funktioista on Katso myös -osan linkeissä.

        • Jos haluat lisätä kaavaan arvon tai laskutoimituksen, kirjoita arvo tai laskutoimituksen merkki Kaava-ruutuun.

      Laskutoimitus

      Merkki

      Yhteenlasku

      +

      Vähennyslasku

      -

      Kertolasku

      *

      Jakolasku

      /

      • Huomautus: Jos kaava käyttää jakolaskuoperaattoria (/), varmista, että jakolaskuoperaattoria ennen ja sen jälkeen on välilyönti. Jos jakolaskuoperaattoria ennen tai sen jälkeen ei ole välilyöntiä, InfoPath saattaa tulkita merkinnän "/" XPathin sijaintivaiheiden erottimeksi jakolaskuoperaattorin asemesta.

      • Voit tarkistaa kaavan syntaksin oikeellisuuden valitsemalla Lisää kaava -valintaikkunassa Tarkista kaava.

        Lisätietoja kaavoista on Katso myös -osan linkeissä.

      Kun lomaketiedot lähetetään sähköpostiviestin liitteenä, vastaanottajien tietokoneessa on oltava asennettuna InfoPath, jotta he voivat avata liitteen.

  7. Valitse Seuraava.

  8. Kirjota ohjatun toiminnon seuraavan sivun Kirjoita tämän tietoyhteyden nimi -ruutuun lähetystietoyhteyden kuvaava nimi.

  9. Varmista, että tiedot ovat oikein Yhteenveto-osassa, ja valitse sitten Valmis.

Sivun alkuun

Vaihe 2: lähettämisen salliminen määrittämällä lomakemalli

Kun olet lisännyt tarvittavat toissijaiset tietoyhteydet lomakemalliin, määrität lomakemallin niin, että se sallii käyttäjien lähettää lomaketietoja. InfoPath lisää tällöin Lähetä-komennon Tiedosto-valikkoon ja Lähetä-painikkeen vakiotyökaluriville, kun käyttäjät täyttävät lomaketta. Sen jälkeen voit määrittää toiminnon, joka tapahtuu, kun käyttäjä napsauttaa Lähetä-painiketta. Tässä tapauksessa lisäät säännön, joka lähettää lomaketiedot jokaiseen lähetystietoyhteyteen, kun käyttäjä napsauttaa Tiedosto-valikon Lähetä-komentoa tai vakiotyökalurivin Lähetä-painiketta.

Voit määrittää samassa valintaikkunassa lähetysasetukset.

  1. Valitse Työkalut-valikosta Lähetyksen asetukset.

  2. Valitse Lähetyksen asetukset -valintaikkunassa Salli tämän lomakkeen lähettäminen -valintaruudun valinta.

    Kun valitset tämän valintaruudun, InfoPath lisää vakiotyökaluriviin Lähetä-painikkeen ja Tiedosto-valikkoon Lähetä-komennon käyttäjien täyttäessä lomaketta.

  3. Valitse Suorita mukautettu toiminto käyttäen sääntöjä ja valitse sitten Säännöt.

  4. Valitse Lomakkeiden lähettämisen säännöt -valintaikkunassa Lisää.

  5. Valitse Lisää toiminto.

  6. Valitse Toiminto-ruudussa Lähetys tietoyhteyden avulla. Valitse sitten tietoyhteys, jota haluat käyttää kyseisessä lähetystoiminnossa, Tietoyhteys-luettelosta ja valitse OK.

  7. Toista vaiheet 5 ja 6 jokaisen lomakemalliin lisätyn lähetystietoyhteyden kohdalla.

  8. Kun olet lisännyt ehdot kaikille lomakemallin lähetystietoyhteyksille, valitse OK kahdesti.

    1. Voit muuttaa käyttäjän lomaketta täyttäessä Vakio-työkaluriville tulevan Lähetä-painikkeen sekä Tiedosto-valikkoon näkyviin tulevan Lähetä-komennon nimeä kirjoittamalla uuden nimen Lähetyksen asetukset -valintaikkunan Komennon nimi -ruutuun.

      Jos haluat määrittää painikkeelle ja komennolle pikanäppäimen, kirjoita pikanäppäimenä käytettävän merkin eteen et-merkki (&). Jos esimerkiksi haluat määrittää Lähetä-painikkeen ja -komennon pikanäppäimeksi ALT+H, kirjoita Lä&hetä.

  9. Jos haluat estää Lähetä-komennon tai vakiotyökalurivinLähetä-painikkeen käytön lomaketta täytettäessä, poista Näytä Lähetä-valikkokomento ja työkalurivin Lähetä-painike -valintaruudun valinta.

    1. Oletusarvon mukaan InfoPath jättää lomakeikkunan avoimeksi käyttäjän lähetettyä lomakkeen ja näyttää sanoman, joka ilmaisee, onnistuiko lomakkeen lähettäminen. Voit muuttaa tätä oletusarvon mukaista toimintaa valitsemalla Lisäasetukset ja toimimalla jollakin seuraavista tavoista:

      • Jos haluat, että täytetyn lomakkeen lähettämisen jälkeen lomake suljetaan tai luodaan uusi, tyhjä lomake, valitse haluamasi vaihtoehto Lähettämisen jälkeen -luettelosta.

      • Jos haluat luoda mukautetun sanoman, joka ilmoittaa lähetyksen onnistuneen tai epäonnistuneen, valitse Käytä mukautettuja sanomia -valintaruutu ja kirjoita haluamasi teksti Toiminnon onnistuessa- ja Toiminnon epäonnistuessa -ruutuihin.

        Sisällytä Toiminnon epäonnistuessa -ruudun tekstiin ohje, mitä tehdä, jos lomakkeen lähettäminen ei onnistu. Voit esimerkiksi kehottaa käyttäjää tallentamaan lomakkeen ja ottamaan yhteyttä tukipalveluun.

      • Jos et halua, että näyttöön tulee sanoma sen jälkeen, kun käyttäjä on lähettänyt lomakkeen, poista Näytä onnistumis- ja epäonnistumissanomat -valintaruudun valinta.

Sivun alkuun

Huomautus: Konekäännöksestä ilmoittava vastuusvapauslauseke: Tämä artikkeli on käännetty tietokonejärjestelmällä, eikä kieliasiantuntija ole muokannut sitä. Microsoft tarjoaa nämä konekäännökset avuksi muille kuin englantia puhuville käyttäjille, jotta he saavat lisätietoja Microsoftin tuotteista, palveluista ja tekniikoista. Koska artikkeli on koneellisesti käännetty, se saattaa sisältää sanasto-, lauseoppi- ja kielioppivirheitä.

Kehitä taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×